Jump to content

Chirby

Members
  • Posts

    123
  • Joined

  • Last visited

Everything posted by Chirby

  1. Tendré que hablar con quien lleva eso ... porque yo no puedo cambiar esas cosas. Muchas gracias por la ayuda, ya postearé cuando lo tenga probado.
  2. Gracias de nuevo! También lo tengo así, yo creo que tiene que ser algo más del tipo... parametros del servidor.. o algo así... es un servidor de los que no me gustan one&one. el parametro mod_rewrite esta correctamente, pero no se si debería haber algo más, porque al ladito de las urls amigables, solo me pasa en one&one me pone: La reescritura URL (mod_rewrite) no está activo en su servidor o no es posible comprobar la configuración del servidor. Si desea utilizar URLs debe activar este mod. aún estando activado el mod:rewrite. También creo que estoy casi segura que... cuando dejo tirados los prestashop directamente en el raiz sin carpeta funciona bien, pero si está dentro de una carpeta ya no. Aunque en prestashop le ponga la base a /nombrecarpeta/ Pero tampoco es una cosa que se cumpla al 100% puesto que tengo un Prestashop que esta en una carpeta y ahí funciona correctamente. También llegue a pensar que era por la version de prestashop, aunque me parecia raro porque nadie comentaba nada de ese problema, así que proba a "volver a hacer" el proyecto en una versón más baja, obteniendo el mismo resultado. ahora uso la útima, 5.4.1 y probé con 5.3.1 pero nada. El problema lo tengo con la redireccion del error 404, que no me reescribe la url , en el resto de páginas funcionan perfectamente las url amigables. Un saludo,
  3. Gracias por contestar, pero hasta ahí he llegado, ya te digo lo "típico" y "básico" ya está probado.
  4. Hola de nuevo, algun detalle más, esto es en la última versión. He visto que en "Red" salta el error GET pagina-no-encuentra 404 Not Found despues debería saltar: GET asdfasdfas 301 Moved al poner en la url asdfa.... pero nunca llega a saltar... mirando el .htaccess al final si está puesto: ErrorDocument 404 /mmweb/index.php?controller=404 ¿Nadie sabe nada? Gracias. Un saludo,
  5. Buenos días/tardes, Tengo un problema con el redireccionamiento de la página no encontrada, error 404. Estoy desesperadita , hasta me plantee que fuera de la versión de prestashop y volvi a hacer todo en la 5.3 y nada, me falla tanto en local como subido.... que es lo que me extraña más aún. Todas estas pruebas las estoy haciendo ahora mismo con la plantilla por defecto en local y una plantilla diferente arriba. Me redirecciona temporalmente 302 y no en todas las páginas. Si pongo en una categoria del tipo blabla.es/12-categoria (que sería valida) a blabla.es/11112-categoria (que no es válida) me salta el error bien, la url se convierte a blabla.es/pagina-no-encontrada pero es un redireccionamiento 302 temporal. En cambio si pongo: blabla.es/asdfas11112-categoria (con letras delante que tampoco es valida) el resultado es: la url se queda igual, pero veo la página de Pagina no encontrada y firebug da error 404 pero no hace ningun tipo de redireccionamiento. Si pongo: blabla.es/asdfas el resultado es el mismo que antes, la url se queda igual y visualmente estoy en la pagina no encontrada pero no llega a redireccionar. En el único momento que me redirecciona bien es si añado numero al id de una categoría y no del todo porque es 302 temporal. La misma operacion dentro de un producto.. da error 404 pero se queda la misma página y me dice: Error. Producto no encontrado. Ya he mirado foros ingleses, franceses, probado mil htaccess y nada. ¿Alguna idea? Graciass de antemano.
  6. ¿A nadie le pasa esto en la version 1..5.4.1? .. O nadie se dió cuenta?... o se ha dado cuenta pero no sabe la solución?? ahhhhhh no puedo publicar en este estado jajajajaja.
  7. Me pasa exactamente lo mismo, estoy desesperadita Me redirecciona temporalmente 302 y no en todas las páginas. Si pongo en una categoria del tipo blabla.es/12-categoria (que sería valida) a blabla.es/11112-categoria (que no es válida) me salta el error bien, la url se convierte a blabla.es/pagina-no-encontrada pero es un redireccionamiento 302 temporal. En cambio si pongo: blabla.es/asdfas11112-categoria (con letras delante que tampoco es valida) el resultado es: la url se queda igual, pero veo la página de Pagina no encontrada y firebug da error 404 pero no hace ningun tipo de redireccionamiento. Si pongo: blabla.es/asdfas el resultado es el mismo que antes, la url se queda igual y visualmente estoy en la pagina no encontrada pero no llega a redireccionar. En el único m,omento que me redirecciona bien es si añado numero al id de una categoría y no del todo porque es 302 temporal. La misma operacion dentro de un producto.. da error 404 pero se queda la misma página y me dice: Error. Producto no encontrado. Ya he mirado foros ingleses, franceses, probado mil htaccess y nada. ¿Alguna idea?
  8. en mi tpl tengo esto: <li class="favoriteproducts"> <a href="{$link->getModuleLink('favoriteproducts', 'account')|escape:'htmlall':'UTF-8'}" title="{l s='My favorite products' mod='favoriteproducts'}" class="icon-heart"> {l s='My favorite products' mod='favoriteproducts'} </a> </li> Así sin más la url que me deja es: http://localhost/mmw...roducts/account yo no la quiero así entonces me voy al BackOffice>Preferencias> SEO y URL y le doy a a añadir nueva: elijo del desplegable : favoriteproducts-acount y en reescritura pongo: productos-favoritos La url que me genera está mal, me pone el trozo de la url amigable bien, pero a mayores sigue añadiendome el resto de la url como si no fuera amigable: http://localhost/pro...troller=account y en el favoriteproducts-account.php esta: Tools::redirect(Context::getContext()->link->getModuleLink('favoriteproducts', 'account'));
  9. I'm having real problems with friendly urls in version 1.5.x. They do weird things, the 404 page jumps but the url does not change, for example I invented a page url 404 off but in keeps coming out the erroneous url does not change the friendly url page 404 Sorry for my english.
  10. Hola, a mi está solución no me a modificad nada.. sin url amigables, en mi Cuenta el modulo de productos favoritos. localhost/index.php?fc=module&module=favoriteproducts&controller=account con url amigables sin hacer ese cambio mi url es: http://localhost/module/favoriteproducts/account con el cambio que has comentado es exactamente la misma http://localhost/module/favoriteproducts/account Pero sigue sin estar bien del todo, me voy al BackOffice>Preferencias> SEO y URL y le doy a a añadir nueva: elijo del desplegable : favoriteproducts-acount y en reescritura pongo: productos-favoritos La url que me genera está mal, me pone el trozo de la url amigable bien, pero a mayores sigue añadiendome el resto de la url como si no fuera amigable: http://localhost/productos-favoritos?module=favoriteproducts&controller=account'>http://localhost/productos-favoritos?module=favoriteproducts&controller=account hasta http://localhost/productos-favoritos va bien, es mas si borro a mano en la barra de direcciones el resto carga la página que tiene que cargar.. pero alguien sabe a que puede ser debido???'
  11. Listo, a veces creo que estoy un poco... para allá xD el texto que estaba traduciendo era el alt= de una imágen, el texto que se muestra se configuraba desde dentro del modulo... Coscorrones contra la pared, ouch! que de tiempo perdido xD. Por si alguien es tan despistado como yo, estamos hablando del bloque de reaseguros. Las traducciones visuales se hacen desde la configuración del modulo y desde "Traducciones" son los textos alt. Un saludo xDDD.
  12. Buenos días a todos, estoy instalando una tienda Prestashop 1.5.4.1 y tengo un pequeño problema, ya he probado todo lo que se me ocurre y no hay manera. Tengo un modulo de prestashop, por ejemplo: block reinsurance. Este esta en la carpeta raiz/modules y luego lo tengo también dentro de mi tema, que no es el default con su carpeta translation y dentro su archivo es.php. Cuando me voy a traducciones en el backoffice > traducciones de modulos. Tengo traduccido en el nucleo del modulo la frase: Pago asegurado al 100% por Pago seguro. No me hace caso, entonces pienso.. hum traducción del tema, me voy a la traducción del modulo pero del tema y hago la misma operacion, los archivos en el ftp se ve que han cambiado, lo descargo y está puesta la nueva traduccion, pero, sigue apareciendome la traduccion antigua. ¿cual puede ser el problema? ya que los archivos están con la traduccion correcta. He borrado la cache, compiles y demas y nada. También he probado a cargarme el archivo de traducción de dentro del tema para ver si se regeneraba al guardar, y sí, pero sigue haciendo exactamente lo mismo. ¿alguna idea? me pasa con algún modulo más como por ejemplo el titulo del bloque de publicidad que me salía en frances y con todos los archivos cambiados y entrando a traducciones aparecen bién, pero luego voy a modules y sigue estando mal. Gracias de antemano,
  13. ¿A que te refieres con detalles del producto? A la descripción, yo tengo la 1.5.4.1 y en los campos que son textedit, aparece dos hileras para cambiar el color, la negrita, cursiva, alineación, cortar, pegar, vamos... lo típico.
  14. Si, te iba a decir que importar de 100 en 100 es por la configuración de tu hosting, suelen tener un tiempo de ejecución más corto que lo que dura una importación de bastantes productos, así que se corta antes de tiempo.
  15. Esto no es cierto del todo, sí bieén suele coincidir, porque cuando agregas un producto metes sus imagenes todas juntas, lo relacionas todo y guardas... pero la relación de carpetas de img/p lo único que tienen es CIFRAS-tipoimg.ext las cifras hacer referencia siempre al id_image de la carpeta imagen y que suelen ser correlativas las del mismo producto por lo que he dicho, pero si guardas una imágen de un producto y luego agregas otra para otro producto, veras que es la siguiente pero que no tiene porque coincidir con id de producto ni nada parecido. No se si me explico, pero vamos hay una tabla de imagenes que tiene un ID_IMAGE autoincrement que es el que añade como prefijo en los archivos de img + su tipo de imagen.
  16. Aún estando con la version 1.4.8 de Prestashop, el problema se ha solucionado instalando la última version de la pagina de addons de prestashop.
  17. Perdón, me daba un error al postear pero solo salía el cajetín en rojo sin el mensaje del error y me redireccionaba demasiado rapido a www.prestashop.com, por eso probe a poner uno sencillo ^^
  18. Hola a todos, tengo un pequeño problema con el pago express de paypal. Todas las compras terminan correctamente sin errores pero: -Compra de una línea: correcta -Compra con varias líneas: correcta -Compra con varias líneas y gastos de envío gratuitos: correcta El problema es: Una línea y cupón de descuento y Varias líneas y cupón de descuento, osea los cupones de descuento. Lo que ocurre es: La compra en la ventana de paypal, marca el importe total bién, se realiza bién pero... el campo descripción, donde aparecen la lista de productos (que sin cupones si se muestran) aparece vacío, aunque el total es correcto. Ejemplo compra con cupón: Ejemplo compra sin cupón: Toda ayuda es bienvenida. Gracias.
  19. Hola tengo una dudilla... en la version 1.4.8 de prestashop el registro sencillo está disponible? o se añadió a partir de la 1.5? es que no encuentro esa opcion que en la 1.5 encuentro sin problemas. Gracias de antemano. Un saludo.
  20. Buenas tardes, aquí dejo un modulo probado y me está funcionando en la versión de Prestashop 1.5. El contenido original es: http://code.google.com/p/prestashop-facebook-opengraph-module/ Dentro del .zip he añadido un leeme, donde se explica que se necesita de manera MUY facilita. Espero que os ayude, funciona con multidioma y por ejemplo en los productos, muestra por defecto la imagen principal del producto y la descripción corta. Un saludo, fbopengraph.zip
  21. Esto fué lo que hice, cambiando la raiz de mi hosting a mi carpeta y en seourls de prestashop cambia el directorio raiz y tuve que poner las url amigables a no y luego a si para que se regenerará. Todo OK Gracias!!!!
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More