Jump to content

Arakiss

Members
  • Posts

    341
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Arakiss

  1. Buenas Enrique, Efectivamente es un error de la plantilla, se me ha pasado comentarlo más temprano, ya casi lo tengo solucionado, todavía estoy tocando la vista product.tpl, pensé que era un error de PS ... con la plantilla por defecto funciona correctamente. Un saludo y gracias por tu tiempo!
  2. He probado la solución que proponen aquí y nada: https://www.prestashop.com/forums/topic/520353-combination-and-specific-price-add-impact-to-discounted-price/
  3. Me pasa algo similar a esto: https://www.prestashop.com/forums/topic/342476-solvedold-priceproductpricewithoutreduction-with-combination-is-not-changed/
  4. Buenas, Hace mucho que no me paso por aquí. Me esta pasando una cosa muy rara que en estos momentos no entiendo porque pasa. Tengo un producto que en este caso es un colchón, cada medida de este colchón tiene un precio diferente. Ejemplo de producto: Colchon guay 2030 Primera combinación: 90x180 = 100€ Segunda combinación: 90x190 = 120€ Tercera combinación: 90x200 = 150€ Los precios no los definimos en la pestaña de precio, sino directamente en las propias combinaciones generadas. Para ello utilizamos la opción de: impacto en el precio ; de esta forma nos es mas fácil poner el precio directamente para cada medida. Hasta ahí todo bien, el problema viene por otro lado, cuando en la pestaña de precio en precio especifico, definimos un descuento para todas las combinaciones, de tal forma que todas las combinaciones se beneficiarían de un descuento de 30% por ejemplo. El descuento lo realiza bien en cada combinación, pero luego el precio anterior de cada combinación NO lo muestra correctamente, siempre pone el precio anterior de la combinación por defecto. No se si me he expresado con suficiente claridad, alguien sabe porque pasa eso? Gracias, un saludo
  5. No se que tendrá que ver esa librería con XAMPP o cualquier otro entorno, pero por si acaso instálate Microsoft Visual C++ 2010 SP1 Redistributable Package que corresponda a tu version de windows.
  6. ¿Las paginas de CMS no te valen?
  7. Hay que detallar mejor lo que se pide, yo por lo menos no lo termino de entender. ¿Lo que piden entonces son dos tiendas? ¿Porque necesita dos tiendas? ¿Ambas tiendas tendrán los mismos productos? Hace falta detallar bien el proyecto para poder recibir ayuda. Un saludo
  8. Procura tener todo esto habilitado y prueba otra vez a ver si te mejora la puntuación. "Smart cache" para las hojas de estilo (CSS)SÍNO "Smart cache" para el código de JavaScriptSÍNO Reducción del código HTMLSÍNO Compresión del JavaScript dentro del código HTMLSÍNO Mover JavaScript al finalSÍNO ¿Optimizar Apache?SÍNO Guardar
  9. Me imagino que quieres decir librerías externas, insisto mas detalles, pon la URL de la web, nos sera mas fácil ayudarte. Puedes utilizar defer o async a la hora de llamar los .js, eso te puede ayudar bastante a la hora de cargar mas rápido el DOM. -EDIT- Échale un vistazo a este articulo: https://developers.google.com/speed/docs/insights/BlockingJS#InlineJS , no es exactamente lo que pides pero te ayudaría a mejorar la carga del DOM. Un saludo
  10. Tendrías que poner la URL de tu tienda para poder ayudarte, utilizas la plantilla que viene por defecto?
  11. Muchas gracias! anímate a escribir mas artículos de ese tipo, aquí tienes un seguidor. Un saludo!
  12. No entiendo que es lo que quieres comprimir, tienes que dar mas detalles.
  13. Puedes probar a subir un php.ini a la raíz de tu servidor o hacerlo a través de .htaccess, añadiendo esto al final del código generado por prestashop, mira a ver que esta comentado el código para que no te líes. php_value upload_max_filesize 20M php_value post_max_size 22M Prueba a ver y nos cuentas, sino tendrás que hablar con tu hosting, es posible que tengas restringidas las posibilidades de modificar esos parámetros.
  14. Llevo mucho tiempo trabajando con las plantillas de Leo desde la versión 1.4 para ser exacto, cuando pocos programadores tenían plantillas de calidad como las que tienen ellos, por no decir ninguno, para mi es uno de los mejores desarrolladores de themes basados en prestashop, si es cierto que alguna vez he tenido problemas con sus plantillas, muchas veces dejaban los bugs a propósito, no se si lo harían por cuestiones de piratería (membresia anual barata para todos los themes) o cuales serian las razones detrás de eso, pero casi siempre estaban al tanto de los errores que tenían, y te explicaban como solucionarlos. Creo que tu caso ha sido bastante desafortunado, como comentaba el otro compañero, a mi también me va bastante bien con ellos, desarrollan todo desde cero, tanto sus módulos como sus plantillas, y tienen una calidad de código impresionante, el framework que tienen integrado es una pasada, no hay mas que trastear un poco con el para darse cuenta. No entiendo que ganarían borrándote la plantilla que tenias por defecto, si la que ellos te instalan no afecta para nada a la antigua que tenias instalada. Instalar un theme de ellos se tarda menos de dos minutos, y hay varias formas para hacerlo, puedes usar el quick install de ellos, que ya viene TODO instalado y configurado con los datos de prueba o hacerlo a mano. Instalación limpia de prestashop, luego subes el zip a la carpeta themes de prestashop, y posteriormente importas la nueva plantilla a partir del zip que tienes alojado en el FTP, tan fácil como eso y es el método que yo recomiendo usar, para evitar posibles errores, así te aseguras que no han tocado archivos importantes de prestashop. Muchas veces es culpa del servidor donde tienes alojada la tienda, que no cumple con todos los requisitos de prestashop, me he encontrado con demasiados casos de ese tipo, una mala configuración del php.ini te puede provocar problemas con la instalación de la plantilla, por darte un ejemplo. Un saludo
  15. Muchas gracias a todos por vuestra participación, un post con muy buena información, se merece un post-it, lo digo sobre todo por vuestros futuros clientes, tienen que entender el trabajo que lleva una migración y que no cuesta 80€ como lo venden algunos por ahí. Suscribo lo dicho por el compañero, hay que ser profesional en todo momento. Un saludo
  16. Si, me pasa con la ultima version, deberia funcionar a la primera, no entiendo que pasa.
  17. Buenas, Hace mucho que no me paso por aqui, por no hablar del tiempo que llevo sin trastear con prestashop, en fin al lio, estoy teniendo un problema bastante raro que me esta volviendo loco, no puedo cambiar el logo?! Pense que tenia algun tipo de cache activada pero no hay nada, la compilacion esta forzada, no esta mostrando error, NADA ... al contrario me dice que mis ajustes han sido actualizados. He hecho pruebas tanto de forma local como remota y el mismo resultado, me pasa con la ultima y penultima version de prestashop, no he probado versiones anteriores porque me parece una tonteria, seguro que a los demas no os pasa esto?! ¿Alguna sugerencia? Gracias, un saludo
  18. ¿Habéis tocado la pestaña de rendimiento? Con migrar a un VPS no bastara, hay que hacer muchas cosas para mejorar la puntuación de Google, el primer paso mirar la pestaña de rendimiento y activar la minificacion de estilos CSS/JS y demás opciones de rendimiento. Suerte.
  19. Poco mas puedo añadir ya lo has dicho todo :-) ... a mi la ultima vez me paso con el modulo de blog de leo themes ... tenia tantos fallos, que al final preferi desarrollar yo uno desde cero y olvidarme de esos dolores de cabeza. Tambien hay que tener en cuenta que los desarrolladores tambien ponen facilidades de instalacion, como es el caso de los quick install de leo, o la instalacion de la plantilla utilizando el modulo de "instalar tema" que trae prestashop por defecto, haciendo eso te lo deja todo configurado sin que tengas que tocar casi nada mas. En definitiva a veces es un problema del usuario y no del programador.
  20. jesa, si tu tienes un problema con una plantilla te pones en contacto con el desarrollador y el esta "obligado" a solucionarte el problema de manera gratuita, las plantillas suelen funcionar suelen ser fallos tontos la gran mayoria de las veces, yo hablaba de fallos mas gordos de programacion en algun modulos, me los he encontrado y he tenido que solucionarlos yo -.-
  21. Amen a eso jesa, yo todos los themes premium que he pillado por ahi vienen mal, pero tiene su logica, de esta manera evitan en cierta medida la pirateria, sobre todo cuando te meten modulos incluidos en el mismo precio. La gran mayoria de las veces son cosas tontas, pero un par de veces me he encontrado con problemas gordos en los modulos de leo themes por ejemplo. Un saludo
  22. He visto toda clase de trolls ... pero lo tuyo es otro nivel compañero -.-
  23. Muchas gracias por tus educadas respuestas radioeventos, creo que statictic te ha contestado por mi, suscribo cada una de sus palabras. Muchas veces es preferible esperar a una versión estable antes de actualizar, yo solo recomiendo actualizar a PS 1.6, como ya he dicho a gente que sean mas que simples usuarios que conozcan el gestor, tiene que ser una persona con conocimientos mínimos de programación y/o maquetacion. De verdad os prometo que os va a gustar esta versión, promete y mucho! Las actualizaciones de los módulos pocas por no decir nunca, me han fallado ... y en el hipotético caso de que fallen son fallos tontos de maquetacion. Muchas veces los usuarios no se dan cuenta de que la actualización de los módulos fallidos, no es por culpa de una mala versión sino por culpa del desarrollador de la plantilla. Fallos tontos a nivel visual , que en vez de que el botón te salga a la izquierda te salga a la derecha o cosas así por dar un ejemplo, eso se debe muchas veces a que el programador de la plantilla no haya usado estilos genéricos para temas de compatibilidad de módulos, me pondría a explicar a nivel mas técnico pero creo que no es necesario, los que nos dedicamos a esto seguramente sepan de lo que hablo. Yo estoy muy agradecido con prestashop, hasta ahora me ha dado de comer y me ha hecho aprender y coger un nivel de PHP que antes no tenia. Un saludo a todos!
  24. Me parece que algunos no entendéis el curro que lleva esta nueva versión y todas las mejoras que llevara con respeto a la versión 1.5 son simplemente impresionantes y dejan a prestashop en un nivel muy superior, ahora si que puede competir con magento ; dejando esto de un lado, repito lo que yo he dicho es una opinión mas, lo he dicho sin animo de ofender a nadie. O yo soy muy cabezón defendiendo a prestashop en plan Quijote o no se yo ... vuelvo a repetir que es un producto gratuito, ellos no os obligan a actualizar a la nueva versión, de hecho la compatibilidad de las plantillas se seguirá manteniendo, tenéis que entender que es una versión estable, la primera de ellas, y que es muy normal que tenga fallos, eso pasa en el mundo del sofware incluso a gran escala. Si quieres una versión de pago con features mas avanzadas te puedes ir a magento o desarrollar tu propio sistema desde cero, y ahí compara gastos de lo que te cuesta prestashop vs magento vs desarrollo propio a medida, no obstante no os preocupéis como he dicho es la primera versión , irán sacando las nuevas versiones y si hay fallos podéis venir el foro que para eso esta la comunidad, yo a los que no sepan programar o mínimo maquetar para prestashop no les recomiendo actualizar. Ellos han fallado al prometer que la primera versión 1.6 seria totalmente compatible, los arreglos que yo veo a nivel visual en muchas plantillas y módulos son bastante tontos, que con unos conocimientos de CSS y HTML se pueden arreglar, otra cosa muy diferente es que ya sea algún fallo a nivel de programación, pero por lo general no he visto bugs gordos, desde que salio la nueva versión he arreglado un par de plantillas conocidas y en casi todos los casos han sido fallos tontos. Pues creo que vivimos en dos dimensiones diferentes, soy usuario de wordpress desde las primeras versiones que sacaron y me he tropezado con tropecientos bugs y fallos muy gordos de seguridad, a nivel de seguridad wordpress siempre ha ido cojeando, es cierto que es la el CMS mas versátil que hay por la cantidad de plugins que tiene, pero no me digas que no ha tenido chapuzas porque si las ha tenido, me hace gracia hablando del sistema de auto-actualizaciones, en las versiones de wordpress la de veces que me ha fallado a mi y montones de clientes, ahora con las ultimas versiones si es cierto que funciona perfectamente, pero cuantas versiones hay ahora mismo de wordpress? Otro de los mayores problemas de wordpress, estan en los plugins, que muchos de ellos no estan programados con seguridad, o el usuario no los actualiza a tiempo y luego pasa lo que pasa, deface by the face. Joomla mas de lo mismo, fallos super gordos de seguridad que han tardado un montón de tiempo en corregir, si comparamos wordpress con joomla en temas de gestores de contenido, wordpress es superior en todos los sentidos. Pero vamos no veo el caso de comparar un plataforma e-commerce con un gestores de contenido, es cierto que con joomla y virtualmart se puede montar una tienda, o wordpress y su multitud de plugins, pero no hay color no es lo mismo, ya lo has dicho tu prestashop es un sistema profesional de tiendas. Por favor lee mi comentario atentamente, me has entendido mal, tengo a clientes que tienen tiendas con la versión 1.4 y jamas han tenido problemas ... porque otros deberían tenerlos? En fin ya lo dejo aquí, no la toméis conmigo, repito es solo una opinión, se han precipitado un poco al lanzar esta versión como estable, de cara a los usuarios normales, de cara a los que nos dedicamos a esto, no tiene demasiada importancia, son fallos que podemos ir corrigiendo poco a poco. Un saludo a todos!
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More