Jump to content

decanet31

Members
  • Posts

    7
  • Joined

  • Last visited

Profile Information

  • Location
    Toulouse, France
  • Activity
    Agency

decanet31's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Bonjour, Avec la version 1.7.6.7 sur une installation Prestashop sans override et avec le multi-boutique activé, j'ai le comportement suivant: J'ai un produit (id=1), avec trois attributs de taille (ids=11, 12 et 13) et deux boutiques (id=21 et id=22). J'ajoute les déclinaisons suivantes avec succès : produit (1) - attribut (11, 12) - boutique (21) Si je passe sur ma boutique id=22, sur le même produit, j'ajoute les déclinaisons suivantes: produit (1) - attribut (11, 12, 13) - boutique (22) Ici, seule la déclinaison ci-dessous s'ajoute: produit (1) - attribut (13) - boutique (22) Un peu comme si le contrôleur de Prestashop vérifiait l'existence du couple id_product + id_product_attribute sans tenir compte du id_shop. En faisant l'ajout de la ligne manuellement dans la base de données, toutes mes déclinaisons apparaissent bien, ce n'est donc pas une contrainte de DB. Bonne journée! Benjamin
  2. Bonjour tout le monde, J'ai un problème avec les frais de port offerts via un code promo. Je m'explique. Dans le back office, j'ai créé un code promo qui n'applique pas de réduction, mais qui a "Frais de ports offerts" activé pour un transporteur cible. Jusque là, pas de soucis. Le problème est côté front-office. Lorsque j'active mon code promo, j'ai bien le transporteur qui apparait comme "gratuit", mais sur la dernière page du tunnel de commande (le récap panier et le choix du mode de paiement), ce n'est pas tout à fait ce qui est appliqué. J'ai ça: Produit : 2€ Frais de port : 4€ Bon de réduction: -4€ Total à payer: 2€ En réalité il faudrait plutôt: Produit : 2€ Frais de port: gratuit Total à payer: 2€ Rien de bien méchant à priori, sauf que du coup j'ai le module Paypal qui déconne complètement et je tombe sur une belle page d'erreur. En effet, le module sépare le montant des produits et les frais de port, ce qui fait qu'en analysant la requête POST envoyée à Paypal, j'ai ça: Sous total : -2€ (les 2€ de produits -4€ de bon de réduction) Frais de port: 4€ Le total fait toujours 2€, sauf que Paypal n'accepte pas un montant négatif en sous-total d'où l'erreur. Dans le cas où le montant des produits est supérieur aux frais de port (on va dire 10€ de produits pour 4€ de frais de port offerts), j'ai alors ça sur Paypal: Sous total: 6€ Frais de port: 4€ Total: 10€ Ce qui n'est pas tout à fait exact sur la répartition, même si le total est bon. Quelqu'un a déjà eu le problème et sait comment appliquer une vraie gratuité des frais de port via un code promo et non un bon de réduction qui s'applique sur le sous total? Merci d'avance Benjamin
  3. Bon, j'ai avancé dans la recherche du problème. En analysant la console JS de mon navigateur, je me suis rendu compte d'une erreur : cannot call methods on slider prior to initialization; attempted to call method 'values' l'appel de la méthode "slider" m'a laissé pensé que c'était le slider du filtre de prix de la navigation à facettes qui posait problème. J'ai essayé de remplacer le filtre "prix" par une saisie de valeurs plutôt qu'un slider, et là toute la navigation (tri et pagination) refonctionne bien, même avec les thèmes autres que celui par défaut. Il semble donc y avoir un problème entre la nouvelle version 1.5.5 de Prestashop et cette fonctionnalité.
  4. Sur les trois sites concernés, la version était la 1.5.4.1. Ce ne sont pas les thèmes par défaut, mais trois thèmes séparés. J'ai tenté sur l'une des boutiques de remettre le thème par défaut, mais le problème est le même. Sur deux boutiques, la mise à jour a été passée via le one-click-upgrade, pour la troisième, via une mise à jour manuelle (envoi des fichiers et appel du script d'upgrade) Merci pour votre aide
  5. Bonjour, J'ai mis à jour trois boutiques Prestashop vers la version 1.5.5 et j'ai rencontré le même problème avec les trois boutiques (fonctionnant avec modules et thèmes différents, seul le module de navigation à facettes est commun). Depuis la mise à jour vers la dernière version, le tri dans les pages catégories (par prix, ordre alphabétique ou en stock), ainsi que la pagination ne fonctionnent plus. Le changement du tri ne fait rien et le clic sur un autre numéro de la pagination (page 2, 3, etc.) grise la liste des produits mais ne change pas de page. J'ai essayé de désactiver le module temporairement et la navigation refonctionne bien. Est-ce un bug connu du module? Existe t-il un fix? Merci d'avance! Benjamin
  6. Bonjour, De mon côté, j'avais la même erreur. En cherchant un peu, j'ai noté une erreur dans les logs disant que le répertoire /config/xml/ n'avait pas les droits en écriture. J'ai donc mis les droits en écriture sur ce répertoire en récursif et la mise à jour est passée. En espérant que ça vous aidera.
  7. Bonjour, Ma boutique Prestashop 1.5 rencontre de grosses lenteurs à l'execution de certaines commandes dans le back office. Tout est rapide, sauf lorsque je tente un import d'un fichier csv qui génère un chargement infini qui aboutit sur un délai d'execution max atteint (qui est pourtant de 20 minutes, le fichier est un fichier test comportant 2 lignes pour mettre à jour une quantité de produits dont l'ID est donné). Je rencontre le même type de lenteur quand je veux créer une boutique sur le multiboutique. J'ai tenté d'activer le debug de Prestashop en affichant les erreurs, mais rien n'apparait. Dans les logs, tout est silencieux également, je n'ai aucune erreur qui remonte. Quelqu'un a déjà rencontré ce problème? Si oui, avez vous une solution ou une piste? En vous remerciant par avance Cordialement Benjamin
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More