Jump to content

Sassenach

Members
  • Posts

    23
  • Joined

  • Last visited

Everything posted by Sassenach

  1. Danke für die schnelle Rückmeldung! Ja, die Datenbank ist UTF-8. Ob ich da von 1&1 eine vernünftige Antwort drauf bekomme??? :-) Gibt es denn irgendeine Möglichkeit, das Problem shopseitig zu umgehen, indem ich bspw. die Umlaute vor Absenden der Mail konvertiere? Wo müsste ich das machen - kann die entsprechenden Stellen leider nicht finden...
  2. Hallo zusammen, in letzter Zeit häuften sich die Rückfragen von Kunden, die keine Bestellbestätigung und auch sonst eine systemseitigen Mails bekommen habe. Wir haben jetzt festgestellt, dass es offenbar alles Kunden sind, die einen Umlaut im Namen haben (wohlgemerkt nur im Namen, nicht in der E-Mail-Adresse). Hat jemand eine Erklärung hierfür bzw. einen Tipp, wie wir das Problem beheben können??? Vielen Dank! Sassenach
  3. Thanks for your answer, phrasespot! Unfortunately, when I replace it by the line you proposed, I'm getting this message: Fatal error: Smarty error: [in /myshop/themes/blackwhite/modules/productcomments//productcomments.tpl line 116]: syntax error: unrecognized tag: smarty.server.REQUEST_URI|escape:'htmlall':'utf-8' (Smarty_Compiler.class.php, line 446) in /myshop/tools/smarty_v2/Smarty.class.php on line 1095 Any ideas??? Thanx a lot for your help Sassenach
  4. Habe es gelöst: der onSubmit-Befehl (onsubmit="return acceptCGV() gehörte in das <form>-Tag und nicht in das Submit-Tag, in dem es vorher drin war...
  5. For me it worked (PS 1.4.2.5)... I would say: install Firebug and take a look at the thumbnails to see which part of the css you have to change to transparent. Greetz Sassenach
  6. Beim Händlerbund gibt es einen ganz praktischen Widerrufstextgenerator für die seit 04.08. gültige Widerrufsbelehrung: http://www.haendlerbund.de/widerrufstextgenerator Der Original-Gesetzestext findet sich im Bundesgesetzblatt vom 03.08.2011: http://www.bgbl.de/Xaver/start.xav?startbk=Bundesanzeiger_BGBl&start=//*[@attr_id=%27bgbl111s1600.pdf%27] VG Sassenach
  7. Hi Chris, I got the same problem with the tax. Tried total_tax - not working either. As for delivery and invoice address, I'm using the following variables and they are working pretty well: {delivery_company} {delivery_firstname} {delivery_lastname} {delivery_address1} {delivery_address2} {delivery_postal_code} {delivery_city} {delivery_country} {delivery_state} {delivery_phone} {delivery_other} and the same for invoice_ ... Someone's got a suggestion for the tax? Thanks a lot! Sassenach
  8. Can anyboldy help me with this? Can't find a solution... Thanks a lot! Sassenach
  9. I'm allowing product comments for registered users only, so I've got a login link in the product comments tab on the products page. For usability reasons, I would like the user to come back to this exact page after logging in. What I found out is that this can be reached by adding a parameter 'back' to the login-url, but: how do I fill this parameter? <a href="{$base_dir}authentication.php?back={CURRENT_PAGE}"> Question is: what do I have to replace CURRENT_PAGE with???? Thanks for your help!!!! Sassenach
  10. change the file yourshop/css/jquery.fancybox-1.3.4.css replace #fancybox-outer { background: none repeat scroll 0 0 #FFFFFF; height: 100%; position: relative; width: 100%; } with #fancybox-outer { background: none repeat scroll 0 0 transparent; height: 100%; position: relative; width: 100%; } This should do the trick... Greetz, Sassenach
  11. Got the same problem. The only solution I found here in the forum was to reinstall the PayPal module - but this was an answer from 2009 and I just don't want to believe that in version 1.4.2.5 it's still the same problem. Anybody found a solution to this??? I've been searching for hours now .... Greetz, Sassenach
  12. Ok, seems like I got it. I replaced the OrderOpcController.php (like ysco proposed in the other thread to this subject) by the same file from the current 1.4.3.0. I just hope it's not messing anything else up because of some incompatibilities, but I'll just have to check that thouroughly. Thanks for your input! Sassenach
  13. Hi zoveress, thanks for your quick reply. You're right, but it was the other way around: in the one page checkout the error messages are showing. Problem is: I don't want the one page checkout :-). And obviously it's not only that the error messages are not showingn in standard checkout, valid vouchers are not accepted / displayed either. ... Sassenach
  14. Did anybody find a solution to this? I'm working with PS 1.4.2.5 and I've got the same problem. No matter if I'm using a valid or an invalid voucher code, nothing happens - no confirmation, no error message, nothing. Just a reload of the same page... I already tried copying the <form>....</form> section from the original prestashop theme shopping_cart.tpl, because I'm using another template, but this didn't change anything either... There must be a solution to this - anybody know it? Sassenach
  15. J'ai le même problème: je voudrais insérer un lien sur "authentication.php" dans le module productcomments sur la page produit et faire retourner le client sur la page produit originaire. J'ai trouvé des liens du style "authentication.php?back=cellepageci.php" - qui me paraissaient parfait, mais combien peux-je faire pour ajouter la page produit correspondante? J'ai essayé avec $_SERVER[‘PHP_SELF’], mais il paraît que je n'arrive pas à mettre la syntaxe correcte. Voici le code où je voudrais insérer le lien sur la page active: {l s='Please' mod='productcomments'} {l s='login' mod='productcomments'} {l s='to post a new comment.' mod='productcomments'} Quoi insérer au lieu de XXXXX? :-) Et: est-ce que ça peut fonctionner? La solution dans le post mentionné par petitemarie me paraît beaucoup plus compliquée... Quelqu'un qui pourrait m'aider? Merci beaucoup! Sassenach
  16. Hallo zusammen,<br/><br/>ich habe in PS 1.4.2.5 die Checkbox zum Akzeptieren der AGBs von der Versand-Seite auf die letzte Seite des Bestellprozesses verschoben (also z.B. modules/bankwire/payment.php). Nun wird aber die Fehlermeldung nicht mehr angezeigt, wenn die Checkbox nicht angeklickt wird und die Bestellung geht trotzdem durch. Hat jemand eine Ahnung, woran das liegen kann? Habe ich irgendetwas vergessen, mit rüberzunehmen? <br/><br/>Hier ist meine modules/bankwire/payment_execution.tpl, in der die Abfragen nun drin sind: <br/><br/> <br/>{if !$opc}<br/> [removed]<br/> <!--<br/> var baseDir = '{$base_dir_ssl}';<br/> --><br/> [removed]<br/> [removed]<br/> var msg = "{l s='You must agree to the terms of service before continuing.' js=1}";<br/> {literal}<br/> function acceptCGV()<br/> {<br/> if ($('#cgv').length && !$('input#cgv:checked').length)<br/> {<br/> alert(msg);<br/> return false;<br/> }<br/> else<br/> return true;<br/> }<br/> {/literal}<br/> [removed]<br/>{/if}<br/><br/>{capture name=path}{l s='Bank wire payment' mod='bankwire'}{/capture}<br/>{include file="$tpl_dir./breadcrumb.tpl"}<br/><br/><h2>{l s='Order summary' mod='bankwire'}</h2><br/><br/>{assign var='current_step' value='summary'}<br/>{include file="$tpl_dir./order-steps.tpl"}<br/><br/>{if $nbProducts <= 0}<br/> <p class="warning">{l s='Your shopping cart is empty.'}</p><br/>{else}<br/>{include file=$tpl_dir./shopping-summary.tpl} <br/><br/><h3>{l s='Bank wire payment' mod='bankwire'}</h3><br/><form action="{$link->getPageLink('validation.php', true)}" method="post"><br/><p><br/> <img src="{$this_path}bankwire.jpg" alt="{l s='bank wire' mod='bankwire'}" width="86" height="49" style="float:left; margin: 0px 10px 5px 0px;"><br/> {l s='You have chosen to pay by bank wire.' mod='bankwire'}<br/> <br/> <br/> {l s='Here is a short summary of your order:' mod='bankwire'}<br/></p><br/><p style="margin-top:20px;"><br/> - {l s='The total amount of your order is' mod='bankwire'}<br/> <span id="amount" class="price">{displayPrice price=$total}</span><br/> {if $use_taxes == 1}<br/> {l s='(tax incl.)' mod='bankwire'}<br/> {/if}<br/></p><br/><p><br/> -<br/> {if $currencies|@count > 1}<br/> {l s='We accept several currencies to be sent by bank wire.' mod='bankwire'}<br/> <br/> {l s='Choose one of the following:' mod='bankwire'}<br/> <select id="currency_payement" name="currency_payement"><br/> {foreach from=$currencies item=currency}<br/> <option value="{$currency.id_currency}" {if $currency.id_currency == $cust_currency}selected="selected"{/if}>{$currency.name}</option><br/> {/foreach}<br/> </select><br/> {else}<br/> {l s='We accept the following currency to be sent by bank wire:' mod='bankwire'} <b>{$currencies.0.name}</b><br/> <input type="hidden" name="currency_payement" value="{$currencies.0.id_currency}" /><br/> {/if}<br/></p><br/><p><br/> {l s='Bank wire account information will be displayed on the next page.' mod='bankwire'}<br/> <br/> <b>{l s='Please confirm your order by clicking 'I confirm my order'' mod='bankwire'}.</b><br/></p><br/><br/>{if $conditions AND $cms_id}<br/> <h2 class="condition_title">{l s='Terms of service'}</h2><br/> <p class="checkbox"><br/> <input type="checkbox" name="cgv" id="cgv" value="1" {if $checkedTOS}checked="checked"{/if} /><br/> <label for="cgv">{l s='I agree to the terms of service and adhere to them unconditionally.'}</label> <a href="../../cms.php?id_cms=3" class="iframe">{l s='(read)'}</a><br/> </p><br/> [removed]$('a.iframe').fancybox();[removed]<br/>{/if}<br/><br/><p class="cart_navigation"><br/> <a >getPageLink('order.php', true)}?step=3" class="button_large hideOnSubmit">{l s='Other payment methods' mod='bankwire'}</a><br/> <input type="submit" name="submit" value="{l s='I confirm my order' mod='bankwire'}" class="exclusive_large hideOnSubmit" ><br/></p><br/></form><br/>{/if} <br/><br/>Wäre für jede Hilfe dankbar!!!!<br/><br/>Gruß,<br/>Sassenach
  17. I need the first name and last name of the delivery address on the order-confirmation.php. I tried to reference it in the corresponding payment-return.tpl by the following code which is used on other pages: {$delivery->firstname|escape:'htmlall':'UTF-8'} {$delivery->lastname|escape:'htmlall':'UTF-8'} But apparently I have to somehow fill the variable $delivery before, probably in the order-confirmation.php - is that right? If it is - how can I do that? And if not - what else do I have to do to print this information on the order confirmation page? Thanks for your help!!! Greetz, Sassenach
  18. Hi, I've got a problem in the admin tool after upgrading from 1.3.1 to 1.3.2: the orders are not displayed properly, he says he's got 7780 orders, but only shows the last one... any ideas??? EDIT: and I only just noticed that I cannot view the one order which is displayed - when I click on the order, the page contains only the header and no contents..
  19. Hi everybody, I've got a problem in my backoffice: the languages are somehow mixed up. When I select English, the tabs are French, but the rest is in English, if I select French, the tabs are Spanish, but the rest is in French and so on... Anybody got an idea? I'm completely clueless here... btw: I'm using PrestaShop 1.3.1 ... Thanks and regards, Sassenach
  20. The same for me - worth every cent! I did have some troubles making the module work, mainly because of our server configuration (allow_url_fopen needs to be on, as for a lot of other prestashop features, but it took us some time to figure out that it was on in the main directory, but off in the admin subdirectory.... ). But everytime I had a problem, Tomer was there to solve it, either via LiveSupport or via email, sometimes even at 5 o'clock in the morning... ;-) Thanks a lot, this really is a perfect support - and a great module! Got all our products, clients, orders, reviews and everything up and running in presta shop ... Top recommendation! Sassenach
  21. probablemente con "oscommerce 2 prestashop" (aquí: http://www.prestastore.com/436-oscommerce-2-prestashop.html&adforum;), pero ya no lo conozco, estoy buscando experiencias mi misma...
  22. Vielen Dank für die ausführlichen Antworten! @rumata: Danke, das klingt eigentlich ganz gut. Wie gesagt, ich hatte schon den Eindruck, dass in den letzten Monaten viel passiert ist, das scheint sich ja zu bestätigen. Wann kommt denn der FinalRelease der Version 1.3 raus?, ggf. würde ich den noch abwarten und dann mal einen neuen Versuch starten. Wirklich beurteilen kann man das ja ohnhin immer erst, wenn man sich den Shop in Ruhe selber anschaut... @popres: Wir haben eine recht alte Version von osCommerce laufen und müssten auf jeden Fall viel Arbeit in eine Aktualisierung stecken. Die Basis von osCommerce ist einfach zu alt, irgendwie ist alles zu sehr zusammengewürfelt, für eine professionelle Lösung meiner Meinung nach nicht geeignet. Kann Dir gar nichts konkretes sagen, wir haben u.a. Probleme mit der SEO, das ist auf jeden Fall suboptimal.
  23. Hallo zusammen, wir sind schon seit einiger Zeit auf der Suche nach einem ShopSystem, das unser "altes" OSCommerce ablösen könnte. Vor einigen Monaten sind wir dabei auf PrestaShop gestoßen, das uns auf Anhieb sehr gefiel, haben uns allerdings von den diversen Aussagen hier im Forum, dass PrestaShop gerade für deutsche Online-Shops nur eingeschränkt bzw. mit großem Aufwand geeignet ist (rechtliche Vorgaben etc.), abschrecken lassen. In der Zwischenzeit hat sich ja anscheinend grundsätzlich viel getan bei PrestaShop, zumindest macht es den Anschein. Hat sich denn an dieser Problematik Grundlegendes geändert? Würdet Ihr PrestaShop für einen "rechtssicheren" (ich weiss, den gibt es nicht ... ;-) ) Online-Shop in Deutschland empfehlen? Und wie sieht es mit der Internationalisierung aus? Wir würden gerne auch ins Ausland versenden und den Shop auch in verschiedenen Sprachen anbieten - funktioniert das gut? Würde mich über eine Einschätzung von erfahrener Seite freuen! Vielen Dank & Gruß, Sassenach
  24. Hi everybody, I've just installed Prestashop (version 1.2.1.0) and started to fill it with some products. Everything seems to be working fine so far, but there's one problem with the product images. In the Demo Shop on www.prestashop.com, when moving over the main product image with the mouse, a bigger version of the image opens. In my shop, when moving over the image with the mouse, the cursor changes into crosshair mode and at the right of the image, a "zoom" of the product picture is shown that shows only the part of the picture the mouse is just crossing over. Why is that so? I think this is very annoying - I would prefer nothing to happen when moving over the image instead of this zoom (if the bigger image cannot be shown). Also, when I click on on of the smaller images below the main image, a new page opens with just this image in it - in the demo shop clicking on one of the smaller images makes it appear as the main image. Can anybody tell me why this is like that and how to change it? I think the way it works in the demo shop is just perfect... Thanks for your help!! Sassenach
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More