Jump to content

tivicrdotcom

Members
  • Posts

    321
  • Joined

  • Last visited

Everything posted by tivicrdotcom

  1. Hello fellow Geeks, so I am migrating an old but good 1.6 PS shop from one server to another, the new server/site is located at http://test.tivicr.com/tintagrafica/ and I am getting the following error: Fatal error: Uncaught Error: Class 'AppKernel' not found in /home/at4gprieu0fh/public_html/tintagrafica/config/autoload.php:28 I have checked everything, files being where they are supposed to such as autload.php, app/AppKernel but can't find anything missing. I checked autload.php and that line reads: define('_PS_VERSION_', AppKernel::VERSION); I don't know where else to look for, to make matters worst, the original website (old server) now has the same error, so both sites are down, I guess going back and forth made matters worst. Thanks in advance!
  2. Hello fellow geeks, so I migrated (1.6 to another server), everything works, except images but that's a different topic, now when I click to any of the CMS links it takes me to the old server/url. You can check the site at https://www.test.tivicr.com Thanks in advance!
  3. Hello fellow geeks, I am running 1.6, I know, but once I complete this migration I will use the old site to try an upgrade to 1.7 and troubleshoot there. Anyways, I migrated all sites but this one is giving me the issue with the images. They are all missing, I have tried everything, I mean, I didn't have any issues on the other one but this one can't seem to get them images to show up. The site is located at https://www.test.tivicr.com Thanks in advance!
  4. Hello fellow Geeks, so whenever I paste the link to my website on WhatsApp or share it another way, instead of nicely displaying a small preview of the website as with my other websites, on http://www.fitnesscostarica.com displays a small preview of smartblog category. It seems as if the index page is redirecting the preview to the smart blog, any clue as to where to edit that? Thanks in advance, cheers!
  5. Hi, good module for sure, I am trying to install it on 1.6.1.24 but I get the following error: CREATE TABLE IF NOT EXISTS `ps_faq_lang` ( `id_qa` int(11) NOT NULL auto_increment, `id_lang` int(11) NOT NULL , `question` text NOT NULL, `answer` text NOT NULL, `created` datetime DEFAULT CURRENT_TIMESTAMP , `modified` datetime DEFAULT CURRENT_TIMESTAMP , PRIMARY KEY (`id_qa`,`id_lang`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8| I go back and I can see it under the module list but when I click on configure, I get this other error (is all about the faq_lang table): CREATE TABLE IF NOT EXISTS `ps_faq_lang` ( `id_qa` int(11) NOT NULL auto_increment, `id_lang` int(11) NOT NULL , `question` text NOT NULL, `answer` text NOT NULL, `created` datetime DEFAULT CURRENT_TIMESTAMP , `modified` datetime DEFAULT CURRENT_TIMESTAMP , PRIMARY KEY (`id_qa`,`id_lang`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8 Thanks!
  6. This works great as it stopped all those Russians spammers but how to adapt it to the create an user screen? I am getting a bunch of new accounts being created with spam. Thanks
  7. Sorry, the 1.6.1.24 does have the install file also, I just had to refresh it, I am gonna try to install this version to see if I don't get an error.
  8. I downloaded the 1.6.1.24 but it's a patch version like you said, I have to get up and running the 1.6.1.10 first which has the install file, I just don't don't why it's giving me issues a fresh install, then I can upgrade to the patched version.
  9. Thanks for replying, I wasn't aware of that version. I am gonna download it and try the install.
  10. Hello Patron, this module doesn't longer work? I was looking to display prices only to signed in customers. Also when customers are not logged in, to have a text display "call us at (xxx) xxxxxx for price. I am running 1.6.1.10. thanks in advance brother
  11. This is the code under that file 82 /* Define API URLs if not defined before */ 83 Tools::safeDefine('_PS_API_DOMAIN_', 'api.prestashop.com');
  12. I am downloading 1.6.1.10 because 1.7 need some work and I am extremely comfortable with the environment of the earlier version. I have 6 stores running 1.6.1.10 smooth, and I wanted to install a new one, so I downloaded the stable version from the prestashop website, and I encounter the following error which like I mentioned, I have never had an issue with that version before. Fatal error: Class 'Tools' not found in /home/content/13/8897513/html/fitnesscostarica/config/defines_uri.inc.php on line 83
  13. Hello fellow geeks, so I bought this SSL on godaddy, running PS 1.6.1.10 and on the BO I checked Enable SSL and Enable SSL On All Pages but when I access the store which is sitting down on the folder tivicr.com/store I get the URL returned as https://https//www.tivicr.com/store/es/ so for some reason is repeating the https has anyone experienced something similar? I am running the following .htaccess under that same directory (store). # ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again # .htaccess automaticaly generated by PrestaShop e-commerce open-source solution # http://www.prestashop.com - http://www.prestashop.com/forums <IfModule mod_rewrite.c> <IfModule mod_env.c> SetEnv HTTP_MOD_REWRITE On </IfModule> RewriteEngine on RewriteCond %{HTTP:Authorization} ^(.*) RewriteRule . - [E=HTTP_AUTHORIZATION:%1] #Domain: www.tivicr.com RewriteRule . - [E=REWRITEBASE:/store/] RewriteRule ^api$ api/ [L] RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L] # Images RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] # Dispatcher RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^.*$ - [NC,L] RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] #Domain: https://www.tivicr.com RewriteRule . - [E=REWRITEBASE:/store/] RewriteRule ^api$ api/ [L] RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L] # Images RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] # Dispatcher RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^.*$ - [NC,L] RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] </IfModule> AddType application/vnd.ms-fontobject .eot AddType font/ttf .ttf AddType font/otf .otf AddType application/x-font-woff .woff <IfModule mod_headers.c> <FilesMatch "\.(ttf|ttc|otf|eot|woff|svg)$"> Header add Access-Control-Allow-Origin "*" </FilesMatch> </IfModule> <IfModule mod_expires.c> ExpiresActive On ExpiresByType image/gif "access plus 1 month" ExpiresByType image/jpeg "access plus 1 month" ExpiresByType image/png "access plus 1 month" ExpiresByType text/css "access plus 1 week" ExpiresByType text/javascript "access plus 1 week" ExpiresByType application/javascript "access plus 1 week" ExpiresByType application/x-javascript "access plus 1 week" ExpiresByType image/x-icon "access plus 1 year" ExpiresByType image/svg+xml "access plus 1 year" ExpiresByType image/vnd.microsoft.icon "access plus 1 year" ExpiresByType application/font-woff "access plus 1 year" ExpiresByType application/x-font-woff "access plus 1 year" ExpiresByType application/vnd.ms-fontobject "access plus 1 year" ExpiresByType font/opentype "access plus 1 year" ExpiresByType font/ttf "access plus 1 year" ExpiresByType font/otf "access plus 1 year" ExpiresByType application/x-font-ttf "access plus 1 year" ExpiresByType application/x-font-otf "access plus 1 year" </IfModule> <IfModule mod_headers.c> Header unset Etag </IfModule> FileETag none <IfModule mod_deflate.c> <IfModule mod_filter.c> AddOutputFilterByType DEFLATE text/html text/css text/javascript application/javascript application/x-javascript font/ttf application/x-font-ttf font/otf application/x-font-otf font/opentype </IfModule> </IfModule> #If rewrite mod isn't enabled ErrorDocument 404 /store/index.php?controller=404 # ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
  14. Rather than a problem is to compliment the SEO on Prestashop which works beautifully, we get so many businesses from SEO alone and we top big players (companies) which I assume don't have quite as good of a SEO as ours. I would like to read some technical notes on how the Prestashop SEO works. Happy selling! Cheers, AJ
  15. So when a customer is on the product page, at the bottom right corner the "Pay with PayPal" is displayed, if the customer clicks on it then a pop up window opens for him to log in and proceed with the purchase. Now, If the customer goes through the entire process of check out until step 5, he can see the "Pay with PayPal" option, but when the customer clicks on it, the pop up window opens up but nothing comes up. The URL displayed is: https://www.paypal.com/webapps/hermes/error Running PS 1.6.1.10
  16. I concur, to each its own and at the end stick to whatever works. In my case I was happy running 1.4 but I migrated to 1.6 only because of the theme, which was responsive and mobile friendly. I have been 2+ years with 1.6.1.10 and works like a charm.
  17. I haven't upgraded to 1.7 although I have played with it, I still have all my shops running on 1.6 and to me that's the best release yet. Sort of like with Windows, every so other version were great, but not all of them. Is has a nice theme, loads fast and is easy to troubleshoot. What versions do you guys like the most, or have found out to be the best one to work with? AJ
  18. Awesome module, thanks for the collaboration, really needed indeed. Hopefully this will stop those "@email.ru" spammers. Successfully tested on 1.6.1.10
  19. Thanks for replying Dh42, but GtMetrix gives some Page Details such as: Fully Loaded Time 2.2s Total Page Size 1.13MB Requests 47 Now it's lightning fast, I believe it's the hosting, it may be time to get a dedicated server, not a shared one.
  20. I don't quite understand how can I get the following Performance Scores at GtMetrix: PageSpeed Score (91%) A YSlow Score (81%) B Yet my website is extremely slow, I am running 1.6.1 and sometimes is lightning fast and sometimes is so slow it times out. The website can be accesses at http://www.tivicr.com
  21. En los dos últimos días hemos estado experimentando mucha lentitud en nuestro sitio web sin embargo recibimos una calificación de A (92) en gtmetrix.com? Como puede ser esto posible?
  22. Hello fellow geeks, so I am trying to add an extra menu link on the user account, I do it but how to move it left?
  23. This developer sold me this nice Amazon module which allowed us to extract Amazon products directly from their databases to our virtual stores. We specified the ASIN and it extracted everything but most important, it kept synched with Amazon db to change accordingly quantities and prices. Recently, it stopped working and we can't longer locate the developer, if we provide the core files can someone fix the issue?
  24. Has anybody experienced this issue? Not being able to see/view the log i n as a customer button?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More