Jump to content

base888

Members
  • Posts

    67
  • Joined

  • Last visited

Everything posted by base888

  1. Bonjour à tous Prestashop 1.6.1.16 Thème par défaut bootstrap https://www.mangalatitude.fr Je viens de m'apercevoir qu'il est impossible pour un client connecté d'ajouter un produit depuis la page d'accueil du site. Cela est possible si pas de connexion au compte client mais si le client se connecte, pas d'ajout au panier depuis les produits en page d'accueil. Si le client est connecté et rentre dans une fiche produit, l'ajout au panier fonctionne bien, dans les 2 cas (connecté au compte client ou pas). Il n'y a que les produits en page d'acceuil qui ne peuvent être ajoutés au panier si le client est connecté. Dans la console Chrome, je n'ai aucune erreur sur la page d'accueil, juste ceci : call 4 JsWidget.js:98 window loaded JsWidget.js:114 jQuery defined Cela semble correspondre à mon module d'avis.Je l'ai désactivé pour test mais le problème persiste. J'ai activé le mode Debug mais aucune erreur n'apparait. J'ai également testé une solution d'Eolia sur le forum qui disait que cela pouvait venir des cookies de Chrome, mais après avoir vidé le cache Chrome, rafraichi la page, le problème demeure. J'ai testé avec Firefox, le problème est le même Je vous remercie par avance pour votre aide ou pistes éventuelles
  2. Bonjour à tous Je sollicite un peu d'aide en CSS afin de changer l'emplacement d'un button en front office. Il s'agit du boutton à la page Récapitulatif du panier "Modifier le point relais" du module Mondial Relay. Celui apparait lorsque vous avez choisi Mondial Relay comme transporteur et un point relais de livraison.Actuellement il est placé à droite et collé à "Point relais sélectionné" J'aimerais simplement le placer comme visible sur la pièce jointe, sous l'adresse du point relais. Dans la console, j'ai ces informations : - HTML : <button id="mondialrelay_change-relay" type="button" class="btn btn-primary" style="margin-left: -180px; margin-top: 95px; margin-bottom:10px;"> <i class="icon-pencil"></i> Modifier le Point relais </button> et en CSS : .btn-primary { color: #fff; background-color: #428bca; border-style: none; J'ai bien réussi à le placer là ou je veux en rajoutant ce CSS dans le fichier modules/mondialrelay/front/checkout/relay-summary.tpl : style="margin-left: -180px; margin-top: 95px; margin-bottom:10px;" mais je crois savoir que cela n'est pas vraiment recommandé. Lorsque j'inspecte l'élément : j'ai cette info : button#mondialrelay_change-relay.btn.btn-primary Comment créer une nouvelle règle CSS qui ne s'appliquerai qu'à ce bouton et dans quel fichier placé le nouveauu CSS.Dans le global.css du thème ? J'ai bien essayé de mettre ceci dans global.css mais cela ne marche pas : button#mondialrelay_change-relay.btn.btn-primary {margin-left: -180px; margin-top: 95px; margin-bottom:10px;} Un lien vers le site : https://www.mangalatitude.fr/ Je vous remercie pour votre aide Prestashop 1.6.1.16 Thème par defaut bootstrap Module Mondial Relay V3.0.2
  3. Oui, je suis injuste sur ce coup car il m'est arrivé souvent de solutionner mes problèmes grâce aux réponses de pointures du forum (merci Eolia, Doekia, et tous les autres) J'étais juste un peu amer car là, je demandais juste aux utilisateurs de MR de me dire si leur module se comportait comme le mien, j'avais pensé puisqu'il ne s'agissait pas de trouver une solution à un problème, que j'aurais eu un peu plus de retour Mais tu as raison, c'est la loi d'un forum et je te remercie pour ton retour, ainsi que toutes les personnes qui m'ont un jour dépanné. Mea culpa ! Bonne journée à tous
  4. Bonjour Joept69 Merci pour ta réponse qui me rassure un peu concernant Mondial Relay. De toute façon, je n'ai plus qu'a attendre la reprise du réseau MR pour voir si cela ne vient pas d'un bug sur mon shop. Il est parfois très difficile sur ce forum d'obtenir de l'aide, a voir le nombre de réponse reçue pour une simple question alors que je ne demandais aucune aide particulière. mais bon ca fait parti du jeu, ma question a surement dû paraître sans interêt Pour DPD, je ne peux malheureusement pas t'aider, je n'utilise pas ce transporteur. Bon courage et bonne continuation
  5. Bonjour Kerlin, merci pour votre réponse Non, en effet il n'y avait pas de trace des tables du modules productcomments dans PHpMyAdmin En fait, j'ai téléchargé un autre zip du module donné par Doekia dans un autre post sur le forum et je viens de l'installer sans problème. Je ne sais pourquoi, la version est identique au module que j'avais téléchargé sur Github, c'est à dire la la V 3.6.1. Encore merci pour votre retour
  6. Bonjour à tous J'utilise Prestashop 1.6.1.16 avec le thème par défaut bootstrap J'essaie d'installer le module "Commentaires produits" natif V3.6.1 (que j'avais désinstallé) mais une fois le module chargé, j'ai bien le message en BO "le module a été installé avec succès" mais impossible de le retrouver dans le back office. J'ai chargé le module sur github : https://github.com/PrestaShop/productcomments/releases, en choissisant la version V3.6.1, celle qui était incluse dans le pack Prestashop 1.6.1.16 Pire, il n'apparait pas dans le dossier module sur mon FTP Je précise : - j'ai bien bien séléctionné "Modules installés et non installés", "Activés et désactivés" et "Tous" - Je suis connecté en tant que Super Admin - les droits sur le dossier module sont en 755 - je n'ai pas de cache serveur D'ou peut provenir ce problème ? Merci pour votre aide
  7. Rebonjour à tous Pas d'utilisateur de Mondial Relay ? J'ai édité le titre du post qui n'était peut-être pas très clair. Merci pour vos retours
  8. Bonjour à tous Dès que j'ai appris que Mondial Relay ne fonctionnait plus suite à la crise sanitaire en France, j'ai désactivé le transporteur Mondial dans ma Boutique Prestashop. Suite à des modifications apportées à mon site (passage à la page standard One Page Checkout, installation d'un nouveau module de paiement), j'ai réactivé le transporteur Mondial Relay en back office pour voir si l'OPC fonctionnait. Sauf que maintenant lors d'une commande test lorsque je choisis Mondial Relay, les points relais s'affichent bien mais je ne peux pas en sélectionner un en particulier. Le module Mondial Relay se comporte-t-il de la même manière dans vos boutiques (impossibilité de sélectionner un point relais) ou est-ce le module sur ma boutique qui bugge depuis mes mises à jour ? Je me dis que Mondial Relay ayant fermé, ils ont peut-être interrompu "la passerelle" qui lie le module Prestashop Mondial relay à leur système et que ce problème vient de là. Quelqu'un peut-il confirmer qu'il est actuellement normal de ne pas pouvoir sélectionner un points relais en particulier, ou me fournir des informations ? Merci à tous pour votre aide
  9. Un grand merci Eolia, J'ai désactivé ce que vous me demandiez dans le thème via l'admin et ca fonctionne. Par contre je conserve la première version de la règle : .order .container {width: 100%;max-width: 100%} car si je mets : .order-opc .container {width: 100%;max-width: 100%} les éléments s'affichent alors sur l'intégralité de la page sans respecter les marges à droite et à gauche comme sur le reste du site. Merci Eolia et bonne soirée à vous
  10. Je viens de rajouter la règle dans global.css mais rien n'y fait Je m'occupe de voir vos dernières instructions Merci encore
  11. Merci pour votre aide Eolia, le thème c'est default-bootstrap et voici l'URL de ma page one page checkout : la règle .order .container {width: 100%;max-width: 100%}, je la place dans global.css ou order-opc.css ? Je vous remercie pour votre aide et votre temps
  12. Bonjour Eolia Merci pour votre réponse mais je parlais de .col-sm-9 et pas de col-lg-9. Si je comprends bien il faut modifier la largeur du container mais ou ? Je ne vois rien dans la console qui fait référence à la largeur d'un container quand j'inspecte le code de la page.
  13. Bonjour à tous Prestashop 1.6.1.16 / theme : default-bootstrap Après 2 heures de recherches et de test, je sollicite votre aide pour un souci d'affichage de la page "one page checkout" Je joins une capture d'écran En fait je souhaiterai simplement que les éléments de la page s'affichent sur toute le largeur de la page. En cherchant avec la console Chrome, ces éléments me renvoie vers global.css et en particulier : @media (min-width: 768px) .col-sm-9 { width: 75%; Ok, mais si je passe le width à 100%, les éléments de la page opc s'affichent bien sur toute la largeur mais cette modification à des conséquences désastreuses sur les autres pages du site. J'ai aussi essayer de modifier le fichier order-opc.css en rajoutant width:100% à #order-opc mais cela ne fonctionne pas. Je vous remercie par avance pour votre aide
  14. Ok, je m'incline si ca ne sert à rien mais ca me chiffonne, j'aimerais comprendre pourquoi Google ne prend pas en compte mon display-font ! pour la règle comme ceci, dans le global css : @font-face { font-family: 'FontAwesome'; font-display : swap ou fallback; src: url("../fonts/fontawesome-webfont.eot?v=4.3.0"); src: url("../fonts/fontawesome-webfont.eot?#iefix&v=4.3.0") format("embedded-opentype"), url("../fonts/fontawesome-webfont.woff2?v=4.3.0") format("woff2"), url("../fonts/fontawesome-webfont.woff?v=4.3.0") format("woff"), url("../fonts/fontawesome-webfont.ttf?v=4.3.0") format("truetype"), url("../fonts/fontawesome-webfont.svg?v=4.3.0#fontawesomeregular") format("svg"); font-weight: normal; font-style: normal; } et dans le header : <link rel="preload" href="FontAwesome.woff2" as="font" type="font/woff2" crossorigin="anonymous"> Merci pour votre temps
  15. Bonjour Je vous remercie pour vos réponses mais si je m'y intéresse, c'est que j'ai dans l'outil un triangle rouge (le seul) signifiant sûrement que ce point mérite mon attention. Mais malheureusement vos réponses ne m'aident guère, sinon je suis d'accord avec vous pour dire qu'il ne faut pas prendre au pied de la lettre tous les résultats de ces audits. Auriez-vous une piste pour m'aider à résoudre ce point : " Utilisez la fonction d'affichage de la police CSS afin que le texte soit visible par l'utilisateur pendant le chargement des polices " Je pensais le résoudre en rajoutant font-display mais visiblement cela ne suffit pas à Google. Merci pour votre attention
  16. Bonjour à tous Prestashop 1.6.1.16 / thème de base default-bootstrap Page Speed Insights me notifie : " Assurez-vous que le texte reste visible pendant le chargement des polices Web " avec comme recommandation :" Utilisez la fonction d'affichage de la police CSS afin que le texte soit visible par l'utilisateur pendant le chargement des polices Web" Après avoir effectué des recherches, j'ai rajouté un font-display dans le css de mon thème à la règle @font-face. J'ai choisi comme variable et l'ai donc rajouté au global.css : font-display: block J'ai également rajouté au header.tpl demon thème : <link rel="preload" href="FontAwesome.woff2" as="font" type="font/woff2" crossorigin="anonymous"> Mais rien n'y fait, Google me notifie toujours le problème. Que faire pour résoudre ce point ? Merci pour votre aide, je désespère de le résoudre et pourtant ce n'est pas faute d'avoir cherché !
  17. Je continue mes investigations.... J'ai donc récupérer l'ID du module et les tables dans lequel cette ID se trouvait : ps_module, ps_module_acces, ps_module_group et ps_module_shop. Si je supprime toutes ces entrées, le module sera-t-il supprimé ou je dois faire autre chose, supprimer après le dossier via FTP ??? Cette solution est-elle propre ? Quelqu'un pour confirmer svp ?
  18. Bon, je me reponds à moi-même : il est fortement déconseillé de supprimer un module directement par FTP Par contre, est-il possible de supprimer ou désactiver le module en allant dans la BDD ? Je me suis connecté à ma BDD et le module apparait bien (vaec le nom d'origine du module alors que je l'ai renommée) Un peu d'aide serait la bienvenue Merci à tous
  19. Ok, en renommant le dossier du module, j'ai récupéré le BO et le FO Le problème est qu'en renommant le dossier, il n'est plus visible dans la liste des modules, je ne peux donc pas le désinstaller Peut-on supprimer un dossier de module via FTP sans risque ? Merci pour votre aide
  20. Bonjour à tous J'ai installé un module gratuit sur ma boutique 1.6.1.16, Il semblait fonctionner....en tout cas en FO Mais en retournant dans le BO, je m'apercois que je n'ai plus d'accès à la plupart des fontionnalités du Bo et l'icone du pinguoin ne cesse de s'actualiser (les flèches tournent sans cesse) Le FO est également figé Le problème : le bug m'empêche également de supprimer le module depuis la liste des modules. J'ai renommer le dossier du module mais cela n'y fait rien. Est-il possible de supprimer directement le dossier du module via le FTP sans risques ? Je vous remercie pour votre aide
  21. Bonjour à tous Je suis en prestashop 1.6.1.16 Suite à une migration de ma BDD, je m'apercois que certains produits n'ont pas été importés. Je tente de les importer via la fonction import en utilisant l'ID du produit. Mais j'ai ce message d'erreur : 2 erreurs Nom du produit (ID: 8528) ne peut pas être enregistré Property Product->width is not valid Je précise que dans mon fichier import .CSV, je n'ai pas de colonne "width" car je ne me sers pas des dimensions des produits. J'ai vérifié dans la BDD si le produit existait et il existe bien en fait !! Et je ne vois rien d'anormal lorsque j'edite le produit, en tout cas pas dans la table ps_product ! Mais il n'apparait pas dans la liste des produit en BO, impossible de le retrouver en tapant l'ID ou la référence du produit. Quelqu'un a-t-il déjà rencontré ce problème ? Merci à tous pour votre aide
  22. Un petit up car j'ai bien trouvé des tutos concernant la migration d'un site en local vers un serveur ou d'un serveur à un autre serveur mais pas de renseignement concernant mon cas de figure. Et une précision que j'ai oublié de vous livrer : je souhaite changer d'hébergeur. Je vais donc mettre fin à mon offre d'hébergement sur laquelle est mon site en production et souscrire à l'offre qui héberge actuellement mon site en developpement Peut-être auriez des pistes à me communiquer concernant les modifs à effectuer mis à part changer le nom de domaine et le chemin du dossier dans l'administration ?
  23. Bonjour à tous J'ai déjà un site un production en version 1.4 dont le nom de domaine est www.monsite.fr J'ai effectué la migration de mes données de 1.4 vers un prestashop 1.6 hébergé (online) dont le nom de domaine est .devmonsite.fr (sans les www devant) Je souhaiterais savoir lorsque le site sera achevé, quelle modification ou manipulation devrais-je effectuer sur le site en developpement (.devmonsite.fr) pour retrouvé mes URLS d'origine. Suffira-t-il de remplacer dans l'onglet Preférences > SEO & URLS dans les champs "URLs de la boutique" : - Domaine de la boutique :" .devmonsite.fr" par" www.monsite.fr" - Domaine SSL : " .devmonsite.fr" par" www.monsite.fr" - Chemin de base : je laisse "/" puisque les 2 sites sont à la racine du serveur Y-a-t-i d'autre chose à prévoir ? Peut-être regénéré le .htaccess ? Je vous remercie pour vos conseils
  24. Bonjour Eolia Bien merci mais cela va un peu trop vite pour moi ! Plutôt que de cacher mon site en dev avec le nom de domaine de mon site en production, ne serait-il pas plus judicieux de prendre un autre nom de domaine (fantaisiste !) et de le modifier par la suite par mon vrai nom de domaine (tout ceci dans le champ "nom de domaine" de mon presta de dev) ? C'est possible cela ?
  25. Bonsoir Eolia Merci pour ta réponse, j'ai noté cette solution mais malheureusement je ne pas comment inclure le chemin vers mon site dans le fichier htacess J'ai trouvé ceci à inclure dans mon htacess : AuthUserFile /var/www/vhosts/mon-site.com/httpdocs/.htpasswd AuthName "Zone protégée par mot de passe" AuthType Basic <limit GET POST> require valid-user </limit> Mais la première ligne me pose problème.L'URL de mon site en dev est du type : https://monsite.000webhostapp.com/ Avec cette URL, je ne sais pas comment compléter la première ligne : AuthUserFile /var/www/vhosts/mon-site.com/httpdocs/.htpasswd Je ne souhaite pas me rater vu les conséquences Pourrais-tu m'expliquer comment rédiger la première ligne du code ? Merci
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More