Jump to content

semor

Members
  • Posts

    429
  • Joined

  • Last visited

Everything posted by semor

  1. J'alimente le topic de mes dernières informations. Le debug profiler m'affiche une page blanche sur toutes les pages (meme CMS), sauf sur un produit --' Qui plus est un produit sans remise ! J'avoue ne rien y comprendre. Un peu d'aide serait très appréciable
  2. Je précise aussi que en activant le report d'erreur, je n'ai aucune erreur affiché. Donc je suis perduuuuuuu..
  3. Bonjour à tous, une petite question pour une réponse qui me serait forte utile ! Sur un PS 1.5.6, Je souhaite activer le Debug Profiler (comme je fais déjà sur d'autres sites que je gére), mais malheureusement j'ai une super page blanche en front office qui s'affiche.. Je précise que le Debug Profiler fonctionne en back office. C'est assez fâcheux Avez vous des idées la dessus ? Je suis preneur si modification du code Merci à tout ceux qui me répondront !
  4. Rien du tout malheureusement --' La seule chose que j'ai trouvé c'est le module que j'ai mis en lien. Autrement je suis autant surpris que vous que ça n'est pas prévu de base à Prestashop.
  5. Désolé de déterrer ce sujet, mais ce bug est toujours prèsent ! Et je ne sais pas quoi faire pour le résoudre.. HELP Je confirme également que mon PS 1.5.6 venant d'une version plus ancienne (1.4), j'ai également le champ id_product_2 dans la table ps_specific_price en Unique. Champ qui n'existe pas sur une version fraiche en PS 1.5.
  6. Bien le bonjour, Tu n'es pas le seul à avoir ce soucis la, moi aussi.. Et je n'ai pas trouvé d'autres topics, ni meme en anglais qui en parle :/
  7. Autant pour moi je n'avais pas vu que tu voulais juste le nom, j'aurais pu te donner le code Tant mieux si tu l'as, pense à mettre [RESOLU] dans le nom du topic Hum sur le coup je n'ai pas compris ton message Loulou66, je sors l'id fabricant {$packItem.id_manufacturer} Ce code permet d'afficher les images des fabricants des produits du pack. Ma fonction 'getItemTable' (je ne me rappelle pas l'avoir modifier pour ma part, et aucun override) : public static function getItemTable($id_product, $id_lang, $full = false) { if (!Pack::isFeatureActive()) return array(); $sql = 'SELECT p.*, product_shop.*, pl.*, MAX(image_shop.`id_image`) id_image, il.`legend`, cl.`name` AS category_default, a.quantity AS pack_quantity, product_shop.`id_category_default`, a.id_product_pack FROM `'._DB_PREFIX_.'pack` a LEFT JOIN `'._DB_PREFIX_.'product` p ON p.id_product = a.id_product_item LEFT JOIN `'._DB_PREFIX_.'product_lang` pl ON p.id_product = pl.id_product AND pl.`id_lang` = '.(int)$id_lang.Shop::addSqlRestrictionOnLang('pl').' LEFT JOIN `'._DB_PREFIX_.'image` i ON (i.`id_product` = p.`id_product`)'. Shop::addSqlAssociation('image', 'i', false, 'image_shop.cover=1').' LEFT JOIN `'._DB_PREFIX_.'image_lang` il ON (i.`id_image` = il.`id_image` AND il.`id_lang` = '.(int)$id_lang.') '.Shop::addSqlAssociation('product', 'p').' LEFT JOIN `'._DB_PREFIX_.'category_lang` cl ON product_shop.`id_category_default` = cl.`id_category` AND cl.`id_lang` = '.(int)$id_lang.Shop::addSqlRestrictionOnLang('cl').' WHERE product_shop.`id_shop` = '.(int)Context::getContext()->shop->id.' AND a.`id_product_pack` = '.(int)$id_product.' GROUP BY product_shop.id_product'; $result = Db::getInstance(_PS_USE_SQL_SLAVE_)->executeS($sql); foreach ($result as &$line) $line = Product::getTaxesInformations($line); if (!$full) return $result; $array_result = array(); foreach ($result as $prow) if (!Pack::isPack($prow['id_product'])) $array_result[] = Product::getProductProperties($id_lang, $prow); return $array_result; }
  8. Bonjour, C'est la faute d'une extension Google ou Firefox (Dingo Deals), tu ne peut rien faire contre ça. C'est sur le navigateur de ton client, ce n'est pas de ressort. Dis lui de desinstaller l'extension qui doit lui pourrir la vie en plus
  9. Ca devrait t'aider (si c'est bien ça que tu veux dans product.tpl) : {if $packItems|@count > 0} {foreach from=$packItems item=packItem} <a href="{$link->getPageLink('manufacturer.php',true)}?id_manufacturer={$packItem.id_manufacturer}" style="margin-right:5px"><img src="{$img_manu_dir}{$packItem.id_manufacturer|escape:'htmlall':'UTF-8'}-medium_fab.jpg" alt="$product->name" /></a> {/foreach} {elseif $product->id_manufacturer} <a href="{$link->getPageLink('manufacturer.php',true)}?id_manufacturer={$product->id_manufacturer}"><img src="{$img_manu_dir}{$product->id_manufacturer|escape:'htmlall':'UTF-8'}-medium_fab.jpg" alt="$product->name" /></a> {/if}
  10. Bonjour, bonjour, Dans le dossier modules/loyalty/loyalty.php normalement. A partir de la ligne 430 pour les hooks.
  11. Bonjour, bonjour ! Alors tout dépends ce que tu sous entends par 'personnalisable', mais regarde déjà celui d'origine ensuite à l'époque de PS 1.4 il y avait un module 'Advanced Search 4' qui était vraiment bien mais non porté sur PS 1.5.
  12. Quel est la version de Prestashop utilisé ? Avez vous regardé du coté du Github Prestashop, si c'est un problème détecté et résolu ?
  13. Bonjour, bonjour, Deux petites choses avant de commencer à creuser ton problème, un lien de ton site peut être ? Afin d'y jeter un oeil Le dossier Img est configuré avec en récursif 777 ?
  14. Ah d'accord dans l'utilisation de produits numériques je peut tout à fait comprendre ! Je voyais mal dans l'utilisation de produits physiques l’intérêt de ça en fait, autant pour moi.
  15. Bonjour, Tout dépends du budget que tu souhaite mettre, mais ton topic n'est pas vraiment bien placé (plutôt dans module payant, ou discussion générale). Ensuite un petit tour sur addons : http://addons.prestashop.com/fr/recherche?search_query=exportation Ou bien ici : http://www.prestatoolbox.fr/search.php?orderby=position&orderway=desc&search_query=export&submit_search=OK Et tu verras pas mal de modules différents qui peuvent correspondre à ta requête. Si tu veux un module gratuit, je te conseille la recherche dans le forum ou bien l'utilisation de l'export produit intégré déjà dans Prestashop. Cordialement.
  16. Bonjour, bonjour, Juste par curiosité, quel est l’intérêt de ça ? Il va être alerté, brusqué, et il va partir parce qu'il aura une fenêtre du genre Pop-up qui va débarquer en lui disant qu'il à déjà commandé ça (Enfin moi je vois ça comme ça... Je suis peut être anormal )
  17. (Déterré un article vieux de trois ans pour faire de la publicité pour votre module, c'est un peu too much non ? ) PS : Ma remarque n'est pas méchante, et je comprends que vous souhaitez vendre votre module aux plus nombreux mais le faire sur des posts plus récents c'est peut être mieux PS2 : Peace
  18. Bonjour, C'est assez bizarre si vous avez fait un sous dossier, que vous avez copié exactement la même chose, et que la ça fonctionne :/ Avez vous essayé de re-uploader tout sur la racine ?
  19. Bonjour, Ah oui gros soucis la Dans un premier temps oui le cache, sinon si tu ne te sers pas du module ' Expertise Prestashop' tu peut le désactiver. A ce que je vois dans ton screenshot, c'est ce module la qui coince.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More