Jump to content

Jean Francois G

Members
  • Posts

    1,692
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by Jean Francois G

  1. Bonjour a tous. Sur une nouvelle boutique qui soit être mise en prod pour le 1er Janvier, après avoir créé une regle panier (donc un code promo), la case "code promo" n'apparait pas dans le résumé, ni sur la page avant le paiement. Le site est en 1.5.6.1. Créé à partir d'un presta vierge, et utilisant la dernière version du thème arundo. J'ai fait le test avec le thème par défaut et pas de case non-plus. Y a t'il quelque chose à activer sur la 1.5.6.1 pour faire apparaitre cette case ? Est ce un bug connu de la 1.5.6.1 ? J'ai cherché sur tout le forum et tenté de mettre en place des soluces données pour la 1.5.3, mais rien n'a changé. J'ai besoin de votre aide d'urgence. Car sinon je ne pourrais pas mettre le site en prod à la date prévue. Merci d'avance. ps (j'active le site pendant une journée pour que vous puissiez constater le problème)
  2. as tu bien vérifié le bon nom du fichier image concerné (il y a plusieurs dossiers d'images et donc plusieurs possibilités d'adresses ? Passes tu par SSH ? Après avoir fait la modif, verifie tu un peu plus tard que le CHMOD à bien fait la modif en 444 et qu'il l'est toujours ? Car passer le fichier en droits 444 signifie : Aucun droit de modification autorisé ni au public, ni au propriétaire, ni aux utilisateurs avec pouvoirs. Aucun droit d’exécution (idem que precedemment) Droit de lecture uniquement Donc le logo ne peut plus être changé, ni par le module lui même, ni par paypal.
  3. de mon coté je me dis aussi : Pourquoi des modules externes sont ils proposés directement dans la liste des modules par défaut ? Ils devraient être comme tous les autres : Dans les plateformes d'achats de modules. D'autant que ces mêmes modules ne peuvent même pas être supprimés de la liste. C'est carrément une mise en avant qui penalise d'autres concepteurs qui pourraient proposer des modules équivalents. Ce que je trouve encore moins normal, c'est l'impossibilité de supprimer de la liste pas défaut ces fameux modules. Et ils sont nombreux ces modules inutiles et qui nous sont "fortement recommandés". Quelqu'un sait il d'ailleurs comment les virer de la liste des modules ?
  4. Une cliente souhaiterais me passer une commande avec une adresse de livraison "armée" de type SP 85012, 00806 ARMEES Comment puis je faire avec prestashop et quels sont les procédures vis à vis de la poste pour ce genre d'adresse ? Merci a tous
  5. Problème, nous n'avons pas accès au "avancées" car les droits ont été restreints. Je n'ai que accès au modules simples.
  6. Bonjour, Le site d'un ami, que j'ai récupéré dernièrement (le site, pas l'ami) est à l'abandon car son ancien administrateur/hebergeur à fermé et à déposé le bilan (en encaissant bien sur les sommes de toute l'année..) et à modifié avant de partir toutes les données admin du site sans les lui donner . J'ai découvert que ce prestataire à déclaré les domaines sous sa propriété propre (sauf un nom en .fr ou apparait l'adresse mail de mon ami, mais impossible de récuperer le domaine quand même) donc impossible de récupéré l'administration des domaines et le back office du client est réduit au minimum avec juste les droits d'installation et utilisation des modules, aucune autre possibilité de faire quoi que ce soit. En gros il s'est fait entubé comme un bleu en faisant 100% confiance à son prestataire L'idée est de faire une redirection 301 sur le htaccess pour pointer sur le nouveau site qui est en cours de conception. Mais comme le FTP n'est plus accessible, et l'administration du domaine non plus, il est impossible d’accéder au fichier. Il y a la possibilité d'une redirection javascript via un module html, mais cela ne va pas plaire du tout pour le SEO.. Quelle possibilité puis je avoir sur ce presta 1.4 pour accéder au htaccess depuis le back office seulement afin de le modifier ? Existe t'il un module gratuit pour accéder au fichier (je rends service, donc investir dans un module.. arf) ? Merci d'avance de vos réponse qui lui sauveront peut être son magasine et son référencement.
  7. Merci a vous deux, il faut donc que je transfert mon dossier image à chaque fois sur mon 2eme hebergement quand je crée des articles. Merci pour ceette précision !
  8. J'ai appliqué un chmod en 0444 sur le fichier image correspondant. Par contre je l'ai fait en SSH directement sur le serveur linux car avec filezilla ca ne fonctionnait pas (filezilla me disait que les droits étaient changés mais ce n'était pas vrai et ils restaient en lecture/ecriture). Donc en faisant la manip via SSH, l'image n'a plus changée et ce depuis juillet 2013
  9. Ce qui tourne en arrière plan est correct puisqu'il s'agit du serveur mail, su service de sécurité du virtualiseur de l'anti-virus etc.. Peut être que vous avez tout simplement un module ou un programme indésirable dans votre site, et celui ci s'accapare les ressources du serveur. Pour ce qui est du mail, vous pouvez désactiver le serveur en désinstallant l'appli (avec "apt get remove") ou en stoppant le service avec la ligne : postfix stop Vous pouvez gagner en ressources aussi en désinstallant l'anti-virus qui n'est pas obligatoire. Et en dernier, si les php-CGI pose problème, désactivez les. A noter que de toute manière le soucis vient de votre coté car ce comportement n'a été aucunement rapporté sur les dizaines de serveurs qui ont utilisés le tuto. Il va falloir fouiller dans le camboui..
  10. Lorsque des CDN sur un domaine extérieur sont créés et configurés, si l'on crée de nouveaux articles, ou les images sont elles enregistrées ? Dans chaque CDN + dans le site principal ? Dans tous les CDN mais pas dans le site principal ? Dans un seul CDN et le site principal ? Sur le site principal et pas dans les CDN ? Car comment prestashop fait il pour obtenir les droits d'écriture sur le CDN pour y insérer de nouvelles images ? Tout ce la est un mystère pour moi que j'aurais bien aimé lever .. Quelqu'un aurait il des réponses à m'apporter ? Merci d'avance !
  11. Il y a de fortes chances qu'effectivement le secure key ne correspondent pas au hashage du mot de passe. Les deux sont en intime relation, puisque c'est le secure key qui va permettre de décoder le mot de passe (pour ne pas que n'importe qui puisse, via un utilitaire, décodé à la volée tous les mots de passe du site). Je pense qu'il faut réencoder tous les mot de passe le bon secure key et cela devrais rentrer dans l'ordre.
  12. Malheureusement non, et aucune réponse de personne pour ce problème. Ni du staff prestashop ni des utilisateurs..
  13. je viens de me remettre sur ce projet que j'avais abandonné faute de temps.. Bon la je vais l'abandonner faute de comparateur. Effectivement, les inscriptions sont fermés et d'après un échange avec la personne qui s'en occupe, ils vont passer en payant. Bon ça aurait du être fait depuis longtemps mais bon.. En tous les cas, le projet de ce comparateur n'est plus viable pour les utilisateurs de prestashop => on oublie.
  14. selon les versions c'est dans /cache/smarty/cache et cache/smarty/compil à vérifier sur votre ftp on peut aussi vider le cache du thème. le cache va se restructurer de lui même avec les informations a jour. Quelques fois, après avoir modifier un fichier on oublie de le tester en vidant le cache et on est persuadé que tout est ok. Puis un jour on vide le cache et la.. boum tout est changé ! Donc, une sauvegarde est en tous les cas conseillée avec chaque modif de fichiers.
  15. Le problème est sans doute cela. Vous créez avec des données qui ne sont pas complètes, j'irais même jusqu'a dire franchement partielles. Hors ce n'est pas parce que les catégories sont dans un des fichiers articles qu'elles sont automatiquement créées dans le fichier "catégories" De plus si vous recreez des catégories identiques à celles manquantes, les ID de ces catégories ne correspondront pas à celles de l'importation et cela ne changera rien. A mon sens, soit vous avez la sauvegarde complète de votre base de données et vous l'importez correctement soit vous recréez tout de A a Z. Mais je peux me tromper..
  16. Non vous devez modifier les css. Pour cela utilisez l'outil "firebug" proposé par l'explorateur internet "firefox" Grace à cet outil, vous allez pouvoir "pointer" le bouton ou la ligne ou le block que vous voulez déplacer et firebug vous donnera le nom du fichier et les lignes à changer. De plus vous pouvez faire un essai "en live" pour voir les modifs en local. Un bijou en somme..
  17. votre problème est apparu comme ça tout seul ou avez vous fait des modifs avant ? L'installation est neuve ou date t'elle déja ?
  18. perso j'ai juste modifié le product.tpl pour qu'il ne s'affiche que lorsque le stock est <=0 C'est encore le plus logique.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More