Jump to content

belialek

Members
  • Posts

    13
  • Joined

  • Last visited

belialek's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hello, I would like to show customers accessories (bottom of product page) with actual price, old price and reduction percent like they can see at main product page - by default it;s only actual price. How can i do it?
  2. Wyczyściłem cache przeglądarki i... faktycznie działa już sie przeraziłem, bo walczę od kilku godzin z odpaleniem SSL i myślałem że przez te eksperymenty połozyłem sklep. Przepraszam za zamieszanie i dziękuje za pomoc - idę kombinować dalej z SSL
  3. Witam, Mam problem ze sklepem na prescie 1.6 - otóż na wersji 1.4 sklep działał pod adresem w tym momencie wpisanie takiegro adresu skutkuje biała stroną z informacją "strony nie znaleziono" lub zostaje traktowane jako zapytanie google (firefox). Co ciekawe, można wejść np na konkretny link w sklepie" ale już po kliknięcie w logo (które powinno przenieść na stronę główną) znowu lądujemy na nieodnalezionej stronie. Sama strona główna działa, można na nią wejść ręcznie wpisując dopisując /pl/ za adresem . Wcześniej działało bez zarzutu bez konieczności dopisywania przedrostka języka w adresie - w tej chwili nie działa nawet przekierowanie z google, które do tej pory kierowało do . Co mogę zrobić, aby to działało poprawnie?
  4. Witam, W sklepie włączone są 4 języki, 3 z nich działają normalnie (Polski, Angielski, Niemiecki) ale jeden (Hiszpański) niestety powoduje pewne problemy - mianowicie nie można przejść przez proces zamówienia: Página no disponible Lo sentimos, la página no se encuentra disponible. Para buscar un artículo, por favor, indique su nombre en el siguiente campo: Ten komunikat pojawia się już po kliknięciu w check-out (/es/order?step=1) i każdy kolejny krok powoduje taki sam błąd (jedynie /es/order.php działa poprawnie) - w przypadku pozostałych języków strona wyświetla się normalnie... Gdzie mogę szukać przyczyny? PS 1.4.2.5
  5. Tak, wiem - ale nie mam pojęcia jak to "wyciągnąć" i wrzucić do warunku... Czy ta zmienna jest w jakiś sposób gdzieś przechowywana w jakiejś zmiennej globalnej, czy jakoś samemu ją trzeba wyciągnąć? Generalnie podejście obiektowe to dla mnie czarna magia, więc poruszam się po tym pliku jak dziecko we mgle...
  6. Witam, Potrzebuję wykonać modyfikację (PS 1.4), umożliwiającą ustawienie kwoty od której obowiązywać będzie darmowa przesyłka. Do tej pory częściowo udało mi się uzyskać taki efekt modyfikując plik classes/cart.php, ale niestety nie jest to do końca to czego oczekuję. if ($orderTotalwithDiscounts >= (float)($free_fees_price) AND (float)($free_fees_price) > 0 AND (int)$id_zone == 9) Modyfikacja nalicza darmową przesyłkę od danej kwoty dla każdego klienta na terenie Polski, a mi zależy na ustawieniu różnej kwoty dla różnych grup klientów, np: grupa A - darmowa dostawa od 300zł grupa B - darmowa dostawa od 600zł W jaki sposób zmodyfikować ten warunek, aby brał pod uwagę grupę klienta? Nie wiem w jakiej zmiennej przechowywana jest informacja o grupie (domyślnej) klienta... Bardzo proszę o pomoc. EDIT: ewentualnie, żeby chociaż ten warunek podany wyżej ograniczał się dla jednej grupy klientów - tej drugiej mogę dodawać darmową przesyłkę kodem rabatowym (jakby nie brak możliwości określenia kraju w kodach rabatowych, to bym z braku laku obie grupy tak obsługiwał, no ale niestety...)
  7. Witam, Czy komuś się udało zmusić szablon mobilny (Mobile Theme, presta 1.4.2.5) do współpracy z językiem polskim? W katalogu z modułem są tylko 4 języki (brak polskiego). W panelu administracyjnym w dziale "Tłumaczenia -> Moduły" są tylko pola z tłumaczeniem back office... Próbowałem skopiować plik w katalogi modułu lang/de.php i zmienić mu nazwę na pl.php ale w dalszym ciągu po wybraniu języka polskiego mam wszystkie komunikaty po angielsku, czyli raczej w ten sposób nie zrobię sobie tłumaczenia... Będę wdzięczny za każdą pomoc Pozdrawiam!
  8. Witam, Po instalacji modułu PrestaShop Mobile Template zarówno na podglądzie w konfiguracji modułu jak i na przeglądarkach mobilnych wyświetla się pusta, biała strona... Gdzie mogę szukać problemu?
  9. Dołączę sie do pytania - u mnie również produkty powiązane się nei wyświetlają. Na stronach produktów powiązanych pojawia się zakłądka "Zobacz też" ale jest pusto. Po usunięciu powiązania zakładka znika. Tutaj przykład dwóch powiązanych produktów - jak widać zakłądka "Zobacz też" sie pojawiła. http://prestashop.su...troller=product http://prestashop.su...troller=product Tutaj powinno być widoczne powiązanie - nie robiłem większych zmian w plikach tpl, zresztą po wrzuceniu oryginalnych katalogów katalogu modules oraz themes z paczki instalacyjnej w dalszym ciągu jest tak samo. Być może coś źle robię? W edycji produktu klikam w opcję "Powiązania", wybieram docelową kategorię produktu, na dole wpisuję nazwe powiązanego produktu i klikam "Zapisz". Po odinstalowaniu moduły dodającego zakładkę "Produkty powiązane" jest tak samo (zresztą przed jego instalacją też tak było). Czy ewentualnie istnieje jakiś moduł umożliwiający powiązanie produktu omijając ten niedziałający u mnie mechanizm Presty? Bardzo prosze o pomoc
  10. Dziękuję - w tej chwili strona już w miare działa. Niestety na stronei głównej jak i na każdej podstronie otrzymuję komunikat "Strona niedostępna Niestety podany przez ciebie adres URL nie jest dostępny Aby wyszukać produkt wpisz jego nazwę". Po zmianie domeny wygenerowałem na nowo plik .httaccess tak więc już nie mam pojęcia gdzie szukać przyczyny... W zapleczu widać wszystkie kategorie, produkty, zdjęcia... Skórka też wygląda poprawnie tylko jest problem z tą zawartością. Będę wdzięczny za dalszą pomoc. Pozdrawiam! EDIT: Pomogło włączenie rewrite_module na serwerze Idę walczyć dalej...
  11. Witam, Zabieram się do aktualizacji Presty z 1.4 do 1.5 - w celu weryfikacji wykonanych kopii plików oraz bazy danych chciałem uruchomić sklep na swoim PC. Po odtworzeniu bazy oraz skopiownaniu plikow zostaję automatycznie przekierowany pod adres internetowy mojego sklepu - czyli po wpisaniu localhost/presta zostaję przenoszony na adres www.sklep.pl. Czy coś jeszcze trzeba zmienić/ustawić? Boję się ruszać czegokolwiek na serwerze produkcyjnym, dopóki nie będę pewny że w każdej chwili będę mógł odtworzyć kopię zapasową. Z góry dziękuję za pomoc i pozdrawiam!
  12. Witam, Mam problem, z którym nie mogę sobie poradzić w żaden sposób - podczas wykonywania zakupów w innej walucie niż PLN, kwota przekazywana do zapłaty (moduł Przelewy24) zostaje przeliczona zgodnie z kursem ustawionym w Prescie ale waluta w dalszym ciągu to PLN. W rezultacie towar wart np 100 PLN, zostaje przez Prestę poprawnie przeliczony na 23.99 EUR, natomiast wg modułu przelewy24 jest to 23.99 PLN i taka kwota widnieje w każdej formie płatności oferowanej przez tego usługodawcę... Tak jakby po drodze była gubiona/ignorowana informacja o walucie. Będę wdzieczny za każdą sugestię...
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More