Jump to content

wmunich

Members
  • Posts

    160
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by wmunich

  1. Hi, war mir bei dem Thema auch unsicher und muss ganz ehrlich sagen das mir die Rechtstexte immer sehr "schwammig" vorkommen und für den "normal" Bürger auch schwer verständlich sind - jedenfalls für mich. Jedenfalls wollte ich sicherheitshalber auch die Artikel Eigenschaften (Material usw.) im Warenkorb und habe es gelöst in dem ich die shopping-cart-product-line.tpl vom theme erweitert habe. Weiß ja nicht ob Du ein eigenes theme verwendest und es anpasst oder die .tpl überschreibst. Hiermit werden alle Eigenschaften ausgegeben - ich habe es direkt unter den product-name gepackt. {assign var='features' value=Product::getFrontFeaturesStatic($cookie->id_lang, $product.id_product)} {if isset($features) && $features} {foreach from=$features item=feature} {if isset($feature.value)} {$feature.name|escape:'htmlall':'UTF-8'}: {$feature.value|escape:'htmlall':'UTF-8'}<br> {/if} {/foreach} {/if} Gruß, Tom PS: Falls es eine besser/schönere Lösung gibt dann "lyncht" mich nicht gleich (;
  2. Hi, im admin Bereich wirst Du das gleiche Problem haben d.h hier auch die fonts einfach mit den originalen überschreiben ... zu finden in \admin...\themes\default\fonts\* Komischerweise hatte deine font im frontend Bereich 1 byte weniger wie es haben sollte ... warum auch immer. Gruß, Tom
  3. Hi, nein die kommt nicht falsch von PS! Es ist auch klar das Du im Editor nur die "" siehst da der editor ja nichts von "fontawesome" weiß. Und Du hast die global.css sicher nicht editiert? Schieb mal die original global.css die Du dir gerade runtergeladen hast, ohne diese zu editieren und im UTF-8 Format mal auf deinen Server. Zusätzl. überschreibst bitte auch mal alle fonts in deinem Verzeichniss \themes\default-bootstrap\fonts\* mit den original files. Eins von beiden muss korrupt sein! Gruß, Tom
  4. Hi, meiner Meinung nach hat die global.css ein falsches Format - nicht UTF-8. Entweder falsch auf den Server übertragen oder am server falsch abgespeichert. Wenn Du irgendwo ein backup hast öffne sie in einem Editor der dir das Format anzeigt Notepad++/PsPad o.Ä und check das Format. Dann neu auf den Server schieben aber hier ebenfalls die Transfer settings prüfen. Gruß, Tom
  5. Hi, hier musst Du nicht die ip von deinem Server eintragen sondern die ip von der Du aus Zugriff haben möchtest ... versuch mal http://www.myip.ch/ Gruß Tom
  6. Hi, wenn ich das richtig sehe werden bei Dir keine .js (jQuery usw.) geladen, das natürlich einige Fehler verursacht - schön zu sehen in der Konsole. Weiter bindet sich Dein "cookieNotice" im <head> ein das dort natürlich nicht hingehört sondern in den <body> ... hast zufällig deine header.tpl editiert (; ? Gruß Tom
  7. Hmmm sorry dann weiß ich leider auch nicht weiter ... sehr seltsam das ganze. Da kann ich Dir jetzt nur Glück wünschen das sich noch ein PS Profi einschaltet!
  8. Deine Parameter im script Tag fehlen ... hast Du "HTMLPurifier verwenden" wirklich auf nein? Und unter Erweiterte Einstellungen > Leistung mal auf "Templates nach Datei-Änderungen neu kompilieren" setzen
  9. Nein ist alles richtig, wenn Du dein snippet im quelltext der Seite so siehst wie in deinem screen, also mit den parametern "data-gwid="PZ2303-416" data-siegel-variante="float-left" data-siegel-breite="150" id="gw-siegel-script"" nur ohne den type liegt das Problem wo anders! Sagt denn die JS Fehlerkonsole etwas? Bzw. ein Link zu deinem Shop würde helfen? Ansonsten kann man nur raten... Das kann man nicht schön reden, ein vserver ist schon Aufwand und konfiguration/security und und und haben mich einige Nächte gekostet da ich auch kein Sysadmin bin.
  10. Und was stört Dich daran? Nur das type="text/javascript" fehlt? ... das ist total egal für das ausführen von js Wo kommen denn eigentlich die Punkte "ueft...et" im src Pfad her? Du kopierst dein snippet schon komplett rein oder? Ich bin auch bei Strato allerdings selbstversorger, hatte zuvor einen root server und jetzt bin ich auf einen vserver zwecks Preis umgestiegen. Weiß schon jeder schimpft über Strato aber ich kann mich nicht beschweren ... habe 9 Domains (7 WP und 2 PS) am laufen und bin zufrieden. Mein Spezl schimpft aber auch übelst über sein Hosting Paket.
  11. Das dachte ich mir ... ein normales Paket ist einfach zu schwach. Hab gerade mit einem Spezl tel der ebenfalls ein Paket bei Strato hat ... dort läuft kein modSecurity. Also habe ich dein Problem jetzt auf die schnelle mal nachgespielt, mach mal bitte folgendes 1. Im Admin-Bereich auf Voreinstellungen > Allgemein dort "HTMLPurifier verwenden" ausschalten 2. Im Admin-Bereich auf Erweiterte Einstellungen > Leistung dort "JavaScript ans Ende verschieben" ausschalten 3. Im Modul htmlBox dein snippet einfügen aber mittels Tools > Source Code - ohne deinen div aussenrum Das sollte dann klappen... .
  12. Hmmm ... ich kenne mich bei den Webhosting Paketen von Strato nicht wirklich aus allerdings scheint es mir unwahrscheinlich das Strato Dir bei einem normalen Webhosting Paket Zugriff auf diese Einstellungen ermöglicht. Such mal in deinem Kundenlogin nach ModSecurity/Firewall/SiteLock ob Du da was findest und es eventl. beeinflussen kannst. Rein aus Interesse, welches Paket hast Du denn dort und wie flüssig läuft PS?
  13. Wollte gerade noch Anmerken "wenn das Modul bei Dir läuft" (-; ModSecurity ist ein Apache Modul das zusätzliche Sicherheit bietet. Weiß ja nicht bei welchen Hoster Du bist aber falls Du Plesk oder cPanel o.Ä am laufen hast dann findest Du dort die Möglichkeit das Modul zu aktivieren/deaktivieren.
  14. Hi, das Editor Problem hatte ich auch, bei mir war es modsecurity da es meinte das ich eine code injection starte ... testweise mal deaktivieren! Erklärt allerdings nicht warum es nicht funktioniert wenn Du es direkt in .tpl kopierst. Gruß Tom
  15. Hi, wenn Du es nicht dem Zufall überlassen möchtest welches img wo angezeit wird kannst Du es einfach über css lösen. Bei PS wird ja das body tag mit einer id bzw. class produziert somit kannst du z.B für die Kategorien ein anderes bg image setzen wie auf der Startseite. Also z.B die Startseite hat als body id "#index" die Kategorien "#category" die CMS Seiten "#cms" wenn Du es noch mehr aufbröseln möchtest musst Du über die class definition gehen, konkret im deinem Shop für die Kategorie "Herrenduft" wäre das also ".category-10 .category-herrenduft". Gruß Tom
  16. Hi, liegt vermutlich an deinem ExpiresDefault, lieber etwas granualer handhaben - willst ja deinen content immer aktuell halten. Hier z.B meine <IfModule mod_expires.c> ExpiresActive On ExpiresByType image/gif "access plus 1 month" ExpiresByType image/jpeg "access plus 1 month" ExpiresByType image/png "access plus 1 month" ExpiresByType text/css "access plus 1 week" ExpiresByType text/javascript "access plus 1 week" ExpiresByType application/javascript "access plus 1 week" ExpiresByType application/x-javascript "access plus 1 week" ExpiresByType image/x-icon "access plus 1 year" ExpiresByType image/svg+xml "access plus 1 year" ExpiresByType image/vnd.microsoft.icon "access plus 1 year" ExpiresByType application/font-woff "access plus 1 year" ExpiresByType application/x-font-woff "access plus 1 year" ExpiresByType application/vnd.ms-fontobject "access plus 1 year" ExpiresByType font/opentype "access plus 1 year" ExpiresByType font/ttf "access plus 1 year" ExpiresByType font/otf "access plus 1 year" ExpiresByType application/x-font-ttf "access plus 1 year" ExpiresByType application/x-font-otf "access plus 1 year" </IfModule> Gruß Tom
  17. Das findest Du so in keiner css Datei, musst hinzufügen! Hast also noch kein eigenes css? Kommt ja drauf an was Du so vor hast mit deinem Shop aber eventl. mal überlegen ob ein eigenes nicht sinnvoll wäre > https://dh42.com/free-prestashop-modules/prestashop-free-css-module/ (Modul) > https://www.prestashop.com/forums/topic/466057-solved-additional-custom-css-where-to-place/ (ohne Modul) Wenn nicht dann am einfachsten in die \themes\default-bootstrap\css\global.css Wiso willst Du die Höhe ändern? passt sich ja autom dem Inhalt an bzw. nach (glaub ich) 350 Zeichen kommt ja eh ein "mehr"
  18. Wenn Du nur den zweiten Titel (links von Artikel-Anzahl) in allen Kategorien ausblenden möchtest dann #center_column .page-heading .cat-name { display: none; }
  19. Also Du hast einen Versanddienst mit Spanne usw. angelegt? Diesen Versandienst hast Du dann einem Produkt zugeordnet? oder nur "Zusätzliche Versandkosten (pro Stück)" mit 2€ festgelegt? Und dein Produkt kostet auch brutto unter 15€?
  20. Mal dumm gefragt - Versandkostenfreigrenze überschritten?
  21. Hi, du willst den span mit der class cat-name aus der category.tpl rausnehmen? Ja klar kannst Du das machen, ist halt beim nächsten PS update wieder da aber denk das ist Dir klar. Ansonsten natürlich einfach mittels css ausblenden. Gruß, Tom
  22. Hi, der wird mittel javascript dort plaziert also entweder machst Du es Dir einfach .cart_block_list #payWithAmazonCartDiv { display:none } oder aber du sorgst dafür das er nicht hinzugefügt wird, dafür musst du allerdings ins Modul und die js editieren \modules\amzpayments\views\js\amzpayments.js (pay) \modules\amzpayments\views\js\amzpayments_login.js (pay und login) Gruß, Tom
  23. Hi, also ich blende ihn einfach mittels JS aus ... ansonsten musst glaub ich schon einen Eingriff im Modul machen. Gruß, Tom
  24. Das kann nichts mit dem neugernieren der Bilder zu tun haben...an anderen Ecken auch rumgespielt? Du hast die "neuen produkte" und "empfohlene Produkte" ja in der sidebar und auf der http://s454224513.online.de/index.php?id_product=2&controller=product&id_lang=1 z.B sind sie noch drin nur auf der Startseite fehlen sie. Cache schon gelöscht?
  25. Rumspielen ist immer gut (-; Hmmm, die formate sehen eigentlich ganz gut aus. Was mir auffällt ist das Du noch "home_default" etwas anpassen könntest. Dir fehlen jetzt auch nur noch die Bilder in deinem Carousel oder? Welches Modul verwendest Du da und verwendet dieses Modul "m_scene_default" Ansonsten sind die Produktbilder jetzt gut? Lösch bei Gelegenheit mal deinen Cache (Erweiterte Einstellungen / Leistung / cache löschen), besonders wenn Du die Bilder auf der Startseite bearbeitet hast!
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More