Jump to content

manulito

Members
  • Posts

    76
  • Joined

  • Last visited

Everything posted by manulito

  1. hi, yes, when you give a credit slip for an order where a discount has been used, the amount of the credit slip is the amount without discount, so he receives more money than he spent... eg: order 100€ and discount 20€ => payed 80€ credit slip =>100€ is it clear ?
  2. i ve got the same problem, still unsolved... nobody met the same problem with 1.5.4.1? how can we fix this order slips problem please?
  3. bonjour, up aussi j'ai toujours ce problème... cela devient de plus en plus embêtant car les avoirs faux s'accumulent... pas encore de solution trouvée ?
  4. bonjour, merci de vous interesser à mon problème, je l'avais reprise dans les fichiers de l'admin,voici le code: (j'ai fais un essai de traduction en passant par $module->l('First Name') à la place de $this->l('First Name'), comme dans certains modules, mais ca n'a rien changé..) public function renderList() { $module = new mwdconcessionnaires(); $this->addRowAction('view'); $genders = array(); $genders_icon = array('default' => 'unknown.gif'); foreach (Gender::getGenders() as $gender) { $gender_file = '../genders/'.$gender->id.'.jpg'; if (file_exists(_PS_IMG_DIR_.$gender_file)) $genders_icon[$gender->id] = '../'.$gender_file ; else $genders_icon[$gender->id] = $gender->name.'.jpg'; $genders[$gender->id] = $gender->name.'.jpg'; } $this->_select = 'a.*, a.id_employee as idEmployee, a.id_customer as idCustomer, a.id_customer as idCustomerAdd, a.id_customer as idCustomerOrd, gl.`name` AS Cname, ad.id_address AS id_address, ad.phone AS phone, ad.phone_mobile AS phone_mobile'; $this->_join = ' LEFT JOIN `'._DB_PREFIX_.'address` ad ON (ad.`id_customer` = a.`id_customer`) LEFT JOIN `'._DB_PREFIX_.'orders` o ON (o.`id_customer` = a.`id_customer`) LEFT JOIN `'._DB_PREFIX_.'customer_group` cg ON (cg.`id_customer` = a.`id_customer`) LEFT JOIN `'._DB_PREFIX_.'group_lang` gl ON (gl.`id_group` = cg.`id_group` AND gl.`id_lang` = '.$id_lang = (int)Context::getContext()->language->id.') '; $this->_where = 'AND cg.`id_group` NOT LIKE 1 AND cg.`id_group` NOT LIKE 37 AND cg.`id_group` NOT LIKE 38 AND cg.`id_group` NOT LIKE 43 AND cg.`id_group` NOT LIKE 44';/**/ if($this->context->employee->id){ $idEmployee = $this->context->employee->id; $employeeGroup = Db::getInstance()->getValue(' SELECT `concession` FROM `'._DB_PREFIX_.'employee` WHERE `id_employee` LIKE '.(int)$idEmployee); $this->_where .= ' AND gl.`name` LIKE \''.$employeeGroup.'\''; } $this->_where .= ' GROUP BY id_customer'; $this->_orderBy = 'Cname'; $this->_orderWay = 'ASC'; $this->fields_list = array( 'id_customer' => array( 'title' => $this->module->l('ID') ), 'id_gender' => array( 'title' => $this->l('#'), 'width' => 50, 'align' => 'center', 'icon' => $genders_icon, 'orderby' => false, 'type' => 'select', 'list' => $genders, 'filter_key' => 'a!id_gender', ), 'firstname' => array( 'title' => $module->l('First Name'), 'havingFilter' => true ), 'lastname' => array( 'title' => $this->l('Last Name'), 'havingFilter' => true ), 'email' => array( 'title' => $this->l('Email') ), 'phone' => array( 'title' => $this->l('Phone') ), 'phone_mobile' => array( 'title' => $this->l('Mobile') ), 'idCustomerOrd' => array( 'title' => $this->l('Nb Orders'), 'callback' => 'getCustomerNbOrders', 'orderby' => false, 'search' => false ), 'id_address' => array( 'title' => $this->l('Address?'), 'width' => 70, 'align' => 'center', 'type' => 'bool', 'callback' => 'printAddressIcon', 'orderby' => true, 'filter_key' => 'id_address' ), 'newsletter' => array( 'title' => $this->l('News.'), 'width' => 70, 'align' => 'center', 'type' => 'bool', 'callback' => 'printNewsIcon', 'orderby' => true ), 'optin' => array( 'title' => $this->l('Opt.'), 'width' => 70, 'align' => 'center', 'type' => 'bool', 'callback' => 'printOptinIcon', 'orderby' => true ), 'catalogreceived' => array( 'title' => $this->l('Catalog received'), 'width' => 70, 'align' => 'center', 'type' => 'bool', 'callback' => 'printCatalogIcon', 'orderby' => false ), 'idEmployee' => array( 'title' => $this->l('Account creator'), 'callback' => 'getEmployeeName' ), 'Cname' => array( 'title' => $this->l('Concession') ), 'active' => array( 'title' => $this->l('Active'), 'active' => 'status' ) ); $lists = parent::renderList(); // Check if we can add a customer /*if (Shop::isFeatureActive() && (Shop::getContext() == Shop::CONTEXT_ALL || Shop::getContext() == Shop::CONTEXT_GROUP)) $this->can_add_customer = false; */ $this->can_add_customer = true; parent::initToolbar(); $html = ''; if (Tools::getValue('export')) $this->csvExport(array('layers' => 2, 'type' => 'line', 'option' => '1')); $html .= ' <p><a class="button export-csv" href="'.Tools::safeOutput($_SERVER['REQUEST_URI']).'&export=1&exportType=1"><span>'.$this->l('CSV Export').'</span></a></p>'; $this->content=$html; return $lists; }
  5. bonjour, sur ps 1.5.4.1 j'ai eu ce problème lors de la migration vers la 1.5, que j'ai contourné en reconstruisant la table a la mano. mais maintenant lorsque j'édite la réf fournisseur d'un produit, la réf est bien mise a jour dans la table ps_product_supplier, mais la table ps_product non... et c'est par exemple ce champ qui est utilisé dans l'affichage des produits en liste dans l'admin... j'ai lu dans le bug tracker que c'etait résolu, avec un lien vers la classe cart.php, hummm je ne vois pas bien le rapport avec le probleme vu que c'est dans l'édition d'un produit et non en rapport avec le panier, et ca ne corrige pas ce souci en tout cas. est ce que les corrections que vous faites pourraient résoudre aussi ce probleme? est ce qu'il y a un post avec une solution que je n'ai pas vu? merci d'avance pour votre aide.
  6. ce n'est pas dans les tuyaux, donc tous les avoirs générés sur des commandes avec réduction sont fausses ? et personne ne s'inquiète ? je ne comprends pas le "on demande l'inverse" (le post donné en lien est mon post, avant de trouver celui-ci, je ne vois pas "l'inverse") l'inverse voudrait dire qu'il y aurait donc des vendeurs qui veulent que lorsqu'ils font des avoirs à leurs clients, si ces derniers ont payé 80€ en utilisant un bon de réduction, qu'ils récupèrent 100€ ? c'est bien ca ? si oui, pouvez-vous me donner les coordonnées de ces gens que j'aille vite passer plein de commandes, pour les annuler ensuite, et qu'ils me génèrent plein d'avoirs supérieurs à mes paiements ? plus sérieusement, je trouve votre réponse un peu étrange, si je l'ai bien comprise...
  7. Bonjour, j'ai un problème de traduction des entetes des colonnes de la liste des clients, par mon module qui reprend l'affichage d'origine des clients. l'affichage est nikel, les traductions de la vue de chaque client est bien traduit. il ne me manque que les titres des colonnes... si quelqu'un a une idée.. j'ai beau chercher sur la forge, sur le forum, mais rien n'a marché pour le moment... Merci d'avance
  8. bonjour, une correction ok, mais sur quels fichiers ? quels lignes ? je ne peux pas remplacer tous les fichiers de ma boutique en production par des fichiers "en développement"... merci d'avance
  9. bonjour, un petit up, j'ai remarqué le meme soucis, personne d'autre n'a ce problème ???? je suis sur ps 1.5.4.1
  10. Bonjour, sur ps 1.5.4.1 lorsque je génère un avoir pour une commande sur laquelle un bon de réduction a été utilisé, l'avoir se fait sans tenir compte du bon de réduction, et donc l'avoir est plus important que ce qui a été payé. exemple: une commande avec un produit à 100€, 10€ de fdp, un bon de réduction de 20€. le client va payer 90€, très bien. je rembourse la commande+fdp: l'avoir sera de 100€ + 10€, soit 110€. disparus les 20€ de réduction, ce n'est pas pris en compte... je ne trouve aucun message à ce sujet sur les forums, ni en fr ni en uk, et rien non plus sur la forge. a croire que personne n'utilise de bon de réduction, ni d'avoirs... ou alors le bug n'est que chez moi mais je n'ai pas fait de modification spéciale.. si quelqu'un a le meme problème qu'il se manifeste, on sera 2 ^^ et si quelqu'un a une solution, ca serait fantastique ^^ et juste une remarque personnelle en voyant tous ces messages restants sans réponse sur les forums, j'ai l'impression que depuis cette 1.5, les problèmes sont beaucoup liés aux modules installés, et certains problèmes vont apparaitre pour certaines personnes mais pas pour d'autres...
  11. Bonjour, de jour en jour, je trouve de nouveaux problèmes avec ce ps.... lorsque je veux importer 15 produits, j'obtient: 3262 erreurs (ID: No ID) ne peut pas être enregistré Property Product->name is empty (ID: No ID) ne peut pas être enregistré Property Product->name is empty (ID: No ID) ne peut pas être enregistré Property Product->name is empty (ID: No ID) ne peut pas être enregistré Property Product->name is empty ...................etc................................... j'utilise le multiboutique, il y a en tout 4 boutiques. comment 15 produits sur 4 boutiques, en 5 langues (je n'ai renseigné que le francais pour mon import), ca peut donner 3000 erreurs ? ? ? et mes 15 produits sont bien créés, et tout est bien renseigné. mais quand mon client importe des produits, et qu'il obtient 3000 erreurs, j'ai beau lui dire, mais non ca marche quand meme, il ne trouve pas que ca marche..... ce qui est un peu normal. d'ou peuvent venir ces 3000 erreurs ? merci pour votre aide
  12. ALLO ?????????? pourquoi personne ne répond a mes questions ici ??? sur les problemes de 1.4, j'avais toujours des réponses, des idées, la plus rien ......
  13. Bonjour, lorsque je veux modifier un trnasporteur sur ps 1.5.4.1, j'ai ce message et ca me créé un nouveau transporteur a chaque fois, que je ne peux supprimer.... [PrestaShopException] Property Carrier->max_weight is not valid at line 837 in file classes/ObjectModel.php 831. 832. $message = $this->validateField($field, $this->$field); 833. if ($message !== true) 834. { 835. if ($die) 836. throw new PrestaShopException($message); 837. return $error_return ? $message : false; 838. } 839. } 840. 841. return true; ObjectModelCore->validateFields - [line 265 - classes/ObjectModel.php] - [0 Argument] ObjectModelCore->getFields - [line 599 - classes/ObjectModel.php] - [0 Argument] ObjectModelCore->update - [line 1536 - override/classes/controller/AdminController.php] - [0 Argument] AdminController->processDelete - [line 1478 - override/classes/controller/AdminController.php] - [0 Argument] AdminController->postProcess - [line 580 - controllers/admin/AdminCarriersController.php] - [0 Argument] AdminCarriersControllerCore->postProcess - [line 158 - classes/controller/Controller.php] - [0 Argument] ControllerCore->run - [line 349 - classes/Dispatcher.php] - [0 Argument] DispatcherCore->dispatch - [line 50 - matgestion/index.php] - [0 Argument] j'ai trouvé ca sur le forum, mais la table est déja comme ca: el upgrade que hace la 1.5.4.1 es este: ALTER TABLE `PREFIX_carrier` CHANGE `max_weight` `max_weight` DECIMAL( 20, 6 ) NULL DEFAULT '0'; j'espere que quelqu'un aura eu ce problème, j'ai souvent l'impression d'etre le seul a rencontrer ces problèmes vu le peu de messages traitant le meme probleme... Merci d'avance ! edit: ps 1.5.4.1 sur dédié
  14. Bonjour, sur ps 1.5.4.1, sur serveur dédié dans le bo, dans la page catalogue, la case "Filtrer par catégorie" est décochée par défaut, pas de problème. si je la coche, la liste des catégories apparait bien, et je peux naviguer, c'est ok. Mais si après ca je veux voir tous les produits, je décoche la case ou je clique sur "réinitialiser", la page se recharge, mais la case est toujours cochée.... et impossible de la décocher... je ne peux donc pas faire de filtre sur ton mon catalogue, seulement catégorie par catégorie.... est ce que quelqu'un aurait une solution ? merci d'avance
  15. up? personne n'a ce problème ??? j'ai l'impression que plus personne ne répond aux problèmes sur cette 1.5... énormément de problèmes sur le forum restent sans réponses....
  16. Bonjour, sur ps 1.5.4.1, sur dédié. j'ai un probleme avec l'affichage des références fournisseur, par exemple sur le détail des produits d'une commande, si la référence commence par un 0, il est tronqué. ex: 08976 s'affiche 8976 dans le code du tpl (_product_line) il n'y a aucune mise en forme particulière de la référence. si quelqu'un a une solution, je suis preneur ! merci d'avance
  17. Hi, i tried this, the id_cart appear in the $params, but still empty... but i think i understood the problem: i use this module and this hook on the create order, in BO, but when the page is loaded, the cart doesn t already exists. it s created in the db when a customer is selected. so when the form.tpl or my module is loaded, the cart_id is empty because there is no cart_id defined... how can i check the cart_id when an event is done? the best would be when the user is selected. i don t think there is a hook called when this action is done, do you know how i could create a hook for this ? Edit: i found in the doc 1.5 this: These objects are only accessible for the customer Context: Customer. Existing customer retrieved from the cookie or default customer. Cart. Current cart. Controller. Current controller instance. These objects are only accessible for the administrator Context: Employee. Current employee. does it mean i can t access to the cart objet by the context if im in BO ? thanks for your help
  18. Hi, i tried this, but the cart_id is not in it: Context Object ( [cart] => [customer] => [cookie] => Cookie Object ( [_content:protected] => Array ( [date_add] => 2013-04-26 10:13:09 [id_lang] => 2 the cart and customer object seems to be empty... i created a hook, i put the call in the override: override/controllers/admin/templates/orders/form.tpl i inserted a line in the db to declare it. the module is correctly hooked and appears i did a print_r() on $params, but nothing about the cart seems to be here: Array ( [cookie] => Cookie Object ( [_content:protected] => Array ( [date_add] => 2013-04-26 10:13:09 [id_lang] => 2 [id_employee] => 1 => [email protected] [profile] => 1 [passwd] => xxxxxxxxxxxxxx [remote_addr] => 1828729758 [shopContext] => s-1 [checksum] => 144873194 ) [_name:protected] => 89507f35cd1520b511e921cf45c2dd8a [_expire:protected] => 1368695949 [_domain:protected] => www.1000mat.com [_path:protected] => /new/ [_cipherTool:protected] => Rijndael Object ( [_key:protected] => 1I2sbNIAYUfaFyxh7MuLkBVXqp6nLCGT [_iv:protected] => [����-m+�̩��� ) [_key:protected] => 0FsfNUYOYf97jFTJCtjgScEsuK2KtjNPNW8kiu17RMN2ou6IIJDBxCCa [_iv:protected] => i28IUZNe [_modified:protected] => [_allow_writing:protected] => 1 ) [cart] => [altern] => 1 )
  19. Hi i m still looking for a way to get the cart_id when i create an order in the back office. in front, i get it in the context, $this->context->cart->id but in BO, if i print_r($this->context) the cart id doesn t appear to be stored here. does anybody know how i could access this id? it s created as when i look the DB, the cart is here... thanks for your help ^^
  20. Bonjour, petite question à laquelle je ne trouve pas de réponse sur le net, j'aimerai dans l'admin avoir un module qui regroupe le formulaire de création de compte et celui de création d'adresse, comme pour le front office. j'ai bien réussi à avoir la copie du formulaire compte client qui s'affiche par mon module, mais comment y intégrer le formulaire adresse? j'ai essayé de reprendre les champs du formulaire adresse que j'ai mis dans le renderform() de mon controller adminclients.php, le formulaire a bien maintenant les champs d'adresse, mais le problème est pour l'enregistrement. sachant que dans le models est défini la table, qui est customer, et la je dois toucher 2 tables, customer et address. donc 2 models? je suis un peu perdu. si quelqu'un a une idée ou une piste, elle sera la bienvenue ^^ merci d'avance Manu
  21. je me suis dis pareil, j'ai fait une recherche avec dreamweaver de id_orders sur tout le dossier prestashop, et aucun résultat...
  22. Bonjour, j'ai créé un module qui reprend entre autre la liste des commandes, toute la liste s'affiche bien, mon problème est lorsque je veux voir le détail d'une commande, au lieu de passer en paramètre l'id_order, il mets un id_orders sans valeur sorti de je ne sais où... du coup, erreur sur la page de détail, mais si je modifie dans l'url le ..&id_orders=&... par ...&id_order=1234&..., alors le détail de la commande 1234 s'affiche bien. le problème vient donc du lien généré pour voir le détail. j'ai fait la meme chose avec les clients, et la pas de problème pour voir ou éditer une fiche. quelqu'un aurait une idée d'ou peut venir le problème? merci d'avance
  23. Bonjour, même problème, j'ai téléchargé la version svn et récupéré le module blockacategories, je l'ai installé, réinitialisé, et là, le module apparait bien, sur le coté et dans le footer.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More