Jump to content

yvanb

Members
  • Posts

    274
  • Joined

  • Last visited

Posts posted by yvanb

  1. Bonsoir et désoler pour ce silence...

     

    J'ai uploadé un module 1.6 sans Jquery et sans Captcha, normalement, il fonctionne, je n'arrive toujours pas à faire fonctionner la version Jquery, j'ai la même erreur que beaucoup "Se produit ne semble pas exister" sur les produits qui ne sont pas rattaché à la catégorie Accueil/Home...

     

    Normalement, l'archive 1.6 que je viens d'envoyé fonctionne, elle est en service sur ma propre boutique et fonctionne quel qu’en soit le produit... Effectivement, le fait d'enlever le Jquery, le formulaire "BetterPrice" apparait dans le code source de la page. Mais bon, ça fonctionne.

     

    Nous allons nous pencher sur le sujet avec okom3pom.

  2. Bonsoir, oui c'est normale, car vous demander au formulaire de "s'envoyer" et de fermer la fenêtre en même temps alors que le résultat de l'envoi du formulaire doit s'afficher dans cette fenêtre... (J’espère que c'est pas trop confus). C'est pour cela que le code que je vous ais donner devrait fermer la fenêtre après le résultat d'envoi du formulaire....

     

    Je vais testé deux trois solutions et vous fait un retour. ;)

    • Like 1
  3. Bonjour à tous

    Merci a vous deux pour ce beau travail, betterprice_1.responsive_captcha, fonctionne très bien chez moi sur version 1.6.11. Comme je t'ai dit si possible que le formulaire se ferme tout seul une fois envoyé ? Amitiés

    Bonjour, oui cela doit être faisable en ajoutant ceci:

    	                        parent.$.fancybox.close();
    

    Après ça :

    				$("#betterprice_frm").hide();
    

    dans le fichier views/js/betterprice.js. Cette manip est une hypothèse, je ne l'ai pas encore testée.

     

     

    Bonjour,

     

    c'est marrant ça, chez moi il n'affiche pas la vignette image 0-medium_default/.jpg

    et j'ai toujours le message: Ce produit ne semble pas exister.

    Effectivement, je me suis aperçu que sur certains produits, ça ne marchais pas... Et je n'arrive pas à en déterminé la cause, même si je soupçonne une histoire de URL rewriting/URL SEO.

    • Like 1
  4. Bonjour,

     

    j'ai une erreur de syntaxe à l'installation :

    Fatal error in module betterprice:
    syntax error, unexpected '.2' (T_DNUMBER)
    

    Version:   BetterPrice 1.6 Modal PS 1.6x

    Cdt...

    Bonsoir, re-téléchargez l'archive, le soucis devrait être corrigé.

     

    Salut 

    Merci encore pour ce partage, C'est possible que le formulaire se ferme tout seul une fois envoyé ? Amitiés

    Oui, cela devrait être faisable, je vais regarder ça ;)

    • Like 1
  5. Bonjour et désoler pour ma réponse super tardive.

     

    Je pense que mon topic est devenu obsolète à partir du moment, où, okom3pom à fait son module gratuit Loi Hamon, disponible ici compatible 1.5 et 1.6. Merci à lui :)

     

    Je reste quand même dispo si vous préférez, ou continuez, à utiliser ma méthode "barbare", que j'utilise toujours personnellement avec quelques améliorations, notamment en utilisant l'override pour éviter de tout refaire à chaque MAJ de PS. ;)

     

    @houin, le fichier cgv_fr.pdf (et/ou cgv_en.pdf), doivent être créées à la main puis déposer dans le dossier /docs/

  6. Bonjour et désole pour ce déterrage. La version de Matt75 est partiellement compatible avec la version 1.6. Partiellement, car il n'est pas responsive.

     

    C'est pour cela que je viens d'adapter le module de Matt75 sur la version 1.6 pour le rendre 100% responsive. Le module fonctionne très bien, il y a juste la page dans le backoffice qui présente une mise en page pas Top Top (surtout au niveau des boutons FR et EN qui sont des liens). Je vous envoi le module tel quel, il fonctionne, est stylé coter client. Voir Screenshot en dessous.

     

    [EDIT]

    La page du backoffice est devenu un peu plus jolie grâce à akom3pom. Merci

    [/EDIT]

    post-21246-0-00024000-1422956352_thumb.jpg

    post-21246-0-68459600-1422965363_thumb.jpg

    post-21246-0-30969300-1423220981_thumb.jpg

    post-21246-0-44451800-1423221149_thumb.jpg

  7. Bonjour et désoler pour mes réponses tardive. De Topic à totalement disparu de mon flux de sujet.

     

    Déjà, merci à vous pour le test sur la version 1.6. Une version responsive devrait être faisable, c'est juste une question de css.

     

    Je me remet au "turbin" pour tenter de vous sortir une version Responsive sur la 1.6 et corriger cette faille avec le SSL.

     

     

    compatible avec la 1.5.6.2 aussi. merci pour le partage, par contre la technique pour les catégories, c'est du viole de code les amis ! quand j'ai le temps je vous rajouterai le bout qu'il manque, mais faire ça comme ça, c'est un allé simple pour Guantanamo des développeurs :D

    Oui effectivement, c'est un peu "cochon" et une fonction intégré dans le back-office serait sympa...(Mais plus le temps :/)

     

    Super ce module!!!

     

    Je suis en train de l'installer sur 1.6 et tout est nickel

     

    Juste une question comment supprimer simplement le logo en haut a gauche du cadre de texte

     

    Merci d'avance

    Le logo est dans le .tpl, remplacez simplement la ligne :

          <td width="625" align="center" valign="top"><a href="{$base_dir}" title="{$shop_name|escape:'htmlall':'UTF-8'}"><img src="{$img_ps_dir}logo.jpg" alt="{$shop_name|escape:'htmlall':'UTF-8'}" /></td>
    
    Par ceci :
          <td width="625" align="center" valign="top"></td>
    
    

     

     

    Salut. 
     
    Je voudrais supprimer la photo sur le côté (femelle) et cms. Mon idée est de laisser seulement le logo de ma marque et le bouton entrer. Je que vous pouvez aider à faire les changements?. 
     
    Merci. Grande contribution

     

    Pour supprimer la demoiselle, editez le fichier disclaimer.jpg. Pour retirer la page CMS modifiez la ligne :

         <td rowspan="3" align="left" valign="top"><div style="height:385px;width:615px;overflow:auto;"><br /><p align="center"><font color="#FF0000" size="5" style="text-transform: uppercase; font-weight: bold;">{$cms_title}</font></p><font color="#000000">{$cms_content}</font></p></div></td>
    
    Par ceci :
          <td rowspan="3" align="left" valign="top"><div style="height:385px;width:615px;overflow:auto;"></div></td>
    

    Je tiens également à cette page d'accueil apparaisse toujours. J'ai essayé et affiche seulement la première fois, après que c'est comme si pour détecter les post précédent vous accéder à la page directemen

    Pour faire ceci, il suffit d'enlever la création du cookie dans le fichier hopopup.php, supprimez cette ligne :

     $hopopup_cookie_value = isset($_COOKIE[Configuration::get('HOPOPUP_COOKIE_NAME')]) ? $_COOKIE[Configuration::get('HOPOPUP_COOKIE_NAME')] : false;
    

    Ainsi que cette ligne :

    'hopopup_cookie_name' =>	Configuration::get('HOPOPUP_COOKIE_NAME'),
    

     

    Bonjour,

     

    J'ai installer le module sur la version 1.6.0.11 dernière née, il fonctionne très bien mais oui y a un mais  :)  il me fait une faille dans le protocole SSL de ma page.

    Comment je peut faire pour résoudre ce problème ???

     

    Merci d'avance de vos raiponces 

     

    Pascal

    Quelle est votre faille, effectivement je ne l'ai pas testé avec SSL.

     

    PS: Une version simplifiée a été créée à cette adresse : http://cyrilchalamon.fr/produit/popup-sur-page-daccueil-prestashop-1-5/

  8. Bonjour et désoler pour ma réponse très tardive.

     

    @Bodo502 : je ne veux pas dire de bêtises, mais le dossier \products dans le répertoire  override\controllers\admin\templates\ n'existe pas d'origine. Il faut le créer.

     

    Pour ce qui est du thème, il n'y a pas de dossier products, il faut modifier le fichier themes/votre_theme/product.tpl, comme indiqué dans l'archive ;)

  9. Bonsoir, après quelques recherche infructueuses, j'ai adapté un code pour avoir le PPC sur votre boutique, sans acheter de module. Testé à l'instant sur PS 1.6.0.9.

     

    Tout d'abord, vous devez vous rendre dans PhpMyAdmin pour ajouter un champ RRP dans la table ps_product. Utilisez cette requête :

    ALTER TABLE ps_product ADD rrp decimal(20,6) after price
    

    Ensuite, prenez l'archive jointe : RRP 1.6.0.9.zip et remplacez les fichiers.

    ATTENTION, l'archive contient le fichier original product.tpl du thème default-bootstrap !

     

    Pour mettre en place le RRP sur votre thème, éditez le fichier product.tpl comme ceci :

     

    Ouvrez product.tpl (celui de votre thème) et recherchez ceci :

    <!-- prices -->
    

    Ajoutez, juste en dessous, ceci :

    	{if $product->rrp|floatval}
    
    	<p>{l s='RRP:'} <strike>
    	{convertPrice price=$product->rrp} 
    	{if $tax_enabled && ((isset($display_tax_label) && $display_tax_label == 1) OR !isset($display_tax_label))}
    		{if $priceDisplay == 1}{l s='tax excl.'}{else}{l s='tax incl.'}{/if}
    	{/if}
    	</strike></p>
    	
    	<p>{l s='You Save:'}
    {if $priceDisplay >= 0 && $priceDisplay <= 2}
    		{convertPrice price=($product->rrp - $productPrice)}
    		{l s='(~'}{round((($product->rrp - $productPrice) / $product->rrp) * 100, 0)}%{l s=')'}
    		 
    	{elseif $priceDisplay == 1}
    		{convertPrice price=($product->rrp - $productPrice)}
    		 {l s='(~'}{round((($product->rrp - $productPrice) / $product->rrp) * 100, 0)}%{l s=')'}
    	{/if}
    	</p>
    {/if}
    

    Voila, le champ PPC/RRP apparait dans l'admin et si vous indiquez le prix, il sera automatiquement calculé sur la fiche produit avec et sans promotions. Il ne vous reste plus qu'à faire un tour dans les traduction de Prestashop pour traduire les nouvelles "variable" RRP.

     

    Voici ce que cela donne :

    post-21246-0-54829200-1412971820_thumb.jpg

     

    post-21246-0-00839900-1412971838_thumb.jpg

    • Like 1
  10. Bonsoir, j'ai me permet de remonter ce topic car depuis le passage de la 1.4.9 à la 1.6.0.6, je rencontre ce même soucis.

     

    Le module "Bloc Nouveaux Produit" ne n'affiche plus rien. Lorsque je clique sur Nouveaux Produits dans le footer, par exemple, j'arrive sur une page avec un joli message indiquant qu'il y a aucun nouveaux produits... Et ce, dans le bloc, sur le front (TAB) et sur la page dédié à cet effet... Hors, pas mal de mes produits on la mention NOUVEAU (le bandeau en biais à droite)...

     

    Une idée ?

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More