Jump to content

jfuentesp

Members
  • Posts

    16
  • Joined

  • Last visited

Posts posted by jfuentesp

  1. Hola albarelys, después de probar mil opciones cambiando programa, al final se me ha solucionado de la siguiente forma tan simple:

    entra al B.O. > Preferencias >Temas , pestaña de "Dispositivos móviles", dónde pone "Activar el tema móvil", deja marcada la casilla "Quiero desactivarlo".

     

    No es necesaria ya que el tema, por defecto, es responsive y debe generar alguna incompatibilidad .

  2. Hola,

     

    mis versiones coinciden con las tuyas, me dió el primer error y dejé la versión antigua al no verlo claro.

    Me surge una duda, finalmente la versión del módulo que has subido y te funciona ha sido añadiendo las dos líneas que comentabas o la versión original y el problema era que no forzabas la compilación?

     

    Muchas gracias y un saludo

     

    Lola

    Hola Lola,

    El módulo que me funciona es el original, sin necesidad de tocar las dos líneas.

    En mis pruebas anteriores, lo de modificar la líneas no me funcionó.

    Finalmente no he sabido si me funciona porque inicialmente no borraba el módulo y porque no forzaba la compilación, o era por ambas cosas. El caso es que haciendo ambas cosas (borrando y forzando compilación) funciona. 

    Saludos.

    • Like 1
  3. Por si mi experiencia le es de utilidad a alguien, relato mi proceso de cambio a Paypal SSL V3 a TLS:

     

    En mi caso utilizo Prestashop 1.4.11.0 y Paypal 3.4.5.

     

    Ante que nada, como siempre, realizo copias de seguridad de mi base de datos y también en este caso del módulo .../prestashop/paypal. Especialmente esta última opción nos será de gran ayuda por si nos surge algún tipo de inconveniente, ya que simplemente volviendo a copiarlo en el servidor, tendremos restaurada nuestra versión en funcionamiento.

     

    Descargo de Addons la última versión del módulo 3.8.1. y la guardo en mi equipo como fichero .zip

    Voy a la carpeta de Módulos de Prestashop y en la opción "Añadir un módulo desde el ordenado" añado el módulo Paypal 3.8.1.

    Compruebo que las opciones de Paypal son correctas (datos de identificación, Pago Express (sí), entorno en modo real (marcado) y guardo. Me aparece que ya puedo utilizar Paypal y efectuo un simulacro de compra por Paypal en mi tienda.

    Me aparece el siguiente mensaje de error (que tambié recibo por correo):

     

    PayPal response:
    TIMESTAMP -> 2014-11-28T18:57:52Z
    L_ERRORCODE0 -> 10472
    L_SHORTMESSAGE0 -> Transaction refused because of an invalid argument. See additional error messages for details.
    L_LONGMESSAGE0 -> CancelURL is invalid.
    L_SEVERITYCODE0 -> Error
    PayPal response:

    TIMESTAMP -> 2014-11-28T18:57:52Z
    L_ERRORCODE0 -> 10472
    L_SHORTMESSAGE0 -> Transaction refused because of an invalid argument. See additional error messages for details.
    L_LONGMESSAGE0 -> CancelURL is invalid.
    L_SEVERITYCODE0 -> Error

     

    Restauro las API de Paypal, pruebo a añadir en prestashop\modules\paypal\paypal_connect.php:

    @curl_setopt($ch, CURLOPT_SSLVERSION, 4);

               @curl_setopt($ch, CURLOPT_SSL_CIPHER_LIST, 'SSLv3');

     

    ¡Todo inútil! me sigue apareciendo el error.

     

    Finalmente he conseguido hacer funcionar el módulo mediante el siguiente proceso:

    -Borro la carpeta Paypal de la carpeta de módulos, en su defecto supongo que se puede suprimir el módulo desde la pestaña de módulos.

    -Instalo la nueva versión mediante la opción "Añadir un módulo a partir de mi ordenador"

    -Reinicio el módulo e introduzco los datos de configuración (opción Modo real) y mis API de Paypal.

    -Activo en la pestaña "Preferencias">"Rendimiento" la opción Forzar Compilación en "Sí" (recordar desactivarla después).

    ¡Funcionando!

     

     

     

  4. Hi mnementh64,

     

    I'm trying install your module in our shop (Prestashop 1.4.6.2): www.inteligentes.org/prestashop

    I have made the changes like you said in your blog:

    a) I have installed the second hack in the config.inc.php

    B) I have modiffied the line

    $pss_wpinps_install_dir = '/blog/';

    by

    $pss_wpinps_install_dir = Configuration::get('PRESTASCOPE_WPIPS_WP_DIR');

    Your modul isn't working.

     

    When the mouse is over "VISIT THE BLOG" the link is the same like our shop: www.inteligentes.org/prestashop

    Our blog is in: www.inteligentes.org/blog

    ¿what are we going doing wrong?

    Best regards

  5. Gracias.....

    Sí, shacker. Las imágenes de las categorías estaban ya creadas y se han regenerado.

    Tengo una duda...cuando hablas de crear en el BO las imágenes productos/prestabook y blockcaterory/categorías, la palabra "blockcaterory" ¿es correcta?, ó ¿debería ser: "blockcategory"?

    Otro detalle...(como puedes ver en: www.inteligentes.org/prestashop) el texto del catálogo me aparece en inglés. Supongo que es porque toma este idioma por defecto ¿dónde puedo seleccionarlo?

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More