Jump to content

payn4

Members
  • Posts

    52
  • Joined

  • Last visited

Everything posted by payn4

  1. POINTS DE RÉDUCTION quand le client a transformé ses pts de fidélité et que le vendeur annule la commande, le bon de réduction est conservé, les pts annulés. image Todo le bon doit être annulé en même temps que les pts de fidélité. Si le bon de réduction est généré à partir des pts de fidélité de plusieurs commandes et qu'une (ou x) commande(s) est(sont) annulée(s), déduire les pts générés par cette(ces x) commande(s) du montant total du bon de réduction (les pts de réduction sont quant à eux bien décomptés en fonction des produits/commandes annulés) dans history.php, si un bon a été utilisé, le montant du bon est barré => à changer ? image dans admin > clients > paniers le bon de réduction affiche -0,00€ image ____________________________________________ WISHLIST possibilité dans le BO de désactiver le bouton Ajouter à ma liste lorsque le produit est épuisé (utile pour ceux qui vendent des produits uniques) ____________________________________________ PRODUIT Lorsqu'épuisé, possibilité de mettre une image à la place du bouton 'ajouter au panier' (actuellement, le bouton n'est pas affiché) Ex: lors de la création d'un produit, ajout d'une ligne Message/Image quand hors-stock sous la ligne Message quand en stock Ex 2 (mieux): dans admin > préférences > produits Si la case non est cochée pour Autoriser la commande de produits hors stock, ajouter dessous le choix d'afficher ou non une image si produit hors-stock Ca serait plus rapide que de modifier toutes les pages ou le bouton peut apparaitre. ____________________________________________ EMPLOYÉS Lorsqu'on ajoute un employé, ce dernier ne reçoit pas de mail contenant ses identifiants. ____________ 1.1 & SVN 640
  2. {if $product.price==9999} {l s='Call us' mod='blockcategories'} {else} {displayWtPrice p=$product.price} {/if}
  3. J'aime pas trop ce bricolage, mais en attendant d'avoir mieux.. remplace dans scenes.tpl href="{$product.link|escape:'htmlall':'UTF-8'}" rel="#scene_products_cluetip_{$scene_key}_{$product_key}_{$product.id_product}" class="cluetip" style="width:{$product.zone_width}px; height:{$product.zone_height}px; margin-left:{$product.x_axis}px ;margin-top:{$product.y_axis}px;"> par href="{if $scene->id==5}lien vers la page contact{else}{$product.link|escape:'htmlall':'UTF-8'}{/if}" rel="#scene_products_cluetip_{$scene_key}_{$product_key}_{$product.id_product}" {if $scene->id!=5}class="cluetip"{/if} style="{if $scene->id==5}padding: 0 284px 187px 9px{else}width:{$product.zone_width}px; height:{$product.zone_height}px; margin-left:{$product.x_axis}px ;margin-top:{$product.y_axis}px{/if};">
  4. Essaye de mettre à jour ton checkConfig.php Regarde ici
  5. tu as testé ça ? _____________________________________________________________________________________ Edit : Apparemment tu as réussi à faire fonctionner l'url rewriting. J'ai installé le shop et ça marche aussi pour moi ;-)
  6. Mon .htaccess AddType x-mapp-php5 .php AddHandler x-mapp-php5 .php # URL rewriting module activation RewriteEngine on RewriteBase / # URL rewriting rules RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$2$4 [L,E] RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$1$3 [L,E] RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1 [QSA,L,E] RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ cms.php?id_cms=$1 [QSA,L,E] RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ supplier.php?id_supplier=$1$3 [QSA,L,E] RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E] # Catch 404 errors ErrorDocument 404 /404.php Pour ceux qui utilisent la solution donnée ici en modifiant leur checkConfig.php (/install/xml/checkConfig.php), il faut remplacer // Functions list to test with 'test_system' $funcs = array('fopen', 'fclose', 'fread', 'fwrite', 'rename', 'file_exists', 'unlink', 'rmdir', 'mkdir', 'getcwd', 'chdir', 'chmod'); // Test list to execute (function/args) $tests = array( 'phpversion' => false, 'upload' => false, 'system' => $funcs, 'gd' => false, 'mysql_support' => false, 'config_dir' => INSTALL_PATH.'/../config/', 'tools_dir' => INSTALL_PATH.'/../tools/smarty/compile', 'sitemap' => INSTALL_PATH.'/../sitemap.xml', 'img_dir' => INSTALL_PATH.'/../img/', 'mails_dir' => INSTALL_PATH.'/../mails/', 'module_dir' => INSTALL_PATH.'/../modules/', 'theme_lang_dir' => INSTALL_PATH.'/../themes/prestashop/lang/', 'translations_dir' => INSTALL_PATH.'/../translations/', 'customizable_products_dir' => INSTALL_PATH.'/../upload/', 'virtual_products_dir' => INSTALL_PATH.'/../download/', ); $tests_op = array( 'fopen' => false, 'register_globals' => false, 'gz' => false, ); par // Functions list to test with 'test_system' $funcs = array('fclose', 'fread', 'fwrite', 'rename', 'move_uploaded_file', 'file_exists', 'unlink', 'rmdir', 'mkdir', 'getcwd', 'chdir', 'chmod'); // Test list to execute (function/args) $tests = array( 'phpversion' => false, 'upload' => false, 'system' => $funcs, 'gd' => false, 'mysql_support' => false, 'config_dir' => INSTALL_PATH.'/../config/', 'tools_dir' => INSTALL_PATH.'/../tools/smarty/compile', 'sitemap' => INSTALL_PATH.'/../sitemap.xml', 'img_dir' => INSTALL_PATH.'/../img/', 'mails_dir' => INSTALL_PATH.'/../mails/', 'module_dir' => INSTALL_PATH.'/../modules/', 'theme_lang_dir' => INSTALL_PATH.'/../themes/prestashop/lang/', 'translations_dir' => INSTALL_PATH.'/../translations/' ); $tests_op = array( 'register_globals' => false, 'gz' => false, 'root_dir' => INSTALL_PATH.'/../', 'admin_dir' => INSTALL_PATH.'/../admin/', ); Dans le checkConfig.php donné ici (pas mis à jour ?), la ligne suivante est manquante 'sitemap' => INSTALL_PATH.'/../sitemap.xml', et celle-là remplacée par 'theme_lang_dir' => INSTALL_PATH.'/../themes/default/lang/', Chez moi le dossier modules/ n'était pas accessible en écriture malgré un changement en CHMOD 777 manuel, car bloqué par la ligne manquante (pourtant le sitemap.xml était accessible.) Un admin peut-il confirmer ceci ? v1.1.0.5 ______________________________________________________________________________________ Edit : Après ajout d'un php.ini dans le dossier admin/, j'ai pu tester le bon fonctionnement de l'url rewriting chez 1&1; allow_url_fopen = On allow_url_include = On checkConfig.php
  7. Merci pour la réponse. Autre problème déjà indiqué sur la bêta ici Quand on crée un nouveau produit puis clique sur le bouton enregistrer et revenir à la catégorie, message d'erreur: Bug toujours présent sur la v1.1.0.5 stable
  8. Bonjour. Tout d'abord, bravo à la team pour cet outil efficace. Le problème: back-office [Version 1.1 stable] J'ai repéré une erreur au niveau de l'incrémentation d'id, je ne pense pas que ça soit voulu. Je crée un nouveau produit (ex. id= 62), puis un autre (id=63). Ensuite je supprime le produit (id=63), et en crée un autre. Le nouveau produit créé se retrouve avec un id=64. Dans la liste des produits, les id sont 59, 60, 61, 62, 64... » le 63 n'existe pas :exclaim: Ma question: quand on supprime un produit, il n'est sauvegardé nulle part, pourquoi l'id associé n'est-il plus utilisable ? Sinon, serait-il possible à un client d'envoyer des pièces jointes à partir de la page contact ? Merci
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More