Jump to content

Nikita9999

New Members
  • Posts

    9
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Nikita9999's Achievements

Rookie

Rookie (2/14)

  • One Month Later Rare
  • Week One Done Rare
  • First Post Rare
  • Conversation Starter Rare

Recent Badges

0

Reputation

  1. Ha super effectivement je me suis mélangé les pinceaux entre taxe & règle de taxe ... les noms des règles étant quasiment identique Je suis sur un Presta 1.6.1 je n'avais pas précisé, donc en résumé : - Taxe Basé sur Adresse de facturation - Règle de taxe : Belgique 10% - France 20% (ainsi que pleins d'autres pays à 20%) dans règle TVA qui est appliquée à tous les produits - Adresse de Facturation Belgique / sur une commande la taxe passe à 0% - Adresse de Facturation France / sur une commande la taxe passe à 20% - Adresse de Facturation N'importe quel autre pays à 20% / sur une commande la taxe passe à 20% Donc je ne vois pas pourtant il n'y a qu'une fois Belgique dans ma règle
  2. Bonjour, je tourne en boucle sur un soucis lié à la TVA ... j'ai un site presta FR donc produit par défaut en Règle de taxe à 20% tout est ok Désormais j'aimerais créé une règle de taxe pour un autre pays en zone Europe (on va dire belgique pour l'exemple) j'ai donc suivi la procédure suivante : - Désactiver toutes les règles qui existent à part 20% que je n'applique qu'à la France, vérifié que tout est ok si on passe en Belgique on a aucune TVA appliqué - Créé une nouvelle règle identique à la précédente mais seulement pour la Belgique avec un montant différent 10% Et là pas moyen de faire fonctionner cette 2ème règle même si le pays de livraison est Belgique cela reste à Zéro, la seule règle qui fonctionne c'est 20% si j'inverse dans les règles France/Belgique la seule règle qui persiste à fonctionner est 20% Si je n'active que la règle à 10% cela ne fonctionne pas la seule qui fonctionne c'est 20% alors que les paramètres sont strictement identiques Donc je sèche ... j'ai l'impression qu'il y a quelque chose que je ne comprends pas mais j'ai regardé les documentations et pas vu mon erreur comment puis je faire ? merci
  3. Hi, I want to add a new column to backoffice list of product, so I've created a module to do that, here is the list of what I think I'll need to do and my questions : Override twig file : Done : modules/cs_displaysupplier/views/PrestaShop/Admin/Product/CatalogPage/Lists/list.html.twig -> add the new column for each product Done : modules/cs_displaysupplier/views/PrestaShop/Admin/Product/CatalogPage/Lists/products_table.html.twig -> add the title of my new column + filter : ok it's working ToDo : I need to bring the supplier reference to my twig file, I wanted to use a static method : ProductSupplier::getSupplierCollection but it's not possible directly inside the twig file, I've found this method : https://stackoverflow.com/questions/32920217/how-to-call-static-function-in-symfony2-twig-template#46636220 but I don't know wich controller do I need to override to do that ? Todo : I need to add the filter for the column -> is it possible to override the file /src/PrestaShopBundle/Entity/AdminFilter.php ? Perhaps there is an easiest way to do that ? thanks
  4. Ok thank you I'll take a look on it to see how it works I closed the topic as my issue is solved
  5. {assign var='features' value=Product::getFeaturesStatic((int)$product.id)} Thanks thats exactly what I wanted to do in the controller !! it's working perfectly I don't understand what you mean by using the displayProductListReviews hook ? do you have an example ?
  6. but displayProductListReviews is a tpl hook, I'm in the php controller I can't use it ? In the tpl I miss some informations related to the product (feature value id) and I want to add them using the controller
  7. Thanks for your answer, in fact I want to override this method from CategoryController and add feature value and their id : protected function getProductSearchQuery() { $query = new ProductSearchQuery(); $query ->setIdCategory($this->category->id) ->setSortOrder(new SortOrder('product', Tools::getProductsOrder('by'), Tools::getProductsOrder('way'))); return $query; }
  8. Hi, I'm looking for a way to get the feature value id (not the feature id) inside my category page I've done an override of CategoryController, and want to grab the product list then loop on it and do something like this : $ids_feature = array_column(Product::getFeaturesStatic((int)Tools::getValue('id_product')), 'id_feature_value'); to attach on each product the id_feature_value but I'm stuck to retrieve the product list, or perhaps is there a better way to retrieve the id_feature_value Thanks
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More