Jump to content

DenisDenis

Members
  • Posts

    65
  • Joined

  • Last visited

Profile Information

  • Activity
    User/Merchant

DenisDenis's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. I'm very sorry but It's been a while now and I actually forgot what got changed, so many files to edit...
  2. I think it's because i use different languages it's giving me trouble, the url adds ?id_lang=5 that has to be changed to /en for example, i have no experience with these rewriting rules but i'll look into it when i've got the time.
  3. Yes, i tried it and everything is working fine my site (www.deepdevotionshop.com) is now running on nginx using the tutorials i posted in my previous article. The only thing that isn't working is friendly urls, the rewriting rules are different for nginx, so i'll have to look into this. I also hired this guy on freelancer: http://www.freelancer.com/u/nostyia.html I payed him €100 and he really optimized the server for maximum speed, very friendly guy and really worth the money.
  4. On some item pages the top menu seems to not load, it only appears to load when i right click anywhere on the page and choose 'inspect element' in chrome. This issue is tested in IE, Chrome and FF and happens in all 3. When this happens i can no longer choose another language from the language selector or another currency. This is an example of one of the products it sometimes happens: http://www.deepdevot...troller=product Is there anyone with a simular issue? I noticed when this happens i get the following line in the Chrome error log: Uncaught ReferenceError: productPriceWithoutReduction is not defined. My prices seem to be correctly set up on the backoffice though..
  5. I got everything fixed, had no clue where to begin solving this, so i hired this guy from freelancer: http://www.freelancer.com/u/nostyia.html Very friendly, very fast, solved the caching problem too while he was at it. My VPS is running super smooth now!
  6. Hey guys I have a prestashop 1.4.0.17 for 2 years now, hosted on a shared hosting plan, everything was really fast (+- 600 products). A couple of weeks ago i decided to upgrade to the newest 1.5.4 version, first tried again on the same shared hosting, loading times were +10seconds, I decided i would just switch to a cloud VPS, guess i had to upgrade sooner or later, on this VPS (single core 2,5GHZ, 1GB ram) speeds improved alot, homepage loaded in 2 seconds, product pages however take about 5 seconds. I noticed 1 visitor opening 1 page takes up 100% of my cpu, I figured this can't be normal at all, at this rate it would mean if there are 20 people on my site I'd need a 20-core machine just to have the 5 second loading times for all of them. I'm running on nginx + php-fpm so ram is no issue at all, staying under 400mb at all times. I was wondering if anyone has any idea what is causing this high resource consumption, and how they handled the new PS version?
  7. I just found this article: http://www.howtoforg...zy-ubuntu-12.10 Explaining how to install prestashop 1.5.x on a VPS with nginx which is apparently a much faster alternative for Apache. Here is the installation of Ubuntu 12.10: http://www.howtoforg...cot-ispconfig-3 Hopefully this can be usefull to someone.
  8. I just found this article: http://www.howtoforg...zy-ubuntu-12.10 Explaining how to install prestashop 1.5.x on a VPS with nginx which is apparently a much faster alternative for Apache. Here is the installation of Ubuntu 12.10: http://www.howtoforg...cot-ispconfig-3 the article was uploaded 2 days ago, so it seems like perfect timing! Just ordered my VPS am now waiting for the credentials. Be sure to let me know how everything went! J'ai trouvé cette article: http://www.howtoforg...zy-ubuntu-12.10 Qui explique l'installation de prestashop 1.5.x sur un VPS avec nginx qui est apparemment un alternative plus rapide d'Apache. Et ici l'installation d'Ubuntu 12.10: http://www.howtoforg...cot-ispconfig-3 P.s.: my french sucks
  9. I was wondering if anyone could tell me if there is something specific i should look out for, I'm moving over to a VPS with 1 2,5 Ghz core 1 Gb ram, and have some experience with setting up servers. Any optimal software i should install to get that extra bit of speed out of my setup, all tips are welcome! Kind regards Denis
  10. I was wondering if anyone could tell me if there is something specific i should look out for, I'm moving over to a VPS with 1 2,5 Ghz core 1 Gb ram, and have some experience with setting up servers. Any optimal software i should install to get that extra bit of speed out of my setup, all tips are welcome! Kind regards Denis
  11. I'm sorry for not getting back to this topic, I think I found the solution. Everything was copied over correctly, I found the problem was in the way the import works. Apparently prestashop encrypts the passwords when they get imported, but because they were exported already encrypted this was not necessary. I took the encrypting part out of the code in this file: controllers/admin/AdminImportController.php file. I changed if ($customer->passwd) $customer->passwd = Tools::encrypt($customer->passwd); to if ($customer->passwd) $customer->passwd = $customer->passwd; I hope this helps someone else out with the same problem! Thank you for your time axel!
  12. I tried copying the cookie key into my new installation but none of the passwords are working. I dont really understand the complete process you are saying, you want me to install 1.5.4 copy the cookie key, then delete that installation and then import my old database? Because 1.4 doesn't have the same db tables as in 1.5.4.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More