Jump to content

ChOmar

Members
  • Posts

    34
  • Joined

  • Last visited

Everything posted by ChOmar

  1. I mean Prestashop of course, where exactly i create this topic then ?
  2. I ask for security for example and if new version is more faster?
  3. I have Prestashop version 1.7.5 should I update to 1.7.7 or I must wait ?
  4. the form in photo 1 I want it to be like photo 2 I work in this code right now $format['sellerImage'] = (new FormField()) ->setName('sellerImage') ->settype('file') ->setLabel( $this->translator->trans( 'photo or logo', [], 'Shop.Forms.Labels' ) ) ->setRequired(true) ;
  5. I got the solution So insert with phpmyadmin the table ps_order_state: INSERT INTO `ps_order_state` (`id_order_state`, `invoice`, `send_email`, `module_name`, `color`, `unremovable`, `hidden`, `logable`, `delivery`, `shipped`, `paid`, `deleted`) VALUES (1, 0, 1, 'cheque', 'RoyalBlue', 1, 0, 0, 0, 0, 0, 0), (2, 1, 1, '', 'LimeGreen', 1, 0, 1, 0, 0, 1, 0), (3, 1, 1, '', 'DarkOrange', 1, 0, 1, 0, 0, 1, 0), (4, 1, 1, '', 'BlueViolet', 1, 0, 1, 1, 1, 1, 0), (5, 1, 0, '', '#108510', 1, 0, 1, 1, 1, 1, 0), (6, 0, 1, '', 'Crimson', 1, 0, 0, 0, 0, 0, 0), (7, 1, 1, '', '#ec2e15', 1, 0, 0, 0, 0, 0, 0), (8, 0, 1, '', '#8f0621', 1, 0, 0, 0, 0, 0, 0), (9, 1, 1, '', 'HotPink', 1, 0, 0, 0, 0, 1, 0), (10, 0, 1, 'bankwire', 'RoyalBlue', 1, 0, 0, 0, 0, 0, 0), (11, 0, 0, '', 'RoyalBlue', 1, 0, 0, 0, 0, 0, 0), (12, 1, 1, '', 'LimeGreen', 1, 0, 1, 0, 0, 1, 0), (13, 1, 0, '', '#DDEEFF', 0, 0, 1, 0, 0, 0, 0);
  6. Could you Resolve this issue? I have the same problem. I have not been able to correct it.
  7. I have exactly the same situation. Any update about this bug ?
  8. module/ps_wirepayment/validation i GET this bug Invalid new order status
  9. i add input like that array( 'type' => 'file', 'label' => $this->l('Logo or photo'), 'name' => 'sellerImage', 'image' => $image_url?$image_url:'No Image', 'size' => $image_size?$image_size:' : No size for Image', 'display_image' => true, 'col' => 6, ), and this for add Image to folder public function renderForm() { /** @var Customer $obj */ $image_url = false; $image_size = 0; $customer = new Customer((int)Tools::getValue('id_customer')); $image = PS_IMG_DIR . 'sellers/' .$customer->id_customer . '.jpg'; $image_url = ImageManager::thumbnail($image, (int)$customer->id_customer.'.jpg',200, 'jpg', true, true); $image_size = file_exists($image) ? filesize($image) / 1000 : false; public function postProcess() { if (!$this->can_add_customer && $this->display == 'add') { $this->redirect_after = $this->context->link->getAdminLink('AdminCustomers'); } if ($_FILES['sellerImage']['name'] != "") { if (!Seller::saveSellerImage($_FILES['sellerImage'], $id_customer)) { $this->errors[] = $this->module->l('The image seller format is incorrect.', 'AdminSellersController'); } } parent::postProcess(); } and that's not working for me please help AdminCustomersController.php
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More