Jump to content

danielsaar

Members
  • Posts

    99
  • Joined

  • Last visited

Everything posted by danielsaar

  1. Hallo alle, wenn ich im CategoryTree eine Kategorie klicke wird mir im "Content" gezeigt "46 Artikel gefunden". Darunter nur 6 Produkte dieser Kategorie. Der Rest wird nicht angezeigt. Im Backend bei Template und Logo-> Pages Configuration dann bei "Content" steht "Set the numbers of products you want to display per page and how." Darunter finde ich nur "Artikel pro Seite" wo derzeit 100 steht und nicht 6. Im HTML finde ich diese 6 Produkte in <section class="featured-products clearfix"> Weiter unten im HTML steht die Section <section id="products" Diese ist komplet leer. Fragen: Wenn in einer Kategorie K n Produkte zugeordnet sind werden diese n auch alle bei Klick im Kategiebaum auf K angezeigt? Was bedeuten diese beiden Sectionen? Kann man die Anzahl der Produkte in diesen Sectionen einstellen? Wenn ja, wo? Warum steht auf der Seite (siehe oben) 46 Artikel gefunden, aber man sieht nur 6 und es gibt keinen Link zb "zu den restlichen xy Artikel" ? Das Template ist "Advanced Classic". Presta 1.7.7.5. Beste Grüße Daniel
  2. Lösung: in meinem Fall im Child dann \modules\ps_categorytree\views\templates\hook\ps_categorytree.tpl In der Datei habe ich die class angepasst und "in" hinzugefügt <div class="collapse in" id="exCollapsingNavbar{$node.id}"> Achtung: Es gibt dann etwas Chaos mit den + (aufklapp-icons). ::: EDIT 1::: Sehe grade nicht wo ich es auf "erledigt" setze
  3. Hallo alle, der Kategoriebaum hat in meinem Beispiel 4 Ebenene. Also nach "Start" nochmal 3. Start - a (ebene 1) - b (ebene 1) -- b1 (ebene 2) --- b11 (ebene 3) klicke ich auf b11 verschwinden b11 und b1. Warum ist das so? Warum nicht auch a und b. Dann sähe man "Start" und dahinter ein +. .... Wie kann ich es einstellen, dass ich immer ALLE Kategorien im Kategoienbaum sehe? Welche Files sind für dieses Modul verantwortlich. Bzw in welchem Verzeichniss muss ich schein? Mir geht es vor allem auch um die js-Files. Falls ich das anpassen muss. lg daniel
  4. Hallo SchmidtSon, nachdem ich dann sah, dass sich trotz Änderungen nichts an den Mails änderte hab ich mir die "Strukturen" auf dem Server angeschaut und dort an paar Stellen die Datei für das order_conf gefunden. Nach mehrerer Versuchen und nachdem ich dann diese Datei im Child-Thema anpasste war es in der Mail letztlich auch geändert. Es war weniger ein If ( Problem X) Then { ändere Z;} sondern ein If else , if else , try error, try error. Vielleicht ist das aber auch das "Feature" von Presta, dass es einem (wie in einem Rollenspiel) viele Wege offen lässt, dass man den ganzen Spaß beim Erfahrungen sammeln erleben kann. Ein Weg der half: Einfach mal alle Files umbenennen, von denen glaubt, dass sie verantwortlich sind. Wenn es dann immer noch geht, ist es keines der Files. lg daniel
  5. HI rictools, genau diese wollte ich ändern. Ich versende nur HTML-Mails. Ich hatte es geändert, leider ist nichts passiert. Es war wie Zauberei. Denn ich suchte im Backend an allen Stellen, wo es noch sein konnte und fand nichts. Später musste ich viele Files auf dem Server "anfassen", bis dann endlich ein Effekt zu sehen war. lg daniel
  6. Hi all, I also changed in all order_conf.html - Files I could find on Serverside the "hallo..." Text to "Guten Tag". But in the order-confirmation Mail I get an ugly "hallo". Presta Cache is deletet, var/cache folder too. There are any other places, like a little joke from developer-side, I need to check? Any hidden/secrete folder server side I need to change too? First I tried this: https://belvg.com/blog/how-to-edit-email-templates-in-prestashop-1-7.html But it didn't work. Someone here who can help? Presta, I love you. :::: EDIT:::::: Now the "child-folder" did it!!! Puh... if you want to change the text: Upload the file you need in your child. There, change the text! I dont know why it first didnt work. But now, its working :::: EDIT:::::: yours, DAniel
  7. Anders gefragt: Wo kann ich bei der Bestellbestätigung order_conf, das "hallo ..." ändern? Eine Datei in einem Verzeichnis? Verteilt und überall, je nachdem, den Cache bedenken, ein laden aus einer DB-Tabelle in bestimmten Fällen, Montags immer aus Datei xy und an Weihnachten aus dem Xmas-Folder? Bitte einfach ALLE Stellen angeben, die man berücksichtigen muss. lg daniel
  8. Hallo alle, über order_conf ändere ich den Text in den "vordefinierten" Mails. Es hat keinerlei Auswirkung. Aus einem "Hallo ...." mache ich ein "Guten Tag ..." doch in der Kauf-Bestätigungsmail steht immer noch "Hallo". Was muss ich tun? Cache löschen, Folder löschen, Sonstwo klicken...? presta-entäuschte grüße daniel
  9. Bonjour à tous ! Je souhaite que les frais d'expédition indiquent "non affranchi". Au page de produit, et aussi dans le mail apres la commande. Comment je peux faire la ? S'il s'agit de quelque chose dans le menu "traductions", veuillez être très précis, à quel endroit il faut modifier quelque chose. salu daniel
  10. Hi alle, ich hätte gerne bei Versandkosten "unfrei" stehen. Wie kann ich das machen? Falls es etwas im Bereich "Übersetzungen" ist, bitte sehr genau angeben, an welcher Stelle etwas geändert werden soll. lg daniel
  11. Hi JulienPct, I deleted this Version and started by zero. yours Daniel
  12. Hi musicmaster, I deleted the cache - folder. "destroyed", is really a vague term It didnt destroy. The only point was, that the Presta in the Folder dev1 was full of errors. I couldn't login anymore. (front and BO). yours Daniel
  13. Yes. After I made a copy from Presta in folder dev1 to the folder dev2 I first checked it: I changed some product-names in the Presta in Folder dev2. When I compared the product of both Prestas in folder dev1 and dev2. The product in dev2 had my changings, the Presta in dev1 not. So I knew, the dev2-Persta was connected with the DB-2. (And Pesta in dev1 with the own DB-1) When I logged in Presta Version in dev2 and run the downgrade-Module. On the End both Pestas were destroyed.
  14. Hi JulienPct, I sad that I made the downgrade on one system (here it was the Presta in Folder /dev2). But 1) the downgrade doesn't work 2) It destroyd also the Presta-Version in Folder /dev1 Point 2 is maximum stupid. The Question is, why a completely different system crashes a nother Presta-Installation. yours, Daniel
  15. "If I understood correctly, you have a site on dev1 in 1.7.8, you copied it to dev2 and then downgraded it to dev2?" I wanted downgrade the kopie (in folder dev2) to the Version 1.7.7. I made the copie to work on the copy (dev2) and not on the original (dev1). "Going back to the images, when you inspect the code, the image source link is something like: /dev1/image.png?" Yes, on the dev2-version I had a string "dev1" in the source-link. That was the reason, I thought that presta use absolut source-links insead of relative. yours, Daniel
  16. Hi JulienPct, I did it in the way you wrote. The Produkt-Images in my dev2 - Version I could not see, because in the img-url was something with dev and not dev2. You write nothing about changing any table with image-urls. This means, that the url of the images are relativ - is this correct? In the BO of my dev2-Version in an article I could see the product-image, but in the FrontEnd not. To make the copy was not the big thing (only I had problems to see the fotos in the frontend). The Problem was to use the Module "1 click upgrade". I used it to go back from 1.7.8 to 1.7.7 as the 8-version made a lot of stress. After I clicked I had only a page with read writings about DB-problems. Also, the dev-version was defect. I can not understand it. Because the parameters.php I changed in the dev2 - Version. I checked this by changing a produkt name. In dev it was the old name, in dev2 the name I changed. So I knew, that I am working in the copied DB. It could be this: If the 1 click upgrade makes an "return" to older Version, it also will set the url in the ps_shop_url back to the old (dev) one. I dont know. Probably there is a kind of DB-history-table. The module takes the data from there and change all table-data to this old-data. I dont know how the Modules makes an "return to older Version". yours Daniel
  17. Hi Wolfsauge, das dir noch keiner geantwortet hat ist schade. Ich glaube die Leute die Presta gut kennen sind einfach überfordert wegen den vielen Baustellen. Wo findet man eine Übersetzungsanleitung? lg daniel
  18. Hi all, Presta (my deep love) Why I made a copy of my page? I made a copy to run in the module "1 click backup" the return to an older Version-Function. I had two Folder dev and dev2 Also the parameter.php was different, because I had a copy of the original dev-DB für my dev2- version. After I used the the Module-Function dev2 do not work (500 server error) and dev not work. In dev I get "Fatal error: Uncaught Unknown column 'active' in 'field list' SELECT active FROM `pswo_hook` h WHERE (h.name = "moduleRoutes") LIMIT 1 .../htdocs/dev/classes/db/Db.php on line 769" Probably the Modul do not work correct. I also do not understand, why dev is not working as I run the modul in dev2. The only thing I know is, that there is the ps_shop_url table to set the Shop-Url. In the .htaccess is nothing about any dev-thing. For me this means, that I need to start by Zero. My confidence in the stability of Presta is shaken. That is a great pity. I hope in the futur the systems does not behave like try and error or searching for the needle in the haystack. works, works not, works, works not, works .... like a coin toss. Ok, I try again... yours Daniel
  19. Thanks Ambassadors, Oh, the images are with absolut-path?! Its like in wordpress Ambassadors, have you a tipp, there I smart can change the path of the images? Probably I need a UPDATE to a table?! yours, Daniel
  20. Hi tintina125, I have a similar problem. I get Mails but without PDF-Invoice. The bigger Problem is, there is no internal logging/ check feature history or something similar. Or I am blind and there is somethin like that As the PDF will be created on the fly, I have also no way to check the PDF was created -> There is no real .pdf - Ending File on the Server - Harddisk. But there is also no logging with the message: PDF-Invoice was not sent. The point is, that also the thema monitoring could be a little bit better. ?!The good way would be: Execute Feature 1 Test Feature 1 was without error. If error write in a loggfile anything smart. Could be, that there is no specification for feature monitoring. The module-developer are perhaps free to do so. But I do not know Presta well enough. Could be there ist something like that. I hope you can find a solution - I did not find one. yours DAniel
  21. Hi all, my installation is in domain.de/folder1 and I made a complete copy of it to domain.de/folder2 The DB - Parameters I changed for the DB-copy. But if I open domain.de/folder2 in the browser I come to domain.de/folder1 Where in the DB or else I have to change something? An no! I can not loggin into the Backend, because the URL directly goes to folder1. In the .htaccess I find nothing about /folder1 Is where any field in the DB I have to change? And yes! I deleted the var/cache Folder. yours Daniel
  22. Hi apollux, I understand the complexity of the problem. On the end, we find html-code in the browser. Perhaps it would help to assign a new attribute to a html-tag. The attribute a non-developer can find in the console (ok, when he have to know what a "console" is ) translation="backend seetings" or translation="in international->translation" .. Probably I need to check the code-files (.tpl etc) and search whether there is a special kind of code to know, the translation is a setting in the module or I should search in BO Menu-point "international". yours, Daniel
  23. Hi AshChook, "and later" is not so fine written. But on the other hand the alternative is a lot of stress for the developers. They have to check each Presta-Version with new Php-Versions. I don't know, but it could be, that a newer version of php mostly is backwards-compatible and the developer-community made the experience, that presta mostly runs under newer Php-Versions. Sometimes a comando is deprecated in Php -thats true. I don't know what here would be the best praxis. yours DAniel
  24. "The reason behind updating is to keep developers in their job " Wua 🙃 Great.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More