Jump to content

Alaincassis

Members
  • Posts

    49
  • Joined

  • Last visited

Everything posted by Alaincassis

  1. Bonsoir à tous, j'ai une erreur 500 depuis quelques heures, c'est un Presta 1.4.5.1 devenu hier un tout frais 1.6 avec le 1 click upgrade . Tout fonctionnait (à peu près) bien jusqu'au moment où j'ai voulu arrêter le mode debug, et remis les parametres dans define.inc.php et config.inc.php. Depuis, plus rien ne fonctionne! C'est peut-être pas à cause de ça ? Erreur 500 avec cet affichage: Notice: Constant _PS_DEBUG_SQL_ already defined in /home/MONSITE/web/www3/boutique/config/defines.inc.php on line 36 Fatal error: Cannot redeclare p() (previously declared in /home/MONSITE/web/www3/boutique/config/config.inc.php:90) in /home/MONSITE/web/www3/boutique/config/alias.php on line 32. J'ai changé de version de PHP du 5.6 au 7 et vice versa, rien ne change. J'ai regardé sur le net, une ou conseils sont proposés, mais inefficaces pour moi. J'ai peut-être écrasé le nouveau config.inc.php par un ancien ! en effet , sur mon config.inc.php figurent les dates 2007-2011 PrestaShop !!!! et non 2007-2017 comme les autres fichiers !! Est-il possible de le régénérer ??? Si quelqu'un pouvait me donner un avis? Merci d'avance Alain
  2. Bonjour à tous, Je viens de mettre à jour de 1.4.5.1 vers le1.6.1.24. un peu laborieux , je n'ai pu faire la mise a jour qu'en désactivant les mise a jour du thème. J'ai donc le vieux thème du1.4, Prestashop, et le nouveau 1.6 Défaut-bootstrap. Je n'ai que 8 produit à vendre mais à 2000 clients avec beaucoup de récurrents qui ont presque tout un compte . Je ne pouvais pas repartir à zéro. Avec la MAJ, le thème bootstrap parait opérationnel, mais en voulant passer une commande j'ai l'erreur: Fatal error: Uncaught --> Smarty: Unable to load template file '/home/Monsite/web/www3/boutique/themes/default-bootstrap/./order-opc-new-account.tpl' in '/home/Monsite/web/www3/boutique/themes/default-bootstrap/order-opc.tpl' <-- thrown in /home/Monsite/web/www3/boutique/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 129 Dans themes/default-bootstrap, je n'ai pas order-opc-new-account.tpl ( qui lui est dans la directory du thème (inutilisable) par défaut du 1.4), j'ai order-opc-new-account-advanced.tpl . Par contre quand on commande en tant que client avec compte, tout va jusqu'au bout du process . Quelqu'un pourrait-il m'éclairer sur ce que je peux faire pour améliorer cette situation ?? En ,tout cas, bonne soirée à tous !! Je crois avoir résolu le souci. J'ai changé le nom du fichier order-opc-new-account-advanced.tpl par order-opc-new-account.tpl Et cela fonctionne jusqu'au bout sans erreur.. J'espère que je n'aurais pas de mauvaise surprise...
  3. En fait, "Invalid address #135" c'est l'ID d'une adresse que le client client a effacé dans ps_adress , après qu'ill ait eu fait un panier. Du coup, l'ID dans ps_adress saute de 134 à 136. La solution est soit de vider le fichier ps_cart, ce que je n'ai pas osé faire, soit voir les enregistrements concernés où l'adresse #135 existe et remplacer l'ID 135 par un numéro valide ( n'importe lequel, il suffira après d'effacer le panier dans le BO). C''est pas très normal que Presta n'accepte pas qu'une adresse client soit effacée, c'est peut-être un bug de la version ? 1.6.1.3 pour moi.-
  4. Ouf, c'est résolu, j'ai fini par trouver !. Mes commandes aboutissent bien maintenant ! Dommage qu'ici personne ne réponde....
  5. J'ai passé une commande test qui a été non finalisée. Malgré le DEV "true", écran figé après paiement Paypal, avec "sécurisation de vos informations". Au bout de 2mn, j'ai rafraichi l'écran: Warning à la ligne 1585 du fichier /home/site3781/web/www/classes/controller/AdminController.php [2] Cannot modify header information - headers already sent by (output started at /home/site3781/web/www/classes/cache/CacheFs.php:40) Client débité, mais commande sans produit ni paiement. Après rafraichissement de la page figée, une 2e commande vide apparaît, avec une erreur Paypal
  6. Bonjour à tous j'ai un souci aléatoire qui est passé de 5% à 50% en 3 mois, sur mes commandes. Un client passe une commande avec un panier, le paiement est OK , mais la commande est en statut "annulé" et il n'y a aucun produit. Meme en mettant la commende en statut "paiement accepté", il faut que je déstocke à la main les produits. Un indice, parfois, quand je déstocke dans le BO, j'ai cette erreur: Notice: unserialize() [function.unserialize]: Error at offset 90078 of 90112 bytes in /home/site3781/web/www/classes/cache/CacheFs.php on line 40 Cela a-t-il un rapport avec les commandes vides ? J'ai l'impression que c'est un souci récurrent les commandes mal finalisées ! Merci d'avance
  7. Bonjour à tous, Sur mon 1.6.0.11, JqZoom fonctionne bien sur mon Mac. Mais sur iPad & iPhone, il n'y a pas le curseur carré, l'image agrandie est bien dans le cadre, mais elle est impossible à déplacer. Avez vous eu ce souci ??
  8. Ouf, ca y est !! ca (re)marche..avec le 1.6.0.11 !!! Après avoir fait quelques recherches, j'y suis arrivé. Et avec le panier AJAX, la mention disparait quand on dépasse la somme et réapparait quand on enlève un produit . Tout comme avant !!
  9. Dans le shopping_cart.tpl du 1.4.5.1 : <tr class="cart_free_shipping" {if $free_ship <= 0 || $isVirtualCart} style="display: none;" {/if}> <td colspan="6" style="white-space: normal;">{l s='Remaining amount to be added to your cart in order to obtain free shipping:'}</td> <td id="free_shipping" class="price">{displayPrice price=$free_ship}</td> </tr> J'ai essayé de le faire marcher dans le shopping_cart.tpl du 1.6.0.11, il marche à moitié, quand je met en dur le montant de gratuité : displayPrice price=( 50-$total_products) . Par contre j'arrive pas à faire le test et le faire disparaitre quand le remaining amount a été dépassé ! Il faut mettre la ou les bonnes variables, elles sont probablement toutes dans le shopping_cart.tpl. Mais lesquelles ??? je ne suis pas développeur !
  10. Dans les versions 1.4 de PS , cette fonctionnalité était très utile: Lors de la commande, il s'affichait sous le récap du panier la phrase : "Pour obtenir la gratuité des frais de port, vous devez encore commander pour: XX€ Et dans les nouvelles versions, cette phrase existe toujours dans les fichiers lang/fr.php !. C'était, dans le shopping_cart.tpl du 1.4.5.1 : <tr class="cart_free_shipping" {if $free_ship <= 0 || $isVirtualCart} style="display: none;" {/if}> <td colspan="6" style="white-space: normal;">{l s='Remaining amount to be added to your cart in order to obtain free shipping:'}</td> <td id="free_shipping" class="price">{displayPrice price=$free_ship}</td> </tr> Je suppose que pour l'utiliser dans le shopping_cart.tpl , il faut mettre les bonne variables . Mais lesquelles ??? je ne suis pas developpeur ! Si quelqu'un avait une idée, j'ai vu sur le forum que pas mal de gens cherchent la solution Merci d'avance Alain
  11. Hi all, On my old PS 1.4.5.1 website, it was a very useful function: When decided the amount of order over which shipping is free , this is what appears in the cart (in one page checkout option ) : Remaining amount to be add to your cart in order to obtain free shipping: XX€. In 1.4.5 shopping_cart.tpl : <tr class="cart_free_shipping" {if $free_ship <= 0 || $isVirtualCart} style="display: none;" {/if}> <td colspan="6" style="white-space: normal;">{l s='Remaining amount to be added to your cart in order to obtain free shipping:'}</td> <td id="free_shipping" class="price">{displayPrice price=$free_ship}</td> </tr> How can I use it in 1.6.0.11 shopping_cart.tpl ? Which variables we have to use, instead of $free_ship etc... Thanks a lot if somebody give the answer !
  12. As-tu mis les "true" et "on" nécessaires au debuggage dans config/defines.inc.php pour voir éventuellement ce qui se passe ?
  13. Bonjour à tous !, je met à jour une boutique 1.4.5.1 en 1.6.0.11 ( 1200 articles + les images qui vont avec !) . Tous se passe à peu prés bien, mais je suis étonné de voir que dans le 1 click checkout,dans la commande la mention "Pour obtenir la gratuité des frais de port, vous devez encore commander pour.." dans le panier ou le résumé de commande a totalement disparu !. Pourtant cela était pas mal utile dans le 1.4.5.1 pour augmenter les ventes. Quand le client s'approchait un peu de la somme fatidique, il achetait très souvent un complément pour dépasser ce seuiL Dommage de s'esquinter à faire une telle mise à jour et avoir l'impression de régresser.... Il y a-il un moyen simple pour faire redevenir visible cela, ou faut réimplanter totalement la procédure ?? Merci d'avance si quelqu'un a une solution, à moins que cela soit toujours implanté et qu'il suffise de le réactiver (comment?) Alain
  14. Ce serait parfait si le visiteur avec par défaut le site mobile apparaissant ,il aurait un lien pour aller à la version classique du site. Ou réciproquement :-)
  15. J'utilise pas Analytics pour ce site, mais une solution payante permettant d'avoir, en plus des fonctionalités d'Analytics, les parcours individuels de chaque visiteur. Nos visiteurs ne savent pas souvent ce qu'ils veulent, ils viennent très souvent de Google Image. , Et les produits qui vous semblent inintéressants sont certainement intéressant pour d'autres !. Et vice-versa. Quand on va au marché aux puces ou dans une brocante, l'intérêt c'est de trouver la perle rare au milieu de plein de choses inintéressantes. Cela s'appelle chiner. Sinon, on va chez un antiquaire classique quai Voltaire ou un contemporain rue de Seine et en 3 minutes pour 40 à 100 k€ , on a une table de salle à manger très convenable ;-) En ce qui concerne les ventes, effectivement je cherche à les améliorer. Mais en Europe francophone, je ne vois pas quel site pourrait en vendre plus que nous .... à part Leboncoin ou Ebay à la rigueur. C'est une micro-niche Le thème n'est pas génial , je l'ai choisi pour le switch de l'affichage grid/list des produits à une taille qui me convenait. Il y a probablement mieux ! Merci encore et bonne soirée. Et n'hésitez pas
  16. Merci de vos remarques. Et j'apprécie votre franchise. Mon site ( plutôt celui de ma femme), vend 1200 articles qui sont tous des pièces uniques et en un seul exemplaire. Il s'agit de boutons de manchette anciens. Le principal concurrent est en fait leboncoin.fr (hélas !) Il ne me semble pas que leboncoin n'utilise pas le responsive uniquement pour des raisons budgétaires. Jamais chez moi un client n'achète en 3 clics, ce serait un fou ! Plutôt au minimum après avoir vu en détail au moins 50 ou 100 produits , et souvent survolés tous les 1200 (ca fait quand même quelques centaines de pages) . Je le sais avec précision, car avec le compteur que j'ai mis en place, je peux tracker mes visiteurs individuellement: Je sais qu'un acheteur a regardé tant de pages, tels produits en détail et quel était son équipement. Je connais un peu le commerce, ayant été fondateur et principal actionnaire d'une chaine de magasins informatique coté en bourse. Mais ca c'était avant... Merci en tout cas de votre attention !
  17. C'est Megashop de ThemeForest. Ce qui me gène, c'est que dans un browser de mobile, quand il y a 400 articles dans une catégorie, ils apparaissent à le queue leuleu 2 par 2 au mieux. Dans mon bon vieux site 1.4.5.1, on a à faire avec une version simplement réduite du site. Beaucoup plus ergonomique (amha). Bien sur qu'il y a un meilleur paramètrage à faire, mais le principe restera le même. Le site de test (pas en prod) : www3 Dot boutonsdemanchette Dot fr . Il n'est pas fini, c'est pour cela que je m'interroge avant de remplacer mon site de production ... Merci de vos remarques Cordialement
  18. Merci de votre réponse, C'est le theme Megashop de Themeforest. Je pensais que le bouton désactiver faisait partie du Prestashop de base et pas du theme. C'est vrai que c'est mon premier site responsive qui me pose un problème d'ergonomie. En fait ce qui me gène, c'est que dans un mobile, les articles apparaissent les uns après les autres à la queue leuleu. Dans mon site 1.4.5.1, on peut survoler le tout dans une version réduite du site. c'est http://www3.boutonsdemanchette.fr C'est le site test, pas celui en production . Merci de me donner votre avis !
  19. Bonsoir à tous, je suis passé d'un 1.4.5.1 en Prestashop 1.6.0.11 (en test sur un sous-domaine) et je ne suis pas fan du tout du Responsive, vu que j'ai 1200 produits et que les visiteurs aiment souvent en survoler quelques centaines s'articles avant de se décider. Le responsive n'étant pas , il me semble adapté à cela, j'aimerai le désactiver. Mais le bouton activer/desactiver Responsive de la page theme n'a pas l'air de fonctionner. Comment faire alors ? Merci d'avance de vos conseils !
  20. Oui, tables bien sur !. Mais existe-t-il un memo de toutes les tables de la 1.6.0.11 ? Il y en a quand même 282, dont 21 pour ps_order_xxx et autant pour cart, customer, products, et des tables qui s'appellent d'un nom neutre, comme ps_adress et j'en oublie...
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More