Jump to content

WebWeber

Members
  • Posts

    45
  • Joined

  • Last visited

Everything posted by WebWeber

  1. Das scheint tatsächlich zu funktionieren (sogar rückwirkend !?!). Auch wenn es keine saubere Lösung ist markiere ich mal das Problem als gelöst, da es ja möglich ist bei Watungsarbeiten vorrübergehend die eigene IP einzutragen und sie anschließend einfach wieder zu löschen Danke!
  2. I added it now to the end of templates/_partials/head.tpl and it works like it should! Thanks again!
  3. Hi Leo, hatte es oben unter dem Wort Forum verlinkt, aber nicht so offensichtlich... Danke für Deine Hilfe!
  4. I've been trying to setup Plausible.io but fail in integrating it 😂 There is a documentation and the whole magic should be to insert this snippet: <script async defer data-domain="my-prestashop.de" src="https://plausible.io/js/plausible.js"></script> into I tried to add it into /themes/classic/templates/_partials/head.tpl and /themes/classic/templates/_partials/header.tpl but didn't succeed. Somehow they both don't contain a clear <head>-section. Can anyone hint me where to add this code?
  5. So, der Checkout funktioniert wieder! Was mir letztendlich geholfen hat war: das PayPal-Modul resetten Danach gab's (aus welchem Grund auch immer) eine Fehlermeldung: [PrestaShopDatabaseException] Table 'myshop.ps_mailalert_customer_oos' doesn't exist<br /><br /><pre> SELECT id_customer, customer_email, id_shop, id_lang FROM `ps_mailalert_customer_oos` WHERE `id_product` = 38 AND `id_product_attribute` = 0</pre> at line 769 in file classes/db/Db.php Dank der Hilfe aus dem Forum konnte ich das Problem durch Resetten der Einstellungen des "Benachrichtigungen"-Moduls (ps_emailalerts) lösen, warum auch immer das plötzlich involviert war!
  6. Yeah, right! So far I was a bit disappointed by the PS-community. Seemed rather asleep and inactive and difficult to find help for the smallest problems! I might be wrong 😀
  7. Thanks, your my hero of the day!
  8. Checkout broke a couple of days (at least that's when I noticed it) in my webshop runnning on PS 1.7.7. Since the error was connected to the PayPal-module I reset its settings and tried again, but get the following error-message: [PrestaShopDatabaseException] Table 'myshop.ps_mailalert_customer_oos' doesn't exist<br /><br /><pre> SELECT id_customer, customer_email, id_shop, id_lang FROM `ps_mailalert_customer_oos` WHERE `id_product` = 38 AND `id_product_attribute` = 0</pre> at line 769 in file classes/db/Db.php 764. if ($webservice_call && $errno) { 765. $dbg = debug_backtrace(); 766. WebserviceRequest::getInstance()->setError(500, '[SQL Error] ' . $this->getMsgError() . '. From ' . (isset($dbg[3]['class']) ? $dbg[3]['class'] : '') . '->' . $dbg[3]['function'] . '() Query was : ' . $sql, 97); 767. } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) { 768. if ($sql) { 769. throw new PrestaShopDatabaseException($this->getMsgError() . '<br /><br /><pre>' . $sql . '</pre>'); 770. } 771. 772. throw new PrestaShopDatabaseException($this->getMsgError()); 773. } 774. } As I didn't find anything related to this db-table (ps_mailalert_customer_oos) here in the forum I decided to setup a fresh install of PS 1.7.7 on a test-server to copy the table, but this table doesn't exist in the new PS-database either?!? What I did before: I had to redo some canceled orders and noticed that checkout just stops on the last step without any error-message, neither in the front-end nor in the backend or even logs🤔 The shop had been running and even taking orders for about 4 weeks before! The error disappeared when I deactivated the PayPal-module, but that can only be a temporary solution. Since I had errors anyway I decided to upgrade from PS 1.7.6.9 to 1.7.7
  9. Thanks! It helped me to find out, that the PayPal-module is my problem! Unfortunately this solution doesn't work for me, since I want to use the Paypal-module have it configured and still I'm stuck...
  10. Danke! Wenn man sich erstmal beruhigt dass der Shop nicht funktioniert und in Ruhe die Fehlermeldung liest, steht da u.U. auch schon des Rätsels Lösung! Es war die ps_guest Tabelle die gefehlt hat und hier habe ich auch den Befehl um sie einzufügen gefunden! Nun bin ich wieder bei meinem ursprünglichen Problem: Das Paypal Modul funktioniert nicht und selbst wenn ich es beim Checkout nicht auswähle (das Modul an sich aber aktiv ist) kommt folgende Fehlermeldung: (1/1) FatalThrowableError Type error: Argument 1 passed to PrestaShop\PrestaShop\Core\Payment\PaymentOption::convertLegacyOption() must be of the type array, string given Diesmal habe ich versucht etwas besser aufzupassen. Es hat mit Payment und PaymentOption::convertLegacyOption() hätte gerne array, bekommt aber string??? Da verließen sie mich... Was ich mich zusätzlich frage: Wo kommt plötzlich so ein Fehler her??? Und gibt es eine Möglichkeit bei solchen Fehlern benachrichtigt zu werden? Ich bekomme immer wieder die gleiche Warnung, dass ein Artikel erkauft ist, aber sowas "Wichtiges"nicht!
  11. Sehe gerade das ist wohl Standard... Hast Du mal geschaut, was autoload.php in Zeile 26 vorhat? Bei mir spinnt der Shop auch gerade, anscheinend das Paypal-Modul obwohl es die Ganze Zeit funktioniert hat. Dachte ich schaue mal während ich auf Hilfe warte, ob ich wem anders helfen kann, aber ich befürchte nicht.
  12. Hmm, seltsam. Immerhin gibt der Fehler explizit die Datei UnitofWork.php an. Was macht denn das Plugin?
  13. Vielleicht kannst Du mal testweise das ORM/UnitofWork-Plugin oder was es ist deaktivieren und schauen ob es dann geht?
  14. EDIT: Problem gelöst (s. letzter Beitrag). Der Bestellvorgang hängt beim letzten Schritt und der Debug-Modus spuckt folgenden Fehler aus: Soweit ich verstehe hängt es mit den Zahlungsmethoden zusammen, habe da aber nichts dran geändert. Beim Versuch Probleme mit dem Statistik-Modul zu lösen habe ich vielleicht Mist gebaut. Wenn ich nach diesem Fehler suche finde ich nur Fehler mit irgendwelchen Modulen, die bei mir nicht vorhanden sind... Hat jemand einen Rat für mich? EDIT: Habe jetzt doch was gefunden und dort hing es mit dem Paypal-Modul zusammen. Obwohl ich daran nix geändert habe, habe ich es mal deaktiviert und es geht weiter, allerdings nur einen Schritt und dann kommt:
  15. Meine "Verkomplizierung" kam daher, dass ich mein Telefon nicht für Mails nutze und gerne über neue Bestellungen informiert werden wollte ohne ständig am PC nachzuschauen (dann halt per PUSH-Nachricht). Jetzt werde ich halt eine separate Mail-Adresse für die Bestellungen nehmen und diese auf dem Telefon einrichten... Danke für Dein Feedback. Hat mir geholfen
  16. Trotzdem danke! Dachte die wären evtl praktisch um unterwegs neue Bestellungen und Versandadressen abzurufen, aber vielleicht ist das auch ein bißchen verkehrt herum gedacht und mit Spatzen auf Kanonen und so...
  17. Leider nein! Das einzige "Cookie-Modul", das ich gefunden habe ist "European Union Cookies Law", welches ich von Hand installiert habe, aber es hat keinen Einfluss auf die Statistik_Funktion Andere Idee: Wie sehen den bei Dir folgende Einstellungen (Shop-Einstellungen-> Traffic & SEO) aus?
  18. Habe heute mal nach Apps zur Verwaltung des Shops geschaut und festgestellt, dass es da mehrere gibt. Allerdings fand ich es schwierig einzuschätzen welche denn nun vertrauenswürdig und gut sind. Wenn sich hier also schonmal jemand da durchgewühlt hat, oder schon länger eine App nutzt und damit sehr zufrieden ist, würde ich mich freuen davon zu hören! Auch ob Ihr dann dafür einen extra Backoffice-Account angelegt habt oder so...
  19. Was mir an Deiner Konfiguration auffällt, ist, dass Du PHP 7.3 verwendest obwohl Deine PS Version nur PHP 5.2-7.1 offiziell unterstützt! Das wäre schonmal ein Versuch wert, wobei das im ungünstigsten Fall dazu führt, dass ich hier wieder alleine mit meinem Problem bin 😂 Speichergrenze -1 heißt meines Wissens nach, dass keine definiert ist.
  20. Hätte mich auch gewundert, wenn es ein einzigartiger Fehler wäre.... Da Du nichts weiter schreibst vermute ich mal, dass Du keine weiteren Indizien oder auch Tipps hast, wie es weitergehen könnte, oder? Vielleicht können wir ja gemeinsam versuchen das Problem einzukreisen, bzw möglich Fehlerquellen zu suchen. Auch wenn wir sicher nicht die Einzigen sind, so scheint es ja doch bei den Meisten zu funktionieren Wie sieht's denn bei Dir mit PHP & SQL-Version aus?
  21. Smarty is enabled, but I didn't install any caching modules manually if that's what you mean...
  22. Strange as the whole thing is: Now the dashboard doesn't even show sales, orders, etc. anymore!
  23. Thanks, I've seen it, but I already have StatsData 2.1 installed now! About the Prestashop Update: I will not try it on a weekend afternoon on a live system. Maybe monday or, even better, first on a test system...
  24. Oh, sorry. Yes I do! I use classic theme, PS 1.7.6.9 and PHP 7.2 (had 7.3 before, but found out that it's not supported for 1.7.6.x)
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More