Jump to content

jihef2

Members
  • Posts

    27
  • Joined

  • Last visited

About jihef2

  • Birthday 04/02/1943

Profile Information

  • Location
    Lyon

jihef2's Achievements

Newbie

Newbie (1/14)

2

Reputation

4

Community Answers

  1. Bonjour, Merci de votre réponse. Je vais voir ce que ça donne. Au cas où je ne m'en sortirai pas, je reviendrai vers vous... Cordialement, JF David
  2. Bonjour à tous, J'utilise Prestashop V1.6.1.4. Je voudrais insérer la variable {gift_message} dans le mail de confirmation de commande envoyé au client. Cette variable se trouve dans la table "ps_orders" de la base de données. En l'insérant directement dans le code HTML du mail, ça ne marche pas. Je suppose donc qu'il faut appeler cette variable auparavant. Mais je ne sais pas comment faire ! Si quelqu'un peut m'aider ? Merci par avance de vos réponses. Cordialement, JF David
  3. Bonjour, J'ai fait la manip avec {delivery_other} sur une version 1.6.1.4 Etes-vous sur d'avoir inséré la variable {delivery_other} au bon endroit dans le tableau html du mail ? Essayez peut-être d'insérer une autre variable pour tester, par ex {delivery_lastname} Peut-être que le nom de la variable a changé dans la dernière version de PS, mais c'est peu probable. Pour le moment je n'ai pas téléchargé cette dernière version et je ne peux guère vous aider davantage. Bon courage, cordialement JF David
  4. Je me réponds à moi-même, ayant trouvé la solution (qui peut éventuellement servir à d'autres ayant le même problème). Ce n'est pas la variable {other} qu'il faut faire afficher dans le mail mais {delivery_other} Par ailleurs j'ai modifié le mail directement par FTP. Celui que je voulais modifier est dans : mon-theme/modules/mailalert/mails/fr/new_order.html et pour la version anglaise dans ...mails/en/new_order.html
  5. Bonjour à tous, J'utilise PS 1.6.1.4 Je voudrais ajouter un champ dans le mail reçu par le commerçant lors d'une nouvelle commande (New order). Ce mail est envoyé par le module mailalerts. Je voudrais y ajouter le contenu du champ "other"; correspondant à la zone "Additionnal information" du formulaire de saisie des adresses. Ce champ est dans la table "ps_address". J'ai essayé tout simplement de rajouter {other} dans la traduction du mail concerné (mailalerts/New_order/Modifier la version HTML), mais ça ajoute juste le texte {other} dans le mail reçu par le marchand, et non le contenu de ce champ ! Est-ce que quelqu'un pourrait m'aider ? Merci par avance, cordialement, JF David
  6. Bonsoir, Et merci de votre réponse. Il n'y a pas de "display: hidden" dans le css du module homeslider (thème responsive default-bootstrap), mais en cherchant mieux sur le forum, j'ai trouvé la réponse : dans la configuration du module, on peut l'activer ou le désactiver, sur mobile comme sur tablette. Il fallait y penser ! Cordialement JF David
  7. Bonjour, J'utilise le module homeslider natif (V1.6.0) sur une boutique version 1.6.1.3. Il fonctionne très bien, tant sur ordinateur que sur tablette. Par contre j'ai constaté que sur mon smartphone, le slider ne s'affiche pas, quelle que soit la position de l'écran (portrait ou paysage). C'est un smartphone Galaxy Core 4G sous Androïd, écran 540x960 px. Toutefois, si dans les paramètres du smartphone je coche la case "Voir version ordinateur", le slider s'affiche alors normalement (mais a priori personne ne connait ni ne coche cette case !) J'ai essayé quelques modifications dans "homeslider.css", mais sans succès. Ce problème est un peu gênant, d'autant que de plus en plus d'internautes font des achats depuis un smartphone. Est-ce que quelqu'un pourrait m'aider à trouver une solution ? Vous remerciant par avance. Cordialement, JF David
  8. Ça a été un peu laborieux mais, finalement, j'ai réussi à faire la mise à jour (V1.3.7 vers V1.6.1.3) tout en récupérant les mots de passe client opérationnels. Pour ceux que ça pourrait intéresser, voici la suite des opérations réalisées : Déplacer la V1.3.7 du site opérationnel vers un site de test. C'est bien expliqué dans le "guide de l'administrateur" http://doc.prestashop.com/pages/viewpage.action?pageId=4096124 (dernier item du menu) Vérifier dans le fichier "/config/settings.inc.php" que les valeurs des "_COOKIE_IV_" et "_COOKIE_KEY_" sont bien conservées lors du passage depuis le site opérationnel vers le site de test. Vérifier que le site de test est pleinement opérationnel (connexion de qq utilisateurs, commande d'un produit, mails reçus par la boutique et le client...). Ensuite, tout va se passer dans le site de test. Faire la mise à jour du site de test vers une V1.4. J'ai appliqué la procédure en deux temps de Johann Corbel : ( http://www.johanncor...lle-prestashop/ ). J'avais fait auparavant une MAJ directe avec le module MAJ en 1 click, mais j'avais eu les déboires de mots de passe signalés en début de ce topic). Après la MAJ et en cas de problème dans l'onglet "Modules" du Back Office, utiliser l'affichage des erreurs : dans "config/config.inc.php", passer "@ini_set('display_errors', 'off'); à "on". Les modules en erreur s'affichent et on peut les supprimer par FTP. Installer dans la V1.4 le module "MAJ en 1 click". J'ai dû le télécharger manuellement pour avoir la dernière version de ce module (qui permet de faire la MAJ vers la dernière version stable de Prestashop). Suivre scrupuleusement la procédure indiquée et lancer la MAJ. Pour moi tout a bien fonctionné. Changer si besoin le thème. j'ai pris "default-bootstrap" que j'ai ensuite exporté/réimporté/renommé pour pouvoir l'adapter à ma convenance. Merci à Johann Corbel pour son aide tout au long de ce topic. Bon courage à tous JF David
  9. Bonjour à nouveau, En cherchant encore, j'ai vu que sur la 1.4 et pour afficher les erreurs, il fallait agir non pas sur "config/defines.Inc.php" mais sur "config/config.inc.php". J'ai donc passé "@ini_set('display_errors', 'off'); à "on". Cette manip faite, dans mon BO et en cliquant sur l'onglet "Modules", j'ai eu successivement deux messages d'erreur indiquant les modules posant pb. Après les avoir supprimé, j'ai récupéré tous les modules bien visibles dans cet onglet. Je vais maintenant passer à la suite de mes travaux : vérifier que la nouvelle version 1.4 est pleinement opérationnelle, puis utiliser autoupgrade en 1 click pour passer à la dernière version de PS. Merci à Johann, tu m'as mis sur la bonne piste. Cordialement JF David
  10. Merci de ta réponse, Donc il ne semble pas y avoir d'erreur. Pourtant dans mon BO, quand je clique sur l'onglet "Modules", aucun module n'apparaît (les autres onglets fonctionnent normalement). Est-ce que tu vois d'où ça peut venir ? Je vais encore chercher et si je n'ai pas d'autre solution, je relancerai la MAJ par autoupgrade en 1 click, mais après avoir recopié les "_COOKIE_IV_" et "_COOKIE_KEY_", depuis mon site de production vers mon site de test (la manip que tu m'as indiquée dans ton post du 2 décembre 2015. En tous cas merci de ton aide, Cordialement JF David
  11. J'ai passé _PS_MODE_DEV_ à true. Mais comment je peux voir maintenant s'il y a une erreur, de mémoire ou autre ? Dans le BO, Outils/log, je n'ai aucun message d'erreur. Par contre, en FTP, dans le dossier log, j'ai le message suivant (date et heure correspondent effectivement à mon installation) : *ERROR* 2015/12/20 - 22:07:41: PHP error: /* PHP:remove_module_from_hook(blockcategories, afterCreateHtaccess); */ Dans le BO Modules/positions, je ne vois pas de blockcategories. Mais j'ai ça : After htaccess creation - 0 module [After htaccess creation] (Nom technique :afterCreateHtaccess) Aucun module pour ce point d'accroche Mais maintenant, qu'est-ce que je peux faire avec tout ça ? Merci par avance JF David
  12. Bonjour, J'ai récupéré ma version 1.3.7 et vérifié qu'elle fonctionnait correctement. J'ai ensuite fait la mise à jour vers la version 1.4.11.1, selon la méthode de Johann Corbel ci-dessus. En faisant l'install finale, j'ai le message en vert indiquant que le site est maintenant en 1.4.11.1, mais j'ai aussi l'indication en rouge "Unfortunately, 1 SQL errors have occured" Le FO semble correct, mais le menu principal ne comporte que deux liens : "Accueil" (qui conduit à une liste de CMS) et "Mes boutiques" (qui conduit à la page de Miami !). Par contre si je rentre les adresses à la main dans mon navigateur, j'obtiens les pages correctement. Le principal pb est dans le BO : l'onglet "Modules" conduit à une page quasi-blanche, avec les sous-onglets (Positions, Catalogue des modules et thèmes, Mon compte, Thèmes) mais aucun module n'est affiché. (j'ai vidé le cache sans succès). J'ai supprimé par FTP plusieurs modules que je soupçonnais non-compatibles, mais sans succès. Voila où j'en suis, comment faire maintenant pour refaire fonctionner l'onglet Modules du BO ? Merci par avance de votre aide. Cordialement JF David
  13. OK, bien reçu, je vais me lancer dans cette mise à jour en deux temps. Ça va me prendre un moment, j'ai les scripts mais je n'ai plus de 1.3.7 en ligne, il faut d'abord que je la récupère depuis le site opérationnel (je fais tous mes test sur un site en ligne mais bidon). Je te tiendrai au courant et compléterai ce forum avec le résultat de mes essais. En tous cas merci du temps que tu as passé à m'aider. Cordialement JF David
  14. J'ai fait la mise à jour avec le module 1 click upgrade, après avoir lu sur plusieurs forums que ça marchait même sur la 1.3.7, malgré l'avertissement de compatibilité qui accompagne ce module. Et donc la maj s'est bien passée (j'ai récupéré toutes les tables, clients, produits, commandes, etc), sauf ces problèmes que j'ai évoqués ci-dessus : mots de passe clients non reconnus (mais avec la recopie que tu m'as indiquée, ça marche), arrivée des messages mailalert en spam, pas de RIJNDAEL. S'il n'y a pas d'autres solutions, il faudra que j'essaie la mise à jour en deux stades tels que tu les as indiqués. Cordialement JF David
  15. Bonjour Johann, Je complète mon message précédent avec un problème je n'avais pas perçu : Après la recopie des "_COOKIE_IV_" et "_COOKIE_KEY_", le client peut effectivement se connecter avec son mot de passe initial. Mais, s'il fait une commande, les mails envoyés par le module mailalerts arrivent dans sa boite spam (testé avec gmail). A noter que les mails envoyés à la boutique (arrivée d'une nouvelle commande) viennent bien dans la boite de réception de la boutique. Si par contre le client demande un nouveau mot de passe et se connecte avec ce nouveau mdp pour faire une commande, les mails lui arrivent bien dans sa boite réception. Aurais-tu une solution à ce pb de spam, presque aussi embêtant que de demander aux clients de changer tout de suite leur mdp ? Cordialement, JF David
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More