Jump to content

Andi111

Members
  • Posts

    241
  • Joined

  • Last visited

Everything posted by Andi111

  1. Danke für die Antworten. Wenn ich jetzt alles in einem neuen Ordner im FTP herrichte und dann soweit fertig bin, wie bekomme ich die Kundendaten vom jetzigen Shop in den neuen? Also Produkte usw. bekomme ich denke ich hin, aber ich weiß nicht wie ich die Kundendaten dann in den neuen Shop bekomme. Reicht es hierfür aus wenn ich die Datenbank von meinem jetzigen Shop in den neuen übertrage? Aber hier ist denke ich das Problem dass ich dann mehr Sachen importiere als ich brauche oder?
  2. Hallo Nickz, bei Ionos. Was meinst du mit Controlpanel?
  3. Hallo zusammen, ich möchte meinen PrestaShop Onlineshop mal komplett neu aufsetzen. Das hat mehrere Gründe, weil mir das Design nicht mehr gefällt und weil gewisse Sachen nicht so funktionieren wie ich es gerne hätte. Ich würde jetzt gerne meinen PrestaShop im Classic Design nutzen, aber mit gewissen Modulen. Wichtig ist mir aber dass ich meinen jetzigen Shop derweil laufen lassen kann und den neuen Shop dann einfach online schalte und den alten offline. Die Produkte, Produktbilder, Produktbeschreibungen, bisherigen Bestellungen und die Kundenaccounts sollten jedoch erhalten bleiben bzw. übertragen werden. Ich möchte ihn gerne neu aufsetzen, also nicht nur das Theme ändern, damit es keine Störungen gibt und damit das alles mal "bereinigt" wird. Hat hier vielleicht jemand eine Anleitung wie man das am Besten und einfachsten umsetzen kann? Ich nutze PrestaShop in der Version 1.7.7. Grüße
  4. Habs gefunden. Sollte es noch jemand anderes suchen: Admin -> autoupgrade -> backup Hier sind dann die Backups als ZIP Datei abgespeichert. Sobald man sie runter geladen hat, hat man die selbe Ordnerstruktur wie am FTP.
  5. Hallo zusammen, ich habe bei meinem Shop ein Update durchgeführt und leider nicht dran gedacht dass selbst angepasste Sachen überschrieben werden. Da PrestaShop vor dem Update (über das Modul "1-Click Upgrade") ja noch ein Backup macht hoffe ich dass die Daten nicht verloren sind. Explizit geht es mir um die custom.css Datei vom Standard Template. Kann mir von euch jemand sagen wo diese Backups abgespeichert werden und vielleicht sogar ob hier eine Chance besteht die Datei wieder zu bekommen? Grüße
  6. @Whiley ok danke für die schnelle Antwort. Verstehe ich dann ehrlich gesagt nicht weshalb sowas dann angeboten wird. Ist das dann nur Marketing von den Anbietern solcher Module?
  7. Hallo zusammen, ich habe ein Modul gekauft für SEO. Unter anderem kann ich dort einstellen was in den Google Einträgen stehen soll. Mir ist nun aufgefallen dass in die Google Einträgen oftmals was ganz anderes steht als das was ich eigentlich hinterlegt habe. Ich habe unter anderem eingestellt dass das was in der Kurzbeschreibung der Produkte steht in der Google Beschreibung stehen soll. Bei den neuesten Produkten die wir bekommen haben steht jetzt das was in der Hauptbeschreibung als letztes steht in der Beschreibung von Google. Kann mir jemand erklären an was das liegen kann? Kann ich das irgendwie ausbessern? Oder macht Google einfach manchmal was es will bzw. die Daten wurden von Google falsch ausgelesen?
  8. Hallo zusammen, vorab die Informationen zu meinem PrestaShop: Version 1.7.7.2 PHP 7.3 Mir ist aufgefallen dass der Status (ob das jeweilige Produkt sichtbar ist oder nicht) unter Katalog -> Stocks falsch angezeigt wird. Dort wird der Status der Produkte als sichtbar (grüner Hacken) angezeigt, obwohl ich sie als nicht sichtbar eingestellt habe. Unter Katalog -> Artikel werden sie richtig angezeigt. Es funktioniert auch, wenn ich die Artikel als nicht sichtbar (rotes X) einstelle, werden sie im FO auch nicht angezeigt. Unter Stocks werden die Produkte jedoch fälschlicher Weise trotzdem als sichtbar angezeigt. Es ist jetzt nicht sehr schlimm, aber trotzdem wäre es gut wenn die Produkte unter Stocks auch richtig angezeigt werden würden. Damit es übersichtlicher ist. Ich habe schon andere Browser ausprobiert, überall das selbe Problem. Kann mir von euch vielleicht jemand weiter helfen? Grüße
  9. Hallo zusammen, vorab nochmals danke an @rictools für den Tipp für diese Erweiterung. Kann mir aber bitte jemand erklären wie ich mehrere Artikel einer Kategorie zuweisen kann? Ich habe es so probiert: 1. Einloggen 2. Bei "Products" dann "Switch to Checkbox Mode" ausgewählt 3. Alle gewünschten Artikel ausgewählt 4. Unter "Mass update" auf "Category", dann "Add" und dann die Kategorie ausgewählt 5. Auf "update all editable records" geklickt Anschließend lädt die Seite neu, aber wenn ich zurück zum BO gehe hat sich nichts geändert. Kann mir bitte jemand sagen was ich hier falsch mache? Installiert habe ich es unter /admin/Prestools_Suite. Grüße
  10. Ich habe gerade eben PrestaShop neu angelegt, um das zu testen. Da ist mir aufgefallen dass eine neue Version raus gekommen ist (1.7.7.5) und im Changelog steht: "- #24269: Fix already selected condition group on safari inside catalog price rules (by @NeOMakinG)" Also war es wirklich ein Bug, wenn ich das richtig verstehe aber nur in Safari. Wenn ich gewusst hätte dass es an Safari liegt, hätte ich einfach einen anderen Browser benutzt. Auf die Idee das mal zu testen bin ich nicht gekommen. Und siehe da, in der Version 1.7.7.5 funktioniert es wieder ganz normal. Aber da sich das mit Prestatools Suite echt interessant anhört, ist es das was du gemeint hast?
  11. Danke für den Hinweis mit "Prestools-Suite", aber heißt das Modul genau so? Denn ich finde es nirgends.
  12. Also ich habe gerade eben mal in meine Datenbank geschaut. Dort ist kein einziger Eintrag mit "price" oder "rule" zu finden. Kann es denn möglich sein dass bei dem Update der Datenbankeintrag dafür nicht integriert wurde? 😅
  13. @rictoolsgibt es denn irgendeine Möglichkeit mehrere Produkte gleichzeitig einer weiteren Kategorie hinzuzufügen und zu entfernen? Denn wenn ich 1000+ Produkte ins Angebot und wieder raus nehmen möchte und jeden Artikel anklicken und dann der Kategorie zuweisen muss, könnte ich gleich bei den einzelnen Artikeln den Rabatt hinterlegen. Oder verstehe ich dich irgendwie falsch?
  14. Ja, schon immer wieder mal. Da es für mich einfacher ist komplette Kategorien zu rabattieren als einzelne Artikel. Werde ich mal schauen, ich danke dir.
  15. Hallo @rictools, wenn ich die Regel anlege funktioniert es ganz normal. Erst wenn ich nochmals auf die Regel klicke, um z.B. die Kategorie oder den Rabatt zu ändern, zeigt es mir die falsche Kategorie an und wenn ich jetzt auf speichern klicke ist der Rabatt nicht mehr auf der gewünschten Kategorie sondern auf der die im ABC zuerst kommt. Nach was muss ich denn in der Datenbank suchen, mal ganz doof gefragt.
  16. Vielleicht nutze ich auch den falschen Weg um das zu erreichen was ich möchte. Ich möchte auf komplette Kategorien einen Rabatt von z.B. 20% geben. Ich könnte natürlich hierfür jedes einzelne Produkt durchklicken und dort den Rabatt eingeben, aber da würde ich nicht mehr fertig werden. @rictoolsdieses Problem tritt auch auf wenn ich die Preisregel nur für eine Kategorie mache. Eigentlich muss es ein Bug sein, denn mit PrestaShop 1.7.7.2 hat es, wenn mich nicht alles täuscht, noch einwandfrei funktioniert. Es gab auf alle Fälle eine 17.7.X Version bei der es funktioniert hat. @Claudiocooles kann schon vorkommen dass ein Produkt mehrere Unterkategorien hat. Also z.B. Kategorie 1/Kategorie 2/Kategorie 3, aber die Artikel sind dann immer in nur einer letzten Kategorie, nie in mehreren letzten Kategorien. Aber daran kann es eigentlich nicht liegen, denn ich habe einen frischen PrestaShop erstellt und dort ist das selbe Problem. Ich habe an dem neuen Shop nichts gemacht außer mit den vorgefertigten Sachen Preisregeln zu erstellen. Blöde Frage, kann sowas an der PHP Version liegen? Denn ich nutze PHP Version 7.3, diese wird doch aber seit neuestem unterstützt oder habe ich hier etwas falsch verstanden? Ich habe meinen Server bei Ionos angemietet und hier wird die ältere Version nicht mehr unterstützt, deswegen habe ich das Update gemacht.
  17. Hallo rictools, danke für deine Antwort. Ich weiß mir echt nicht zu helfen, vor allem da es ja sogar in der Version vorkommt die man aktuell bei PrestaShop runter laden kann. Eigentlich ist es recht einfach zu erklären: Wenn ich unter "Katalog Preisregeln" eine Preisregel, z.B. auf eine Kategorie 20% Rabatt, anlege funktioniert der Rabatt zwar, aber wenn ich ein zweites Mal drauf klicke um z.B. eine weitere Kategorie hinzuzufügen ist nicht mehr die ursprüngliche Kategorie hinterlegt sondern die die im ABC als erstes kommt. Ich weiß ehrlich gesagt aktuell nicht was ich machen soll, denn so ist es nicht wirklich brauchbar. Kann mir von euch vielleicht jemand ein Modul für sowas empfehlen?
  18. Ich weiß nicht an was das liegt, hat das Problem von euch niemand?
  19. Ich habe jetzt zum testen einen komplett neuen Shop aufgesetzt, hier passiert das Selbe. Dort habe ich keinerlei Module installiert. PrestaShop Version 1.7.7.4, aber in Version 1.7.7.3 funktioniert es auch nicht. Ich gehe unter Rabatt -> Katalog Preisregeln, gebe der Preisregel einen Namen, klicke auf "Neue Preis-Regel" und wähle dort die Marke "Test" aus. Anschließend wird mir unter "Konditionsgruppe 1" die Marke "Test" angezeigt. Dann klicke ich auf "Speichern". Sobald ich aber wieder auf die Katalog Preisregel drauf klicke wird mir die allererste Marke angezeigt, die Marke "ABC". Der Rabatt wird aber richtig zugewiesen, dieser gilt für die Marke "Test". Wenn ich aber die Marke "Test" hinzugefügt und das abgespeichert habe, anschließend nochmal auf die Katalog Preisregel drauf klicke und mir dann anstatt "Test" die Marke "ABC" angezeigt wird und ich dann auf Speichern klicke springt der Rabatt von "Test" auf die Marke "ABC". Kann diesen Fehler von euch jemand bestätigen bzw. weiß was man dagegen machen kann? Denn wenn man in einer Konditionsgruppe mehrere Marken, Kategorien oder was auch immer drin hat wird es sehr unübersichtlich, weil man dann nicht mehr nachvollziehen kann welche Marke wo ist. Alternativ müsste ich für jede Marke eine extra Katalog Preisregel anlegen und diese dann nach der Marke benennen, was aber viel aufwändiger wäre. Dieser Fehler existiert aber noch nicht so lange, denn vorher hat es ja auch funktioniert. Wenn mich nicht alles täuscht mit Version 1.7.7.2. Ich habe euch hier mal ein paar Screenshots angehängt. Edit: Da es jetzt nach dem Posten anders rum angezeigt wird muss ich mich verbessern. Das Bild mit "Test" als Marke ist vor dem Speichern und das Bild mit "ABC" als Marke ist nach dem Speichern.
  20. Hallo zusammen, ich nutze PrestaShop in der Version 1.7.7.2 und PHP 7.3. Ich habe "Katalog Preisregeln" einmal mit 10%, einmal mit 20% und einmal mit 30% Rabatt erstellt. Wenn ich bei 10% Rabatt keine Marke hinzugefügt habe, aber bei 20% schon, wird die Marke die ich bei 20% hinzugefügt habe mit 10% rabattiert. Wenn ich bei 10% eine Marke hinzufüge und bei 20% auch werden zwar beide Marken richtig reduziert. Aber was sehr komisch ist, bei den 10% wird im FO zwar die richtige Marke rabattiert aber bei den Katalog Preisregeln unter 10% wird eine komplett andere Marke angezeigt als ich eingestellt habe. Dort wird dann die erste Marke die ich auswählen kann angezeigt. Ich habe vorher Marke A dort bei den 10% eingestellt, gespeichert und diese Marke wird im FO auch richtig rabattiert. Als ich dann nochmal dort auf die 10% rauf geklickt habe wird mir eine andere Marke (die erste die ich dort auswählen kann) angezeigt. Ist das normal so? Edit: Egal wieviel neue Preisregeln mit unterschiedlichen Marken ich bei 10% hinzufüge und anschließend auf speichern klicke, sobald ich nochmal drauf klicke wird bei jeder Preisregel die erste Marke die ich bei Marken auswählen kann angezeigt.
  21. @rictools, danke dir! Du hast ja gerade die Schriftgröße beschrieben oder? Mit "#ui-id-2" konnte ich die Feldgröße in der custom.css Datei ändern.
  22. Kann diesen Post bitte jemand löschen? Ich habe versehentlich zwei Mal den selben Thread aufgemacht, weil mir ein Fehler angezeigt wurde.
  23. Hallo zusammen, mir ist gerade eben aufgefallen dass das Favicon welches ich eingestellt habe nicht angezeigt wird wenn ich im FO die Startseite da habe und in der Adresszeile, wenn man die Seite eingibt, auch nicht. Dort wird dann das PrestaShop Favicon angezeigt. Sobald ich aber etwas in die Suchleiste eingebe, also mich von der Startseite weg bewege, wird es aber angezeigt. Ich habe PHP Version 7.3 und die PrestaShop Version 1.7.7.3
  24. Hallo nochmal, @JBW @rictools Mir ist gerade eben aufgefallen dass das ganze in der mobilen Ansicht (am Smartphone) nicht funktioniert. Dort wird noch immer die Kategorie mit angezeigt. Ich habe jetzt mal in der selben Datei geschaut, aber nichts zu "mobil" gefunden. Könnt ihr mir hier eventuell nochmal helfen? Edit: Sorry, hat sich erledigt. Lag daran dass ich dort die Cookies noch nicht gelöscht hatte. Aber kann mir von euch jemand vielleicht noch sagen wie ich die Schriftgröße und die große des Feldes bei den Suchvorschlägen ändern kann?
  25. Hallo @rictools, danke für die Infos! Es hat sich nichts verändert. Es wird noch immer Kategorie > Produkt bei der Suche angezeigt wenn man etwas ins Suchfeld eingibt. Ist schon irgendwie komisch, wenn ich zwei komplette Stränge raus lösche und es dann noch immer funktioniert. Als Programm zum editieren benutze ich "Brackets". Wenn ich CSS Dateien editiere funktioniert es aber auch. Edit: Hoppala, mein Fehler. Ich hatte meinen Browser Cache nicht gelöscht. Jetzt wo ich das getan habe funktioniert es. Diesen Cache habe ich vorher aber noch nie gelöscht, nur den Cache von PrestaShop und es hat immer funktioniert. Ich danke euch vielmals. Kann man euch auf irgendeiner Weise einen Kaffee spendieren? Wie oft ihr beiden @rictoolsund @JBWmir schon geholfen habt!
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More