Jump to content

abouzouzou

Members
  • Posts

    295
  • Joined

  • Last visited

Everything posted by abouzouzou

  1. allez dire cela aux clients qui vont avoir l'erreur, pour moi ce n'est pas une solution viable. qui plus est vous allez ravoir l'erreur prochainement....donc ce n'est pas une solution
  2. hello, any news ? i am trying to retrieve customers (users based on login password), i saw in 1.7 this is the way to encode password : $password = md5('5BeHRGBt7r012341t1t1LXDDo1234yON1r67JyM4321VHDgnq4321CmS' + 'rl61122'); but i can't manage to retrieve it
  3. J'ai revert le multiboutique car il y avait tous les jours des problèmes de paiement avec onecartcheckout et j'en avais marre d'avoir des soucis.... depuis plus de problème. donc je pense que comme a dit un collègue les cookies ou header devenaient trop gros... à part supprimer verification fronted etc.... je sais pas ce qui peut arranger le soucis.... peut être voir avec les developer prestahop sur github leur multiboutique en 1.7 est assez catastrophiqe
  4. Bonjour, je suis en train de developpé des appels REST vers le webservice. Lord de GET tout se passe bien, mais lors de POST ou PUT voici mes erreurs : Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. j'ai ajouté des header dans le dispatcher.php et dans HTACCESS pour les options mais rien. Vous avez une idée ?
  5. Oui le thème c'est prévu dans tous les cas. après je sais que ca va être une galère car sans CDC et sans documentation des fonctionnalité c'est mort ! cela vous semble jouable de mettre en place un configurateur et ensuite ajouter au panier via les webservices le résultat du configurateur ?
  6. Pour ma part j'installe tout en 1.7 car la plupart des sites ont pas trop de gros besoins. après je reprend surtout les commentaires des prestashoppeurs sur la version 1.7 pas très stable Pour mon propre site 1.7.6.8 j'ai testé le multiboutique et la catastrophe, 10 jours sans aucune commande, les paiements qui ne fonctionnent pas, les livraison non plus etc... marche arrière oblige, et marche arrière d'un multiboutique c'est tout à la main ! par contre ce qui m'a toujours étonné c'est la différence de gestion des updates contrairement à worpdress, wordpress j'amais eu de soucis de migration inter génération.... c'est fou !
  7. je ne suis pas développeur prestashop à la base (je vous en avais fais la référence dans d'autres posts). de base j'ai déjà expliqué au client les tenants et aboutissants de ce qu'il veut. 1. Migrer en prestashop 1.7 n'est pas conseillé (étant donné la qualité par rapport à une 1.6 par les experts comme Eolia, doekia etc...). Est-vraiment justifier de migrer la version 1.5 ? pour ma part vu la complexité de son projet je ne pense pas que ce soit un choix judicieux, mais vous connaissez les clients ils font ce qu'ils veulent, malgré nos conseils, car son développeur lui a dit que de 1.5 à 1.6 il n'y avait aucun intéret 2. Un ancien developpeur à créé un module custom sans documentation bien sûr, avec un backend de ce module en DRUPAL (allez savoir pourquoi) 3. je sais que de 1.5 à 1.6 on pourrait si je ne me trompe pas garder le module et peut être l'adapter un peu.... mais la 1.7 change fondamentalement et donc serait à recoder complétement. 4.il veut garder les commandes, les clients, les points fidélités etc et les pages CMS (pour toute cette partie je ne pense pas avoir de réélle complexité, bien que les module d'upgrade peuvent ne pas fonctionner si simplement) J'ai proposé plusieurs solutions : 0 laisser comme cela car cela fonctionne, faire les quelques modifications et au moins pas d'argent perdu, pas de revert car incompatibilité etc (mais bon on sait que ce sera NON) 1 faire tout full prestahsop version 1.7 car le client veut 1.7 (mais dans quelques années il sera reconfronter au meme soucis mais au moins tout est géré sur une seule plateforme) 2 rediriger sur une application tierce le configurateur (en JS par exemple, vue, react ou autre) et une fois la configuration terminée envoyé l'article au panier via les webservices REST.de ce fait les migration futures seront plus aisées 3 ce qu il devrait faire mais n'a pas le budget coder tout dans un site complètement custom, mais long à faire , plus couteux, mais au final plus évolutif et plus libre de faire comme on veut) sachant que le budget est en dessous de 5000 euros je pense que la seule solution viable pour lui est la 0 ^^ merci vous pour votre compréhension car c'est plus grâce à vous que j'apprends plus que grâce au forum prestashop
  8. Bonjour, Nous avons un site en version 1.5 avec un module de customisation de produits fait sur mesure en 1.5. Le client souhaite migrer sa version 1.5 en 1.7 du coup il va falloir migrer aussi ce module. Est-ce simple à réaliser ? ou devons nous tout recoder ? merci !
  9. qi désactive javascript de nos jours... je prend note pour les outils... mais avec les paramètres utm vous arrivez à calculer un ROI sur google ads ou facebook ? nombre de conversion, valeur de conversion etc ? oui facebook et google il y a les double transactions qu'il faut enlever avec les ID et totaux de transaction on avait galérer avec le google tag manager en tout cas un grand merci grâce à vous on avance plus vite
  10. et surtout je préfère demander aux experts au piliers d'un domaines ce qu'ils en pense car ils ont du forcément du passé par là... donc pour ma part j'ai supprimé ce tag qui est inutile... car de nos jours tous les support supportent javascript
  11. je suis développeur java à la base. la c'est plus un passe temps ^^. et oui j'ai été formé ainsi. coder proprement pour éviter la dette technique et se poser des questions sur le fonctionnement de quelque chose. car il faut distinguer entre les validateurs comme sitechecker (et voir si c'est pas lui le problème) voir les plugins qui sont censés nous faciliter la vie etc.... pour le plugin facebook il va forcément récupérer des données sensible puisqu'il arrive a detecter un client qui vient de facebook et d'une promotion pour vous donner des tatts d'achat etc... donc à un moment donné si on veut certaines données on a pas le choix que de leur ouvrir les portes et de ne pas regarder tout ce qui se passe. On sait pertinement qu'il va forcément regarder autre chse pour ma part j'ai pas le temps de regarder
  12. je vais virer complétement cette balise après j'essaie de comprendre le pourquoi du comment car en tant que développeur on se doit de se dire si les personnes ont fait comme cela c'est que c'est utile, et qu'il y a une raison.. mais dès fois effectivement...
  13. non ce n'est pas ce que je dis. je dis que le problème ne vient pas dans module ou de quelque chose qui en passant sur le code le modifie car j'ai testé différents sites internet et je trouve la même erreur, je vais donc voir en la supprimant car il est clai que si jamais on a un poste sans javascript de toute facon plus rien ne fonctionnera
  14. par contre je viens de remarquer que c'est pareil pour tout le monde, si vous regardez vous devez avoir la même chose dans vos sources
  15. nono moi c'est lui {* * 2007-2017 PrestaShop * * NOTICE OF LICENSE * * This source file is subject to the Academic Free License (AFL 3.0) * that is bundled with this package in the file LICENSE.txt. * It is also available through the world-wide-web at this URL: * http://opensource.org/licenses/afl-3.0.php * If you did not receive a copy of the license and are unable to * obtain it through the world-wide-web, please send an email * to [email protected] so we can send you a copy immediately. * * DISCLAIMER * * Do not edit or add to this file if you wish to upgrade PrestaShop to newer * versions in the future. If you wish to customize PrestaShop for your * needs please refer to http://www.prestashop.com for more information. * * @author PrestaShop SA <[email protected]> * @copyright 2007-2017 PrestaShop SA * @license http://opensource.org/licenses/afl-3.0.php Academic Free License (AFL 3.0) * International Registered Trademark & Property of PrestaShop SA *} <!-- Facebook Pixel Code --> {literal} <script> !function(f,b,e,v,n,t,s) {if(f.fbq)return;n=f.fbq=function(){n.callMethod? n.callMethod.apply(n,arguments):n.queue.push(arguments)}; if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.agent='plprestashop-download'; // n.agent to keep because of partnership n.queue=[];t=b.createElement(e);t.async=!0; t.src=v;s=b.getElementsByTagName(e)[0]; s.parentNode.insertBefore(t,s)}(window, document,'script', 'https://connect.facebook.net/en_US/fbevents.js'); fbq('init', '{/literal}{$id_pixel|escape:'htmlall':'UTF-8'}{literal}'); fbq('track', 'PageView'); </script> <noscript> <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id={/literal}{$id_pixel|escape:'htmlall':'UTF-8'}{literal}&ev=PageView&noscript=1"/> </noscript> {/literal} <!-- End Facebook Pixel Code --> <!-- DO NOT MODIFY --> <!-- End Facebook Pixel Code --> <!-- Set Facebook Pixel Product Export --> {if $page.page_name == 'product'} <meta property="og:title" content="{$product.name|escape:'htmlall':'UTF-8'}"> <meta property="og:description" content="{$product.description_short|strip_tags:false|escape:'htmlall':'UTF-8'}"> <meta property="og:url" content="{$product.link nofilter}"> <meta property="og:image" content="{$product.images.0.bySize.medium_default.url}"> <meta property="product:brand" content="{$product_manufacturer->name}"> <meta property="product:availability" content="{if $product.available_for_order == 1}In stock{else}Out of stock{/if}"> <meta property="product:condition" content="{$product.embedded_attributes.condition}"> <meta property="product:price:amount" content="{$product.price_amount}"> <meta property="product:price:currency" content="{$currency.iso_code}"> <meta property="product:retailer_item_id" content="{$product.id}"> {/if} <!-- END OF Set Facebook Pixel Product Export --> {if !empty($content)} {literal} <script> fbq('{/literal}{$track|escape:'htmlall':'UTF-8'}{literal}', '{/literal}{$type|escape:'htmlall':'UTF-8'}{literal}', {/literal}{$content nofilter}{literal}); </script> {/literal} {else if !empty($type) && empty($content)} {literal} <script> fbq('{/literal}{$track|escape:'htmlall':'UTF-8'}{literal}', '{/literal}{$type|escape:'htmlall':'UTF-8'}{literal}'); </script> {/literal} {/if}
  16. ah non la c'est le pixel de facebook , mais vous me dites que cela pourrait être le plugin de business tech qui pose le soucis ?
  17. bizarre surement pour dire oups , mais est-ce bvraiment utile ? car quelque chose ajoute les quotes devant et derrière ... une idée ? j'ai réinitialiser le plugin mais otujours pareil et c'est venu que depusi quelques temps
  18. ca je l'ai compris moi ce qui m'interesse c'est comment est généré ce no script, quel modul si c'st un module
  19. on ne fais plus plusieurs transporteurs pour une commande PRESTASHOP 1.7 la loose
  20. Bonjour, depuis quelques jours j'ai cette erreur vous avez une idée de ou cela peut provenir ? merci !
  21. ouai mais les derniere choses , templates evolution sont en version 7 non ? merci ! c'est vraiment du gachi
  22. comment on règle ce genre de problème de modules prestashop ? comment on meur indique de se charger apres le chargement de jquery ? merci !
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More