Jump to content

Yann Marec

Members
  • Posts

    13
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Yann Marec's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Bonjour à tous, existe-t-il un moyen d'ajouter un champ "complexe" sur une page produit ou (ce qui m'intéresse en ce moment) une page catégorie qui proposerait comme le champ "produit associé" de saisir une liste de produits ? Je recherche une solution de ce type pour mon besoin de créer une sélection de produits à mettre en avant pour une catégorie. Cette solution serait aussi utile sur la page manufacturer pour mettre en avant les produits stars d'une marque. De manière plus générale, existe-t-il une doc qui répertorie tous les types de champs qu'on peut ajouter via le dev d'un module ?
  2. ah ok, j avais pensé à prendre le problème de cette façon. Merci pour la réponse hyper-rapide 💪
  3. Bonjour, je connais la fonctionnalité CMS qui permet de créer des "petites" pages avec du contenu statique mais aujourdhui ce n'est pas ce qui m'intéresse. Je travaille sur le thème de ma boutique, sur la page statique "Nos magasins". Pour la modifier, je dois travailler sur le fichier template/cms/stores.tpl et je suis très libre de la travailler en html/css/js. Ma question, c'est de savoir s'il est possible de créer d'autres pages statiques comme celle-ci, c'est à dire générée à partir d'un fichier tpl contenu dans mon repertoire theme plutôt qu'à partir de code source enregistrée dans la base de données (comme les pages se trouvant dans Apparences/CMS). Si quelqu'un a des infos là dessus ou a déjà réalisé de telles pages, je suis preneur; j'ai bien cherché à droite à gauche mais pour le moment je n'ai pas trouvé.
  4. non, pas de CDN activé. Les réponses d OVH sont toujours les mêmes, c'est un problème de prestashop donc débrouillez-vous. Depuis ma dernière modif c'est quand même plus simple car j'ai pas la page d'erreur un clic sur deux. Mais par contre, je reste persuadé qu'il y a un lien avec l'hébergement, j'ai beaucoup moins de soucis ce week-end en travaillant toute la journée. Et les seules fois où j'ai un message d'erreur, c'est en uploadant des images : HTTP 502 - NGINX Error ... alors que je suis sensé être sur un apache... je verrais demain, voir si c est pas un problème de surcharge de serveur mutualisé.
  5. je continue à fouiller dans le code de prestashop et j'ai fait "évoluer" mon problème. Dans la classe PrestaShopBundle\EventListener\TokenizedUrlsListener, méthode onKernelRequest, j 'ai commenté toute la partie vérifiant le token : /* $token = false; if ($request->query->has('_token')) { $token = new CsrfToken($this->username, $request->query->get('_token')); } elseif (isset($request->query->get('form')['_token'])) { $token = new CsrfToken('form', $request->query->get('form')['_token']); } if (false === $token || !$this->tokenManager->isTokenValid($token)) { // remove token if any if (false !== strpos($uri, '_token=')) { $uri = substr($uri, 0, strpos($uri, '_token=')); } $response = new RedirectResponse($this->router->generate('admin_security_compromised', ['uri' => urlencode($uri)])); $event->setResponse($response); }*/ je n'ai plus la page token invalid qui apparait, mais à la place, lorsque je valide un formulaire de création de produit, j ai le message d'erreur suivant qui apparait et le form n'est pas validé : "The CSRF token is invalid. Please try to resubmit the form." Est-ce que ça vous dit qqchose ?
  6. je suis passé en php 7.1 mais toujours les mêmes problèmes. J'ai de sérieux doutes sur ovh, je soupçonne une modif au niveau serveur mais pour le moment je n'arrive pas à avoir l'info avec le support, ils me disent que le site est bien accessible. C'est en effet le cas pour le front, il n'y a aucun problème. Le problème se situe bien dans le back où cette p... de page token invalide apparait un clic sur deux. Quelqu'un saurait comment désactiver temporairement cette vérification de token, histoire que nous puissions avancer sur la création des fiches produit en attendant d'avoir une réponse sérieuse de la part d'ovh. J'ai cherché un peu dans le code de prestashop mais pour le moment sans succès. J'envisage de rapatrier tout le site en local pour que nous puissions créer les fiches (on aurait aimer ouvrir le site assez rapidement en version clic-n-collect pour compenser un peu la perte d'activité de notre fermeture de boutique, mais 3000 fiches à créer et cette ano ne nous aide franchement pas) mais j'aurais aimé éviter parce que j'ai peur de perdre un temps fou à resynchroniser le presta de prod avec les données locales.
  7. Merci pour vos réponses. J suis sur prestashop 1.7.5.2, hebergé en mutualisé sur ovh, sur un apache. Au niveau des modules, j'ai uniquement ajouté 1-click upgrade, mais il y a plus de 6 mois et je m'en suis pas servi depuis. Au niveau des tokens, ils sont stockés dans quel répertoire ? Guim, la solution consiste en quoi ? modifier la version php utilisée ? actuellement, je suis en 7.2
  8. Merci pour ta réponse. Mais j'ai déjà désactivé cette option et toujours le même problème. Et ce n'est pas un problème de temps de session, le problème peut arriver au bout de quelques minutes. Et j'ai beau cliqué sur "oui, je comprends les risques" ou "sortez-moi d'ici", me déconnecter, me reconnecter, le problème persiste. Et comme je disais, j'ai fait les tests en normal, en navigation privée, sur plusieurs navigateurs et sur plusieurs pc, toujours le même soucis
  9. Bonjour, j'ai déjà essayé, mais le problème persiste, que ce soit avec une navigation privée, firefox ou chrome ou sur d'autres ordinateurs.
  10. Bonjour à tous, depuis le confinement ma boutique physique étant fermée je travaille sur l'ouverture d'une boutique en ligne. Mais depuis lundi, j'ai énormément de soucis car j'ai sans arrêt l'erreur "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité." qui apparait lorsque je valide une fiche ou lorsque je navigue dans le back-office. L'erreur n’apparaît pas à chaque changement de page mais très très souvent. Mon site est hébergé chez OVH, je leur ai demandé s'il y avait eu des problèmes de leur coté mais je n'ai pas encore de réponse. Jusqu'à hier, j'arrivais encore à avancer en utilisant le partage de connexion 4G de mon téléphone car j'ai remarqué que l'erreur arrivait beaucoup plus souvent en étant connecté sur ma ligne adsl free. Mais depuis ce matin, aucune différence, l'erreur arrive une page sur deux, que ce soit en 4G ou adsl. Est ce que je suis le seul à rencontrer ce genre de problème ? Est-ce que quelqu'un aurait une solution, même temporaire ? j'ai essayé de désactiver le contrôle de token mais sans succès (dans mes recherches internet j'ai trouvé des pistes parlant de modifier la méthode isLoggedBack de la classe Employee mais je ne vois pas d'amélioration).
  11. Pour le moment, je créé un attribut spécifique "nomproduit-texture" mais je trouve ça bizarre de polluer la liste des attributs pour un produit. Le mieux serait de pouvoir utiliser un attribut dont les valeurs seraient définies directement dans la fiche produit et pas ailleurs. Mais je ne sais pas si ça existe.
  12. Bonjour, j'aurais besoin de conseils sur la gestion des attributs pour les déclinaisons de produit. J'ai plusieurs produits avec déclinaisons pour lesquelles l'attribut décliné est très spécifique dans mon catalogue (textures); cet attribut ne sera jamais réutilisé par d'autres produits. Que dois-je faire ? dois-je quand même créer un attribut général qui ne sera utilisé que par cet article ou y a-t-il une solution pour définir l attribut et ses valeurs directement dans la fiche du produit ?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More