Jump to content

maw95

Members
  • Posts

    10
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

maw95's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Witam, mam problem z konfiguracją multistore - problem jest bardzo podstawowy, więc domyślam się, że rozwiązanie jest banalne, ale niestety nic mi nie przychodzi do głowy. Mam działający sklep, który do tej pory miał wyłączony tryb multistore. Próbuję zrobić drugi sklep zgodnie ze wskazówkami z dokumentacji Presty: 1. Włączam "tryb Multisklep" w "Preferencjach" 2. Wchodzę w "Zaawansowane->Multisklep", klikam "dodaj nowy sklep" 3. Wybieram konfigurację nowego sklepu, powiązane kategorie, szablon itd. - sklep się tworzy 4. Dodaję do nowego sklepu adres URL: jest przypisany do mojego drugiego sklepu jest włączony domena/domena SSL są takie same jak domena starego sklepu fizyczny URL domyślny ("/") w wirtualnym URL wpisuję nazwę nowego sklepu, np. "/test" 5. Sklep w backoffice pokazuje się dobrze, za to przy próbie wejścia na np. "mojadomena.com/test" wyskakuje mi error 500 - nawet nie 404, tylko 500. Włączenie trybu debugowania nie pokazuje żadnych nowych informacji, tak samo jak aktywacja error_reporting w php.ini. Próbowałem robić to samo na kilku sklepach, w tym na czystej instalacji Presty - wszędzie jest tak samo. Tutaj pojawiają się pytania: co robię nie tak? czy powinienem ręcznie utworzyć folder "test" przez FTP? jeśli tak, to czy powinienem do niego coś wgrać? skopiować pliki ze starego sklepu lub wgrać do niego świeżą instalację Presty? jeśli mam tworzyć ten folder i ręcznie coś do niego wgrywać, to do czego służy opcja importu przy tworzeniu nowego sklepu? Z góry dziękuję za odpowiedź
  2. @JBW Well, after switching it on the problem has been solved I guess - I don't think there's anything better to do :) Thanks!
  3. Hi, I have a problem with Product Combinations that have more than one attribute (i.e. size and color). Example: My product is a shirt, and it has 4 possible combinations: - white S - white M - black S - black M Default combination is white S. 2 combinations are out of stock - white M and black S. When i land on the product page, white S is selected. I have two lists of attributes - size and color. On the size list, there are two options - S and M. On the color list, there is only one - white (I have one black M shirt in stock though, but it doesn't matter) The problem is that when I try to change the size to M, it doesn't work - it keeps reverting me to default combination, white S. I think that the problem is that Presta checks combination availability right after selecting an option - so when I try to change white S to black M, I have to change the size first - so after selecting the "M" option, Presta checks if there is white M available (because color is still white) - white M is out of stock, so Presta reverts user to default available combination, white S. So, I have black M on stock, but user can't add it to cart. Maybe it's a little bit complicated, and screenshots wouldn't explain much - here are two examples: - https://4horse.pl/en/helmets/1773-1015-kask-ked-paso-mesh.html#/3-size-l/17-color-brown Here you can change from Silver M to Brown L, but you can't revert it - every time you try to select M, Presta keeps reverting to L - https://4horse.pl/en/saddle-clothes/1424-579-czaprak-evo-torpol.html You can't change to size VS from default combination - because there aren't navy ('granatowy') VS's on stock. In order to get VS size, you have to select DRE size first - then select green ('zielony'), then choose size VS - because we have green VS on stock I'll be very glad for your help - I've tried everything, but still don't have any idea what's going on.
  4. Hello, I have a problem with generating combinations on one of my sites - every time I try to generate them, there's a red error popup in top-right corner: "Can't update settings". Error in the Chrome console is: "POST {back office url}/index.php/sell/catalog/products/1?_token=sORZZ_cpZHnCNZ04SH0C9NMNqkGEsMif3-u0mfkDwA4 400 (Bad Request)" Ajax response (in 'network tab') is: {"combination_12_attribute_ecotax":["This value should not be blank."],"combination_12_attribute_minimal_quantity":["This value should not be blank."],"combination_12_attribute_quantity":["This value should not be blank."],"combination_13_attribute_ecotax":["This value should not be blank."],"combination_13_attribute_minimal_quantity":["This value should not be blank."],"combination_13_attribute_quantity":["This value should not be blank."],"combination_14_attribute_ecotax":["This value should not be blank."],"combination_14_attribute_minimal_quantity":["This value should not be blank."],"combination_14_attribute_quantity":["This value should not be blank."],"combination_15_attribute_ecotax":["This value should not be blank."],"combination_15_attribute_minimal_quantity":["This value should not be blank."],"combination_15_attribute_quantity":["This value should not be blank."]} Most interesting things here are: - I've upgraded Presta from 1.7.6.3 to 1.7.6.8 - with no result - There's PHP 5.6 on the server, but there are many other PrestaShop shops on this server - and combinations work there properly - I don't try to make huge amount of combinations - it doesn't matter if I try to do 8, 4 or 2 of them - there's always the same error - It doesn't appear to be browser issue - tried on Chrome, Firefox and Edge Errors, form data and server information are on screenshots. Anyone can help?
  5. @szym3k a masz moduł UPS? Jeśli tak, to on jest powodem. Moduł UPS podmienia wartość nagłówka strony (o ile dobrze pamiętam Content-Security-Policy) na 'none', przez co nie możesz podglądać swojej strony nawet poprzez panel admina, więc LiveEditor się wykrzacza. Znalazłem 2 rozwiązania: - wyszukać w plikach modułu frazy "Content-Security-Policy" i zmienić wartość 'none' na 'self' przy wszystkich wystąpieniach tej frazy - odinstalować ten moduł i zainstalować zamiennik, bo z modułem UPS generalnie jest sporo problemów Jeśli nie masz modułu UPS to prawdopodobnie inny moduł podmienia Ci zawartość tego nagłówka, albo masz 'Content-Security-Policy:none' gdzieś w ustawieniach serwera.
  6. U mnie tak samo, może znalazł ktoś jakieś rozwiązanie? W dispatcher.php też dodawałem nagłówki, nic się nie dzieje.
  7. Hello, I've got a little situation with my shop and its "Change product position in category" feature. When I add a new product and assign categories to them, its position in the category is set to the last place by default, and I have to drag-and-drop it to the first position manually. It wouldn't be a problem, but I have almost 3000 products - so dragging and dropping a product from last position to first position takes forever - and I add new products really often. So the question is, can I change it through a panel or through a code? I mean, when I assign a product to a category, it's default position should be first, not last. It's Presta 1.6.1.23.
  8. PrestaShop 1.7.6.3 Classic theme Split order has few bugs in Front Office... When user is trying to buy products with different (mutually exclusive) carrier options, he/she: - in carrier-choosing step sees only a list of carriers for last part of order. Therefore, user doesn't even know that his/her payment is divided and can't choose carrier for previous parts of order - in order confirmation page sees only products and prices from the last part of order For example, we have two products: - product 1, with two carrier options (DHL and personal pickup) - product 2, with one carrier option (UPS) When placing an order, user sees available shipping methods. As I said, he has only one option to choose (GLS). Funny thing is that when you add products to cart in reverse way (first product 2, then product 1), user can choose between DHL and personal pickup. After placing an order, our client waits few seconds (Presta has huge lags during order splitting) and sees order confirmation page. Client sees only miniature and price of product 2, not a single mention about product 1. At the bottom of the page, client sees payment info - amount is product 1 price + product 1 shipping + product 2 price + product 2 shipping, so it's all right. Is there any workaround or way of fixing this? I prefer "changing code by myself", but if there is any module, which can deal with it, it would also be all right.
  9. Opcja dzielenia zamówienia na kilka części w sytuacji, w której chcemy zamówić produkty z różnymi (wykluczającymi się) opcjami wysyłki, wydaje się mieć kilka wad. O ile po stronie Back Office wszystko jest w porządku, o tyle w trakcie składania zamówienia klient: - podczas wyboru przewoźnika ma do wyboru tylko listę przewoźników dla ostatniej części zamówienia (dla produktu, który został dodany do koszyka jako ostatni). Przez to klient nawet nie wie, że jego zamówienie dzieli się na dwie części, nie może wybrać przewoźnika dla pierwszej części zamówienia. - po złożeniu zamówienia widzi ekran z potwierdzeniem zamówienia, na którym jest przedstawiona tylko ostatnia część zamówienia. Przykładowo, mamy dwa produkty: produkt 1, ma możliwą tylko jedną opcję wysyłki, czyli "Kurier DHL" produkt 2, ma możliwą tylko jedną opcję wysyłki, czyli "Wysyłka po uprzedniej wycenie" Użytkownik przy składaniu zamówienia, kiedy już poda swoje dane i adres, widzi opcję wyboru wysyłki. Tak jak wspomniałem, ma do wyboru tylko jedną opcję wysyłki, która jest przedstawiona jako "Wysyłka po uprzedniej wycenie". Zabawną rzeczą jest to, że jeśli najpierw dodamy do koszyka produkt 2, a dopiero potem produkt 1, opcja wysyłki zostanie przedstawiona jako "Kurier DHL firmy A". Nasz klient po zatwierdzeniu zamówienia czeka dłuższą chwilę, bo z jakiegoś powodu Presta mocno zamula w takim wypadku. Potem jego oczom ukazuje się ekran potwierdzenia zamówienia. Tutaj pojawia się pewna nieścisłość. Klient widzi miniaturę i cenę tylko produktu nr 2, i koszt jej wysyłki. Pod spodem widzi wezwanie do zapłaty, w którym pokazana jest odpowiednia kwota, czyli suma kwot: produkt 1 + wysyłka produktu 1 + produkt 2 + wysyłka produktu 2. Czy istnieje jakiś sposób na naprawienie lub obejście tego problemu? Mam na myśli raczej własnoręczne zmiany w kodzie, ale jeśli istnieje jakiś moduł, który może w tym pomóc, również będę wdzięczny za podesłanie linku do niego.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More