Jump to content

8ternity

Members
  • Posts

    77
  • Joined

  • Last visited

Everything posted by 8ternity

  1. Hi Guys, Like many peoples, i was struggling to download the 1-Click Upgrade official module. When you hit "Download" the latest version on your store, it's refer to the Prestashop Addons Store and it has no download button. Warning: Before making an upgrade, updates of any module, please make a backup of your Database + Files! Also, always download the latest version of the module 1-Click Upgrade. The download is located on their Github Project. Which is weird and really hard to find. It's refered nowhere on their website. URL: Prestashop 1-Click Auto Upgrade Module Download For now, the version is 4.11.0 Hope this help you guys loosing less time to search for the module. Thanks,
  2. Hi. I do have Prestashop 1.7.5.1 with a theme that use side cart ajax (not blockcart module) and i want to remove the "Shipping" text line. I do need to keep it into the cart only when the customer has been in the step #3 of shipping quote. I purchase a module to get Free Shipping over 75$ and Prestashop still shown Free Shipping everywhere until the customer has entered his address. I do change the label name in database everywhere for "Address Required" but with really Free Shipping over 75$, the label still remain "Address Required". So i rollback my label replacement, but i do need to remove the line on the side cart. Has you can see on live Html, i do see the division of "total-line shipping". But in reality, the template look like generating an array for subtotal types. I don't know what is the workarround to resolve this, but im out of knowledge for this one. Anyone has a fix for this? Thanks Stephen.
  3. @oxyHd: Désolé j'ai voyagé à travers le temps et répondu 1 an plus tard, lol. En fait, dans l'installateur, effectivement j'avais installer la langue Francais Québec. Mais les locales ne suivent pas avec ça. C'est pas le bon ISO pour le language et le pays. QC-qc n'est pas représentatif des locales normales. fr-CA "fr_CA" sont les bonnes locales. j'ai corrigé la base de donnée et changé dans ps_lang Maintenant les traduction des produits ont disparu. Par contre, lorsque je clique sur les traductions, il ne reconnaisent pas les locales, donc ne peut plus modifier les traductions dans "Conception > Internalisation";
  4. Fixed! I download a Fresh installation of 1.7.6.3 files and copy the line 788 of \src\Adapter\Presenter\Product\ProductLazyArray.php, replace the line 766 into the version of 1.7..5.1 currently in my store (same file). Replace } elseif ($product['quantity'] - $product['quantity_wanted'] < 0) { for } elseif ($product['quantity_wanted'] > 0 && $product['quantity'] > 0) { It's working now with the label entered into "Product Settings".
  5. I resolved it. I download a Fresh installation of 1.7.6.3 files and copy the line 788 of \src\Adapter\Presenter\Product\ProductLazyArray.php, replace the line 766 into the version of 1.7..5.1 currently in my store (same file). Replace } elseif ($product['quantity'] - $product['quantity_wanted'] < 0) { for } elseif ($product['quantity_wanted'] > 0 && $product['quantity'] > 0) { And now it's fixed. It was present in my version 1.7.5.1 and with the changes into the v1.7.6.3, it's working now with the label entered into "Product Settings".
  6. Hi, I have the version 1.7.5.1 installed with two differents languages. I've modified the default label for "Out of Stock" in english, and "En Rupture" for French. We can clearly see that the label is set into product settings: In Github, they have a fix for the Product which i already applied. https://github.com/PrestaShop/PrestaShop/pull/12655/commits/1132abd94382fc13c614371a85c108be1cc26a31 I clear cache, clear browser cache, delete \var\cache\dev and \prod folders. Message are still shown has default one. Maybe i can translate the label from the ProductLazyArray.php for the english part, but what about the French label? Anybody can help me with that issue? PS 1.7.5.1 with French Canada "qc" + English Canada "en" languages. Thanks.
  7. I've done the fix from Github and exactly the samething. Both languages are still shown default message. I don't know how to fix it in version 1.7.5.1. Github changes on ProductLazyArray.php https://github.com/PrestaShop/PrestaShop/pull/12655/commits/1132abd94382fc13c614371a85c108be1cc26a31 Not fix it for me.
  8. It's worked. My god, thank you ! You helped me a lot. Im not a programmer but i can learn some things and i was close. Thanks a lot
  9. Its a part of code on page.tpl into template folder. Original code <section id="main"> {block name='page_header_container'} {block name='page_title' hide} <h1 class="page-heading">{$smarty.block.child}</h1> {/block} {/block} I want to do : <section id="main"> {block name='page_header_container'} {if $smarty.get.id_cms > 0} {else} {block name='page_title' hide} <h1 class="page-heading">{$smarty.block.child}</h1> {/if} {/block} {/block} Is gonna work that way? EDIT: No, it's breaking the page to load. I just to to hide the <h1> object if smarty get id from CMS.
  10. If i want to include all CMS pages? not just one page ID's? How we can do it. Thanks.
  11. Not working. The full path is "/html/body/main/section/div/div/div/div/div/section/h1" Their is not #cms section in the HTML itself. It's why i think a {if} rules. But i don't know well in php or smarty programmation. I have knowledge on HTML and CSS only. If i use #main, all titles will not be shown (product pages, etc.)
  12. Hi, In Prestashop 1.7.5.X i want to remove the title name for CMS PAGE (Conception > Pages). I've located the file into Template/page.tpl we can see: <section id="main"> {block name='page_header_container'} {block name='page_title' hide} <h1 class="page-heading">{$smarty.block.child}</h1> {/block} {/block} I want to add a {if} rule which says - If page-content is cms page "not show this section/or bypass to add the <h1>...</h1>" otherwise show the <h1> class. I have no such experience in developping. Anyone experienced with that? Any help is appreciated. Thanks. 8ternity | Montreal | Canada
  13. IF anyone still asking update on this software, i use it since last year and it's a solid software. I never get problem or crash with this software. I was having a issue one time and submit samples videos and they fixed on the last update quick. Technical support is awesome. They have integrations with IceCat, Ebay, Amazon, also the product import from XLS works super flawlessly. I love and recommend the software. I use with PS 1.7.5.1 but they also just realease an update for version 1.7.6.0 and already working on newer version.
  14. OH ok. It's version 1.7.6.2. Good things you've made with the bug report. @calleeja: If you have such products and categories, i've purchase a software which works really well with managin products, orders, categories, etc. Its called eMagicOne Prestashop Manager https://emagicone.com/products/solutions-for-prestashop/ If your only one using the admin panel, with this software its super easy to work with. I also bulk import products, manage features, brands, category, move stuff in bulk, etc. You should take a look.
  15. Im still getting issues with Translactions. After some months of work, i do understand what is the issue, but how resolve it is another problem. The product is Prestashop itself. It's install in 1.7.5.0 French Canada language has qc-QC locales and fr-CA for language id and coutry. Is qc is not a language, and QC are not a country. They seems to fix the French Canada language in version 1.7.6.1 and more. When i edit translations, it's post has fr-CA locales. In reality, the store still think we're in qc has locales instead of fr. It's weird, also hard to fix.
  16. You want to backup the categories ? What do you want to do ? Is that related to Features?
  17. We install Prestashop 1.7.5.0 a couple of months ago. Prestashop has set for French Canada, qc-QC for locales and language. I set the language identifier for fr and country for CA. It was before Qc-QC. Im still getting error on locales. In language, Prestashop install the iso code to qc and language code to qc. When i edit a product, i have the error. Also on translating some modules i get error on saving translations. If i rename the code iso and country in Prestashop, the site crashed. I try on a second domain i build for testing modules. Did someone know how to resolve that?
  18. Thanks. I also see it into Github closed issue. Works again now.
  19. Answered by myself, Yes it's worked. Thanks.
  20. If it's an issue you faceted, post the issue on Github. https://github.com/PrestaShop/PrestaShop/ If it's how to configure module, try the documentation. I purchase a module instead of trying to keep the native module. They still have issue with version 3.X.X right now.
  21. Resolved. It was the Theme "Mecon Mobile" which has such a lack of completion on the theme. I found another theme which are more way powerfull, fast and complete!
  22. Look likes resolving after the latest native module "Newsletter" v2.5.1. Sorry for delay, i was living with some issues after some native modules updates. Thanks GP !
  23. Hi, I've started build a store in the last months and i have this error happen when i try to get a complete log of employee modifications into the system. I think it was initially installed has 1.7.5.0 and updated to 1.7.5.1. The error is : Value for :employee not found in params array. Params array key should be "employee" Here more Symfony log : Uncaught Exception: An exception occurred while executing 'SELECT l.*, e.email, CONCAT(e.firstname, ' ', e.lastname) as employee FROM ps_log l LEFT JOIN ps_employee e ON l.id_employee = e.id_employee WHERE (e.lastname LIKE :employee OR e.firstname LIKE :employee) AND (l.date_add BETWEEN :date_from AND :date_to) ORDER BY id_log desc LIMIT 10 OFFSET 0' with params ["2019\/10\/01", "2019\/10\/07"]: Value for :employee not found in params array. Params array key should be "employee" Uncaught PHP Exception Doctrine\DBAL\DBALException: "An exception occurred while executing 'SELECT l.*, e.email, CONCAT(e.firstname, ' ', e.lastname) as employee FROM ps_log l LEFT JOIN ps_employee e ON l.id_employee = e.id_employee WHERE (e.lastname LIKE :employee OR e.firstname LIKE :employee) AND (l.date_add BETWEEN :date_from AND :date_to) ORDER BY id_log desc LIMIT 10 OFFSET 0' with params ["2019\/10\/01", "2019\/10\/07"]: Value for :employee not found in params array. Params array key should be "employee"" at /var/www/vhosts/******/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php line 131 I've think first it may be related to database update, but seems to be identical has installation .sql on install folder. Any clue on how resolving the issue?
  24. HI, With Prestashop 1.7.5.1, does it have a possibility to add the Articles Number into the Cart Icon Button on the main page? The button doesn't show when articles are present in card. Thanks
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More