Jump to content

Valdic

Members
  • Posts

    8
  • Joined

  • Last visited

Posts posted by Valdic

  1. Same here with PS 1.7.3.3. This is working totally different to PS 1.6 and this is not the best way to do it.

    If you have a product with combinations and you want a "global" image for product front-end, you have to assign that image to all combinations. The problem is when you select the combination at front-end it do not change the main image.

    Any fix for this?

    • Like 1
  2. Yo de momento lo que he hecho es una mezcla de la solución que dio Cavallanti. Edité el estado "Pedido pendiente por falta de stock (Pagado)", le puse ocultar al cliente y no enviar email, de ese modo ese estado el cliente no lo ve y no se le notifica. También le cambié el nombre para no liarme yo.

  3. 10 hours ago, sebarrab said:

    Poner 999 en las cantidades del producto.

    A ver, chapuza es pero es también para salir del paso.

    ¿Cómo vas a hacer eso si trabajas con stock real? ¿Si te compran 10 y solo tienes 5? Eso no es una opción, solo traería problemas, a no ser que vendas algo que tengas "ilimitado" o que puedas conseguir al momento.

  4. Mismo problema por aquí con 1.7.3.3... Un cliente acaba de hacer un pedido de un producto que estaba en stock, solo quedaba 1 unidad. Tras el pago, el pedido quedó en estado "Pedido pendiente por falta de stock (Pagado)" y la tienda envió un email al cliente informando de eso lo cual es falso.

    Tengo desactivado permitir pedir productos sin stock, pero vamos, que estaba en stock cuando el cliente lo compró.

    ¿Alguna solución que no sea la de cavallanti? Que para salir del paso no es mala idea, todo sea dicho :)

    Gracias :)

  5. This is the fix if someone needs it, at least just for my shop (PS 1.7.3.3).

    Quote

     

    If deleted this lines:

    if (defined('_PS_ADMIN_DIR_') === false)

       define('_PS_ADMIN_DIR_', _PS_ROOT_DIR_.'/admin/');  

    and changed this one:

    return basename(_PS_ADMIN_DIR_);

    with:

    return basename(PS_ROOT_DIR_.'/admin/');

     

     

    Problem is related to cronjob module. If you disable the module, the problem is solved. But if you need the module, you have to do that modifications to the file modules/cronjob/cronjobs.php

    Make a backup of the file before, and it's better to comment the lines than delete them.

     

    Credit of this fix: https://www.prestashop.com/forums/topic/372966-url-du-bloc-langues-contenant-le-paramètre-controlleruriindex/#comment-2309428

    • Like 1
  6. On 24/4/2016 at 4:45 PM, Serpes said:

    Bonjour

     

    I had the same problem. After investigating a little I've seen that controllerUri is used when _PS_ADMIN_DIR_ is defined. It's supposed that this constant it's not defined in front office but, in my case, there was one module that was defining it. It was the prestashop module Cronjobs.

     

    If deleted this lines:

    if (defined('_PS_ADMIN_DIR_') === false)

       define('_PS_ADMIN_DIR_', _PS_ROOT_DIR_.'/admin/');  

    and changed this one:

    return basename(_PS_ADMIN_DIR_);

    with:

    return basename(PS_ROOT_DIR_.'/admin/');

    Thank you! That was the solution for me. Same problem with Prestashop 1.7.3.3.

    Problem was related to cronjob module, if I disable it problem was gone. But as I need the module, with that fix the problem is gone with module enabled and working.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More