Jump to content

dhernandez

Members
  • Posts

    21
  • Joined

  • Last visited

About dhernandez

  • Birthday 12/20/1985

Profile Information

  • Location
    Spain

Recent Profile Visitors

280 profile views

dhernandez's Achievements

Newbie

Newbie (1/14)

4

Reputation

  1. Solved it!!!!! It was caused by an old Override from a previous module that I had installed. Uninstalling the module didn't clean after itself and left me a little present in the shape of an override that was making paying impossible. I was just trying random things, in my desperation, and disabled all shipping modules and just left a "pick up" free shipping configuration within PS, and discovered that the shipping module I was using didn't delete it's own overrides either, and I had to disable all overrides within PS Backoffice to get the website to work. And then I tried buying something and there they were, my payment methods in all their glory showing up when prompted!!!! So, I went on a quest about identifying every single override and why the heck was it there. IT was arduous (i'm not that good at code and PS is crazy complicated), but eventually found one of the overrides referencing a module I tried once (and didn't work) named "WaitToPay" (Finances wanted to do crazy things like ask the client to wait for us to call him before completing the payment, wich was promptly discarded after all).... I deleted the f*** out of it, deleted cache/class_index.php, and VOILA! People can buy at our store! After more than a week! I feel depleted after this...
  2. I'll bump this up, hoping someone that knows what's going on sees it. I don't like random bumping so I won't be doing it anymore, I hope you accept it this one time and it's not too annoying or against the rules. If someone wants to help, I can even give access to the backoffice and we can look at it together. I'm sure the problem is me, I've done something wrong along the lines, but I can't get it working no matter how much I try. Please help if you are able, Thank you.
  3. Hello. Yes, I know, yet another thread with the same error, but I have been days struggling with it, I've scrubbed every answer I could find and tried every possible solution that came up, and still I can't get any Payment module to show on checkout. At first I thought it was a problem with Paypal, so I tried to make it work with bank wire or something like that, but I still got the same issue. I activated the express checkout shortcut on Paypal, and it appears and it seems to be working properly. I have installed and reinstalled paypal too may times to count. I've attached pictures of my "Modules - Payment" options. On Country Restrictions I have every country enabled (though probably I shouldn't) just to be 100% sure that's not the problem. I tried enabling Stock Management, and Advanced Stock Management, to no avail. Left it disabled just to have one less thing to worry about for the moment. The store is: eu.photoboothparts.com <-- It is supposed to work only in Europe. If you visit from the US you'll get redirected to "photoboothparts.com" (without the "eu."). Surprisingly enough, paypal works perfectly fine in our US store. In fact we separated them because I wasn't able to install 2 different paypal modules to have 2 different paypal accounts... But that's another issue. I've been at this for more than a week and I can't get it working. More frustrating is that I know this worked a couple of months ago, when I published the site. But a few days ago someone from my team alerted me that you couldn't buy anything. The ONLY difference between now and then is I installed the MailBoxes ETC module for shipping. I have tried disabling or deleting it too, and It does nothing. Other than that I talked to the sales team and they said they had reports of payment not working since last monday (Feb 04) and I installed the module (not knowing yet there was problems with payments) on thursday 07, so I am inclined to believe the MBE module is not the problem. I'm just saying just in case someone knows better than me. I dunno, I'm desperate. The shop has been not working for more than a week already. Please help. EDIT: Adding info I forgot: I'm working with PrestaShop 1.6.1.18 Paypal module is v3.12.1
  4. Sorry what I did didn't work at all in the end. I ended up making an HTML block, and just handmade a screen with a category grid myself. It's totally the worst solution possible because I need to be changing it every time something is updated, but it's the only one I could make work.
  5. Lo arreglé al final. Me estaba concentrando mucho en los archivos que aparecían en negrita (por eso de que están en negrita), y no conseguía nada. Al final me di cuenta de que el archivo que no estaba en negrita era siempre el mismo. En el FTP me aparecía que tenía 2 bytes mas que el original en mi ordenador. He vuelto a subir el archivo, y problema arreglado. Phew.....
  6. Hola! Llevo unos días preguntando cosas aquí así que a lo mejor estáis hartos ya de mi. El caso es que me he tenido que hacer cargo de la tienda, que estaba "CASI" acabada. Pero no se había dicho al freelance que la hizo temas importantes, como que tenían que haber dos almacenes y dos configuraciones de paypal y UPS. Pregunté por aquí y se me dijo que la mejor solución era convertir la tienda en multi-tienda, y tenia toda la pinta de que sí. Como no estaba muy seguro de lo que hacía (ni sigo estándolo), fui al FTP al que está subida la tienda y descargué toda la carpeta, guardando un backup en mi ordenador. Hice lo mismo con la base de datos, exportandola en un archivo SQL que guardé junto al zip de los archivos. Despues de hacer las copias de seguridad, he decidido intentar lo de la multi-tienda, y tras mucho probar he descubierto que el modulo de UPS no está del todo dividido, y ambas tiendas deben compartir información, con lo que no me sirve. El de Paypal hacía algo semejante solo que peor. A parte de esto el estilo de la tienda se había ido al garete... Temiendo haberlo hecho mal, he decidido restaurar la tienda a como estaba por la mañana a las 8 am, con los archivos que había sacado. He hecho un drop a las tablas y borré la carpeta que contenía prestashop en el servidor (por si habían archivos extra que no fueran a ser sustituidos, después de crear la multistore). He restaurado la base de datos con el SQL sin error alguno, y he subido los archivos a su ubicación original, tambien sin error alguno. Pero la tienda no funciona. Solo consigo un error 500. Siguiendo consejos de este foro, he activado el modo debug con lo que he sacado un error algo mas detallado, y buscando de nuevo la solución mas viable pasaba por A- Darle permisos 755 a la carpeta de prestashop y B- borrar un archivo en concreto en la carpeta caché. No recuerdo exactamente el error ni el archivo (que no borré, simplemente renombré con un old_ delante), debería habérmelo apuntado, ya que ahora al no estar en la oficina no puedo conectarme al FTP a mirarlo. El caso es que después de hacer eso, me han aparecido otros 3 errores distintos: Esto he intentado también buscarlo en google pero no he tenido éxito. Ya no sé que hacer. Con toda mi buena fe guardé los archivos y el backup de la base de datos pensando que si la liaba, podría arreglarlo. Ahora mismo lo que tengo es que me he cargado mas de un mes de trabajo del Freelance que contratamos, y estamos peor que antes de empezar. ¿Se os ocurre algo? Muchas gracias.
  7. Tengo problemas para avanzar. He creado la Multi-Tienda sin problemas, y pueod elegir diferentes opciones para cada una sin complicaciones, excepto cuando intento configurar UPS. Dentro del modulo "Connect to UPS", teniendo seleccionada la tienda de US, pongo la dirección del almacen en US, y en la tienda de Europa la dirección del almacen Europeo, sin problemas. El problema viene cuando en cada tienda quiero configurar los servicios: 1.- En la tienda de USA quiero utilizar las siguientes opciones: Rate Service group: United States Domestic Shipments Pickup Type: Daily Pickup Packaging Type: Package Calcul mode: Split one item per package Delivery Service: UPS Ground UPS Three-Day Select UPS Next Day Air Early A.M. 2.- En la tienda de Europa quiero utilizar las siguientes opciones: Rate Service group: Shipments originating in the European Union Pickup Type: Daily Pickup Packaging Type: Package Calcul mode: Split one item per package Delivery Service: UPS Express UPS Standard Cuando configuro una de estas dos opciones en una de las tiendas, la otra se desconfigura, y me vuelve a pedir los "Delivery Service" que quiero usar. Es decir, toda la información se guarda independientemente en cada tienda, excepto los Delivery Service, por alguna razón, y por tanto no puedo activar el modulo de UPS a la vez para ambas tiendas :/ ¿Hay alguna solución que no incluya comprar el modulo de pago? ¿El modulo de pago serviría para arreglar esto?
  8. Muchas gracias! Me pongo a crear la multistore ahora mismo.
  9. Hola! Tengo unos cuantos problemas con prestashop ahora mismo. Nuestra tienda era MUY antigua (version 1.4) y recientemente se decidió actualizarla a la versión 1.6.1.18 (La última estable) Teniamos a un freelance encargandose del cambio pero el proyecto se estaba alargando mucho y tras unos cuantos desacuerdos, terminamos la relación y ahora me toca a mi acabar el trabajo. Nuestra tienda antiguamente solo vendía al continente Americano, así que tenemos una cuenta de Paypal americana y un modulo de UPS que funciona para allí. Ahora queremos expandirnos y poder vender al resto del mundo via web (y no por telefono, como se hace hasta ahora). Por temas de contabilidad que escapan un poco a mi comprensión (algo sobre impuestos distintos en cada región) se quieren asignar dos cuentas de Paypal a la tienda. Para empezar, ya tenemos un geolocalizador que dependiendo de tu ubicación te muestra los precios en una moneda u otra, y tenemos varios almacenes (warehouses) , aunque creo que falta configurarlo del todo bien. La idea es que si alguien entra desde USA prestashop sea lo bastante inteligente como para ofrecerle articulos en el almacen de USA, enviarlos desde USA, y cobrarle con la cuenta de paypal Americana. Y si procede del resto del mundo, lo mismo pero en la versión internacional de la tienda. ¿Es esto posible? Hasta ahora solo he visto una manera de configurar un único paypal, y no veo manera de vincular la geolocalización con la elección de almacén. Si no fuese posible tal cual, ¿es la opción de "Multistore" mi única opción? ¿Es overkill? ¿O me producirá otros problemas peores?
  10. I followed your advice and with help from your tutorial, a lot of google-fu and some wall-bashing with my head, found a way to do it. It's amateurish and lacks any kind of personalization, but I don't have the time to do more... Maybe in my own free time i'll finish it and upload it here so people can use it if needed. Thanks again!
  11. Hi again! It's me again, with another problem. I am trying to have my categories and subcategories in my front page, but I'm not having much success.... I'd like to have the "Categories" as titles and then every subcategory after as a picture with a link to that subcategory. Something like: CATEGORY <subcategory> <subcategory> <subcategory> CATEGORY <subcategory> <subcategory> <subcategory> For the moment I have some kind of mockup with Vekia's HTML Block, you can see it here -> http://tester.photoboothparts.com/ It's just a bunch of pictures with static links to it's subcategories, so it's crude and functional.... But I'd like it to be dynamic. So whenever the guys at marketing / design want to add a category, or change a picture or whatever, this front page updates automatically. I've been trying to use a module I've found around the forums (homecategories) but with it I can get my categories, but I have not been able to add the subcategories to it. I've tried a tutorial (also from Vekia) ( link ) but this is thought to work in the categories page, not at home, and I can't even get it to recognize that subcategories exist. I'm probably doing everything wrong, but honestly don't know how to do this or what to try anymore.
  12. Don't worry about your english, I'm spanish so not my native language either, but as far as I know yours is spot on. That is what I eventually did! Sorry for not updating this but since there were no answers when I found that solution I thought nobody would care. What I ended up doing is creating the "model" and "type" features as you mention, and in order to not have to manually set that in the almost 3k products, I exported all the products via Database into a CSV, then copied the "categories" column, and with some search and replace magic added the correct format to the categories (Mostly adding "Model:" or "Type:" before it, then a sequential number for order after it, then ":0" to tell Prestashop it is NOT a custom Feature), then reimported all the products and set the filters as you mention. "Categories" seems a bit redundant to me now, but at the very least I have the functionality I needed. Thanks!
  13. Creo que llevas tu mas tiempo que yo con Prestashop, que solo hace un par de semanas que lo toco, así que lo tendras mas por mano tu que yo, y mucho mas no puedo ayudarte en el tema U_U En principio, la cantidad de productos no importa mucho. Yo lo automaticé en excel para que cogiese las categorías y las pusiese con el formato adecuado en la columna Features. (En mi caso usaba solo las categorías como Features) Si quieres que te eche una mano mandame un MP y te ayudo.
  14. Hola @santinuro, yo llevo días intentando hacer algo semejante. En mi tienda vendemos máquinas y recambios de las mismas, y que cuando seleccionen un modelo de maquina, puedan filtrar por tipo de pieza que buscan, y viceversa, si buscan un tipo de pieza, puedan filtrar por maquina compatible. He conseguido algo "funcional" pero para nada atractivo, con las "features". He asignado a cada producto una "Feature" llamada Model, con el "value" del modelo que quiero, y una llamada "part" con el value de la parte que es. Una vez hecho esto he configurado el Faceted Search module para que permita filtrar por esas dos "features" y ninguna otra. Funcionar, funciona. Filtra correctamente los productos y me muestra exactamente los que quiero. Pero es muy anti-intuitivo. Sigue apareciendo un menú encima del filtro que despista mas que ayudar, que solo muestra subcategorias de la categoría en la que estas en vez de mostrar todo el arbol; y creo que es un poco enrevesado, demasiados clicks para conseguir el producto que uno quiere... :S A lo mejor esta información te sirve de algo, y entre los dos sacamos algo en claro. Suerte.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More