Jump to content

Carlos

Members
  • Posts

    14
  • Joined

  • Last visited

Everything posted by Carlos

  1. Hi, I have a possible solution, I think isn't the correct solution but its working... /Backoffice/themes/default/template/controllers/orders/form.tpl change: $('#id_order_state').val(id_order_state); for: $('#id_order_state').val(id status that you want);
  2. Hi, I have the same problem, did you solve it ? Thanks!
  3. Efectivamente Ramón... el cliente lo eliminó y no me dijo nada... he estado tocando código y mil cosas y mira qué sencillo era... ¡¡MIL gracias!!
  4. Buenos a todos, tengo el siguiente problema: El botón del carrito ha desaparecido y cuando añado cualquier producto al carrito no sale el modal aunque internamente si lo añade. Por ejemplo: http://tienda.merceriasantaana.com/inicio/115-6507-tirante-caballero-30-mm.html#/1516-colores-1_negro Ese producto, si pulsas en añadir al carrito, no muestra el modal. He activado el modo debug pero no sale ningún error, entiendo que es algo de js. He actualizado a la última versión y no se ha corregido el error. Esta web tiene muchísimos productos pero no creo que eso influya. No se qué puedo hacer más, alguna idea sugerencia? Muchísimas gracias.
  5. Hola JFCS, he hecho lo que me comentas pero sigue igual, he creado dos reglas de impuestos diferentes y lo he diferenciado por zonas, en el apartado de productos, aunque seleccione que se le aplique el 21% de iva, no lo hace, puedo darte los datos de acceso si lo prefieres. Muchas gracias!
  6. Hola NaturC, te pongo como lo he hecho yo: /classes/pdf/HTMLTemplateDeliverySlip.php (adjunto) En /pdf/ he cambiado y añadido algunos ficheros, te los adjunto todos. Espero que te sirva. Saludos! HTMLTemplateDeliverySlip.php pdf.zip
  7. Muy buenas, estoy buscando en el foro pero no veo la solución. Prestashop 1.6 En Localización / Reglas de tasas, tengo creado un impuesto llamado ES Standard rate (21%) Si como NUEVA REGLA DE IMPUESTOS le pongo España y provincia TODAS, cuando creo un producto y aplico este impuesto, me suma el 21% de iva perfectamente pero si pongo como NUEVA REGLA DE IMPUESTOS todas las provincias, no me aplica ningún impuesto. Esto lo quiero hacer para que en Las palmas y Santa cruz de tenerife tenga impuestos 0% pero en el resto no. Gracias de antemano.
  8. Muy buenas a todo, existe la posibilidad de que cuando se cree un nuevo pedido a través del backoffice, se le mande al cliente el email de confirmación en un idioma u otro? si es español, que se mande en español, si no lo es, se le mande en inglés. Muchas gracias de ante mano. Saludos.
  9. Buenas, ya encontré la solución, os la dejo por si a alguien os pasa: Hay que modificar el archivo /httpdocs/controllers/admin/AdminOrdersController.php Cambiamos esto: if (!Configuration::get('PS_CATALOG_MODE')) { $payment_module = Module::getInstanceByName($module_name); } else { $payment_module = new BoOrder(); } por esto: if (!Configuration::get('PS_CATALOG_MODE')) { $payment_module = Module::getInstanceByName($module_name); } else { $payment_module = Module::getInstanceByName($module_name); } Saludos.
  10. Buenas a todos, me surge un problema con el tipo de pago. Tengo dos tipos de pagos en el backoffice, transferencia bancaria y pago domiciliado. Cuando realizo un pedido desde el backoffice, siempre me pone como método de pago Back office order. ¿Hay alguna forma que me ponga como nombre uno de los anteriores seleccionados? Adjunto captura. Muchas gracias de antemano.
  11. Gracias por tu solución w3bsolutions. Os pongo aquí la solución al problema: Había un bug de Prestashop, cuando se crea el cliente por ahí sólo se estaba enviando al servidor el último grupo de clientes seleccionados de la caja, con lo cual si el último grupo no era también el seleccionado por defecto daba error al "pensar" que no habías asociado también el grupo por defecto al cliente. El código defectuoso estaba en /BackOffice/themes/default/template/form_submit_ajax.tpl. adjunto aquí también la versión arreglada form_submit_ajax.tpl
  12. Hola, tengo la 1.6.1.17 Lo he probado en varios prestashop que tengo y pasa en todos... muchas gracias.
  13. Muy buenas a todos, tengo un problema y por más que busco no encuentro la solución y me estoy volviendo loco, os cuento mi problema. He creado dos grupos de clientes: Con recargo de equivalencia y sin recargo de equivalencia, los demás os obvio. Cuando voy a crear un clientes desde el apartado de Pedidos (Pedidos, nuevo pedidos, añadir cliente) se abre un popup para añadir a un cliente y solo me deja añadir uno de los grupos que tengo, solo uno siempre. Por mucho que los he borrado y creado de nuevo, siempre me deja solo uno. Me da el error Debes seleccionar el grupo predeterminado del cliente. Obviamente lo tengo seleccionado el select último pero no hay forma, de hecho he mirado el array que me devuelve la función !is_array(Tools::getValue('groupBox')) y solo existe uno de los grupos creados. array(1) { [0]=> string(1) "8" } array(1) { [0]=> string(1) "8" } Sin embargo, desde la página Clientes/clientes y añadir cliente, me lo hace perfecto todos los grupos. El array anterior me saca todos los grupos: array(5) { [0]=> string(1) "1" [1]=> string(1) "2" [2]=> string(1) "3" [3]=> string(1) "7" [4]=> string(1) "8" } Investigando he detectado que el problema está en el popup que abre en ajax, si en el fichero Backoffice/themes/default/template/controllers/orders/form.tpl le quito al botón de añadir cliente &submitFormAjax=1, me lo hace perfecto el problema es que no me cierra el popup, me sale en el mismo el listado de clientes. Ahí me quedo y no consigo solucionarlo. Es muy raro todo... Alguien podría ayudarme? Muchísimas gracias de antemano.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More