Jump to content

macu

Members
  • Posts

    36
  • Joined

  • Last visited

Everything posted by macu

  1. Pues ya no entiendo que es lo que pasa, lo bajo y al intentar instalarlo sale un cartel diciendo : Uy... La subida ha fallado. ¿Que ocurrió? Este archivo no es un módulo en formato ZIP válido. Y en versión de la tienda aparece Versión de PrestaShop: 1.7.2.4 que es igual que la otra por lo que deberia de funcionar sin problemas, En fin creo que volveré a montar la tienda con el docker, aunque me resulta muy raro Ok gracias
  2. Ok gracias por la confirmación. Y ¿sabemos para que lo crea? debería borrarlo o tampoco es neceasario. Gracias
  3. Antes se me ha olvidado comentar un tema, aparte de ser una VM dentro lo que corre es un docker oficial de prestashop asi que pense que estaría todo ok. en cualquier caso tanto en la vm como dentro del docker el ping a 8.8.8.8 funciona asi que entiendo que hay salida a internet. luego buscando el php.ini encuentro esto /usr/local/etc/php/php.ini ; Whether to allow the treatment of URLs (like http:// or ftp://) as files. ; http://php.net/allow-url-fopen allow_url_fopen = On Parece que está OK. Luego para el tema curl no tengo claro como saber si está OK. Si ejecuto dentro del docker curl www.google.es me devuelve una html por pantalla <!doctype html><html itemscope="" itemtype="http://schema.org/WebPage" lang="es"><head><meta content="Google.es permite acceder a la informaci�n mundial en castellano, catal�n, gallego, euskara e ingl�s." name="description"><meta content="noodp" name="robots"><meta content="text/html; charset=UTF-8" http-equiv="Content-Type"><meta content="/logos/doodles/2018/celebrating-garden-gnomes-6194737877876736.5-l.png" itemprop="image"><meta content="Homenaje a los gnomos de jard�n" property="twitter:title"><meta content="Llena tu jard�n de gnomos con &#127804;& ...... mucho más por que entiendo que tambien esta OK, aunque como digo no se mucho de esto. Hay alguna manera de bajarse el ZIP y subirlo a mano Muchas gracias
  4. Respecto a este tema tengo una duda. El caso es que he instalado el módulo en la 1.7.2.4 y aparentemente todo bien, al menos lo poco que conozco, pero he visto que tengo cliente con lose-mail [email protected], este cliente por la fecha y hora se me ha creado al instalar el módulo , podéis mirar si os ha pasado a alguno aunque sea ora versión?. Otra duda que tengo es, aparte de la tienda real, tengo una maquina virtual con la misma version de prestashop, donde hago pruebas y demás he intentado buscar el módulo y sin embargo no me aparece, he usado para buscar gdpr que en la tienda real sin problemas pero en la vm nada, sabeis como debo buscar para que aparezca. Gracias
  5. Buenas de nuevo, Tengo más dudas si caben, el cliente ya me ha enviado el producto, pero no ha generado la orden de devolución en su panel de control, pero bueno yo tengo los productos, bueno no todos, porque al final se ha quedado algunos y tengo que devolver el dinero. He intentando hacer un rembolso parcial y me aparecen los productos pero mal asi que he puesto en cantidad la correspondiente y el importe, pero la cantidad no se si se escribe o no, porque no se ve y el importe parece que si. Al solo verse a medias me he ido a devolver productos y esta vez se ve bien, he marcado los que quería devolver , regresar al inventario y generar factura al inventario, y al final devolver productos, Aparentemente lo ha hecho me aparece reembolsado como se ve en la imagen, en el inventario ha aparecido el producto, se ha generado una factura de abono por la cantidad del producto. Lo único que no veo es que en stripe se genere ningún movimiento, no se si debo de hacerlo a mano desde stripe o que debo hacer ahora, Alguien me puede ayudar. Realmente si tengo que hacer a mano el rembolso , en lugar de hacerlo desde stripe, le puedo hacer al cliente una transferencia por la cantidad y ya está, lo que no quiero es que se le devuelva por 2 sitios como es lógico Por otro lado hay algún problema por haber usado devolver productos y solo marcar algunos y no haber usado devolución parcial? Alguien sabe porque algunas cosas se ven asi de mal en la version 1.7.2.4, se puedo corregir o solo me queda actualizar y rezar jeje Gracias
  6. Buenos días, Tengo algunas dudas con las devoluciones, y espero que me podais ayudar. Actualmente tengo la tienda con Stripe para el pago con tarjeta y quiero saber como gestionar una devolución pagada con tarjeta usando stripe. El cliente genera la devolcuión-->Acepto devolución. Voy al pedido --> devolver productos Marco reingresar al inventario Genero factura por abono, según la documentación se puede como cupón descuento en la siguiente compra. ¿como se puede usar de este modo? Según la documentación "Si el cliente pagó el pedido utilizando una tarjeta de crédito, el sistema de pago debe reembolsar la compra automáticamente" Esto funciona si con stripe? que me hará una cargo a mi cuenta de Banco la plataformar de Stripe? ¿Cuanto tarda? Otra opción pone generar bono descuento entiendo que si marco esta opción el supuesto proceso de devolución a la tarjeta no se produce verdad? Gracias de antemano
  7. Uno que se une a la petición de como se puede hacer backups completos automatizados, actualmente los hago desde softaculos que ofrece el proveedor, pero si se pudiera automatizar estaria genial.
  8. El problema viene si por error quitas el check de alguien que está suscrito, pero no es cliente, ya no lo puedes recuperar o no se como y lo peor es que no se puede volver a suscribir, dice que ya está registrada, y en clientes no aparece y en suscritos tampoco, supongo que habrá que tocar alguna tabla a mano
  9. ¿A nadie le pasa esto?, bueno pues tengo un poco más de información tras un montón de pruebas, he visto que si te suscribes al boletín de noticias al darte de alta en la web, es decir que marcas el cuadradito de suscribirte , no se te envía ni el email de confimación ni el del bono de bienvenidad ni nada, solo el de gracias por darte de alta en la web ..... Sin embargo si de suscribes al boletín desde el pie de página hay si se envia el e-mail de confirmación (si lo tienes activado) el de verificación y finalmente el bono de bienvenida. ¿La duda es esto normal? pasa en todas las versiones o es un bug en esta, que si se suscribes al darte de alta no te lo envíe, hay alguna forma de que lo envie desde ambos sitios? Lo único que se me ha ocurrido es modificar el mail de registro y añadirle el literal a mano, cutre pero si no tengo otra alternativa funcionara.
  10. Buenas estoy tratando de crear un descuento de bienvenida, para ello he creado una regla de carrito, la cual funciona correctamente con su código (QSRRTWG) Ahora me he ido al modulo de boletín de noticias y lo he configurado de este modo La idea es que cuando alguien se de de alta y se suscribe al boletin y ofertas le envie el código, pero he hecho 2 pruebas y el código nunca se envia, y he marcado el enviar verificación despues de la suscripción y nunca se envía el código ni el mensaje de verificación, el mensaje de que te has dado de alta si se envia, pero solo ese. ¿Hay que hacer algo más? Es en versión 1.7.2.4 Gracias
  11. J'ai résolu le problème de la carte dans les ordres avec ceci: https://belvg.com/blog/how-to-fix-google-maps-api-error-missingkeymaperror-in-prestashop.html
  12. Yo tengo montadas 2 tiendas (ambas 1.7.2.4), una de pruebas en local con un docker y me sale perfecto, Pero en la tienda Real no sale, en consola me aparece esto (un error y un warning) sabéis como solucionarlo js:38 Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error _.Kb @ js:38 maps.googleapis.com/maps-api-v3/api/js/32/2/intl/es_ALL/util.js:237 Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys Edito: Me respondo a mi misma por si a alguien le sirve. Hay que buscar el fichero controllers/admin/AdminOrdersController.php (recomiendo hacer una copia del mismo antes de tocar nada) buscas las linea $this->addJS('https://maps.googleapis.com/maps/api/js?v=3.exp'); y la cambias por $this->addJS('https://maps.googleapis.com/maps/api/js?v=3.exp&key=YourKeyMaps'); Yourkeymaps lo obtiene en la página https://developers.google.com/maps/documentation/javascript/get-api-key?hl=ES tienes que obtener tu clave de API Lo que no entiendo porque en la otra me funciona sin modificar nada, Gracias
  13. Buenas noches, he instalado el modulo y no entiendo como va. en la configuración pone indica las páginas que "NO" quieres incluir , es decir si quiero todas no marco ninguna y cuando genero el fichero esta vacio, sin embargo si lo hago al reves marco todo si sale más información, supongo que es un error de traducción. Pero cuando intento crear la tarea cron me da un error que dice esta página no funciona. A alguien le funciona correctamente. Yo navegando he encontrado esto por si a alguien le sirve. https://www.matthieu-jalbert.fr/creer-un-sitemap-sur-prestashop-1-7/
  14. Buenas de nuevo, finalmente para el cambio de letra utilice, body { font-family: "Lucida Handwriting Italic"; line-height: 1.15; -ms-text-size-adjust: 100%; -webkit-text-size-adjust: 100%; } Y perfecto me lo cambio todo como queríamos, ahora he encontrado un pequeño problema en la versión móvil y es que el número de unidades se ve mal y creo que es por el cambio de tipo de letra se ve asi (solo en el móvil): Como podría hacer para cambiar solo este cuadradíto de cantidad y ponerlo con el tipo de letra por defecto (¿por cierto cual es?) He probado a poner en el custom.css input { font-family: "arial"; line-height: 1; -ms-text-size-adjust: 100%; -webkit-text-size-adjust: 100%; } pero claro esto me cambia todos los cuadros de texto, como podría cambiar solo ese y que tipo de letras es el de por defecto en prestashop 1.7.2.4 con el tema classic Gracias
  15. Buenas compañeros, Sigo avanzando un poco en el tema y ahora tengo un par de dudas que son totalmente de diseño y como mis conocimientos de programación son muy limitados pues..., Tengo la versión 1.7.2.4 El logo a la izquierda no me gustaba mucho asi que rebuscando en los foros encontro un modo de centrarlo mas o menos queda bien, ademas va a tener 1 centimetro por abajo transparente asi que quedaría bastante centrado y es más grande como quería para centrarlo he usado este código en el fichero /classic/templates/_partials/header.tpl {block name='header_top'} <div class="header-top"> <div class="container"> <div class="row"> <div class="col-md-12 hidden-sm-down text-xs-center" id="_desktop_logo"> <a href="{$urls.base_url}"> <img class="logo img-responsive" src="{$shop.logo}" alt="{$shop.name}"> </a> </div> <div class="col-md-12 col-sm-12 position-static"> <div class="row"> {hook h='displayTop'} <div class="clearfix"></div> </div> </div> </div> <div id="mobile_top_menu_wrapper" class="row hidden-md-up" style="display:none;"> <div class="js-top-menu mobile" id="_mobile_top_menu"></div> <div class="js-top-menu-bottom"> <div id="_mobile_currency_selector"></div> <div id="_mobile_language_selector"></div> <div id="_mobile_contact_link"></div> </div> </div> </div> </div> {hook h='displayNavFullWidth'} {/block} En mobil no me queda centrado , pero también es aceptable con el centímetro transparente que le voy a dar por debajo a la imagen queda algo así: El problema me ha venido en la parte de checkout que como sabéis han cambiado totalmente y queriendo quitar distraciones al cliente, lo han llevado al minimalismo extremo y el logo me queda a la izquierda y para mi muy pequeño, me gustaría poder centrarlo y un poco más grande me conformo con eso. He rebuscado por internet y la solución que dan es : En el fichero checkout.tpl buscar {include file=’checkout/_partials/header.tpl’} y cambiar por {include file=’_partials/header.tpl’} 2 buscar {include file=’checkout/_partials/footer.tpl’} cambiar por {include file=’_partials/footer.tpl’} Según entiendo esto dejaría la página como en el resto de la navegación pero no es así para mi la deja bastante mal, si ,centrado similar al resto de la navegación pero comiendose la linea superior con medio metro hasta el borde del navegador, en fin. Supongo que modificando el fichero checkout/_partials/header.tpl se puede arreglar, yo he probado y sino me equivoco modificando col-md-6 por col-md-12 lo he centrado pero aún se veía muy pequeño, estaba planteandome en el header.tpl quitar las lineas del logo y teléfono y dejarlo diafano. Y en el movil pues más de lo mismo aunque casi es mejor Alguna idea facil de como podría hacerlo de una manera facil, me conformo con que quede algo asi: E incluso quitará el llamenos que seguro que facilitas las cosas. alguien me puede ayudar GRacias
  16. Buenas, no se si te puede servir esta solución. Puedes crear un grupo de usuarios (Profesionales) tus categorias actuales las pueden ver los 3 grupos standard (visitante,invitado y cliente) , bien pues ahora puedes crear una categoría nueva que sea profesional, esta categoría le das Acceso de grupo profesional y solo ese . A los usuarios que les pensaras dar la contraseña tu desde el BO le añades al grupo de profesional y solo esos usuarios verían el resto de categorias y esa categoria tambien, pero solo los usuarios que has añadido. Y como comentas solo modo catálogo, no se si se pueden activar algunos productos como modo catálogo,sino se puede puedes poner el precio a 0 y el stock a 0 y en la descripción corta pones algo asi como no disponible para venta on-line llamar al telefono o escribir e-mail No se si te puede servir de solución, pero como te comentan con un módulo a medida te quedaría mejor Saludos
  17. ¿? ¿Que versión has instalado de prestashop? Esto me parece raro, y debe ser algo "simple" pero he leido al menos 3 post con el mismo problema Estas en hosting gratuito?
  18. Si lo tienes en un hosting , puedes hacer un backup completo de BBDD y ficheros y hacer la prueba que te comentan para volver a lo que tenias puedes deshacer el cambio y si algo se ha "roto" tiras del backup o incluso casi todos los hosting hacen backups puedes preguntarles y decir lo que vas a hacer y que si tienes problemas si ellos te restauran el hosting a como lo tenias antes, (igual te dicen que hacen backups cada 12 horas), pero las pruebas sirve, Yo como estoy pengandome con todo esto cada dos por tres hago backup hago las pruebas y si algo no me gusta recupero backup y a continuar donde estaba
  19. Buenas, Seguro que es la version 1.7.2.4 yo tengo esa instalada y no se parece en nada Aparte ¿que navegador estas usando? Está instalado localmente o el algún hosting
  20. Buenas noches, estoy tratando de importar combinaciones a traves de CSV, y me sucede algo cuanto menos raro, el caso es que preparo el fichero dejando la fecha de disponibilidad en blanco hago la importación parece que todo OK, y cuando miro detalles del producto me aparece: Fecha de disponibilidad: 2018-02-02 Esto me aperece incluso usando los ficheros de ejemplo (que por cierto en combinaciones hay que crear una columna 2 para que todo cuadre) la fecha la dejo en blanco y siempre me aperece, incluso digo que la ignore al importar y de nuevo aparece, y luego voy al producto combinaciones y abajo en la preferencias de disponibilidad no aparece la casilla para quitar desde cuando está disponible, si creo a mano las combinaciones si lo hace bien y aparece la casilla. http://i63.tinypic.com/262mvb5.png Alguna idea estoy haciendo algo mal? tampoco pasa nada porque se vea esa fecha, al fin y al cabo es anterior pero queda feo y mas en ese formato
  21. Ok gracias por la info, ya he visto tu blog y he entendido el tema, en cualquier caso yo solo quería cambiar el "su cuenta", por un "mi cuenta", es decir el cambio es mínimo y es solo por una cuestión de que creo que queda mejor de cara al cliente. Si ademas me lo cambia en otro sitio tampoco no creo que cambie mucho el sentido, de todos modos buscaré por si se usa en otro lugar.
  22. Buenas de nuevo, pues revisando toda la información que tengo mis backups, para mi está claro que al hacer la actualización de Paypal es cuando se produce el problema. Por suerte la solución ha sido simple, realice una prueba rápida sobre una instalación limpia de prestashop y la cuenta me la reconoce como bussiness, asi que esta claro el problema es en mi tienda, se me ha ocurrido ir a módulos instalados, buscar paypal y desinstalar, a continuación he ido a módulos he buscado paypal e instalo, y ya está ahora funciona me reconoce mi cuenta como bussiness y parece que todo OK. Para desinstalarlo lo he hecho como he indicado desde modulos instalados, buscar paypal y desinstalar, debería de borrar algo de modo manual o con eso es suficiente. Gracias
  23. Me respondo yo sola, debía de buscar mal o algo por el estilo el otro día no me aparecía, y hoy buscando otra traducción por curiosidad lo busque y me ha aparecido, es en Traducciones, seleccionamos Traducciones de tema, classic, español y busco cuenta. De los resultados voy a Shop-->Theme-->CustomerAccount y la primero que aparece es su cuenta, y aqui lo cambio. Gracias
  24. Hola buenas tardes, Esta tarde haciendo pruebas en la tienda, he visto que aparece en modo de pago paypal que necesita ser actualizado, bien lo he actualizado y ahora no me aparece el medio de pago paypal a la hora de pagar. Intento entrar en paypal para configurar y aparece lo que se ve en la imagen http://i63.tinypic.com/214xumd.png Se me ocurre ir a modulos instalados busco paypal, y desde aqui me salen 2 paypal y braintree http://i65.tinypic.com/nnnqcw.png Si intento activar paypal cuando le pongo el e-mail y españa sale para crear una cuenta bussines, pero ya lo es, de hecho antes hace un par de días funcionaba, de hecho si entro en paypal me sale como cuenta bussines, vinculada al nombre de mi tienda es decir parece todo ok. Ahora si vuelvo a metodos de pago paypa, ya no da el error de la imagen1 sale como la imagen2 Alguien está teniendo problemas con paypal? el tema de braintree es lo mismo? ¿o porque lo han separado? ¿Quieren obligar a usar braintree? Gracias
  25. Hi, I used your method to center the logo, and now it is working without problems, but when go to checkout the logo go to the left and now it is very small. I have tryed solved it with the file themes/classic/templates/checkout/_partials/header.tpl, I have modified these lines <div class="col-md-12 hidden-sm-down text-xs-center" id="_desktop_logo"> Now the logo is center, but it is very small, what can I Do to have the same size of logo of previus page Thanks
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More