Jump to content

massimiliano_c

Members
  • Posts

    6
  • Joined

  • Last visited

Everything posted by massimiliano_c

  1. SOLVED!!! A new "not NULL" required attribute was added to the user address db (ps_address). All the "old" user had the value "NULL" for that attribute, so that was causing the Server Error. Solved thanks to the prestashop application exception log.
  2. RISOLTO! Era stato aggiunto un attributo "obbligatorio" nel DB dell'anagrafica utenti, il Codice Fiscale in particolare. Tutti gli utenti creati prima del nuovo vincolo creavano l'errore 500 in quanto il campo obbligatorio era invece NULL. Inserendo un valore di DEFAULT è stato "aggirato" il problema. Grazie @Sito Lab, spero sia utile a tutti!
  3. Ciao, grazie della risposta tempestiva. Purtroppo anche dal LOG non vedo molto: PHP log: [01/Mar/2018:16:10:08 +0000] "GET /index.php" 500 0 - 855 31862 0.113 2097152 71.08% 26.65% "/ordine" Apache log: [01/Mar/2018:16:10:08 +0000] "GET /ordine HTTP/1.0" 500 7537 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 OPR/50.0.2762.67" Ngix Log: status_code:500 79.47.65.78 [01/Mar/2018:16:10:09 +0000] GET /ordine HTTP/2.0 Exception Log: *ERROR* v1.7.2.2 2018/03/01 - 17:10:09: La proprietà Address->dni è vuota. at line 944 in file classes/ObjectModel.php Questa è l'azione registrata/incriminata. Qualche consiglio su dove altro indagare?
  4. Ciao a tutti, avrei bisogno di aiuto e/o pareri su un problema che incontrano alcuni utenti del mio e-commerce: Per solo alcuni utenti, la pagina dell'ordine, alla fine del processo di acquisto, restituisce un errore del server. Solo per alcuni utenti registrati. Ho aggiornato i plugin, svuotato la cache del server, di Prestashop, disabilitato Varnish, cambiato browser, ip, etc. Ho anche disattivato google analytics che dava problemi legati al plugin di GA fornito da Prestashop. Niente da fare. Quando arrivo all'ultima fase d'acquisto, si apre la pagina "/ordine" con errore 500. Ho Prestashop 1.7.2 su Linux, Server Google Cloud su Cloudways. Grazie. Massimiliano
  5. Hi everyone, I have a problem with my Prestashop website. Only for some users, when the user tries to check-out his cart, and confirm the purchase, at the time he gets the page www.mywebsite.com/order , the server returns ERROR 500 SERVER ERROR, and the user can't complete the purchase. If the user goes back, he can change products in his cart, but as he tries to complete the purchase, this error occurs. Has anyone the same problem? I tried with different browsers, different IP's, different user accounts. And only for some users I have this problem. I tried to disable Varnish. I disabled the Google Analytics Plugins by Prestashop because of it's problem with some character in the cookies. I cleared the cache, updated all plugins... I'm running Prestashop 1.7.2 on Linux LAMP, on Google Cloud via Cloudways Thanks! Massimiliano
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More