Jump to content

elode

Members
  • Posts

    20
  • Joined

  • Last visited

Everything posted by elode

  1. Pour info, j’ai lu ça dans le forum anglophone, et ça fonctionne pour moi avec Prestashop 1.6.0.14 : Citation : Hi this does not work for me PS1.6.0.5 . I dont have real latest products. My solution is : I have change this $products = Product::getProducts((int)Context::getContext()->language->id, 0, ($number > 10 ? 10 : $number), $orderBy, $orderWay, $id_category, true); by $products = Product::getNewProducts((int)Context::getContext()->language->id, 0,($number > 10 ? 10 : $number)); in RSS.php You can check here : Fournisseur de tatouage temporaire Real Last product Pour moi, cette modification du fichier modules/feeder/rss.php marche.
  2. Oui, merci beaucoup. Ça y est, ça marche Désolé avec mes questions qui sont celles d’un néophyte. Sinon, si vous voulez vous faire une idée de mon site, qui est encore en construction, voilà un lien : www.lechantdesmuses.fr Je suis graphiste, dessinateur, et je dirige également une petite maison d’édition qui s’occupe de dessin et de bande dessinée. Évidemment, je fais presque tout (y-compris la fabrication des livres), et c’est parfois un peu difficile d’être compétent dans tous les domaines. Merci encore pour l’aide, Très cordialement, Xavier Dole (Monsieur X)
  3. Bonjour, Je suis sous Linux. donc, c’est LAMP qui est installé. Ça revient au même, je crois. J’ai suivi votre suggestion qui consiste à désactiver la réécriture d'URL via prestashop. Maintenant, je me retrouve avec ce message d’erreur : [Debug] This page has moved Please use the following URL instead: http://localhost/prestashop2index.php il n’y a plus de barre entre le répertoire "prestashop2" et le fichier "index.php" Une idée? Merci pour l’aide
  4. Hors donc, j’ai reçu un coup de main en conversation privée, de "Moi c Seb", qui m’a fait un peu avancer. 1ère suggestion qu’il ma donnée : "Via phpMyAdmin, dans ps_configuration chercher PS_CIPHER_ALGORITHM Cliquer sur Modifier et mettre la valeur 1 à 0 puis Exécuter" Et ça a marché… en partie. Il n’y a plus de message d’erreur et maintenant, j’ai accès au BO… quoi que sans feuille de style. C’est du html brut (comme si il ne trouvait pas les feuilles de style css). Idem pour le Front-Office, mais là, il y a un autre problème : les menus, entêtes et pied de page s’affichent en texte (pas d’images ni de feuille de style, et le corps de la page ne s’affiche pas. j’ai à la place ceci : Page introuvableLa page que vous avez demandée n'existe plus. Et si je clique sur une des entrées du menu, j’ai une erreur 404. Comme s’il ne trouvait plus les pages du site. Voilà… ça avance, mais doucement… Quelqu’un aurait-il une autre piste ? Merci
  5. Bonjour, J’ai installé mon site (prestashop 1.6.0.14) chez OVH en mutualisé. Ça c’est passé correctement, le site est fonctionnel. Maintenant, je souhaite en faire une copie chez moi, pour pouvoir faire des essais sans travailler sur le site en production. J’ai donc suivi les procédures décrites dans la doc (http://doc.prestashop.com/pages/viewpage.action?pageId=26148921#Guidedel%27administrateursyst%C3%A8me-D%C3%A9placerPrestaShop), ainsi que dans ce topic du forum : https://www.prestashop.com/forums/topic/298066-transferer-un-site-local-vers-distant-wamp-vers-ovh/ Seulement, quand je tape l’adresse du site en local, je me retrouve avec ce message d’erreur : Fatal error: Call to undefined function mcrypt_decrypt() in /home/elode/www/prestashop2/classes/Rijndael.php on line 70 Quelqu’un aurait-il une idée pour me venir en aide ? Merci…
  6. À oui… merci beaucoup, je n'avais pas vu. C'est tellement riche que j'en découvre tous les jours !
  7. J'ai trouvé. Il faut copier le contenu (en partie ou completement) du fichier fr.php, et le modifier en fonction de la langue…
  8. Bonjour, J'ai un site bilingue (français-anglais). J'essaye de renommer la boite "fabricants" en "auteurs". Ça marche bien pour le français (il faut modifier le fichier /modules/blockmanufacturer/fr.php). Mais pour l'anglais, c'est une autre paire de manches… Comme le fichier fr.php, il y a bien un fichier en.php, mais il est presque vide. Comment faut-il procéder ?
  9. Merci, C'est très gentil à toi. Je crois que dans un premier temps, je vais me contenter de mettre le champ fabriquant dans la liste. C'est quand même le plus important. Je te remercie beaucoup pour ton aide, c'était vraiment le dernier obstacle important pour adapter prestashop à la librairie. Maintenant, je vais pouvoir penser à la mettre en production. Merci encore
  10. Merci beaucoup, ça marche! Mais… J'essaye de mettre les mêmes champs, avec le même code dans la fichier product_list.tpl, pour avoir l'auteur et l'éditeur également dans la liste de produits, et ça ne marche pas… le contenu des champs n'apparaît pas. pourquoi? Une idée? Merci encore pour l'aide
  11. Bonjour, J'installe actuellement une boutique web pour une petite librairie. Je me sers du champ "fabricant" pour entrer le nom de l'auteur; et du champ "fournisseur" pour entrer le nom de l'éditeur. C'est pratique… ça permet aux clients d'avoir un menu déroulant classé alphabétiquement sur les auteurs et les éditeurs. Mais… dans le modèle de base, les champs "fabricant" et "fournisseur" ne sont pas repris dans la fiche produit. Comment faire pour les y inclure? Quel code dois-je insérer dans mon template? Merci d'avance pour vos retours, elode
  12. Bonjour, Quelqu'un a-t-il déjà réalisé une boutique chez Ouvaton? Je suis intéressé par cet hébergeur un peu particulier, mais avant de m'inscrire, j'aimerais savoir ce que vous en pensez.
  13. Bonjour, Je viens d'installer Prestashop chez Free. J'essaye actuellement d'importer un fichier .csv, mais j'obtiens ce message: Fatal error: Call to undefined function array_fill_keys() in /mnt/109/sdb/8/1/zoucaplot/adminzou/tabs/AdminImport.php on line 169 Donc, ça bloque; et je ne crois pas que ce soit lié à un fichier particulièrement. Je joints toutefois le fichier .csv. Merci d'avance pour vos conseils… fichierGestionDeStockEssai.csv
  14. Merci, ça a l'air de marcher Je me demande vraiment ce qui a pu se produire… Merci à tous pour vos réponses.
  15. Effectivement, dans le fichier settings.inc, j'ai cette ligne: define('__PS_BASE_URI__', '/install/m'); Pourtant, quand j'ai fait mon transfert ftp, j'ai tout copié à la racine! Que dois-je faire? Merci beaucoup pour votre aide
  16. Bonjour, J'essaye actuellement d'installer Prestashop chez Free. J'ai bien mis le fichier .htaccess avec «php 1» dedans, et j'ai ajouté un dossier «sessions» Tout c'est bien passé pendant l'installation elle-même. Au moment de me connecter dans l'admin, Prestashop m'a demandé d'effacer le dossier /install pour des raisons de sécurité. Ce que j'ai donc fait. J'ai également renommé le dossier /admin. J'arrive donc à la page de connection qui me demande mon adresse e-mail et mon mot de passe... que je donne, et alors... rien. Je reste sur cette page de connection. Aucun message d'erreur et impossible d'aller plus loin. D'autre part, dans la partie publique, je vois bien la boutique en ligne, mais sans aucun style appliqué. Comme s'il ne trouvait pas la feuille de style. Je vérifie donc en ouvrant le code source de la page... et je trouve ceci: <link href="/install/mthemes/prestashop/css/global.css" rel="stylesheet" type="text/css" media="all" /> Rien ne marche: tous les liens qui partent de ma page d’index pointent sur des pages situées dans le dossier /install… exemple: quand je clique sur panier, j’obtiens une erreur 404; et dans les propriétés du lien, j’ai: http://zoucaplot.free.fr/install/morder.php Bizarre, non? Croyant que qu'il s'était peut-être passé quelque chose pendant l'installation, j'ai tout recommencé depuis le début. (téléchargement, installation, etc.), mais rien n'y fait. Si quelqu'un avait la gentillesse d'éclairer ma lanterne. il aurait toute ma reconnaissance.
  17. En fait, en regardant bien, tous les liens qui partent de ma page d'index pointent sur des pages situées dans le dossier /install… exemple: quand je clique sur panierj'obtiens une erreur 404; et dans les propriétés du lien, j'ai: http://zoucaplot.free.fr/install/morder.php Bizarre, non? C'est peut-être un problème à l'installation. Je vais repartir de zéro.
  18. Bonjour, J'essaye actuellement d'installer Prestashop chez Free. Tout c'est bien passé pendant l'installation elle-même. Au moment de me connecter dans l'admin, Prestashop m'a demandé d'effacer le dossier /install pour des raisons de sécurité. Ce que j'ai donc fait. J'ai également renommé le dossier /admin. J'arrive donc à la page de connection qui me demande mon adresse e-mail et mon mot de passe... que je donne, et alors... rien. Je reste sur cette page de connection. Aucun message d'erreur et impossible d'aller plus loin. D'autre part, dans la partie publique, je vois bien la boutique en ligne, mais sans aucun style appliqué. Comme s'il ne trouvait pas la feuille de style. Je vérifie donc en ouvrant le code source de la page... et je trouve ceci: <link href="/install/mthemes/prestashop/css/global.css" rel="stylesheet" type="text/css" media="all" /> J'avoue ne pas comprendre. On vient de me demander d'effacer le dossier /install et le code source de la page d'accueil fait référence à un fichier de style (global.css) présent dans ce dossier! Si quelqu'un avait la gentillesse d'éclairer ma lanterne. il aurait toute ma reconnaissance.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More