Jump to content

Blue Sash

Members
  • Posts

    29
  • Joined

  • Last visited

Everything posted by Blue Sash

  1. Buenas Tardes, por un casual a alguien le sale en archivo error_log el siguiente error: PHP Fatal error: Uncaught --> Smarty: Missing template name <-- thrown in /home/xxxxxxxx/public_html/vendor/prestashop/smarty/sysplugins/smarty_internal_template.php on line 678 Ya que he probado de todo y a pesar que no se de que viene este error no he hallado con la solución y sale cada 20 Segundos lo mismo. Prestashop: 1.7.2.2 Saludos y gracias de antemano.
  2. Gracias por tu ayuda pero no funciona. Lo que quiero es quitar eso de dentro del producto de "Impuestos Incluidos". Y la línea a la que te refieres de quitar es esta: {block name='product_without_taxes'} {if $priceDisplay == 2} <p class="product-without-taxes">{l s='%price% tax excl.' d='Shop.Theme.Catalog' sprintf=['%price%' => $product.price_tax_exc]}</p> {/if} {/block} Pues no funciona y no se donde narices se encuentra este texto. Gracias
  3. Buenas Noches, Ampliando información sólo para España Llevo tiempo, semanas, meses siguiendo este hilo y se agradece que personas en su tiempo libre realicen trabajos de este tipo. Lo que tendríamos que hacer es todos los que disponemos de la Red de Sermepa (Redsys) y como no tienen competencia en España y por ello disponen de la mayoría de las Entidades es el enviarles como Burofax (son 7 Euros mediante web Correos) hacia la dirección que disponen bajo su web oficial lo siguiente: - Que nosotros ya hemos pagado los 79 € (varia según entidad y tipo de cliente) pero este dinero es para Redsys en su totalidad en base a: En sus condiciones lo ponen y es responsabilidad de ellos el que dispongan los módulos actualizados según avanza la tecnología. Que dejen de engañar al cliente con frases tipo "En breve saldrá" "En unas semanas saldrá" ya que esas respuestas ya las llevamos escuchando hace mucho. Que hablamos de un Addons que se define en "Dinero", es decir es una pasarela de pago y por lo tanto existen riesgos de terceros. Que dejen de Facturar a través de su 902 (Voz IP), es decir cada minuto que te mantienen en su 902 a ellos la Empresa que disponen para el 902 les pagan un 50% a ellos y el otro 50% para la Empresa que tienen contratado el 902. Lo anteriormente expuesto cada uno lo realiza como carta a su modo. Seguidamente con dicho Burofax y copia donde aparece remitente, destinatario y Número de Seguimiento Burofax se acerca uno al Organismo de Consumidores de su Localidad y expone una reclamación. Yo ya lo hice hace semanas y es la única manera de que entiendan las cosas que en sus propias normas lo indican y son responsables de tener los módulos actualizados. Y cuantos más seamos antes se pondrán las pilas. En mi caso yo desde hace ya semanas tuve que conseguir el módulo de pago y tuve problemas y lo tuve que comprar de nuevo pero esta vez dentro de Prestashop y desde entonces sin problemas. Y también adjunté Factura al burofax de lo pagado por el segundo Addons y me ha sido devuelto, por cierto también adjunté la factura de llamada hacia el 902 de ellos ya que pueden tener un 902 pero no con fines de recaudación y os aseguro que hay muchos afectados. Simplemente he querido aportar esta información ya que me parece que se quieran aprovechar de todos y obviamente en esta vida se gana el dinero de forma humilde y no de maneras como esta. Observaciones: Existen varios problemas con el que disponen V 3.0.0 con la versión 1.7 y posteriores, te puede funcionar 1 vez pero a la 3 vez no te funciona y te van a responder que es problema del comercio, es decir de tu banco. También depende del Certificado de Seguridad ya que no vale cualquiera y también de la IP Dedicada. De alguien que ha querido empezar uno de sus negocios desde 0 con la Versión Prestashop 1.7 pasando por todas las actualizaciones hasta al actual 1.7.2.2 y llevo comprando 4 Addons, 1 Tema y todos indican que es compatible con la Versión 1.7 y no lo son... otra cosa muy diferente que ante la novedad de la Versión 1.7 muchos han querido aprovecharse de esto pero finalmente a base de soporte, de reclamaciones y otros recursos he puesto el acento sobre la i. Saludos
  4. Hola Estebanc, En un principio no tendría que darte ningún problema. Te sugiero desinstalar el módulo que dispongas de Paypal, mediante la ruta Modulos / Modulos Instalados y una vez desinstalado también borres por FTP la carpeta "paypal" que lo tienes en modules / paypal. Te vuelves a descargar el Módulo Oficial de Paypal. Enlace: https://addons.prestashop.com/es/pago-tarjeta-carteras-digitales/1748-paypal.html (Es Gratis) Lo instalas y automáticamente te debe aparecer en Español y según necesidades lo configuras a tu gusto.
  5. Buenas, alguien por un casual sabe como se quita lo de "Impuestos Incluidos" que viene dentro del producto al lado del precio? Ya que desde Traducciones no aparece o al menos yo no lo encuentro. Prestashop Versión 1.7.2.2 Gracias
  6. Buenas tardes: Por un casual alguien es tan amable de decirme cual es el archivo donde se encuentra las etiquetas de <body> y de cierre de etiqueta </body> en el tema. Ya que el header.tpl y el footer.tpl en versiones 1.6 y anteriores existe pero en versión 1.7 y superiores no existen. Y no soy capaz de buscar la etiqueta de cierre </body> que lo necesito para implantar justo antes un código fuente. Muchas gracias
  7. Buenas tardes: Tengo otro dilema y es el tema de que yo sólo vendo en España y a la hora de que el cliente va a realizar un pedido pues no sale el campo de Provincias y la pestaña desplegable para que seleccione provincia. He visto en otros hilos pero no me sale. De igual modo tampoco consigo buscar en donde se encuentra en Traducciones lo de "Edit" que en la imagen lo pongo con un punto rojo. Adjunto imagen de como se ve y lo del "Edit". Gracias
  8. Buenas Tardes, Prestashop: 1.7.2.1 El problema que tengo es el siguiente que desconozco si os pasa a alguno de vosotros. El tema es que mi Prestashop lo tengo montado exclusivamente para ventas en España y resulta que en GooGle Adwords lancé recientemente una campaña de publicidad de 10 días y sin problemas a nivel España. Resulta que nuevamente quiero hacer otra campaña y me dicen estos de Adwords que mi web tiene que ser accesible desde todo el Mundo o sino que me sale rechazado. A lo que les respondo como puede ser si ya existe una campaña reciente y sin problemas y sin tocar nada que ahora vaya a crear una campaña y me digan esto de que mi web debe ser accesible a todo el Mundo. Y las dudas son ya que no me cuadra: - Lo del tema de las IPs y buscadores no es aquí donde están supuestamente las IPs de los buscadores tipo GooGle, Yahoo, etc... - Y como se hace para que sea accesible Mundialmente en Prestashop. - Y es normal esto de que la web tiene que ser accesible Mundialmente, no tiene lógica ya que entrarian ventas de todo el Mundo y no me interesa a pesar que sólo y esta marcado que sólo se realizan "Pedidos a España excepto Canarias, Ceuta y Melilla". De antemano gracias por vuestra posible ayuda o si os ha sucedido este tema. Saludos
  9. Buenas tardes, Bajo mi opinión da igual la Empresa sea pequeña que grande, lo que se mira es cara al Cliente final y lo que al final de la compra le aparece el total a pagar, me explico: Quieras o no quieras tienes unos costes de envío y dependiendo de la Empresa de Transporte unos son más altos o más bajos. Estos costes de envío los debes cubrir: Opción 1: Subir el precio del producto y poner envíos gratis. Opción 2: Bajar el precio del producto y cobrar los envíos. Recomendada. Opción 3: Poner unos precios a la Opción 2 y por ejemplo a partir de 60 € de compra los envíos son gratis. Recomendada. Si te fijas en ambas opciones es simplemente jugar con los precios pero que esos gastos de envío debes sacarlos de una forma o de otra pero es el Cliente final quien paga. Personalmente y las indicadas como recomendadas son las que aconsejo y me van bien. Existen otras opciones pero es cuestión de ir jugando con los precios. Saludos
  10. Buenas Tardes, También dispongo del mismo error pero pudiera ser que nadie se ha dado cuenta de este BUG. No te preocupes ya que es problema de la versión 1.7 en adelante, la versión 1.7.2 reciente tampoco lo ha corregido. En mi caso me di cuenta en la versión 1.7.0.2 creo recordar con el template "Classic" es decir el tema por defecto ya que posteriormente he comprado un template y pasa lo mismo y dentro de templates de desarrolladores de Prestashop en 1.7 hace lo mismo que es te pasa de página pero no sube hacia arriba y es el cliente que debe subir la página. A ver si alguien y cuando tenga tiempo pueda reportar este tema o bien que nos confirme este error ya que quiero pensar que nadie se ha dado cuenta. Saludos.
  11. Buenas Tardes, Yo no soy programador ni tampoco entiendo mucho pero me defiendo en lo básico. Bajo mi punto de vista la versión 1.7 y en referencia a las anteriores y ante el mismo sector he notado muchas mejorías y esta ha sido mi trayectoria: - Yo empecé con la 1.7 y actualmente estoy con la 1.7.2 que es la última actualización a fecha actual. - Dispongo de Servidor Cloud administrado. - Dispongo de Template (Tema) de pago. - Dispongo de Módulos de pago (los justos). Lo anteriormente dicho es debido a que todo es un negocio y todos (me incluyo) queremos vender de la manera fácil y sencilla pero desde un inicio y ante la aventura de la versión 1.7 con varios errores se han ido solucionando. Aunque actualmente existen errores como por ejemplo: La barra de navegación de pase de página que si por ejemplo dispones que en cada categoría salgan 9 productos te salen 9 productos pero cuando dispones de más productos en la parte inferior te sale la barra de navegación (página 1, 2, etc...) y si pulsas sobre la página que quieras te pasa de página pero se queda abajo en vez de subir hacia arriba (que es como en anteriores versiones es como funcionaba). Pero como no tengo ni idea de como se reporta esto. Bueno vamos al tema, la nueva versión es brutal en SEO de la rapidez en la que apareces en GooGle, brutal en la que tus imágenes aparecen en GooGle y de la manera en la que aparecen cara al cliente de realizar su compra, el manejo de administración es mucho más llevadero y sencillo. Pero como he dicho antes... esto es un negocio, en donde hay muchos programadores detrás de esto que son los que desarrollan módulos, templates... que a gusto de las necesidades que tiene cada uno pues gasta o no gasta. Punto a tener en cuenta: - No vale en cualquier Hosting ya que precisa de unos recursos para que funcione la versión 1.7 Resumiendo, se nota diferencia entre la versión 1.7 en referencia a las anteriores, SI Saludos
  12. Buenas Tardes: Que tal estamos, todo bien y yo que me alegro. Bueno pues aquí vamos con el Prestashop 1.7.2 a toda vela pero y como todo tiene un pero me he tropezado con un posible BUG o al menos eso creo y como no tengo ni idea de reportar BUG por si acaso primero lo comento y a ver si os sucede o posibles soluciones. El problema esta en cuanto tienes muchos productos en una categoría pues al final te sale un menú para que pases página: Este es el del tema por defecto del Prestashop 1.7 pero y aunque use otro tema el problema me lo da de igual forma. Aquí estaríamos en la 1 de 6, si pulsamos el 2 pasa página pero no sube página. En referencia a la Versión 1.6 y anteriores cuando pulsas sobre una página, lo que hace es cambiar de página y te sube hacia arriba. Y yo me pregunto... os sucede igual o es un BUG. Saludos y como siempre, una Comunidad que aporta mucho.
  13. Hola, Por un casual alguien sabe como se hace el poner las Subcategorias en Horizontal en vez de en vertical. Me explico, cuando creo las categorías salen en Horizontal y dentro de estas creo Subcategorias y dentro de las Subcategorias pues creo los apartados y la duda que tengo es posible que estos últimos salgan en horizontal ya que me salen en vertical. Lo que quiero conseguir es como la captura adjunta y no lo consigo ver ni como hacer Muchas Gracias.
  14. Gracias por preocuparte Jesús, Te explico detalladamente por si te sirve de ayuda, yo dispongo de Módulos y Tema (todos de pago) para la 1.7.1.2 y el Jueves tras últimas revisiones por parte del Programador del Template (muy valorado en Prestashop) me indica tras examinarlo ellos que disponen de un fallo los programadores de Prestashop en este caso de atributos. Inclusive me crearon ellos un artículo de ejemplo con atributos y observaron lo mismo. Y por eso mismo es cuando lo volví a exponer en este hilo. Entonces en la Versión 1.6 cuando se marcaba que cuando un producto dispone de un atributo "sale en color gris" hasta que el cliente selecciona la talla (atributo ejemplo) y cuando selecciona la "Talla" el carrito cambia de color para que el cliente pueda continuar con su compra. Si se entraba desde catálogo entraba al producto pero dentro del producto hasta que marcase la "Talla" no podía continuar. En la versión Prestashop 1.6.X.X funciona. --------------------------------------------- Ahora vamos con la versión Prestashop 1.7.1.2 (es la última pero ya fallaba desde la 1.7 y con el Templane por Defecto Classic) aquí la casilla de "Mostrar el botón "añadir al carrito cuando disponga atributos" al desactivarla pues sigue saliendo el carrito, aquí se adjunta dentro del office con un punto rojo que da igual activarlo que no, hace caso omiso. Ahora vamos a la parte del proceso de inicio, es decir cuando un cliente entra en tu tienda. Aviso es un Template de pago pero pasa lo mismo con el Template Classic, aquí un ejemplo de un artículo con atributo, lo que ves el carrito negro (es gris) pero al poner el ratón te deja entrar. Ahora estamos dentro del producto y es aquí donde esta el problema, el sistema te marca por predeterminado una talla y el carrito sale en negro dando lugar que no es el cliente quien elige sino el sistema y deberían aparecer las tallas (pero sin marcar) y el botón de carrito en color "gris" hasta que no seleccione la talla (en versión 1.6 hasta te decía "Que debe seleccionar para proceder a su compra" y aquí directamente te sale la de por defecto predeterminada marcada. Y aquí adjunto digamos donde creas el atributo, en este caso la talla y donde te deja que marques una predeterminada pero te obliga a hacerlo y no tiene lógica ya que sino por un lado se dispone que si "Dispone de atributos no salga el carrito de compra" y por esta parte nos obliga a que marquemos una predeterminada. Jesús espero que me haya explicado bien ya que yo de Inglés "0" y los Programadores del Tema hablan Inglés pero con el traductor me he ido defendiendo y son los que este Jueves y tras unas cosillas de este template de como iban y otros ajustes pues yo de paso les pase este problema y es lo que me han respondido pero ellos me indican que ellos no tienen nada que ver con Prestashop y Programadores que ellos solo dan soporte a su Template y otros productos que lo veo normal. Saludos y siento darte la lata pero considero que este tema puede afectar a muchos si no lo solucionan y por otro lado quiero quitarme de las dudas de si es un BUG o es tema de Temas aunque no lo creo ya que instalé la 1.7 con el tema Classic y posterior actualicé a la 1.7.1.1 y aquí compré el template y el error era el mismo en ambas.
  15. Buenas a todos... alguien por un casual ha probado si le funciona el tema de Tallas, Colores, etc... es decir los atributos y el "Carrito de Compra". Versión Instalada: 1.7.1.2 Como reporte en este mismo hilo y desconociendo si es problema mío o no... pero resulta que desde "Parámetros de la Tienda" y desactivando el "Mostrar el botón al carrito de compra cuando dispone de atributos" no hace caso el sistema, es decir sigue saliendo saliendo activado el carrito de compras. Lo único que me he dado cuenta es que el sistema te marca por defecto el que tengas marcado por defecto en el producto y atributo pero quiero pensar que al desactivar el "Mostrar el botón al carrito de compra cuando dispone de atributos" tendría que salir el botón "Carrito de Compra" en gris y cuando el cliente marque la Talla, etc... es cuando puede seguir con la compra. Se aporto una captura en mi anterior respuesta. Gracias.
  16. Buenos días, agradecer vuestro esfuerzo por resolver este problema y dedicar vuestro tiempo en ello. Como dijiste Jesús que era un posible BUG y así ha sido y aunque no pueda solucionarlo a través del módulo de 1 Click y actualizar de la 1.7.1.1 a la 1.7.1.2 debido a que al final me sale un error de que no puede actualizar la base de datos, lo que he realizado es bajar la 1.7.1.2 y reemplazar el archivo contactform.tpl que está ubicado en la siguiente ruta a través de FTP. themes/classic/modules/contactform/views/templates/widget/contactform.tpl y listo ya sale bien. Desconozco el porque sale ese error de actualización de base de datos al final, es decir realiza la copia de seguridad y todo pero justo al final cuando llega a lo de la base de datos te salta una pantalla que te dice de restaurar a la 1.7.1.1 pero bueno esto ya será otra cosa. Observaciones: Lo que sí veo que la 1.7.1.2 e instalada de cero en otro dominio sigue existiendo el BUG de lo de el carrito y atributos que tengo abierto en otro hilo https://www.prestashop.com/forums/topic/613546-prestashop-versi%C3%B3n-171-obligar-a-elegir-talla-color/ Gracias, doy por resuelto este tema.
  17. Gracias por tu respuesta kik-off: En primer lugar agradecerte por tu aportación pero hay algo que se me escapa y perdona mi ignorancia ya que he seguido tus pasos y no me funciona. La ruta vía FTP para el archivo javascript.tpl sería esta... themes/javascript.tpl y cuyo código sería este con tu cambio, no? {** * 2007-2017 PrestaShop * * NOTICE OF LICENSE * * This source file is subject to the Open Software License (OSL 3.0) * that is bundled with this package in the file LICENSE.txt. * It is also available through the world-wide-web at this URL: * http://opensource.org/licenses/osl-3.0.php * If you did not receive a copy of the license and are unable to * obtain it through the world-wide-web, please send an email * to [email protected] so we can send you a copy immediately. * * DISCLAIMER * * Do not edit or add to this file if you wish to upgrade PrestaShop to newer * versions in the future. If you wish to customize PrestaShop for your * needs please refer to http://www.prestashop.com for more information. * * @author PrestaShop SA <[email protected]> * @copyright 2007-2017 PrestaShop SA * @license http://opensource.org/licenses/osl-3.0.php Open Software License (OSL 3.0) * International Registered Trademark & Property of PrestaShop SA *} {if isset($js_def) && is_array($js_def) && $js_def|@count} <script type="text/javascript"> {foreach from=$js_def key=k item=def} var {$k} = {$def|json_encode nofilter}; {/foreach} </script> {/if} {if isset($js_files) && $js_files|@count} {foreach from=$js_files key=k item=js_uri} <script type="text/javascript" src="{$js_uri}"></script> {/foreach} {/if} {if isset($js_inline) && $js_inline|@count} <script type="text/javascript"> {foreach from=$js_inline key=k item=inline} {$inline} {/foreach} </script> {/if} {if isset($vars) && $vars|@count} <script type="text/javascript"> {foreach from=$vars key=var_name item=var_value} var {$var_name} = {$var_value|json_encode nofilter}; {/foreach} var chooseFileText = "{l s='Choose file' d='Shop.Theme.Actions'}"; </script> {/if} Y la ruta del theme.js sería esta themes/classic/assets/js/theme.js y aquí se ha cambiado el "Choose file" por "chooseFileText" Ya que existen varios theme.js pero de los que he visto en esta ruta la única que aparece el "Choose file" y quiero pensar que es en este. Observaciones: No se si sirve de ayuda pero antes de abrir este hilo si que me di cuenta que en cuanto abres el "Contáctenos" y en plena carga se carga así: Y enseguida (milésimas de segundo) se queda así: Saludos
  18. Hola Jesusruiz, gracias por tu respuesta: Es lo que me comentaba en este hilo "Sergio Ruiz" que podría ser un Bug pero al no tener conocimientos en Inglés yo pues no se reportarlo. Realmente es un problema ya que si decidimos el instalar la versión 1.7.1 es debido principalmente a que decía siempre tener la última versión de Prestashop y como son muchas referencias, nos preguntemos para que instalar la 1.6 si luego va a ver problemas. Es decir, se ha instalado desde 0 la versión 1.7.1 Entonces en el presente ya la tenemos casi finalizada con módulos de pago para la 1.7.1, Redsys, Paypal con recargo, Zoom, etc... y ubicada en un Servidor Dedicado SSD y claro nos estamos encontrando con este problema (el cual se adjunta captura) pero no hace caso, también dispone de otros problemas que los estoy reportando en otros hilos mientras me los voy encontrando como por ejemplo: - Cuando se introduce una nueva referencia no sale en primera página. - En el apartado "Contáctanos" en el campo que aparece "Archivo Adjunto" en el botón de "Adjuntar" pues sale "Choose File" en vez de "Archivo" y en las traducciones pues salen correctas pero no en la web. Hay un hilo abierto a este punto. También he de decir que impresionante los Load de Carga y SEO, las velocidades en las que aparece en GooGle son geniales. Pruebas realizadas con doble web (1 experimental y 1 oficial) y en ambas sucede lo mismo. Pero claro, no puedo activar la oficial debido a que el tema de atributos no hace caso y elige la talla por defecto saliendo el "Carrito de Compra" ya que puede derivar a devoluciones y problemas. Es de agradecer que si se reporta a ver que dicen... mientras tanto yo sigo dándome golpes con el sistema y probando y probando. Gracias. http://i64.tinypic.com/24cte38.jpg
  19. Hola kik-off, gracias por tu respuesta: Pero en que archivo y línea hay que introducir ese código. Ya que me parece curioso o no doy con el texto "Choose File" ni mirando archivo a archivo dentro del módulo "contactform" ni en traducciones. Saludos
  20. Gracias por tu respuesta: No te preocupes si yo tampoco es que entienda mucho más que lo básico. Suficiente ya has realizado con poner tu granito de arena. Esperemos que alguien se haya cruzado con este problema y de con la solución. Saludos.
  21. Gracias por tu respuesta: Deberá ser que la que tengo yo es la 1.7.1.1? Y que tu tengas la anterior la 1.7 y por eso no te sale lo de "Archivo Adjunto". Y si ya vi también que salen 2 campos y en los dos los he cambiado por "Archivo" y nada, sigue el "Choose File". Sigo peleando... se me ocurre quizás en vez de en temas que este en "Módulos"...
  22. Ampliando información: Yo en mi caso cuando instalé la versión 1.7.1.1 y a la hora de la instalación se me solicitaba cosillas para poder instalarlo y 3 de ellas era temas de librerías nuevas que no tenía instaladas y tema de MySQL. Entonces desde configuración / parámetros avanzados / información en la zona de "Comprobación de su Configuración" te debe salir: COMPROBACIÓN DE SU CONFIGURACIÓN Parámetros requeridos: OK Parámetros opcionales: OK Quiero pensar que en este campo te debería indicar el error a que se debe. También se me ocurre que te vuelvas a instalar de CERO con otra base de datos la versión 1.7.1.1 y en el apartado de requisitos fíjate en color amarillo que te falta. Saludos.
  23. Gracias por tu respuesta: Si es lo que hago, es decir en ese campo pone "Seleccionar archivo" que es lo que debería salir... pero sigue saliendo el "Choose File" y si pongo "Archivo" en vez de "Seleccionar archivo" como viene sigue saliendo el "Choose File". He limpiado cache y todo, pero que no hay manera. Tu lo has conseguido que se vea en la web en "Contáctenos" ya que guardar si guarda texto pero a la hora de verlo en la web no. Saludos
  24. Gracias por tu respuesta: Es precisamente lo que me sucede que no lo encuentro desde la ruta indicada. Inclusive he ido mirando archivo a archivo de este módulo y tampoco. Donde dices que has encontrado la palabra "Choose File" ya que no la veo, lo que si veo es la palabra "Adjuntar Archivo" que es la que debería salir pero no es así. Adjunto URL captura y lo que pongo con un círculo rojo es el botón y el texto dichoso de "Choose File" que no lo encuentro. https://ibb.co/hAu5YF Saludos
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More