Jump to content

Mako35

Members
  • Posts

    6
  • Joined

  • Last visited

Profile Information

  • First Name
    Dimas
  • Last Name
    E.

Mako35's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I'm on prestashop 1.6.1.14 and I've enabled multistore. When I try to access the api through the url of my B2B shop, nothing happens and it redirects to the homepage. For my B2C shop it works but when I go to https://my-shop.com/api/products?id_shop=all it redirects to the homepage with this url https://my-shop.com/?url=products%2F The redirect rules in my .htaccess are exactly the same for both url shops.
  2. Dans le .htaccess à la racine du site, les règles de redirection sont exactement les mêmes pour mes deux shops. Oui, la clé API est cochée pour les deux sites et bien activée. J'ai contacté le développeur du module en attendant de trouver une solution.
  3. A l'aide de PSWebServiceLibrary.php ? Ou via le .htaccess ?
  4. Bonjour, Je possède deux boutiques sur la même installation Prestashop 1.6.1.14 (multi-boutique): un B2C et un B2B. L'url principale est celle du B2C (de la forme: https://my-shop.com/) Lorsque je souhaite accéder à l'API cela fonctionne pour le B2C cependant lorsque je fais de même pour mon site B2B, l'APi ne semble pas fonctionner. Une redirection a lieu car il faut obligatoirement s'authentifier afin de parcourir le site. J'utilise le module suivant: https://addons.prestashop.com/en/b2b/17359-private-shop-module-for-b2b-business.html J'ai essayé de le désactiver mais rien n'y fait, lorsque j'entre l'url suivante: par exemple: https://b2b-my-shop.com/api/ et bien le site ne me demande pas de clé, n'affiche rien et se redirige vers la page d'accueil contrairement à l'adresse du B2C.
  5. Bonjour, Lorsque je veux accéder au tableau de bord dans le BO, ça prend quelques minutes pour qu'il s'affiche correctement. Les autres menus fonctionnent correctement, ça le fait uniquement pour le tableau de bord. Je suis sur PrestaShop 1.6.1.14, j'ai remplacé le controller AdminDashboardController.php par la dernière version de PrestaShop 1.6 mais c'est toujours aussi lent. J'ai ce problème depuis quelques semaines.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More