Jump to content

couillaler

Members
  • Posts

    310
  • Joined

  • Last visited

Everything posted by couillaler

  1. Hello, Sur mon ancienne boutique(1.7.5), j'utilisais effectivement des modules qui avaient leur propre éditeur (c'était notamment, je crois, un éditeur de blocs HTML), mais cet éditeur ne servait pas pour les produits, c'était juste intégré au module pour son utilisation, dans le cas présent, éditer des blocs HTML qu'on pouvait coller où on voulait. J'ai changé de boutique depuis (nouvelle install 1.7.6.7), et le nouveau thème que j'utilise intègre déjà la possibilité de placer des blocs où on veut, ou en tout cas où je voulais, et donc je n'ai pas réinstallé ce module. Je n'en parlais à l'époque que pour dire qu'il était, à priori, techniquement possible d'avoir un éditeur avancé dans PS, puisque celui du module fonctionnait, mais ce dernier ne remplaçait pas tous les éditeurs de PS, et celui pour les produits était toujours le même. Antoine
  2. Hello, Boarf, connaissances trop limitées, et surtout pas assez de temps disponible pour faire un truc propre (sans compter que j'ai installé une nouvelle boutique à partir de zéro sur une nouvelle version de PS (1.7.6.7) depuis... J'ai donc acheté un module noindex qui se charge d'aller faire les modifs à ma place... 😕 Il fonctionne bien. J'ai conscience, comme pour d'autres modules, que j'aurais pu faire cela moi-même, mais voilà, les connaissances, le temps... le rapport coût de faire soi-même/investissement module... tout ça... Antoine
  3. Hello, Ben n'hésites pas à cliquer sur le petit coeur en bas à droite de nos deux messages pour nous remercier de ces judicieux conseils! Ça flattera nos égos ! Et passe le sujet de ton message en [Résolu] en éditant celui-ci, ça facilite la lecture du forum et aidera d'autres personnes... Antoine
  4. Hello, Une bonne astuce pour repérer ce genre de choses, et qui marche donc pour d'autres images ou zones que celles-ci, c'est d'utiliser la console pour les développeurs de ton navigateur (touche F12 en général, sinon, ça dépend des navigateurs "Options pour les développeurs" sur Chrome par exmple, ou Inspecteur). Par exemple, sur la copie d'écran suivante, tu peux voir, avec Chrome, ce que cela donne sur ma boutique. J'ai chargé la page d'accueil de mon site avec la console développeur activée, j'ai cliqué sur l'outil dans le rond rouge en haut à gauche, j'ai ensuite survolé/cliqué l'image que je recherche, et il indique dans la console le chemin, ici entouré en rouge. Je n'ai plus qu'à modifier celle-ci. C'est une méthode parmi d'autres... Antoine
  5. Mouai, en attendant, moi, et je ne suis pas le seul, même l'ADSL n'arrive pas encore chez moi (je crois qu'on annonce la fibre pour 2023, j'attends de voir ça)... alors ils peuvent augmenter les capacités de stockage comme ils veulent, si déjà on pouvait avoir un réseau internet filaire sur tout le territoire, ce serait intéressant ! J'utilise donc un réseau internet par satellite et ce dernier fait bien la différence entre un site internet qui doit charger 3Mo et celui qui doit charger 800ko, ce n'est pas un leurre financier comme tu dis. On me dit, et par mobile alors ? ben, ici, à la campagne, du moins celle où je suis, c'est à peine si on capte la 4G (et encore, il faut que je sorte de la maison et que j'aille dans le champs), donc, idem, en tant queclient, je préfère les sites "légers". Et je ne suis pas seul (je connais beaucoup de vallées ou de zones de montagnes similaires), nous n'habitons pas tous en ville où on trouve un réseau xG et de l'ADSL ou de la fibre en veux-tu en voilà, et où on perd un peu le sens des réalités informatiques. Donc c'est vrai que gagner 12ko sur un site, comme Google nous pousse parfois à le faire, ça change pas grand-chose, mais passer de 3Mo à 700ko, là par contre, je peux te dire que pour nous autres, les non-pourvus d'internet rapide, ça fait la différence. Et c'est là que je pense à mes clients qui sont, pour certains, peut-être, eux aussi loin des centraux informatiques urbains. Antoine
  6. Hello, Bon, en tout cas, je trouve le score GTMetrix pas mauvais, non ? 95%, 89%, 764Kb chargés... bref, si visiblement ça peut encore être amélioré avec ce "souci" de structure, je trouve déjà le score intéressant, et pas focément pénalisant pour le SEO. C'est vrai que ces scores se jouent à peu de chose, et le ressenti en allant sur le site est plus probant, mais bon, 95 et 89%, c'est déjà bien! Le score n'est pas mauvais non plus sur pagespeed insight... Bien meilleurs que les miens en tout cas... hi hi hi... Antoine
  7. Boutique PS 1.7.6.7 / PHP 7.2.32 / Serveur dédié Cent OS 78 / Plesk Obsidian V.18 Bonjour, J'ai certains produits dont le stock réservé est erroné (sûrement lors de l'import de mon ancienne boutique PS vers la nouvelle actuelle, peu importe). J'aimerais remettre ce stock réservé, sur tous les produits, à zéro ! Ce faux stock génère des erreurs que j'aimerais résoudre. J'imagine que cela se passe dans la BDD ? Je n'ai pas vu dans le BO de PS comment faire. Donc, sur PHPMyAdmin, pas de souci, mais ensuite ? Exemple de produits : En réalité, je n'en ai que vingt en stock, PS en affiche 300, car 280 seraient réservés, ce qui n'est pas le cas. Il doit bien y avoir moyen de réinitialiser ce stock réservé ?!? Merci pour votre assistance, Antoine
  8. Hello, Super! Bonne nouvelle! Pour passer le sujet en mode [Résolu], il te suffit d'éditer le message initial et de changer l'intitulé du sujet. N'hésite pas à réagir aux messages qui t'ont aidé en cliquant sur le petit coeur en bas à droite de ceux-ci. Bonne continuation, Antoine
  9. le peu de recherche que j'ai effectué là-dessus renvoie vers des soucis PHP (à mettre à jour en 5.6 ou 7.1), je t'ai envoyé un MP à ce propos... mais je n'ai pas assez de connaissances pour confirmer que ceci reglera tout. De toute façon, PHP 5.4 pour PS 1.6 est à mettre à jour je dirais. Antoine
  10. N'étant pas chez OVH, je ne sais pas du tout si tu as accès à ta config PHP (php.ini), ou au moins aux options de celui-ci. Cela te permettrait en effet de modifier des choses. La version de PHP 5.4.45 est en effet une version obsolète. Si tu as pas accès à ces modifications, il faut peut-être voir directement avec OVH. Ou bien, peut-être que qqun d'autre ici pourra t'aider, car je ne sais pas comment cela fonctionne chez eux.
  11. Quand tu vas dans le menu Performances Avancées - Informations , ou équivalent dans 1.6, tu as quoi d'affiché pour la version de PHP ? Ta boutique est hébergé chez qui ? sur une solution mutualisée ? Un serveur dédié ? A priori, tu peux ignorer le message, il t'informe juste que ta version n'est pas la plus récente. Entre la 1.6.1.7 et 1.6.1.9, de toute façon, rien de majeur comme mise à jour. Antoine
  12. Pour l'avoir utilisé avec PS 1.7.5.x, je sais que ça a plutôt bien marché (pour moi), mais pour 1.6, je ne sais pas, je n'ai jamais travaillé avec cette version de PS. ??? Ben, pourtant, d'après Prestashop, PHP 7.1 est pourtant la version recommandée : https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/ Pourquoi dis-tu que 7.1 ne fonctionne pas avec PS ? D'où l'intérêt de faire des sauvegardes, en effet. Même si c'est pas facile de deviner qu'un "accident" va se produire, par définition. Et on ne peut pas faire des sauvegardes à chaque manipulation, je le conçois bien. En tout cas, si des fichiers ont été déplacés, tu pourrais avoir des erreurs lors de la mise à jour, si tu la fais, donc une sauvegarde du dossier PS et de la BDD s'IMPOSE avant toute tentative !!! Antoine
  13. Hello, Je n'ai pas l'explication à ton problème, désolé. Par contre, comme tu es en 1.6.1.7, peut-être pourrais-tu tenter une mise à jour vers la dernière version de PS 1.6.1.9 et te mettre sur PHP 7.1 (celle conseillée par PS [et non pas 7.0, qui est certes compatible mais pas optimale]) ? https://www.prestashop.com/fr/versions-precedentes?field_main_version_tid=2875&sort_by=field_version_number_value&sort_order=DESC Cela "écraserait" peut-être le problème.... Ne pas oublier de faire des sauvegardes (fichiers et BDD) avant mise à jour. Sinon, désactiver tous les modules non PS (sauf ceux de ton thème, tu utilise le Classic ou un autre ?), et voir si tu as le même souci. Essayer d'isoler le problème, quoi. L'as tu depuis une mise à jour quelconque ? il est apparu soudainement, sans rien faire ? Antoine
  14. Bonjour, Je rencontre un souci similaire, avec un PS 1.7.6.7 fraichement installé. Le SAV du dévelopeur patine pour l'instant et semble ne rien trouver de simple à faire pour résoudre ce problème. Voyant que vous avez aussi rencontré cette erreur, sur d'autres versions du module/PS, peut-être par contre que la solution trouvée alors est toujours d'actualité ? J'imagine que vous n'êtes pas restés toutes ces années, sans que cela ne fonctionne ? Antoine PS : si j'ai l'explication du développeur, je placerai l'info ici.
  15. Bonjour, Avez-vous trouvé une solution à votre problème de stock réservé ? En dehors du fait de rajouter une unité en stock pour en avoir 2 en physique, un en réservé et donc un en réel disponible ? On ne peut pas modifier ce stock "réservé", d'après le lien donné par @Janett en tout cas, sauf en allant faire des choses dans la BDD j'imagine, mais où exactement ? Quelqu'un sait ? J'ai aussi des unités réservées, qui ne correspondent à aucune commande en cours réelle, et j'aimerais remettre, sur ces références, les choses au propre. J'ai une référence par exemple où d'après PS, j'ai 280 unités en stock, 280 réservés et 0 disponible (ce qui est le cas), mais je sais que je n'ai pas 280 unités de cette référence en attente de commande. Surtout que j'ai supprimé de la BDD tous les paniers abandonnés de mes clients, enregistrés ou non (histoire d'être certain de ne pas en avoir 280 en attente quelque part). Savez-vous où remettre ce compteur de stock réservé à zéro ? Pour info, je suis sur PS 1.7.6.7, PHP 7.2. Merci, Antoine qui profite de la question d' @ANTONIN CATHERINE car je pense qu'on reste dans le même thème...
  16. @Manu-shop euh... c'était un peu déjà le contenu de ma réponse et du lien que je donnais, non ? Sauf si l'idée était plus de faire un peu de backlink facile vers dynamicmachin ? Antoine
  17. Bonjour, Tu ne dis pas si ce souci est apparu soudainement, ou suite à une mise à jour, une nouvelle installation ? Ta version de PHP ne semble pas être celle préconisée par Prestashop, je ne sais pas si cela a un rapport avec ton problème (est-ce que PHP a été mis à jour récemment ?) https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/ Sinon, un affichage en mode Debug te permettra peut-être un affichage de l'erreur. Antoine PS : as-tu vidé les caches + cookies de ton navigateur internet pour voir ? Ou essayé avec un autre navigateur plus simplement, ou un autre ordi ?
  18. Bonjour, Un changement d'hébergeur est toujours possible, heureusement pour les consommateurs que nous sommes. Les limites de fichiers ne sont jamais terrible je trouve, surtout que PS en génère pas mal au final (fichiers, encore plus si tu as plusieurs langues sur ta boutique, images, caches...). Selon la fréquentation de ta boutique et les performances recherchées (sachant que le référencement tient aussi compte de la vitesse d'accès au site), et ton budget alloué à cela, un serveur dédié est aussi une bonne option (tu as aussi ainsi plus la main sur les versions des logiciels installés dessus, sur le redémarrage et d'autres choses encore...), et tu n'es en général alors pas limité par grand-chose dessus... (à moins d'avoir un énorme catalogue, ce qui n'est pas le cas avec moins de 2 ou 3000). Certains hébergeurs se sont aussi spécialisés sur Prestashop. Je ne sais pas trop ce que ça vaut. Perso, j'ai un serveur dédié chez Amen. Pas les moins chers mais je suis satisfait de leurs services. C'est aussi mon registrar. Mais tout le monde pourra te citer le sien, ils ont tous leurs avantages et inconvénients. Antoine
  19. Hello, Question simplette mais si tu coches la case "J'ai lu les CGV...." ça ne fonctionne pas plus ? (elle ne l'est pas sur ta copie d'écran) As-tu vérifié les règles des paiements dans le menu Paiements - Préférences ? (pays, groupes autorisés...) Sinon, ajouter quelques infors techniques est toujours sympathique (version PS, PHP, Modules concernés...) et aidant. Tu dis que tu n'as pas accès au BO, c'est un souci technique ou c'est juste que tu es pas devant le bon poste de travail ? Antoine
  20. Hello, Pop, pop, pop.... obligatoirement, n'exagérons rien! :) Il existe d'autres logiciels qui permettent les modifications de BDD. Mais c'est vrai que phpmyadmin est celui proposé et est surtout très simple et efficace. En plus, il présente les tables à gauches et les données à droites! ;) Dans tous les cas, avant de bidouiller dessus, fait une sauvegarde !!! (un dump). Surtout si tu débutes dans ce type de travail! De plus, comme @Prestaland te le conseille, travailler sur une copie de ton siteest une bonne chose. Cela peut se faire aussi en local sur ton ordi avec une copie de la BDD. Travailler sur une copie te permettra de faire des erreurs sans créer de dommages sur ta boutique en production en ligne, et donc t'évite de mettre ta boutique en péril. Des solutions avec MAMP ou WAMP (selon que tu es sur mac ou windows) existent pour faire ça en local, des tutos aussi. PS est un très bon logiciel, mais aussi assez fragile, il faut donc vraiment créer des sauvegardes de tes fichiers avant toute modif importante (les fichiers de ton site + la BDD). su tu fais beaucoup de modif, des sauvegardes intermédiaires sont effectivement utiles. Antoine
  21. Effectivement, c'est une version supportée, mais la préconisée reste la 7.2 (cf lien ci-dessus). Perso, je me mettrais sur la version préconisée (et plus à jour!) de PHP. Les autres paramètres suivent-ils les recommandations du développeur des modules utilisés ? (certains modules nécessitent des augmentations des paramètres mémoire, temps d'execution...) Sinon, tu peux aussi d'abord aller vider manuellement le cache dans le dossier ../racine_site/cache/ directement sur ton site (la commande Vider le cache du menu paramètre avancé - performances laisse des choses parfois). Il y a aussi cet autre message sur le forum Je ne sais pas quelle version de iqitmegamenu tu as, ni quel message d'erreur tu as. Ni si tu as contacté le développeur pour en savoir plus ? En tout cas, avant la mise à jour en 1.7.6.7, si tu la fais, fais bien une sauvegarde de tes fichiers sur le serveur, et de ta base de données auparavant.
  22. Ah, au fait, pour avoir la version PHP, tu peux voir via OVH je présume (je sais pas, je suis pas chez eux), ou sinon dans ton PS, menu Paramètres Avancés - Information, tu as une rubrique Informations sur votre serveur. Avec quelques paramètres intéressants à vérifier, dont la version PHP.
  23. Hello, Je commencerais par vérifier la version PHP sur laquelle fonctionne le serveur sur lequel est installé sur le site, et l'adapterais ensuite à la version conseillée par PS pour son logiciel. https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/ Tu devrais avoir la version PHP 7.2 idéalement. Antoine
  24. Ha ben en effet, faire un tel changement en 24h, c'est pas mal! Moi, il m'aura fallu plusieurs semaines... mais bon, pas au même rythme! Merci pour la réponse et le suivi, c'est sympa. Bonne continuation, Antoine PS : tu peux passer ton message en [Résolu] en l'éditant.
  25. Bonjour, @HeineFR merci beaucoup, c'est très clair indiqué comme cela... En effet, c'est vrai que renvoyer un lien vers une page qui existe vers une autre, c'est pas terrible en terme de SEO, mais en attendant une solution plus "physique" de masquer les fournisseurs sur le Front Office, je vois pas comment faire. Je vais voir comment adapter cela à mon site multilingue. @Janett Oui, merci, effectivement, j'avais déjà vu cette option, que tu m'avais déjà signalé auparavant (voir message ci-dessus du 26/06/19), le souci, et je l'avais déjà signalé par le passé, c'est que cette fonction devrait être scindée en deux ! Je ne veux pas masquer les marques, mais juste les fournisseurs ! Je trouve très bien que mes clients puissent choisir leur produit en fonction de la marque, et donc se rendre sur la page des marques. Mais en effet, c'est exactement la fonction qu'il faut, tu as raison, il faudrait juste deux boutons, un pour les marques, un pour les fournisseurs! Cela répondrait à beaucoup plus de besoins qu'un seul bouton qui fait les deux en bloc ! J'imagine que le lien Gthub vers les fournisseurs renvoie vers une page que l'on pourrait bidouiller pour rendre les fournisseurs invisibles en FO (c'est sûrement là que le bouton de l'option agit ?), mais je n'ai pas assez de connaissance pour me risquer à modifier cela. Le lien Sitemap renvoie effectivement vers la partie que j'avais déjà modifié sur le fichier SitemapController.php sur les conseils d'@Eolia. Ce qui m'étonne, c'est le peu de demandes à ce sujet, suis-je le seul à ne pas vouloir montrer mes founisseurs à mes clients ? Ou beaucoup de personnes les rendent publics sans le savoir ? Antoine
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More