Jump to content

vlnvln

Members
  • Posts

    26
  • Joined

  • Last visited

Posts posted by vlnvln

  1. On 3/11/2019 at 3:01 PM, ray96 said:

    Hi, first part it's ok and the rich text editor appear and seems to work, but when change code in Validate.php, i have error in all my website: 

    500 Internal Server Error

    Tested in prestashop 1.7.5, maybe something different for the new version?

    Do i really need to change validate.php?

    Thanks

    Raimundo

    Open Debug Mode on "Advance Parameters > Performance > Debug mode" u may missing some php module's I Have many errors because of this recently i change php to 7.2 and i get a lot of error's so after comparing with old version there are many modules that needed and installation did not inform me that i miss.

    Also you may have problems from file and directory right's.

    if u have access in console reset rights 

    sudo find /var/www/ -type f -exec chmod 644 {} \;
    sudo find /var/www/ -type d -exec chmod 755 {} \;

    /var/www/ = Change to your website site root path.

    And do not forget to clear cashe.

    Also in cpanel MultiPHP INI Editor i have  this settings some that missing are disable or left as it is

    my settings

    • allow_url_fopen = on
    • allow_url_include = on
    • file_uploads = on
    • max_execution_time = 60
    • max_input_time = 120
    • max_input_vars = 5000 'Use to help for get all translation's must have  in PS 1.6'
    • memory_limit = 128 'That make huge difference on back office some menu just not work at all'  
    • post_max_size = 20M
    • session.gc_maxlifetime    1440
    • session.save_path = /tmp 'The Default get me in trouble so as i read i change it to this'
    • upload_max_filesize 15M

    Hope to help a little.

     

    Thank you Vekia for post this 

    Working in PS 1.7.5.1 PHP 7.2 -- i have not try inframes 

     

  2. Αυτό λογικά είναι στο css

    Το display του footer ή όπως αλλιώς το λέει είναι μάλλον σε block και όχι inline θέλεις ίσως και inline-block...

    Πάτα f12 να σου ανοίξει αυτό που βλέπεις το "κώδικα" του site εκεί θα έχει και το υπεύθυνο css μπαίνεις αν δεν έχεις άλλο τρόπο από ftp ή cpanel και το αλλάζεις

    Μπορείς να κάνεις όλες τις αλλαγές από mozilla ή chrome και μετά να το αλλάξεις

     

  3. On 9/9/2016 at 10:58 AM, tapanda.gr said:

    Γέφυρα η Access με Presta; Are you sure; Πώς τη συνέδεσες στο διαδίκτυο; Όσο για το timeout αν ξέρεις ποιους πίνακες να πειράξεις, κάνεις καρφωτή εισαγωγή csv στην mysql και όλα good :)

     

    Μακάρι να είμαστε έστω μια ομάδα 4-5 άτομα διάσπαρτοι σ όλη τη χώρα και να μεγαλώνουμε με τον καιρό :)

     

    ΥΓ. Αν θες δώσε μας κάποιο link δικής σου σελίδας ώστε να μπορούμε να σε βρίσκουμε πιο "επίσημα" :P Και στην τελική να πούμε και τη γνώμη μας αν θες για τα projects που έχεις στήσει

    Προφανώς μιλάει με WebService - Api (Xml).

    Τα καρφωτά είναι καλά άλλα κρύβουν και προβλήματα.

  4. Εεεε παιδιά νομίζω ότι το http://mysite/admin δεν υπάρχει το admin γίνεται replace από ένα νέο όνομα μετά την εγκατάσταση και γενικά το αλλάζει το prestashop για προστασία αν μπεις στο root λογικά θα δεις ένα φάκελο admin12m342j ή κάτι παρόμοιο αν το αλλάξεις σε admin θα ξαναπάρει νέο όνομα μπορείς βέβαια να του δόσεις άλλο όνομα πχ admintositetougiorgou και να το κρατήσει

  5. Το βασικό πρόβλημα είναι με τις μεταφράσεις στην 1.6.χ.17 -18 έχω παρατηρήσει ένα πρόβλημα με το search (δε κάνει Index σε όλα τα προϊόντα )

    η tophost σου δίνει τη δυνατότητα να πειράξεις ρυθμίσεις του Apache;

    να μεγαλώσεις τη μνήμη στον Apache η κάποιες άλλες παραμέτρους που χρειάζονται πχ για τις μεταφράσεις.

    υπάρχει και η transip που έχεις το server δικό σου να κάνεις ότι θες η και cpanel 

  6. εμένα που είχα πρόβλημα ποιο παλιά φταίγανε οι μεταφράσεις ν έχει πρόσβαση στο sql βρες το login σου και βάλε default τα αγγλικά.

    εύχομαι να είναι μόνο αυτό το πρόβλημα.

  7. Με το Libreoffice Calc το έχεις δει;

    έχει αρκετές δυνατότητες σε αυτό το αντικείμενο.

    βασικά πάρε export τη βάση σε αρχείο sql και κάνε πείραμα τοπικά τρέξε το sql script άλλα κάνε create database με utf-8

    και αν έχει latin στα tables μέσα στο script κάνε  find replace σε utf

     

  8.  οτι erp και να έχεις αν έχει βάση δεδομένων με ένα view βολεύεσαι  άλλα  μετά μένει να το συνδέσεις.

    το πρώτο που μου έρχεται στο μυαλό σαν άμεση λύση είναι το csv  κάνε το copy και κράτα 6000 γραμμές  στο ένα και σβήσε μέχρι τις 6000 γραμμές από το δεύτερο δηλαδή διαίρεσε το αρχείο σε δυο έτσι θα ρίξεις τους χρόνους και θα είσαι μέσα στα όρια του server.

    Καλύτερα με το Libreoffice Calc είναι ιδανικό για αυτή τη δουλειά.

  9. 2 hours ago, system_error86 said:

    Καλήμερα κι από μένα,

    Δουλευω σε μια εταιρεια εμπορειας αθλητικων ρουχων και παπουτσιων. Εχουμε eshop στην εκδοση 1,6,1,11 και με τη βοηθεια ενος module που εχουε αγορασει κανουμε import με csv αρχειο τα προιοντα μας που εξαγωνται απο το erp μας. Η διαδικασια του import ειναι καπως περιπλοκη οι τιμες καταχωρουνται σε καθε combination του προιοντος κι εχει κι αλλες λεπτομερειες που δεν ειναι αναγκη τωρα να αναφερθουν. Το προβλημα μας τωρα ειναι το εξης: Η ανανεωση του στοκ χρειαζεται να γινεται στο 10λετπο διοτι τα φυσικα  καταστηματα ειναι 4 αυτη τη στιγμη και σε λιγο θα γινουν περισσοτερα, πραγμα που αυτη τη στιγμη δεν εχουμε σαν δυνατοτητα γιατι με το που διπλασιαστηκαν τα προιοντα το Import κανει πανω απο 10 λεπτα πλεον κι αυτο δεν μπορει να γινεται και στο μελλον. Επισης ενα αλλο προβλημα που εχουμε ειναι οτι εχω run time error η κατι τετοιο τελος παντων το σφαλμα που μου δειχνει στο log αρχειο του server ειναι αυτο (70007)The timeout specified has expired: AH01075: Error dispatching request to : . 

     

    Υπαρχει καποιος εδω μεσα που να εχει κανει αυτη τη διαδικασια και να δουλευει σωστα το site; Υπαρχει καποια ελληνικη εταιρεια που να ασχολειται με prestashop να μας βοηθησει, να δωσει μια προσφορα, κατι;; 

     

    Ευχαριστω πολυ.

     

     

    Καλησπέρα αρχικά με το error δες τα παρακάτω.

    Πρέπει να πειράξεις το web server αυτό βρήκα με μια πρόχειρη ματιά.

    Λογικά επειδή όπως είπες διπλασιάστηκαν τα προϊόντα το script που κάνει import κάνει παραπάνω χρόνο και γενικά υπάρχουν όρια που τα υπερβαίνει και σκάει.

    talk.plesk.com/threads/problem-php-fpm-70007-the-timeout-specified-has-expired-ah01075-er.335211/

    και

    forums.cpanel.net/threads/the-timeout-specified-has-expired.603207/

     

    Μήπως πρέπει να κοιτάξεις το ενδεχόμενο να ξεκινήσεις με webservice και όχι import από csv ξεκινώντας από το erp

    Βασικά δε καταλαβαίνω ποια είναι η σχέση eshop με τα φυσικά καταστήματα;

    πχ. είναι online μεταξύ τους; και ξέρεις το stock του κάθε ένα καταστήματος και το γενικό;

    Και τι εννοείς διπλασιάστηκαν τα προϊόντα; και για τι ποσότητα μιλάμε;

     

     

  10. Οκ κατάλαβα το πρόβλημα.

    Με κάποιο τρόπο μου έδωσε τη δυνατότητα να διαγράψω τη κατηγορία Home που είναι κάτω από την αόρατη Root και μετά απλά δε δούλευε τίποτα.

    το module PrestaShop Cleaner το χρησιμοποίησα χωρίς πρόβλημα.

     

     

    Γενικά προσοχή με τις μεταφράσεις δημιουργούν πολλά προβλήματα.

  11. Κατέβασα νέα έκδοση για ένα νέο project και διαπίστωσα τα παρακάτω.

     

    Αρχικά αν η γλώσσα εγκατάστασης είναι στα Ελληνικά βγάζει error 500 κατά τη δημιουργία της βάσης.

    Αυτό με αλλαγή γλώσσας εγκατάστασης στα Αγγλικά αυτό λύθηκε.

     

    Το δεύτερο που παρατήρησα είναι ότι αφού έβαλα το module  PrestaShop Cleaner άλλα δε ξέρω αν έπαιξε ρόλο 

    καθάρισε τους πίνακες με τα προϊόντα και γενικά ότι είχε μέσα.

     

    Οι κατηγορίες δε φαίνεται να παίζουν καθόλου σωστά καθώς δεν εμφανίζονται στα προϊόντα για να επιλέξεις κύρια κατηγορία (Main category) αν και μπορώ να επιλέξω (ASSOCIATED CATEGORIES) δε δουλεύει στο save .

     

    Κατά τη δημιουργία νέας κατηγορίας δε μπορώ να επιλέξω γονική κατηγορία και όταν κάνω Expand All για να διαλέξω γονική κατηγορία πετάει σφάλμα (Root category must be an integer value) μέσα στο πεδίο Parent category.

    Και στη βάση στους πίνακες φαίνονται όλα καλά 

    Δοκίμασα σε firefox kai Chrome.

     

    Μάλλον κάτι δε δουλεύει με τη Root 

    θα ξανά κάνω εγκατάσταση από την αρχή χωρίς να βάλω το module PrestaShop Cleaner να καθαρίσει τι βάση και θα ενημερώσω 

     

  12. Καλησπέρα

    Γενικά έχουμε βρει σχεδόν όλα όσα χρειάζεται για να δουλέψει με το webservice API που έχει

    Άλλα δε μπορώ να περάσω σε νέο προϊόν stock καθώς το stock_availables δεν υποστηρίζει POST

    όπως και στο products το quantity δεν δουλέυει;

    Υπάρχει κάποια άλλη διαδικασία που να δουλεύει μέσω webservice api;

     

    Prestashop 1.7.2.4

  13. Όχι δεν έχει άλλα προφανώς κάτι κάνει και σκάει κατά τι διαδικασία σκέφτομαι ότι κάποιος χαρακτήρας το πειράζει

    Και δεν ανέφερα ότι πριν δούλευε κανονικά.

    Μια από τις δόκιμες ήταν ότι έκανα disable όλα εκτός του ονόματος  απενεργοποίησαν τα φίλτρα ούτε περιγραφές ούτε κατηγορίες ούτε τίποτα άλλο στο index

    Επίσης δεν είναι από τα τελευταία id είναι διάσπαρτα αυτά που λείπουν

  14. Καλημέρα

    Στην έκδοση 1.6.1.17 φαίνεται να έχει πρόβλημα κατά την δημιουργία του index καταλόγου.

    Μετά από ψάξιμο βρήκα ότι ενώ υπάρχουν οι λέξεις στο πίνακα ps_search_word, στο ps_search_index που συνδέει τη λέξη με το προϊόν δεν υπάρχει συνδεσμος αρα είναι στον αέρα.

    Προφανώς υπάρχει πρόβλημα κατά τη διαδικασία δημιουργίας του ευρετηρίου.

    Δεν έχει πρόβλημα με τα ελληνικά καθώς ορισμένες εγγραφές δουλεύουν και βλέπω και ελληνικά κανονικά στη βάση άλλα και στο site (για όσες λέξεις είναι σε αντιστοιχία στους πίνακες).

    Επισυνάπτω και από τη βάση PrintScrn.

    Εννοείτε έχω κάνει Clear Cash και truncate τους πίνακες και Rebuild Index ξανά.

     

    Το έχει αντιμετωπίσει κανείς;

    prestashop_search_problem.jpg

  15. Καλησπερα και απο μενα,

    αντιμετωπιζω κι εγω το ιδιο προβλημα μονο στην μεταφορα απο τον server πχ σε local . Αυτο που εκανα ειναι να κανω copy paste τα translations απο μια προηγουμενη εκδοση εγκατεστημενη στο local στο site που μετεφερα απο το server και δουλευει κανονικα. Δεν γραφει σε κανενα log εντομεταφυ που χτυπαει αλλα τεσπα. 

     

    Μια υποψία αν και δεν έχει σχέση άλλα δες κακού καλού

     

    Μήπως πρέπει να δηλώσεις μέσα στη βάση το όνομα το site

    πίνακας "_configuration"

    name "PS_SHOP_DOMAIN" kai "PS_SHOP_DOMAIN_SSL"

  16. Ευχαριστώ για τη βοήθεια παιδιά

    Ακολούθησα τα λεγόμενα του system_error86

    Και τελικά η συνταγή πέτυχε !

     

    υλικά:

    prestashop 1.6.1.8

    και  από εδώ το translation 1.6.0.11

     

    Εκτέλεση:

    μετά έκανα εγκατάσταση (Copy Paste) μόνο το αρχείο "\translations\el\admin.php" και δούλεψε.

  17. Να τα πάρουμε από την αρχή

    1. ανέβασα το αρχείο και το έκανα extract 
    2. έκανα το setup στα αγγλικά 
    3. τέλος setup  αφαίρεσα το install και όλα καλά
    4. μπήκα στο backend 
    5. έβαλα ελληνικά και το έκανα default 
    6. πέρασα προϊόντα κατηγορίες όλα ΟΚ όχι import
    7. κάποια στιγμή βγήκα (logout)
    8. όταν επέστρεψα να ξανά μπω στο login πρώτη παρατήρηση το κουμπί δεν έχει περιγραφή. Το πατάω αν και τα στοιχεία είναι σωστά δε μπαίνει απλά περιμένει και αν ανανεώσω τη σελίδα μου τα ξαναζητάει (εννοείτε έβαλα επίτηδες λάθος κωδικό και επιστρέφει μήνυμα λάθους )
  18. Πάντα έχω όλα τα στοιχεία του server βάση  site κλπ σε ασφαλή τοποθεσία 

    αν έχει πρόβλημα με το κωδικό μου το λέει άλλα δεν το πειράζει αυτό γιατί το δέχεται απλά δε προχωράει στο login

     

    Σε περίπτωση λάθους κωδικού βγάζει το παρακάτω 

    1. Ο υπάλληλος δεν υπάρχει, ή ο κωδικός πρόσβασης είναι λάθος. 
  19. όλα γενικά δουλεύουν ρολόι άλλα αν βάλω default τα Ελληνικά 

    κάνω logout και login 

    στο login βάζω mail και Pass 

    πατάω το κουμπί για να μπω στο backend και δε μπαίνει άπλα περιμένει στην εικόνα με τ πιγκουίνο 

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More