Jump to content

rachpat

Members
  • Posts

    36
  • Joined

  • Last visited

Everything posted by rachpat

  1. Ah, très bien ! Au fait, je ne sais plus faire pour rajouter [résolu] à cet échange... Sauriez-vous me dire comment modifier le titre ?
  2. en effet je vais laisser tout comme c'est ! j'avais peur que ne pas faire suivre le language php me provoque des problèmes à l'avenir, par exemple selon l'évolution des modules, qui eux se mettent à jour régulièrement... mais je vais donc rester en php 7.1 ! merci de vos conseils et bonne journée
  3. oups pardon si je me suis embrouillée dans les chiffres ? en fait je parlais de faire évoluer mon prestashop, de façon à ce qu'il fonctionne bien avec ma version php la plus récente, car j'ai bien accès à la version php 1.7.4 sur mon hébergeur (nuxit) mais j'ai des bugs dans prestashop lorsque je mets cette dernière version de php... et j'hésite à upgrader prestashop, de peur de perdre des paramétrages ou autre... c'est donc à ce propos que je vous sollicite pour des conseils... quel est la version prestashop la plus adéquate ? merci d'avance de votre aide
  4. Ahhh... Merci ! Voilà qui m'éclaire en effet ! Du coup j'enchaine sur une autre interrogation : y'a-t-il beaucoup de soucis à craindre si je passe de prestashop 1.7.4 à 1.7.8 ? Merci d'avance de vos conseils !
  5. Bonjour, j'utilise Prestahop 1.7.5.2, theme classic de base. Je me rend compte aujourd'hui que je n'ai plus accès aux traduction, j'ai un écran qui s'affiche telle la capture ci-jointe, impossible de cliquer nulle part... Pensez-vous que c'est lié à l''évolution en php 7.4 (j'ai passé dernièrement mon hébergement sur php 7.4.13) ou à tout autre réglage additionnel à faire ? Merci de votre aide et très bonne journée
  6. Merci de cette information, je n'étais pas au courant... Ce qui me chiffonne c'est qu'en affichant les frais de port avant la finalisation de la commande, il faut choisir un transporteur par défaut... Du coup il y a pas mal de chances pour que l'info des frais de port soit erronée ! et si je choisis le frais de port le plus avantageux (gratuit), c'est carrément de la fausse info limite arnaque... C'est pourquoi j'aimerais ne pas les afficher avant que le client ne renseigne son choix de transporteur, quitte à ce que s'affiche un petit message : "frais de port à rajouter"... Pensez-vous que techniquement ce soit jouables ? Merci d'avance pour les réponses, avis, commentaires !
  7. Bonjour, j'utilise Prestashop 1.7.5.2 et le thème classic. j'aimerais que les frais de port ne s'affichent qu'au moment de choisir le transporteur, quel(s) fichier(s) faut-il bidouiller pour éviter l'affichage des frais de port dans le panier en début de commande ? j'ai vu plusieurs échanges sur le sujet mais aucun dans ma version de prestashop du coup je n'y arrive pas ! merci d'avance de votre aide (je ne sais pas programmer mais je me débrouille bien avec des copié-collé !)
  8. Bonjour, Afficher le chiffre d'affaires chaque mois par groupe de clients, c'est exactement ce que je souhaiterais pouvoir faire... Voilà pourquoi je relance ce post 3 ans plus tard... pour savoir si vous aviez une piste pour un module identique compatible avec prestashop 1.7.5.2 ? Merci d'avance et très bonne journée !
  9. Merci de cette indication... Si vous avez un nom de module je suis preneuse, je n'ai pas trouvé de mon côté...
  10. Bonjour et merci de votre intérêt pour ma demande, votre copie d'écran correspond en effet à ma page produit du site en 1.7, et le résultat n'est pas satisfaisant dans le cas de produits ayant de nombreuses photos car au-delà de 5 images, il faut vraiment les chercher pour les voir : https://www.editionhuguet.com/livres-d-art/435-le-charnier-des-possibles.html tandis que dans le cas de mon site en 1.6 avec la fancybox, la série d'images défile comme dans un diaporama, c'est plutôt ce type d'affichage que j'aurais souhaité : https://www.berneluthier.fr/boutique/cordes-frottees/258-yayli-tanbur.html À voir si un tel affichage est prévu ou envisageable sur la version 1.7 ? Merci d'avance de votre aide et très bonne journée
  11. Bonjour, j'ai un site 1.6.1.24 et un autre site prestashop 1.7.5.2, j'utilise pour chacun le thème de base gratuit proposé par prestashop. Dans le site 1.6, dans les paramètres d'affichage des images du produit, j'ai le choix entre activer JqZoom ou utiliser Fancybox. J'utilise Fancybox qui me plait davantage. Dans le site 1.7, je ne trouve pas d'option pour activer fancybox et l'unique mode d'affichage proposé n'est pas très adapté pour des produits avec beaucoup d'images, je préfèrerais les voir affichées en fancybox... Y'a-t-il un réglage que je n'aurais pas trouvé ou une combine facile à mettre en place pour cela ? (Je n'ai pas trouvé de module qui propose cela sur les produits.) Merci d'avance pour vos pistes et très bonne journée !
  12. je me réponds à moi-même, si ça peut en aider d'autres ? je viens de comprendre que c'est le module "Ajouter un formulaire de contact" que j'ai installé récemment (car le module de contact de base ne fonctionnait plus...) qui est la cause de ce souci, dès que je le désactive la fancybox re-fonctionne ! résultat : je vais essayer de refaire fonctionner le module de contact de base... !
  13. Bonjour, pour information, mon 1er problème est résolu : l'affichage de la description du produit est à nouveau là sur ma facture pdf, super ! mode debug : en fait je suis allée fouillée le fichier ProductController.php ligne 258 et j'ai compris qu'il y avait peut-être un problème de signe dans les titres de certains produits accessoires... j'avais des nom avec des accents circonflexes, j'ai éliminé les accents, et je n'ai plus aucun message en mode debug, super ! en revanche, la fancybox ne fonctionne toujours pas... j'ai même essayé de revenir en php 5.6 mais c'est pareil... quelqu'un a-t-il le même problème : la fancybox qui ne fonctionne pas sur les pages produits, prestashop 1.6.1.24 ? merci de vos retours !
  14. Merci beaucoup de votre réponse rapide, voici les éléments demandés, merci d'avance pour la suite... J'y pense... pour info j'étais aussi passé au langage en php 7.3... 1) voici ce que j'avais fait pour avoir l'affichage de la description sur la facture pdf : - modification du fichier www/pdf/invoice.product-tab.tpl (en pièce jointe fichiers avant / après) - ajout du fichier www/override/classes/order/OrderInvoice.php (en pièce jointe) 2) en passant la boutique en mode debug sur une page produit avec problème sur la fancybox, voici le message que j'obtiens : Warning: Use of undefined constant MCRYPT_RIJNDAEL_128 - assumed 'MCRYPT_RIJNDAEL_128' (this will throw an Error in a future version of PHP) in /home/www/paty/berneluthier/boutique/classes/Rijndael.php on line 124 Deprecated: strpos(): Non-string needles will be interpreted as strings in the future. Use an explicit chr() call to preserve the current behavior in /home/www/paty/berneluthier/boutique/modules/sekeywords/sekeywords.php on line 89 Warning: count(): Parameter must be an array or an object that implements Countable in /home/www/paty/berneluthier/boutique/controllers/front/ProductController.php on line 254 OrderInvoice.php invoice.product-tab NON (sans description produit).tpl invoice.product-tab OK (avec description produit).tpl
  15. Bonjour, je suis récemment passée de prestashop .6.1.6 à 1.6.1.24 (j'utilise le thème classic par défaut), et depuis lors je remarque plusieurs choses qui ne fonctionnent plus, dont ces 2 que j'aimerais pouvoir résoudre : - la facture qui n'affiche plus la description du produit (j'avais modifié invoice.product-tab en conséquence mais désormais cette astuce ne marche plus...) - la fancybox qui ne fonctionne plus sur la page produit (cliquer sur une vignette ouvre la photo sur une page blanche... du coup en attendant j'ai coché JqZoom mais je préfère de loin la fancybox) J'ai fouillé sur le forum mais je n'ai rien trouvé sur ces 2 sujets. Avez-vous des routes à suivre pour résoudre ces 2 problèmes ? (je ne suis pas programmatrice mais je bidouille sans souci dans le code avec des copié-collés), merci d'avance pour votre aide !
  16. Bonjour, merci de votre intérêt pour ma question mais j'ai pu résoudre le problème en remplaçant $product.cover par $product.images[1] dans mes fichiers product-cover-thumbnails.tpl et product-images-modal.tpl. Merci et bonne soirée !
  17. Pour information (si certains suivent mon problème), têtue comme je suis dans et poursuivant la piste d'un problème chez l'hébergeur, j'ai provisoirement installé cette même boutique sur un hébergement que j'ai chez phpnet histoire de faire un test... et l'envoi des mails fonctionne parfaitement ! Résultat : j'ai lancé un ticket d'assistance chez online pour savoir s'ils peuvent faire quelque chose et sinon je serai obligée de déménager... Personne d'autre n'a eu la même expérience d'incompatibilité online/prestashop ? ou d'un réglage à faire sur le compte de l'hébergement ? à suivre...
  18. Bonjour et merci de la suggestion mais le réglage est bien : Utiliser la fonction mail() de PHP (recommandé ; fonctionne dans la majorité des cas) et j'ai fait un ticket d'assistance chez online qui m'a confirmé que la fonction mail() de PHP était bien activée chez eux... et "envoyer un e-mail test à ..." fonctionne... Toute autre idée est la bienvenue... (je me pose vraiment la question de la compatibilité avec online... ?)
  19. Bonjour, j’ai un problème dont j'ai trouvé trace dans de nombreux sujets mais après 2 journées dessus je sèche... c’est à propos des envois de mails depuis ma boutique prestashop… le test d’envoi mail fonctionne mais aucun mail ne part de la boutique dans le cas d’une commande, d’un changement d’état de commande, ou d’une création de compte… j’ai fouillé plein de discussions mais pour moi rien ne fonctionne, et suis perdue dans les paramètres, car : - j’ai une boutique prestashop 1.7.3.2 hébergée chez ovh : ça a fonctionné tout de suite, avec le module alertes par mail installé via le back office - j’ai une boutique prestashop 1.7.3.2 hébergée chez phpnet : ça a fonctionné tout de suite sans que je ne m’en préoccupe, et après vérification je vois que mailalerts n’apparait même pas dans les modules installés via le back office... - j’ai une boutique prestashop 1.7.5.2 hébergée chez online : ça ne fonctionne pas, alors que j’ai installé et activé le module mailalerts (et j’ai bien un dossier /www/themes/classic/mails/fr) Pensez-vous que le problème vient de la version de prestashop ? de l’hébergement ? de la version du module mailalerts … ? Merci de votre aide !
  20. Bonjour, je suis sur prestashop 1.7.5.2, hébergement online, et j'ai ce même problème : le test d'envoi mail fonctionne mais malgré l'installation du module emailalerts et la présence du dossier /www/themes/classic/mails/frmails (j'utilise le thème classic), aucun mail n'est envoyé lors d'une commande, ni au vendeur ni à l'acheteur, et aucun mail n'est généré lors d'un changement d'état, j'ai toujours ce message : une erreur est survenue lors de l'envoi de l'e-mail au client est-ce que ça peut être lié à online ? que me conseillez-vous ? merci de votre aide
  21. Merci merci beaucoup, c'est exactement ce que je cherchais, ça fonctionne parfaitement !
  22. Bonjour, Je cherche à ne pas afficher l'image de couverture dans la fiche produit, car j'ai fait des zooms pour mes images de couvertures mais je ne souhaite plus les voir affichés lorsqu'on ouvre la page du produit... Après des recherches dans le forum j'ai écrit sur ce sujet dans une discussion (en copie à la fin de ce post) mais je m'aperçois que la publication datait de 2008 alors je me dis que ce serait sûrement plus adapté d'écrire un nouveau sujet... Le sujet semblait résolu mais pour une version antérieure de prestashop mais j'utilise Prestashop 1.7.5.2 et le fichier /www/controllers/front/ProductController.php (si c'est bien celui-ci qu'il faut modifier) ne contient pas exactement le même code... Merci d'avance si vous avez des pistes, quel serait le fichier à modifier et quel morceau de code remplacer ? Très bonne journée !
  23. Bonjour, je cherche à faire la même chose mais dans prestashop 1.7.5.2... je vois à peu près dans quelle zone du fichier ProductController.php il faudrait agir mais n'étant pas programmatrice je ne sais faire que des copiés-collés... quelqu'un saurait-il me guider pour transformer l'affichage des images dans les fiches produits : ne pas y afficher l'image de couverture et dans le cas où il n'y a qu'1 image ne pas afficher les vignettes ? Merci pour votre aide
  24. Bonjour, j'ai le même problème sur prestashop 1.7.5.2 : comment faire disparaitre "ajouter au panier" si mon produit n'est pas accessible à la vente... J'utilise le thème par défaut, j'ai regardé mon fichier product.tpl au premier plan du thème "default", je trouve une référence à add_to_cart, ligne 443, mais je ne sais pas comment agir là-dessus (si c'est bien là qu'il faut faire quelque chose !) : {if (!$allow_oosp && $product->quantity <= 0) OR !$product->available_for_order OR (isset($restricted_country_mode) AND $restricted_country_mode) OR $PS_CATALOG_MODE} <span class="exclusive"> <span></span> {l s='Add to cart'} </span> {else} <p id="add_to_cart" class="buttons_bottom_block"> <span></span> <input type="submit" name="Submit" value="{l s='Add to cart'}" class="exclusive" /> </p> {/if} Merci de votre aide !
  25. Pour info, j'ai farfouillé, et j'ai découvert que mon dossier Themes était quasi vidé... J'ai remis la sauvegarde que j'en avais et tout est revenu... Je ne comprends pas ce qu'il s'est passé, une intrusion sur le site est-elle envisageable ? Merci si quelqu'un a déjà eu un cas semblable... En tout cas, me voici bien soulagée !
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More