Jump to content

Tchupa

Members
  • Posts

    646
  • Joined

  • Last visited

Everything posted by Tchupa

  1. Quand je mets "test" dans la condition else bah ça change rien test ne s'affiche pas j'ai toujours le fameux "aucune image disponible".
  2. Bonjour Franck, Donc j'ai testé ton dernier bout de code mais ça ne fonctionne toujours pas pour moi, on édite bien le fichier category.tpl ? {if isset($subcategories)} <!-- Subcategories --> <div id="subcategories"> <h3>{l s='Subcategories'}</h3> <ul class="inline_list"> {foreach from=$subcategories item=subcategory} <li> <a href="{$link->getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}" title="{$subcategory.name|escape:'htmlall':'UTF-8'}"> {if $subcategory.id_image} <img src="{$link->getCatImageLink($subcategory.link_rewrite, $subcategory.id_image, 'medium')}" alt="" width="{$mediumSize.width}" height="{$mediumSize.height}" /> {else} <div class="no_category_image"></div> {/if} </a> <a href="{$link->getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}">{$subcategory.name|escape:'htmlall':'UTF-8'}</a> </li> {/foreach} </ul> <br class="clear"/> </div> {/if} Et pour le fichier css: category.css /* category.tpl */ body#category #subcategories li { height: 136px; width: 108px; margin-right: 3px } div.cat_desc { margin: 0 1em } body#category div#subcategories .inline_list a img { display: inline } #category img#categoryImage { margin-top: 1em } #subcategories ul li a { display: block } body #category div#subcategories .no_category_image{ display:block; width:90%; height:100px; margin: 5px auto; padding:5px; background:#ffa800;} J'ai merdé?
  3. Effectivement ce n'est pas réellement une image mais c'est tout comme au niveau de la présentation: D'ailleur dans mon category.tpl <a href="{$link->getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}" title="{$subcategory.name|escape:'htmlall':'UTF-8'}"> {if $subcategory.id_image} <img src="{$link->getCatImageLink($subcategory.link_rewrite, $subcategory.id_image, 'medium')}" alt="" width="{$mediumSize.width}" height="{$mediumSize.height}" /> {else} <img src="{$img_cat_dir}default-medium.jpg" alt="" width="{$mediumSize.width}" height="{$mediumSize.height}" /> {/if} </a> Par contre ma condition ne doit pas être correct car ça fonctionne pas <div id="subcategories"> <h3>{l s='Subcategories'}</h3> <ul class="inline_list"> {foreach from=$subcategories item=subcategory} <li> <a href="{$link->getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}" title="{$subcategory.name|escape:'htmlall':'UTF-8'}"> {if $subcategory.id_image} <img src="{$link->getCatImageLink($subcategory.link_rewrite, $subcategory.id_image, 'medium')}" alt="" width="{$mediumSize.width}" height="{$mediumSize.height}" /> </a> <a href="{$link->getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}">{$subcategory.name|escape:'htmlall':'UTF-8'}</a> {else} <div class="no_category_image"><a href="{$link->getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}">{$subcategory.name|escape:'htmlall':'UTF-8'}</a></div> {/if} </li> {/foreach} </ul> <br class="clear"/> </div>
  4. Bonsoir, je vais tester tout ça Franck je te remercie. Quand je parle de no image c'est l'image générique que prestashop met quand tu ne mets pas d'image. Cordialement.
  5. Bonjour, quand on crée une catégorie, dans celle-ci tu mets une image ou pas , mais si tu ne mets pas d'image tu te retrouve avec "no image" a la place. Mon but sur certaine catégorie et sous catégorie et uniquement sur celle-ci, je voudrais qu'a la place du no-image par exemple on voit un cadre avec une couleur de fond et le nom de la catégorie dans celui-ci? Tu comprends ou non là ou je veux en venir?
  6. Bonjour, je voudrais remplacer les images de certaines catégories et sous catégories par du CSS, j'aurais aimer savoir si dans un premier c'est possible. Et si c'est le cas , comment s'y prendre? En gros c'est pour m'éviter de créer des images spécifiques sur certaine de mes catégories et sous-catégories afin d'obtenir un gain de temps énorme dans le développement du contenu de ma boutique en ligne. En vous remerciant. Cordialement Tchupa.
  7. Bonjour, je rencontre actuellement un petit soucis avec ce module, je possède la version donateur 1.4.3 quand je désire mettre une vente flash, promotion,solde ou prix coutant a partir de l'onglet "catégorie" du module, je coche bien les catégories que je désire et ensuite je descend je mets la remise en %, et les dates de mon choix et je valide. Sa me dit bien que les changements ont été pris en compte mais quand je vais du coté FO rien n'a bougé aucune promo, ni vente flash, par contre si je le fais dans les onglets "flash", "promotion" pour un article individuel par exemple là ça fonctionne correctement. Auriez vous une idée.? En vous remerciant. Cordialement.
  8. Bonsoir, je comprends pas pourquoi il a déplacé le post dans développement car il y a logiquement une fonction quelque part dans prestashop qui permet de ne pas afficher les frais de port directement dans le panier mais uniquement a l'étape frais de port dans le tunnel de commande mais je retrouve pas ou ça se trouve dans le BO
  9. Personne n'a jamais eut ce problème? Y'a t-il des personnes qui utilise la géolocalisation?
  10. Quelqu'un peut-il m'éclairer sur le fonctionnement des logs de prestashop, car j'ai des alertes mais pas de log donc c'est plutôt difficile de mettre le doigt sur le problème en question. Merci.
  11. Bonjour, tu vas dans ton BO -> préférence -> produits et là tu coche la case "non" a la ligne "Afficher les quantités disponibles sur la page produit" Tchupa.
  12. Bonjour, je ne suis pas sur que se soit réellement faisable en natif, si il offre les frais de port a partir d'un certain montant ou quelque soit celui-ci , tu cré un transporteur générique et il précise dans ses cvg qu'il est libre de choisir le transporteur et ensuite bah quand il expédie il l'envoi via le transporteur qu'il veut. Tchupa.
  13. Soit effectivement, il y du duplicate content, un manque de nouveauté concernant le contenu ou simplement le pinguin qui a encore frappé !!!
  14. Alors pour info j'ai trouvé une solution alternative: <a href="{$base_dir}content/ma_page_cms?content_only=1" class="iframe">mon image</a> Là ça fonctionne par contre y'a toujours le footer dedans vu qu'il est en dur dans mon thème je ne sais pas comment faire pour qu'il apparait dans la fancybox. De même je voudrais que celle-ci s'adapte a la largeur du contenu en question auriez vous une solution ? En vous remerciant. Cordialement .
  15. Bonjour a tous, voilà je rencontre depuis ce matin un petit soucis d'ordre technique, sur certaine de mes pages produits je voudrais afficher un lien qui ouvre une fancybox , jusque là aucun problème. Le contenu de cette fameuse fancybox est le contenu d'une page cms de ma boutique, seulement je n'arrive pas a afficher uniquement le contenu il m'affiche la totalité de la page c'est a dire design inclut !!!! Voilà le lien vers le contenu que j'ai placé dans mon product.tpl <a href="{$base_dir}cms.php?id_cms=8&content_only=1" class="iframe">mon image</a> en fait il prend pas en compte le "content_only=1" surement du a la ré écriture d'url non ? Si quelqu'un a une solution je suis prenneur , en vous remerciant. cordialement Tchupa.
  16. Bonjour, je ne trouve pas de réponse a mon problème j'ai tenter de faire une recherche dans le bug tracker mais je ne trouve rien a ce sujet. Quelqu'un pourrait -il me venir en aide? Merci.
  17. Bonjour, je rencontre actuellement un petit soucis, en effet prestashop m'envoi des alertes de log, mais quand je consulte le fichier de log il est totalement vide . Quelqu'un connaitrez la raison du vide en question dans le fichier /log/log.txt ??? En vous remerciant. Cordialement Tchupa.
  18. Bonjour, personne n'a rencontré ce problème jusqu'a maintenant? Merci. Tchupa.
  19. Bonjour, afin de filtrer les visiteurs sur mon site car beaucoup de robot russe et j'en passe scan a tout va pour rien, j'ai voulu mettre en place la géolocalisation. Une fois activé , le filtre fonctionnait correctement. Par contre j'ai voulu rajouter un article et c'est là que le problème intervient. En effet lorsque la géolocalisation est activée quand je mets un prix dans le champ prix TTC celui-ci est le même dans la case HT et si vous enregistrez la fiche article une fois du coté FO on se rend compte qu'il a encore rajouté 19,6% au prix indiqué dans la case prix TTC du BO . Quelqu'un a t-il déjà rencontré ce genre de problème? En vous remerciant. Cordialement Tchupa.
  20. bonjour, ça me parait assez complexe, il y a beaucoup de différence entre les fichiers en question et comme je suis très loin de maitrise l'ajax je pense pas que je vais pouvoir remettre cette fonctionnalité en service
  21. Bonsoir, tu peux être plus précis stp? Merci. Tchupa.
  22. Bonjour, je voudrais savoir si quelqu'un a déjà rencontrer des problèmes avec ce module et la fonction de sauvegarde du panier qui est natif dans prestashop ? car une fois le module cart prenium installé et cette fonction activé, lorsqu'on ajoute un un produit dans le panier il va bien dedans par contre si on clique sur voir commander ou voir mon panier il est vide donc impossible de commander quoi que se soit !!!!! Tchupa.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More