Jump to content

klifer

Members
  • Posts

    10
  • Joined

  • Last visited

1 Follower

Profile Information

  • First Name
    Roman
  • Last Name
    K

klifer's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. zobacz czy to nie jest to co u mnie: https://www.prestashop.com/forums/topic/600457-smtp-test-dzia%C5%82a-a-produkcja-nie/ pozdr
  2. OK, znalazłem rozwiązanie problemu.. PS trzyma hasło w tabeli ps_configuration select * from ps_configuration where name = 'PS_MAIL_PASSWD'; okazało się, że PS wrzucił w to pole hasełko admina sklepu (!) i w żaden sposób przez panel administracyjny sklepu tego nie można było zmienić. Dlatego wpisywane hasło w module testowym działało, a już w normalnej pracy nie. wystarczyło: update ps_configuration set value = "właściwe_hasło_SMTP" where name = "PS_MAIL_PASSWD"; Pozdrawiam i dziękuję
  3. Hasło jest dość złożone, wieloznakowe. Jeżeli byłoby to związane z odrzucanym uwierzytelnianiem po stronie serwera SMTP, to dlaczego testowe mejle działają? Jeżeli ustawię Gmail jako SMTP to dokładnie takie samo zachowanie (test przechodzi, mejle z workflow sklepu nie działają), a w logach to samo... pozdr
  4. Przepraszam, chyba się nie zrozumieliśmy oczywiście w konfiguracji nie jest to adres [email protected] a inny realny, który zastąpiłem takim przykładowym. W konfiguracji we wszystkich miejscach podany jest pełny, działający adres email. thx
  5. Dzięki za odzew... tak skonfigurowałem dla tego samego adresu. Kontakt sklepu, email użytkownika wszędzie jest ten sam.
  6. OK, już powoli tracę nadzieję Konfiguracja SMTP, niby rzecz oczywista i prosta, podstawowa funkcjonalność sklepu -nie działa. Nie dziwiłbym się gdyby był to jakiś egzotyczny system, wersja web serwera lub inna niestandardowa konfiguracja środowiska, ale nie ... system nowo postawiony, wszystko z paczek, świeża instalacja PS i .. zima Do rzeczy: Problem polega na braku możliwości wysyłania poczty via serwer SMTP (hosting własnej domeny na ZOHO.com). Konfiguracja TLS, test przez moduł konfiguracji SMTP działa bez problemu. Testowo robię zakupy i ponawiam wysłanie mejla do klienta (przez moduł Zamówienia). Wtedy nie działa i widzę w logu PS: Swift Error: Failed to authenticate on SMTP server with username \"[email protected]\" using 2 possible authenticators Nie pomaga zmiana PS na inną wersję (próbowałem 1.7.0.6 i 1.6.1.11 - tę mam obecnie). Nie pomaga zmiana rodzaju połączenia na SSL. Nie pomaga zmiana wersji językowej. PrestaShop version: 1.6.1.11 Current theme in use: default-bootstrap Server information: Linux #88-Ubuntu SMP Wed Mar 8 16:34:45 UTC 2017 x86_64 Server software version: Apache PHP version: 7.0.15-0ubuntu0.16.04.4 MySQL version: 5.7.17-0ubuntu0.16.04.1 MySQL server: localhost Mail method: You are using your own SMTP parameters. SMTP server: smtp.zoho.com SMTP username: Defined SMTP password: Defined Encryption: tls SMTP port: 587 Dziękuję za wsparcie
  7. Hi, thank you for the hint. Unfortunately it doesn't work I downgraded PS to 1.6.1.11 no difference. The same with other SMTP servers (like i.e. Gmail) Klifer
  8. Hey, I just installed a new PS and have a problem with SMTP: SMTP - is configured well and test mail going thru with success result. Anyway workflow mails (for example confirmation for the customer) returns an error like: Swift Error: Failed to authenticate on SMTP server with username \"[email protected]\" using 2 possible authenticators Im using ZOHO mail service. Installation type (new/update): new PrestaShop version: 1.7.0.6 Theme (default/customized): default Classic Code (original/modified): org PHP version: 7.0.15-0ubuntu0.16.04.4 MySQL version: 5.7.17-0ubuntu0.16.04.1 Do you have any ideas? thx Klifer
  9. Hej, podbijam .. mam to samo po włączeniu mod_rewrite i zmianie na Przyjazny adres URL . AllowOverride All, .htaccess włączone. Ktoś coś? thx
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More