Jump to content

ArthurCGN

Members
  • Posts

    31
  • Joined

  • Last visited

Posts posted by ArthurCGN

  1. Hallo @Shad86!


    Vielen Dank für den Tipp mit dem Modul contenbox.org von Miguel Costa - genial und das gratis (Da sollte man wirklich Spenden).
    Habe nur etwas gebraucht, bis ich den Ablauf der Installation richtig verstanden habe:


    1. Modul ContenBox erstellen, als ZIP-Datei herunterladen
    2. Modul ContentBox (ZIP-Datei) als Modul in Prestaschop installieren
    3. Unter Design/Position/Hook namens displayAfterHeader suchen, dann bearbeiten klicken
    4. Dort a) das Modul ContentBox auswählen und b) unter "Übertragen zu:" den Hook displayAfterHeader auswählen und speichern

    Hat prima geklappt! Eine tolle Lösung, solange es nur das gratis Google Analytics Modul für Tracking IDs aber kein gratis Modul für Google Analytics 4-properties für  Mess-IDs gibt.

    Gruß aus Köln
    Arthur

  2. PS 1.7.6.5 auf der index-Seite konnte ich 19 Meta-Suchworte eintragen, beim 20. erhielt ich diese Fehlermeldung:


    "Ein unerwarteter Fehler ist aufgetreten. [PrestaShop\PrestaShop\Core\Domain\Meta\Exception\CannotEditMetaException Code 0]"

    Das ist doch wahrscheinlich ein Bug, denn Meta-Suchwortlisten sollten doch gestatten mehr als 20 Suchworte zu definieren.
    Hat jemand einen Tipp, wie man mehr Suchworte hinterlegen könnte?

    Gruß aus Köln
    Arthur

  3. Um den Seitenaufbau schneller zu gestalten wird empfohlen den PS-Cash zu aktivieren.
    Dazu muß man jedoch auf dem Webserver ein entsprechende Erweiterung installieren.

    Bei meinem iSP ist bereits memcashed via PHP installiert und der freundliche Kundendienst gab mir die entsprechende IP-Adr. und Port-Nr.
    Beides versuchte ich nun bei Prestashop im Cash-Bereich mit der Funktion Server hinzufügen abzuspeichern, bzw. zunächst zu testen.

    Meine PHP-V. ist übrigens PHP 7.2.26
    cash.jpg

    In der ersten Zeile ist der Auswahl-Punkt vor Memcashed via PHP vorausgewählt aber grau - sollte er nicht schwarz sein?
    Einen anderen Auswahlpunkt kann ich gar nicht anklicken. Klicke ich auf die Taste Server testen o. Speichern passiert gar nichts.

    Hat vielleicht jemand eine Idee, was jetzt helfen würde?
    Gruß aus Köln

    Arthur

  4. Folgende eMail-Ordner habe ich:

    a) Hauptordner:      /mail
    b) Theme-Ordner: /themes/classic/de/mail

    Diese eMail-Ordner haben lediglich html u. 3 tpl-Dateien aber keine php-Dateien.

    Einen weiteren eMail-Ordner fand ich im Modul
    /ps_mailalerts"
    Direkt im ps_mailalerts-Ordner sind auch php-Dateien:
    emailalerts.jpg

    Und ich sollte nun alle diese php-Dateien wohin kopieren?

  5. @JBW

    Vielen Dank für die Info.
    Nachdem ich nun Prestashop 1.7.6.5 nutze haben sich die eMail-Versandproblem nur noch auf die eMails die bei neuen Bestellungen an den Admin versandt werden reduziert:
    emailbenachrichtigung.jpg

    Verstehe nicht, wie es zu dem Fehler kommt. Offenbar erhält das Template keine Daten über PHP eingespielt.
    Weiß jemand, was man tun sollte?
     

  6. Sendcloud-Problem gelöst:

    Nachdem ich 3 Wochen lang versuchte das Sendcloud-Modul zu benutzen, viel Sendcloud auf, daß die Verbindungsproblem nichts mit Prestashop zu tun hatten!
    Der Fehler liegt bei Sendcloud!


    Just in der gleichen Zeit meiner Installation hat Sendcloud die Registrierungs-Routine geändert. Es war nun nötig die Bankdaten für eine Test-Anbindung bei Sendcloud zu hinterlegen, anderweitig war eine Modul-Verbindung von Prestashop zum Sendcloud-Server nicht möglich.


    Sendcloud hat sich ohne Kompensation für die Wochenlange Zeitverschwendung entschuldigt.

  7. @Claudiocool
    Vielen Dank für die Info.
    Versuche gerade zu verstehen von wo nach wo ich das fehlende PHP kopieren könnte :)

    Was meinst Du genau mit "...dem Mailverzeichnis..." und was meinst Du mit "...dem normalen Mailverzeichnis..."?

    Im ich sehe 2 Order, die Mail heißen. Der eine liegt im Hauptverzeichnis des Web-Server/mail und das andere im Template-Verzeichnis "Web-Server/Theme/Classic/mail", jedoch sehe ich in beiden Mail-Ordnern keine PHP-Datei.

    Die Bestätigungs-eMails an den Kunden zeigen aber trotzdem alle Kunden- u. Produkt-Daten korrekt an.

  8. Hallo,

    I use the standard theme CLASSIC and all eMails addresst to the customer work fine and show data.
    When I check out the admin-addressed eMail-order alert, I receive it without data:

    emailbenachrichtigung.jpg

    I checked the country-file in the main directory at "mail/de" and realized the missing topl-files:

    download-product.tpl       order_conf_cart_rules.tpl      order_conf_product_list.tpl

    But after copying those from the file "mail/en" and emptying the template-cash the problem was not solved.
    Than I checkt the theme-file "theme/Classic/mail/de" and did not see those tpl files too but copied and pasted them there.

    This was not the breake through :(

    Does anyone see a way how to solve this problem?

    Kind Regards

    Arthur
     

  9. Hallo,

    die Kunden-eMails nach Registrierung und Bestellung kommen korrekt mit Daten beim Kunden an.
    Leider war die Funktion eMail-Versand bei Bestellungseingang an Admin in Prestashop 1.7.6.5 standardmäßig deaktiviert.

    Nachdem ich die Funktion im Backoffice gefunden u. aktiviert hatte, kamen tatsächlich auch Bestellinfo-eMails beim Admin an, jedoch ohne Daten! Es sind nur die Platzhalter-Variablen in geschweiften Klammern zu sehen:

    emailbenachrichtigung.jpg
    Im Ordner "mail" des Hauptverzeichnisses befindet sich standardmäßig nur die Version de, also mail/de/.
    Erst wenn Deutsch im Backoffice als Sprache aktiviert wurde (vermutlich) bei der Installation, wird ein zweiter Ordner de/ angelegt.
    Jedenfalls existiert im entpackten Shop vor dem Server-Hochladen nur die Sprachversion en/.

    Testhalber habe ich im Ordner mail den jetzigen de-Ordner deaktiviert und einen neuen Ordner /de angelegt und den Inhalt des /en-Ordners kopiert und eingefügt. Das Ergebnis war erneut eine Admin-Bestell-Info per eMail ohne Daten...

    Auch habe ich die fehlenden 3 Dateien aus dem Ordner "mail/en" in den Ordner "mail/de" kopiert:

    download-product.tpl       order_conf_cart_rules.tpl      order_conf_product_list.tpl

    Meinen Prestashop-Cash konnte ich im Backend nicht leeren, da ich ihn gar nicht aktiviert habe. Aber auch das Kopieren der drei fehlenden Dateien brachte keine Problemlösung.

    Verstehe gar nicht, daß so eine einfache aber wichtige Funktion auch nach diversen Shop-Versionen noch immer so problematisch ist.

    Die Größe der Ordner mail/de u. mail/en ist übrigens nicht identisch.
    Ich nutze das Standard-Theme "Classic"

    Im Theme-Ordner "Classic/mail/de" haben die o.g. 3 tpl-Dateien ebenfalls gefehlt aber nach dem hineinkopieren ergab auch das keine Lösung des beschriebenen Problems.

    Leider konnte ich im Forum keine ähnliche Problematik finden. 
    Für jegliche Hilfe schon jetzt vielen Dank!

    Gruß aus Köln
    Arthur

  10. Nach der Registrierung eines Test-Kunden stellte ich fest, daß das System 2 eMails verschickt:

    1. Notifying of register: NACHRICHT VON EINEM KUNDEN AUS  ... ONLINESHOP - Danke, dass Sie über unseren Shop registrieren: Wir empfangen wurden Ihrem Konto Anfrage. Allerdings müssen Sie Ihr Konto von einem Administrator überprüft werden.

    Dieses eMail kann man in den Übersetzungen unter Übersetzungen/eMails/idxvalidatinguser/validating

    2. Willkommen...

    Das 2. eMail ist völlig in Ordnung, jedoch würde ich gerne die Betreff-Zeile ändern. Wo finde ich sie? 
    Das eMail Nr. 1. lässt sich nicht über das Modul "Überprüfte Registrierung Deluxe" ändern, es scheint auch vom Shop direkt zu kommen aber ich finde es leider nicht. Könnte man dieses eMail ggf. deaktivieren?

    Hat jemand eine Lösung?

    Gruß aus Köln

    Arthur

  11. Hallo Claudiocool,

    vielen Dank für Deine schnelle Antwort aber ich konnte nicht glauben, daß man dafür in Prestashops Templates was löschen sollte.

    Um den Footer-Link "SHOPS" zu entfernen habe ich einen nettes Tutorial hier gefunden:
    https://medium.com/@buyaddons.com/prestashop-help-how-to-edit-footer-blocks-of-classic-theme-in-prestashop-1-7-default-theme-a10e53baf352

    Also besser über das Backend im Modul-Manager nach "Linkliste" suchen, dann auf Bearbeiten und auf Unternehmen klicken und bei SHOPS den Haken herausnehmen u. speichern.

  12. Wie man in PS v 1.7.6.5 die Links aus der Fußzeile über DESIGN/SEITEN/Seiten in Kategorie Startseite bearbeiten kann habe ich herausgefunden.
    Aus mir unersichtlichen Gründen, fehlt dort aber der Bereich SHOPS als Seite.
    Den Link SHOPS kann man über den Menüpunkt SHOP-EINSTELLUNGEN/KONTAKT/SHOPS zwar bearbeiten aber nicht deaktivieren oder löschen. 

    Vielleicht habe ich ja Tomaten auf den Augen aber wie man den Link SHOPS löschen kann erschließt sich mir leider nicht.

    Kann mir jemand einen Tipp geben?
    Gruß aus Köln

    Arthur

  13. Hallo,

    versuche vergeblich mein Sendcloud-Modul mit meinem Sendcloud-Kto. zu verbinden.

    Der Shop 1.7.6.5 installiert unter PHP v 7.2. funktioniert aber sobald ich auf die Taste "Mit Sendcloud verbinden" klicke kann ich mich zwar mit den Sendcloud Zugangsdaten in meinem Sendcloud-Kto. anmelden, jedoch sehe ich dort, daß ich nicht verbunden bin und keine Bestellungen importiert werden konnten.

    Ein Testnutzer wurde angelegt, eine Testbestellung wurde getätigt, ein DPD-Lieferant wurde angelegt, samt Preisspannen nach Umsatz.

    In den Prestashop Logs steht ein rein informativer Hinweis "Module sendcloud has no vendor folder" was immer das auch heißen soll.
    Das Sendcloud-Modul wurde auch schon gelöscht, neu installiert sowie reseted - nicht war erfolgreich.

    Ich habe einen zweiten Prestashop ohne zusätzliche Module installiert, lediglich das Sendcloud-Modul wurde heruntergeladen u. installiert aber der Fehler bleibt. 

    Der Shop läuft mit SSL und das auf allen Seiten via ALFAHOSTING. 
    Der Sendcloud-Support konnte bisher keine Lösung finden. Ich verstehe nicht, daß ich der einzige Nutzer bin, der dieses Problem hat.

    Weiß jemand Rat?

    Gruß aus Köln

    Arthur

     

  14. So:
    - habe den alten Shop und DB gelöscht und ihn neu aufgesetzt.
    Mit Schrecken habe ich festgestellt, daß er wieder unter der PHP v 7.3 installiert wurde, obwohl ich tags zuvor mit Hilfe meines Hosters den Ordner auf die PHP v 7.2 einstellen ließ.

    Der Shop v1.7.6.4 funktioniert trotzdem einwandfrei, auch der Fehlerhinweis  "Aktivieren Sie die PHP-Funktion fopen() auf Ihrem Server" wird nun nicht mehr angezeigt.

    Der vorher fehlerhafte eMail-Daten-Versand aller autom. verschickten eMails, wie Kd.-Kto.-Bestätigung, Bestellung und Zahlungshinweis wird nun korrekt mit Daten befüllt durchgeführt.

    Der einzige Fehler, der mir derzeit auffällt ist, daß das Modul SENDCLOUD sich bei meiner neuen Shop-Installation nicht mit SENDCLOUD verbindet und keine Bestellungen an SENDCLOUD weiterleitet. In SENDCLOUD wird kein Connect-Log angezeigt, da auch nach mehrfachem Modulneuinstallation keine Verbindung mit Prestashop zustande kommt.
    Heute ist Sonntag, werde am Montag Sendcloud kontakten...

    Langsam wird mir Prestashop unheimlich, da bei jeder Installation, Version und nachinstallierten Modulen neues Fehlverhalten zu Tage tritt.
    Hier ein vielleicht nützlicher Link von professionellen Anwendern zum PS-PHP Versionsverhalten

  15. Hi JBW,

    entschuldige, bei der PHP-Version habe ich mich vertan.
    Meine Shop-Installation v 1.7.6.4 und der Fehler beim eMail-Versand wurde nicht unter der PHP v5.6, sondern unter PHP v7.3 installiert.
    In den Servereinstellung wurde zwar die PHP v 5.6. angezeigt aber von einer htaccess im Installations-Ordner wieder auf PHP v7.3. hochgestuft.

    Durch Zufall fand ich noch die Einstellmöglichkeit der eMail-Themes im Backend, wo man zwischen Theme CLASSIC u. MODERN wählen kann. 
    Beide eMail-Themes kann man testen und seltsamerweise taucht der oben beschriebene Fehler da nicht auf.
    In dieser Test-eMail wird mein Name aus dem Superadmin-Kto. gezogen und bei Adr. u. Lieferanschrift die Daten aus dem Test-Kundenkonto - da funktioniert der eMail-Versand plötzlich, nur eben nicht automatisch bei Bestellungen und Kundenkonto-Registrierungen.


    Ich habe nun auf PHP v7.2 umgestellt aber die autom. Bestätigungs-eMails kommt trotzdem ohne Daten, nur mit Variablen/Platzhaltern an.
    Der im Backend angezeigte Fehler "Aktivieren Sie die PHP-Funktion fopen() auf Ihrem Server" wird nun nicht mehr angezeigt.

    Ich vermute, daß durch die Installation und das anschließende Upgrade auf PS v 1.7.6.4 unter der falschen PHP-Version 7.3 den eMail-Fehler verursacht hat.
    Um Zeit zu sparen, werde ich den Shop löschen und neu installieren :)

  16. Bei Kundenregistrierungen u. Bestellungen werden automatische eMails über das eMail-Modul MODERN versandt.
    Der Versand funktioniert auch, jedoch werden in allen eMails statt der Daten wie Produkt, Preis, Kunden-Name usw. nur die Platzhalter angezeigt.

    Meine aktuelle Version ist 1.7.6.4. nach erfolgtem upgrade der Vorversion. Einen Testkunden und eine Testbestellung habe ich erst nach dem Upgrade angelegt und getätigt.
    Ich weiß also nicht, ob die Vorversion schon den Fehler hatte.

    Die Shop-Installation der Vorversion von PS und das Upgrade auf die PS v 1.7.6.4 erfolgte unter PHP v 7.3.
    Folgende Fehler werden im Backend von PS angezeigt:

    - Aktivieren Sie die PHP-Funktion fopen() auf Ihrem Server.

    Hat jemand einen Tipp ob die o.g. Fehler relevant für die Datenübergabe an die auto.-eMails sind bzw. warum die eMail nicht mit Bestell- u. Kundendaten befüllt sind?
    Hoffe es ist nicht beim upgrade etwas schief gegangen und ich hoffe ich muß den Shop nicht erneut installieren.

    Für einen Tipp wäre ich sehr dankbar.
    Gruß Arthur

  17. After installing PS 1.7.6.4. successfuly I placed an test order.
    I found out that the account automated confirmation eMail "Welcome..." was sent after the first page of the registration procedure, not at the last.
    Reading the confirmation eMail I was surprised to miss all customer-data, the eMail showed just placeholders:

    Hallo {firstname} {lastname},

    This happened also with the order confirmation eMail :(
    What went wrong or what do I need to make the costomer eMails work correctly?

    Kind Regards

    Arthur

  18. Hallo,

    habe die PS Version 1.7.5.1 installiert und konfiguriere gerade das Shopsystem.
    Im vorinstallierten Modul KUNDENVORTEIL habe ich die Datenschutzrichtlinien als Text speichern wollen. 
    Leider sagt das System: Beim Speichervorgang ist ein Fehler aufgetreten. Die Modulversion ist 3.0.2 und auf dem aktuellen Stand.
    Wieso passiert das? Wie kann man das Modul zum Laufen bringen?

    Gruß aus Köln

    Arthur

     

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More