Jump to content

HAIRWEBSHOP

Members
  • Posts

    248
  • Joined

  • Last visited

Everything posted by HAIRWEBSHOP

  1. Hello, I noticed that some of the meta data is displayed incorrectly. The SEO title for our webshop is : HAIRWEBSHOP.NL - De Grootste Webshop Voor Uw Haar Google displays it as: HAIRWEBSHOP.NL - De Grootste Webshop Voor Uw Haar - HAIRWEBSHOP.NL So as you can see, it adds another HAIRWEBSHOP.NL right after it. How can I disable this? Thank you in advance!
  2. Great module, thank you. I'm looking to modify it so that it includes the price class and is able to be divided into the default bootstrap theme tabs. Can someone please help me find a way to do so? Thank you in advance!
  3. Hello rocky, and thank you kindly for your reply. Your solution worked perfectly, thank you!
  4. Hello, We want to add Google Translate code to our theme's header.tpl nav class, but for some reason it will result into an error. Can someone please help us figure out what's going on? We're not interested in using modules btw. Thank you in advance! Fatal error: Uncaught --> Smarty Compiler: Syntax error in template "/htdocs/www/themes/default-bootstrap/header.tpl" on line 102 "new google.translate.TranslateElement({pageLanguage: 'nl', includedLanguages: 'de,en,fr,nl', layout: google.translate.TranslateElement.InlineLayout.SIMPLE, gaTrack: true, gaId: 'xxx'}, 'google_translate_element');" - Unexpected ": ", expected one of: "}" <-- thrown in/home/htdocs/www/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 102
  5. Hello, Customers are not seeing random products in the front page tabs due to caching. Is there a way to exclude products in the products tabs on the frontpage from cache? Thank you in advance!
  6. Hello vekia, and thank you kindly for your reply. I called our webhost, and they told me that the problem lies with Prestashop. Shortly after, everything worked without changing anything.
  7. It's working again, how convenient , but I would still like to know what may have caused this nonetheless.
  8. Hello, Suddenly our webshop is down and it gives us the following error. We did not add, change or updated any of the cole files, modules, themes or .htaccess. Fatal error: Uncaught Error: Call to undefined method Shop::getContextListShopID() in pathtoroot/htdocs/www/classes/module/Module.php:2139 Stack trace: #0 pathtoroot/htdocs/www/classes/Hook.php(495): ModuleCore::getExceptionsStatic('1', '10') #1 pathtoroot/htdocs/www/classes/controller/FrontController.php(579): HookCore::exec('displayHeader') #2 pathtoroot/htdocs/www/controllers/front/IndexController.php(37): FrontControllerCore->initContent() #3 pathtoroot/htdocs/www/classes/controller/Controller.php(189): IndexControllerCore->initContent() #4 pathtoroot/htdocs/www/classes/Dispatcher.php(367): ControllerCore->run() #5 pathtoroot/htdocs/www/index.php(28): DispatcherCore->dispatch() #6 {main} thrown in pathtoroot/htdocs/www/classes/module/Module.php on line 2139 Can someone please help me figure this out as soon as possible? Thank you in advance!
  9. Hello, When I add flags to .htaccess, for some reason prestashop rewrites the file and discard the changes. Why is this, and how do I prevent this from happening? Thank you in advance!
  10. Thank you kindly for your reply, vekia and selectshop.at! @vekia, we cache using file system and varnish cache. @selectshop.at, I've read about the statistics, we find them useful, but we also use Google Analytics so deleting them would not hurt I guess. Some users report having some problems running the module, and I can't seem to download it from the forum.
  11. Hello, Our database is getting quite large fast, and I'm concerned that it may outgrow our 250mb limit. Does someone know what may be the cause and what we can do to prevent it from getting too large? We're using the latest prestashop with the default theme and modudles. Thank you in advance!
  12. Found a solution myself. Add the following snippet to blocktopmenu.js that can be found inside /themes/default-bootstrap/js/modules/blocktopmenu/js $(document).ready(function(){ $('#block_top_menu li').each(function(index){ $(this).attr('class', 'menuItem_' + index); }); }); Now that every menu item as its own class, add the following CSS to your custom stylesheet: .menuItem_1 ul { -webkit-column-count: 5; -moz-column-count: 5; column-count: 5; } .menuItem_1 li { float: none !important; width: auto !important; } @media (max-width: 767px) { .menuItem_1 ul { -webkit-column-count: 2; -moz-column-count: 2; column-count: 2; } .menuItem_1 li { float: none !important; width: auto !important; } } @media (max-width: 479px) { .menuItem_1 ul { -webkit-column-count: 1; -moz-column-count: 1; column-count: 1; } .menuItem_1 li { float: none !important; width: auto !important; } } Make sure to edit the class to match your menu item's class. This will vertically output manufacturers in alphabetical order. Clear all caches afterwards.
  13. Hello tuk66 and ndiaga, and thank you kindly for your reply! I did not install any module, nor have I made any changes in configuration. I was just adding new products, and suddenly uploading an imaged failed and shortly after, this error popped up. This was due to PS_MODE_DEV set to true, setting it to false resulted in an empty front office page with only the logo. The dashboard, however, was fully functional. I tried repairing database tables, and now it works again.
  14. Fatal error: Uncaught You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'hw_hook_module` hm ON hm.`id_module` = m.`id_module` INNER JOIN `hw_hook` h ON h' at line 5<br /><br /><pre>SELECT h.`name` as hook, m.`id_module`, h.`id_hook`, m.`name` as module, h.`live_edit` FROM `hw_module` m INNER JOIN hw_module_shop module_shop ON (module_shop.id_module = m.id_module AND module_shop.id_shop = 1 AND module_shop.enable_device & 1) INNER JOIN `hw_module_shop` ms ON ms.`id_module` = m.`id_module INNER JOIN `hw_hook_module` hm ON hm.`id_module` = m.`id_module` INNER JOIN `hw_hook` h ON hm.`id_hook` = h.`id_hook` LEFT JOIN `hw_module_group` `mg` ON mg.`id_module` = m.`id_module` WHERE (h.name != "displayPayment") AND (hm.id_shop = 1) AND (mg.id_shop = 1 AND mg.`id_group` IN (3)) GROUP BY hm.id_hook, hm.id_module ORDER BY hm.`position` </pre> thrown in /path/to/prestashop/www/classes/db/Db.php on line 791 For some reason, this happend after uploading an image. Backend seems to work fine, ass well as product pages. But a huge chunk of the theme is missing. What's going on and how do I fix this?
  15. Hello shokinro, I'm terribly sorry about the late response to your reply. My employee wants me to somehow do this, so I have to keep looking to find a way.
  16. Hello Teapot Creative, Thank you for your reply, I think I get what you mean. However, my employee does not intent to spend any more money, so I have to find another way to fix this.
  17. Hello tuk66, No we are using the default theme with all the default modules. We did however migrated order id's from our old webshop using litextensions, maybe that module messed with the invoice numbers to match our old webshop?
  18. Hello Teapot Creative, and thank you kindly for your reply, As far as I can tell, there are only two numbers, which are the reference and the invoice numbers. Our order specifically says, "invoice number" and our invoice PDF also specifically says "invoice number". Both should be identical, there's no reason for us to pay for something that should be there in the first place. IN000178 and #13813 are completely different numbers.
  19. Hello, We have two problems with our invoice numbers: Wrong invoice number The invoice number on our Prestashop order says #10813 But on the invoice PDF the invoice number says #IN000180 This is very confusing, how can I solve this? Orders don't follow up Example: 13806 13807 13808 75 13810 13811 Why does one order suddenly get order number 75? Can someone please help me figure this out? Thank you in advance!
  20. Hello bellini13, and thank you kindly for your reply, Although I did not install any new module or theme, I deep searched all of my files. There was not a single file containing either 'phxsical_uri' or 'su.phwsical_uri' This rather looks like a human error that was made on the fly, but no one has access to our Prestashop, but me.
  21. Can someone please help me figure this out? I restored a backup, but who knows when it might occur again. After all, it came out of the blue.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More