Jump to content

MarcoSch

Members
  • Posts

    121
  • Joined

  • Last visited

Everything posted by MarcoSch

  1. So, nachdem das Upgrademodul nun zu funktionieren scheint in der neuen Version ist allerdings immer noch das Problem mit dem zurückspringen bei Auswahl der Produktkombination im FO da. Bei mir scheint es bisher lediglich die Größe zu betreffen (bei Farben waren keine Probleme) und anscheinend nur wenn man die Produkte nicht manuell anlegt sondern mit dem Store Manager importiert. Die entsprechenden Größen sind bereits von dem Import im PS angelegt. Aber nach dem Importieren mit dem Store Manager kann man diese nicht auswählen und die Auswahl springt auf die Standardkombination zurück.
  2. Das Upgrade Modul scheint jetzt zu funktionieren. Zumindest klappte das Upgrade von 1.7.1.1 auf 1.7.1.2 bei mir reibungslos und ohne Auffälligkeiten.
  3. Danke für deine Info. Das sind ja dann mal hoffnungsvolle Nachrichten. Ich offen die brauchen dafür nicht zu lange, zumal die das ja wohl nachvollziehen können. Andersherum frage mich mich allerdings warum das Modul in diesem Zustand dann veröffentlicht wurde wenn das doch ein Problem ist das anscheinend gut zu replizieren ist. Dann warten wir mal ab.
  4. Wie Shad86 schon sagt muss die Variante unter 'Verkauf -> Katalog -> Varianten und Eigenschaften' auch tatsächlich angelegt sein. Hatte das selbe Problem als ich ein paar Testartikel in den 1.7 per Prestashop Manager importiert hatte. Obwohl dieses Tool schon sehr mächtig ist legt auch dieses keine neuen varianten an sondern fügt nur die Werte zu bereits bestehenden hinzu. Einzige Merkwürdigkeit ist allerdings das PS 1.7 dem Kunden die varianten dan trotzdem anzeigt obwohl die eigentlcih gar nicht existieren. Das merkt PS halt erst wenn man die auswählen will und dann springt die Auswahl eben zurück. BTW: in oben genanten Pfad ist den Machern übrigens ein fehler unterlaufen. Das sind die Beschriftungen verdreht. Bei den Artikeleigenschaften kann mannämlich zur Zeit die Varianten bearbeiten und bei den Varianten findet man die Eigenschaften Mich persönlich interessiert momentan am meisten wie man die 1.7.1.1 auf die 1.7.1.2 upgraden kann, denn das 1-Click-Upgrade Modul funktioniert bei mir gar nicht (siehe dazu auch https://www.prestashop.com/forums/topic/617808-ps-17x-1-click-upgrade-modul-funktioniert-nicht/?p=2578115 ).
  5. Ich probiere immer noch nebenher am 1.7 und muss gestehen das es durchaus Forstschritte gibt. Allerdinsg habe ich bis Dato immer eine frische installation gemacht wenn ein versionsupdate innerhlab 1.7 anstand. Da das aber auf dauer Zeitaufwendig ist und man imemr wieder quasi von vorn beginnen muss wollte ich nun beim Upgrade von 1.7.1.1 auf 1.7.1.2 auf das 1-click-upgrade Modul in Version 3.0 zurückgreifen. Hier muss ich leider feststellen das genaus dieses allerdings gar nicht funktioniert. Mir wird der md5 angezeigt und der entsprechende Link zum archiv auf der prestashopseite. Aber keiner der Button reagiert. Egal ob ich den 'sofort upgraden' Button geleich oben klicke oder das Archiv auf den Server lade, es im Dropdown des Modul auswähle und auf den BLAUEN 'speichern'-Button gehe. Auffällig ist auch das der Experten Modus sofort aktiviert ist und dieser sich auch nicht schließt wenn man drauf klickt. Der Versionsvergleich endet übrigens nie wie hier auf dem Bild zu erkennen. Für die die es noch wissen wollen. PHP ist v.7.0.13-1 auf Debian 8.7 Auf dem selben System läuft auch eine 1.6er PS installation ohne Probleme. Ich hoffe jemand kennt das Problem und kann helfen. Aber bitte keine standartisierten Fragen ob ich schon im Debugmodus versucht habe oder ähnliches. Und NEIN ich verwende diese Version NICHT produktiv, sondern lediglich zur Verfolgung der Entwicklung. Danke für etwaige Hilfe.
  6. Hab wieder ein wenig Zeit. Also die Titelbilder werden bei mir definitiv nicht angezeigt. Warum auch immer. Nur wenn ich zusätzlich eines in die Beschreibung lege erscheint auch das Titelbild. Die Settings für Horizontale Navigation (oder jetzt ja Hauptmenü genannt) wurden ein wenig beschnitten im BO. Ich habe in meinem 1.6.1.7 Shop auch noch die Möglichkeit im default_bootstrap die Vorschaubilder der Unterkategorien der aktuell besuchten Kategorien auf der Seite anzeigen zu lassen als Link. Also dort wo jetzt entweder die Artikel zu finden sind oder wenn keine da sind eben das 'Entschudligungsschreiben' Artikel werden dort tatsächlich nur in der Kategorie dann angezeigt der sie zugewiesen sind. Ist ja leider so nicht mehr so simpel möglich und was in Shops mit weniger Artikel in einer Kategorie auch Sinn machen könnte. Ich weis das man im 1.7 festlegen kann wo der angelegte Artikel letztlich sichtbar sein soll. Und auch nicht so das Problem. Ist zwar etwas schade, aber da muss man sich halt anpassen. Bleibt nur die Frage warum die Titelbilder nicht angezeigt werden. Auch nach Neuinstallation nicht. Jedenfalls bei mir nicht mit der aktuellen 1.7.1.0 Im großen und ganzen muss sich sagen das das manuelle Anlegen von Artikel besser gestaltet ist. Als eher negativ empfinde ich jedoch die Art wie das mit den Merkmalen jetzt gehandhabt wird. Diese ständige 'Neue Eigenschaft hinzufügen' geklicke kann bei der Eingabe vieler Artikel schon nervig werden. Musst auch erstmal gucken wo genau überhaupt die Merkmale eingegeben werden können das irgendein Witzbold de Option ja 'Maßnahmen' genannt hat. Auch die Kategorieverwaltung der Artikel wirkt etwas gequetscht. Dafür hätte man vielleicht doch bessre noch einen Reiter anlegen sollen statt es an die linke Seite zu quetschen. Warum ann die EAN erst unter 'Optionen' eingeben kann und nicht wieder gleich bei der Artikelnummer wies ich auch nicht. Da ist das Wort 'Optionen' auch etwas unglücklich gewählt. Ansonsten ist das wohl übersichtlicher und einfacher geworden da man auch nicht mehr ständig speichern muss. Das soll auch kein gemecker sein. Aber man sollte bedenken das die 1.7x ja offiziell Einsteigern zum Download angeboten wird. Da sollte man das ganze doch etwas feinfühliger angehen damit die nicht gleich nach der Installation schon die Hände über den Kopf zusammenschlagen. und das ganze System ratlos und kopfschüttelnd gleich wieder löschen.
  7. Ich kann dir keine link zur Testinstallation geben wenn diese zu Haus auf einen separaten Rechner läuft. Ich habe die Version installiert (ich habe übrigens erwähnt das es sich um die aktuelle handelt, entschuldige das ich die Versionsnummer nicht angegeben habe) um mich ein wenig mehr damit zu befassen. Und bevor ich mir die Mühe mache dort weitere Artikel anzulegen außer die die ohnehin schon Vorhanden sind, sehe ich mir nur mal lieber erst einmal an welche Möglichkeiten überhaupt im FO bestehen es anzupassen. Ich Verkaufe Produkte und entwickle keine Module für Prestashop. Das ist das was ich tagsüber hauptsächlich tu und daher kenne ich mich wahrscheinlich nicht so gut mit Prestashop und seinen Macken und Marotten aus wie du. Und trotzdem setze ich mich zusätzlich noch hin und versuche mich dort rein zuarbeiten. Und das obwohl ich schon lang keine 20 mehr bin und auch noch eine Familie habe die etwas von mir haben will. Wenn man aber gleich angemacht wird, dann vergeht den Leuten die Lust hier überhaupt etwas zu fragen. Es ist nun mal so das nicht jeder alles weis. Wenn das so wäre dann bräuchte man keine Foren in denen man was erfragen muss. ich habe hier meine Eindrücke geschildert. Das im Menü keine Bilder angezeigt werden ist nicht neu. Funktioniert ja auch in der 1.6x nicht. Jedenfalls bei mir nicht. Allerdings werden mir dort die Kategoriebilder im Titel angezeigt sobald ich die Kategorie aufgerufen habe und darüber hinaus auch noch alle Unterkategrorien der Kategorie inklusive Bild. Das vermisse ich hier ganz. So, ich kümmere mich nun mal ein wenig um meine Tochter. Die will nämlich auch mal was von mir haben so lange Ferien sind.
  8. Ja, das mit der Suchbox war blöd ausgedrückt. Die kommt natürlich nur wenn die Kat leer ist. Und da ich diesen Shop erst angelegt habe sind da noch keine Artikel in diversen Kategorien. Aber wie gesagt möchte ich die Suche die dann erscheint gern entfernen, bez. durch einen, für mich sinnvolleren Inhalt ersetzen. Die Bilder der Kategorie werden, zumindest in meinen Tests, gar nicht angezeigt. Weder Titel-, noch Vorschaubild oder Icon. Nur wen ich eines in die Beschreibung lege dann sehe ich es. Auch nach löschen des Cache wird nix gezeigt so lang kein Bild in der Beschreibung hinterlegt ist.
  9. Ursprünglich habe ich es bei der 1.7 in der mainmenu.scss versucht, ohne Erfolg. Weil das nicht ging habe ich die Einträge zum Hauptmenü in der theme.css (global.css gibt es ja nicht mehr - oder doch?) gesucht und es dort hinzugefügt. Was mir allerdings aufgefallen ist, weder das Titelbild das man einfügt, noch das Vorschaubild oder Kategorie- Icon werden angezeigt. Nur wenn man in der Beschreibung ein Bild einfügt wird dies auch dargestellt. Komischerweise sogar 2 mal wenn man Titel und/oder Vorschaubild drin lässt. Nimmt man aber das Bild aus der Beschreibung raus dann sind gleich beide weg. Und BTW: Wo kann man denn die Suchbox entfernen die unter jeder Kategoriebeschreibung erscheint? Mir reicht nämlich die oben im Header.
  10. Danke für die Antwort. ich will das nicht produktiv nutzen. Noch nicht. Jedoch würde ich mich gern schon etwas vertraut damit machen und schon im Vorfeld einiges eingerichtet haben, für den Fall das es doch noch nutzbar wird. Was das Menü angeht, so habe ich allerdings probiert das zu ändern. a[data-depth="1"], a[data-depth="2"] { display:none; } Aber bisher ohne Erfolg. In der 1.6 habe ich in der global.css das eingefügt und da geht das prima: #block_top_menu ul li li ul {display:none!important;} EDIT: Ich habe nun folgendes in der theme.css eingetragen und dann geht das auch : .top-menu a[data-depth="2"] { display: none; } .top-menu a[data-depth="3"] { display: none; }
  11. Danke für deine Antwort. Ja genau. Das Banner soll über alles andere, also über den Warenkorb. Den Hook dafür haben die aber vergessen. Ich bin Optimist und hoffe das da doch noch was draus wird. ich versuche langsam die neue Version anzupassen damit ich nachher weniger zu tun habe wenn man die auch gebrauchen kann. Obwohl es ja mittlerweile einige Module gibt, unter anderen ja auch PayPal und Sofort hab eich nicht vor morgen schon umzusteigen Schon gar nicht bei der Tatsache das man ohnehin Monate braucht um überhaupt mal durch die Struktur zu finden. Allein die Übersetzungsmöglichkeiten sind eine Katastrophe. Viele Dinge findet man gar nicht. Zum Beispiel 'Edit' im Bestellprozess. Wo bitte kann man das ändern wenn es keine auszuwählendes Modul für die Order gibt??? Auch mit den Kategorien ist das so eine Sache. Ließen die sich noch in der 1.6x sehr schön anordnen und auch relativ gut sogar mit dem default theme darstellen, so scheitert das (zumindest bei mir) schon im Ansatz. Kat-Bilder sieht man gar nicht, weder Icon, noch Titel- oder Vorschaubild. Legt man dann eines in der Beschreibung mit rein dann wird allerdings gleich alles 2 mal angezeigt. Das CSS ist ebenso Chaotisch und auch mit dem Hauptmenü wurde nicht dazugelernt. Immer noch gibt es keine Möglichkeit die Kategorietiefe einzustellen. Ebenso frage ich mich warum, wenn doch alles so neu ist, Prestashop noch immer nicht richtig runden kann??????? Kurzum, die große Frage lautet schließlich warum gerade diese wirklich unfertige Version auf der Downloadseite angeboten wird. Ich denke nicht das gerade Neueinsteiger hiermit glücklich werden. Zumal man dann mit seinen Fragen von den Machern ziemlich im regen stehen gelassen wird. Keine wirklich Dokumentation, kein wirklich Schneller Support. Nicht einmal im eigenen Forum könne von den Entwicklern sei einfache Fragen wir meine beantwortet werden. Sehr enttäuschend und der ein oder andere überlegt sich eventuell auf lange Sicht auf Alternativen umzusteigen
  12. Das war ja schon Thema bei der 1.6x und leider ist es wieder präsent in der aktuellen Version. Darum auch zu dieser Version meine Frage wie man das Menü übersichtlich hält und nur die ersten Subkategorien angezeigt werden? Denn wer viele verschachtelte Kategorien hat bietet seinen Kunden nur noch einen riesiges Durcheinander an Links. Wenn also jemand einen Tipp hat dann bin ich ganz Ohr. Ein wenig traurig ist auch das die Devs einen ziemlich allein lassen mit seinen Fragen. https://www.prestashop.com/forums/topic/604327-banner-on-top-in-17/ sollte doch für die Macher kein Problem sein zu beantworten. Lustig ist das das Banner bei einer Neuinstallation auch gar nicht erst in die Nähe von dem Ort gelegt wird wo man es normalerweise findet, sondern ganz unten über den Footer. BTW: in der aktuellen Version (hab gerade die originale aus der zip genommen) ist wohl die themes.css nicht formatiert. die endet nämlich in Zeile 6
  13. After finally there are some modules i took a second look at the v1.7 However, I wonder how to get the banner at the top position. So, quite, above all else. The hooks 'displayBanner' and 'Header' seems to removed in this version? because thats where i have it in my 1.6.1.7 and it works great. But i can't find out how to move the banner at the verry top of the page. I would be grateful for a tip ....
  14. Ich beschäftige mich gerade mit der 1.7. Mal sehen ob die Probleme da gelöst sind mit dem neuen Modul. Ansonsten gibt es ein Kostenpflichtiges für ca. 119 €, aber ob das die Probleme löst weis ich nicht. Zumal ich das ganz schön teuer finde.
  15. Nachdem nun endlich einiges an Module da ist befasse ich mich auch wieder intensiver mit der v1.7 Allerdings frage ich mich wie man dort das Banner an oberste Position bekommt. Also ganz, ganz oben über alles andere. Die Hooks 'displayBanner' und 'Header' gibts ja irgendwie nicht mehr? Da ist es in meiner jetzigen 1.6.1.7 und so wird es mir auch ganz oben angezeigt. Wäre dankbar für eine Tipp....
  16. Danke für die Info. Das das Rundungsproblem noch immer da ist ist wirklich traurig. Zumal es offenbar lediglich den Euro betrifft. Meinst du das der PP-Fehler auftritt wenn man Rabatte in % gibt? Denn das ist nicht der Fall. Ich habe, wegen dem Rundungsproblem, ja umständlich alle Rabatte als Betrag angegeben und trotzdem das Problem. Das PS zig mal rundet und aus einem eindeutigen, hinterm Komma zweistelligen Betrag plötzlich 5 stellen hinters Komma setzt ist schon sehr merkwürdig. Klar das PayPal damit irgendwann durcheinander kommt wenn PS mal auf und mal abrundet und PP dann entgegengesetzt runden will. Was diese ganzen Stellen hinter dem Komma sollen weis ich absolut nicht, denn die werden sogar gesetzt wenn man keine Rabatte gibt. Dazu muss man sich nur mal einen Produktexport direkt aus PS ziehen. Wieso zum Beispiel macht PS aus einem normalen VK Preis plötzlich sowas 36.764706 Warum kann da nicht schon auf 2 stellen gerundet werden? Was soll das denn? Wenn PP solche Werte bekommt ist doch klar das das irgendwann durcheinander gerät. Ich weis auch nicht was die Macher von PS momentan tun. Ich meine das System an sich ist wirklich gut und eine perfekte Software gibt es nicht, aber statt solche, lange bekannten und auch m.e. gravierende Fehler zu beheben wird lieber eine neue Version Einsteigern angeboten die nicht einmal die essentiellen Zahlungsmodule enthält. Sicher, vielleicht kann das PP Plus Problem ja mit dem PS Plus Modul von Prestashop gelöst werden. Eine Garantie gibt es da aber auch nicht und darum ist es mir auch nicht die dafür geforderten 119 Euro wert. Also liebe Programmierer, schaut doch endlich mal wo die besagten Probleme liegen. Für so kompetente Leute wie euch (meine ich ernst ) sollte das doch nicht sooo schwer sein das zu beheben.
  17. Leider nein. Bisher nicht. Ich hoffe nur das niemand der einen Gutschein hat den derzeit einlösen möchte. Dumm auch das man dadurch keine weiteren derzeit vergeben kann. Nicht gerade sehr Verkaufsfördernd. Das ist ja nun auch kein kleines Problem wie ich finde. Da sollte schon jemand mal was zu sagen können.
  18. Ich habe festegestellt das es generell Probleme gibt wenn man das offizielle PayPal Modul (in meiner Version die v3.11.3 in PS 1.6.1.7) in Verbindung mit Gutscheinen gibt sobald man die PayPal Plus Option aktiviert hat. Wird eine Bestellung ohne Gutschein ausgeführt so klappt alles reibungslos. Sobald allerdings ein Gutschein eingefügt wird (egal ob manuell oder per klick auf den Code) so kommt bei der Auswahl der Zahlungsoptionen -> PayPal dann das hier: Kennt jemand das Problem?
  19. Lausli hat sich dem schon freundlicherweise angenommen, allerdings auch keine Auffälligkeiten gefunden. Ich habe das jetzt direkt in der .tpl übersetzt.
  20. Die Steuern sind aktiviert und stehen auch auf DE. Vielleicht werden die nicht angezeigt weil das ja nun auf englisch angezeigt wird? In der Bestellübersicht ist das auf Deutsch und da steht auch nach wie vor (Inkl. MwSt.) Welche Datei/Modul ist denn auf dem Server dafür verantwortlich? Habe im 'blockcart' nichts gefunden was darauf hinweisne könnte das die Datei dazu gehört. Und in den Übersetzungen im BO finde ich das auch nicht. Oder ist in der Datenbank was durcheinander gekommen? Wenn ja, in welche Tabelle müsste ich da nachsehen?
  21. Den cache habe ich gelöscht. Das Problem besteht allerdings nach wie vor.
  22. Ich war gestern nicht wenig überrascht als ich feststellte das das Warenkorb Pop-Up, das beim Hinzufügen eines Artikel kommt nicht mehr in deutsch sondern plötzlich in englisch erscheint. Ich habe in meiner Prestashop 1.6.1.7 nichts geändert und auch keine Module aktualisiert. Eben war noch alles in deutsch und 5 Minuten später erscheint das plötzlich in englisch. Warum???? Der ganze Rest der Seite ist nach wie vor Deutsch und ich habe auch keine weiteren Sprachen zur Auswahl für den Kunden. Und wo kann man das wieder ordentlich übersetzen? Welches Modul ist das bzw. welche abschnitt in der BO-Übersetzung? Ich habe mir schon überall einen Wolf gesucht.... Ich hoffe jemand kann mir helfen, denn so ist das sehr unschön.
  23. Ich habe nun den größten Teil vom Inhalt im BO in der PayPal-Modul Konfiguration nun gefunden. Wenn ich im PP-Modul auf übersetzen gehe, finde ich die meisten Einträge, aber meine Änderungen werden nicht übernommen. welche Datei ist es den auf dem Server in der die Sachen stehen? Dann könnte ich das vielleicht manuell ändern. EDIT: Ok. Ich habe den Rest auch gefunden. Die restlichen Sachen lagen auch irgendwo zwischen den ganzen Modulübersetzungen. Änderungen werden wohl doch übernommen, aber man muss die Übersetzungen erst einmal verlassen und wieder dort hin gehen bevor einem das richtig angezeigt wird. Hat sich also erledigt,.
  24. Ich biete seit einiger Zeit Rechnungskauf via PayPal Plus an. Hierzu verwende ich in meinen 1.6.1.7 Prestashop das offizielle Euro Paypalmodul in aktueller Version 3.11.3 an. Gestern fiel mir jedoch auf das nach Rückführung von Paypal zur Bestellübersicht, also dort wo man dann die Bestellung endgültig bestätigt sämtliche Dialoge, Buttons und Seitennavigationen nur in englisch zu sehen sind, Bis auf dem 'Prozessbalken' des bestellprozess, wie man auf dem Bild sieht. Nun meine Frage. Kommen die Daten ausschließlich von PayPal und wenn ja, weis jemand ob man die Sprache dort einstellen kann? Und wenn es eine Übersetzung hierfür in Prestashop bzw. dem PayPalmodul gibt, wo ist diese dann? Habe schon in den Dateien geschaut aber nichts passendes gefunden. Hier mal ein Screenshot zum besseren Verständnis.
  25. ok. Hat sich erledigt. ich musst unter 'Mengen' die Option 'wenn nicht auf Lager:' von "Standard" auf Bestellungen ablehnen setzen. Das gehts wohl.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More