Jump to content

Rom1CH

Members
  • Posts

    11
  • Joined

  • Last visited

Everything posted by Rom1CH

  1. Hello Gorkij77, No problem for the late answer. In fact, yes, I cleared cache and deleted cache folders manually. With no success, so I ended up modifying root module folder files and not the ones in my child theme. If you have a solution or someone has it, let me know ! Thanks
  2. Hello @gorkij77 I almost managed to set up the child theme. I say almost for 2 reasons, first I don't know exactly what I did to get rid of the errors, (some CDN replications maybe), I don't know... I successfully load assets and generate pages from the theme templates (that I can modify) but I can't custom modules from the child theme in order to not lose it at update. So, what I did, I tried to copy the full folders of modules but it seems that the inheritance of .tpl is not correctly set up when I make a simple change. I activated the debug mode and I can see the original modules path. So I started to hard code paths to the child theme modules folder without success, I still see the original path. Do you remember having done something more than just copying the full module folder ?
  3. Everyone is asking : HOW to connect to prestashop servers for this feature ? while the question should be : WHY to connect to prestashop servers for this feature ? I made a simple observation (you is for a general you, not necessarily the person commenting in this thread), why should you use an avatar/picture of yourself in a private area that only you is accessing ? You know your face, isn't it ? Well, maybe you love yourself, why not, after all this is a possibility, I am not judging. In the case you absolutely want to see you in a place where only you go or you need to display this for any other reason, in those cases, why devs/designers are not adding a simple form to upload your own picture ? Why does people at PS, designed it in a way you HAVE TO request their servers everytime you load pages of the backoffice ?
  4. Hi @gorkij77 It seems I have the same issue as yours. After creating a child theme from an existing parent one, my site has the same issues your sceenshots show. Can I ask you to explain a bit further what you mean here : I have copied the exact same files in the child from the parent theme -> Perfect mirror. I have activated this theme and I have also checked that the shop1.json file has been created in ROOT/config/themes/THE_CHILD_THEME/shop1.json Could you please, let me know what you mean by "...for some untold reason the theme generates these wee images there instead of in the /var/cache folder - where I'd expect them to be. " ? What did you do exactly ? As it might be the key to fix this issue, can you let me know your solution ? Also, I am not sure what you did to fix it : "And theme.css seems hardcoded to read them from the assets/css folder? Seriously team? Why?" ? Looking at the network tab, my CSS child theme file : /themes/THE_CHILD_THEME/assets/css/theme.css is loaded correctly ? I add that I had a js issue coming from a script not loaded. The weird thing is that this script was outsite the /themes/ folder (so the called references should not have been modified when duplicating and activating the child theme ?). I managed to fix it adding the js code of this file at the end of the child theme theme.js file. Any tips/advices about it is apreciated ! Thank you very much
  5. Don't worry. If you don't see any error, I won't be able to help you. Maybe they have removed it or maybe try to compare the code of the file you have on your FTP with the one of a fresh download or Prestashop repo.
  6. Do you see errors in dev tools window when loading a page from BO ?
  7. Hello, I have a question, what is the interest of serving an image in backoffice from the prestashop server ? Why is it done this way while Prestashop uses databases and is installed on a server where files are managed via FTP ? Can't get the point here... It would be so easy for devs to display a default image coming with the installation files or to ask it when an account is created that I don't understand why at every backoffice page requested the Prestashop server are called. Has someone an explanation about it ?
  8. Pour quelle raison ce fichier jpg d'avatar est-il servi depuis les serveurs de Prestashop ? Quelqu'un peut-il m'éclairer car je ne comprend pas ni la logique ni l'intérêt que ce soit pour l'utilisateur ou pour Prestashop ? D'autant que la plupart d'entre eux ont une image générique d'avatar ET qu'ajouter cette image dans les fichiers sources ou proposer l'upload d'une image personnalisée à la création d'un compte employé ne doit pas être si compliqué... Si quelqu'un a une explication rationelle, je suis preneur.
  9. Bonjour à tous, On est en 2019 soit 10 plus tard et j'ai l'impression d'avoir aussi la même question. Pas de problème pour afficher l'onglet 'Modules', mais comment n'afficher que les modules ayant une autorisation de configuration ? Ou, pour être plus précis, comment cacher les modules pour lesquels aucune case n'est cochée et augmenter la granularité des permissions? Le problème ici c'est que dans la colonne de gauche 'Menu', on affiche ou on cache les onglets. Mais si on affiche l'onglet 'Modules', alors c'est comme si on avait cocher toutes les cases 'Afficher' de la colonne de droite 'Modules'. Or ce n'est pas un bon comportement car pour ne pas surcharger le dashboard d'un profil et tout simplement ne pas montrer l'intégralité des modules installés à certains de ces profils, il faudrait pouvoir n'afficher que la liste des modules ayant une case action cochée par ceux-ci (modules paramétrés comme affichables ou configurables ou désinstalables). Et donc cacher ceux qui ne sont ni affichables, ni configurables, ni désinstalables. Jusqu'ici, c'est comme si le fait d'activer l'onglet modules du menu, coche implicitement la case 'Afficher' de tous les modules alors qu'elle est belle et bien décochée. Il y a peut-être une raison valable de la part des développeurs comme par exemple montrer que l'activation de l'onglet 'Modules' de la colonne 'Menu' a bien été prise en compte, dans ce cas, pourquoi ne pas inverser la case 'Afficher' des modules en 'Cacher' ? Ainsi, par défaut, on afficherait tous les modules et selon le degré de permission accordé aux profils, on cacherait ceux que l'on ne juge pas nécessaire. Pour le dire encore d'une autre manière, au lieu d'afficher la liste entière des modules pour un profil autorisé à configurer certains modules, il faudrait n'afficher que les modules que ce profil peut configurer et cacher les autres. N'hésitez pas à me le dire si je ne suis pas clair haha, bon allez au cas où : l'idée est de désolidariser l'affichage de l'onglet Modules de l'affichage des modules en eux-même. Dans l'absolu, on pourrait donc se retrouver avec l'onglet 'Modules' activé et rien dans la page 'Module' jusqu'à ce qu'on décide d'autoriser l'affichage/la configuration d'un ou plusieurs modules à un type de profil. Est-ce que certains d'entre vous ont trouvé une solution pour ce problème ? Je suis preneur, merci. Romain
  10. @Prestachiotte Savior Bonjour Je viens de poser le fichier que tu propose sur mon serveur à la place de l'original MethodEC.php . J'ai exactement le même message et aucun champ n'apparait. Où devrait on les trouver ? Modules > Paypal > configurer ? Merci pour tes éclaircissements ? @momopo As-tu résolu ton problème ? Comment t'en es tu sorti ? As-tu appliqué le correctif fourni par Prestachiotte Savior ? Merci à tous les 2!
  11. Bonjour à tous, J'ai un soucis avec un thème acheté sur la market-place, je ne parviens à créer un thème enfant qui fonctionne pour pouvoir faire des modifications tout en conservant la possibilité de le mettre à jour au fil des updates du développeur. En fait, je créé mon thème enfant dans le répertoire themes je créé le dossier config à l'intérieur, je paramètre le .yml avec les bons paramètres de linking au thème enfant (comme je fais à chaque fois pour chaque thème). Je retourne ensuite dans le BO pour activer le thème enfant fraîchement créé, il s'active bien mais le layout du site en front-end est totalement cassé. Il y des erreurs javascript à cause de variable non reconnu comme si certains fichiers n'étaient pas chargés, or tous les js sont charger et aucune 404. Ce thème, compatible PS 1.7.4, ne semble pas intégrer la "fonctionnalité" du thème enfant, alors je me pose qq questions : Pourquoi ce n'est pas une fonctionnalité par défaut ? Si la compatibilité avec un thème enfant n'est pas une obligation, y a-t-il un endroit sur les pages de présentation des thèmes de la market-place où le développeur indique cette non-compatibilité ? (de sorte à ne pas l'acheter si on compte le customizer!) Comment, dans ce cas, peut-on customiser un thème puis le mettre à jour sans perdre les modifications apportées au fil du temps ? Je vous remercie vivement pour ces éclaircissements! Merci
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More