Jump to content

hulk

Members
  • Posts

    349
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by hulk

  1. Bonjour a tous, travaillant actuellement sur PS 1.4.11, je voulais savoir si c'est possible de faire un avoir partiel sur une commande ? j'ai bien fouillé sur le net mais j'ai rien trouvé pour PS 1.4. J'ai testé la version 1.5.6, et cette fonctionnalité existe bien en natif "Remboursement partiel", et comme je suis pas le chef , je suis obligé a rester sur la 1.4. Je me demande s'il y a un module compatible 1.4 ou une astuce pour adapter le traitement de la 1.5 sur la 1.4. toute idée est la bien venue merci d'avance
  2. Bonjour, Comme j'arrive pas a faire apparaitre mes commandes de test en BO avec le mmodule cm-cic v1 (prestashop 1.4.11) je me demande bien si je dois transmettre l'url de test aussi à la banque. merci de votre retour
  3. pour moi c'est utile car j'ai des anciennes commandes avec taux de taxe = 19.6 % et dont total_shipping = '8.97'. j'ai du le faire pour chaque transporteur à part.
  4. Merci doekia de m'avoir répondu j'ai pensé à ça et j'ai même créer une requête UPDATE pour mettre à jour cette rubrique UPDATE orders set orders.carrier_tax_rate = '20.000' where orders.id_carrier = '10' and orders.total_shipping = '9.00' and orders.carrier_tax_rate = '0.000' mais je suis pas sûr que ça va pas foiré dans d'autres traitement.
  5. Bonjour a tous, comme indiqué dans le titre du topic, j'ai migré mon site 1.2.5 vers la 1.4.11. La mise à jour s'est bien passé, mais lorsque je consulte mes factures, la ligne taxe transport n'est pas affichée (on le comparant par la facture de la 1.2.5). en fouillant dans classes/PDF.php j'ai trouvé le bloc du code qui affiche le taxe transport (L 1298 -> L 1313) // Display carrier tax if ($carrier_tax_rate AND $carrier_tax_rate != '0.00' AND ((self::$order->total_shipping != '0.00' AND !self::$orderSlip) OR (self::$orderSlip AND self::$orderSlip->shipping_cost))) { $nb_tax++; $before = $this->GetY(); $lineSize = $this->GetY() - $before; $this->SetXY($this->GetX(), $this->GetY() - $lineSize + 3); $this->Cell($w[0], $lineSize, self::l('Carrier'), 0, 0, 'R'); $this->Cell($w[1], $lineSize, number_format($carrier_tax_rate, 3, ',', ' ').' %', 0, 0, 'R'); $this->Cell($w[2], $lineSize, (self::$orderSlip ? '-' : '').self::convertSign(Tools::displayPrice($priceBreakDown['shippingCostWithoutTax'], self::$currency, true)), 0, 0, 'R'); $this->Cell($w[3], $lineSize, (self::$orderSlip ? '-' : '').self::convertSign(Tools::displayPrice(self::$order->total_shipping - $priceBreakDown['shippingCostWithoutTax'], self::$currency, true)), 0, 0, 'R'); if ($priceBreakDown['hasEcotax']) $this->Cell($w[4], $lineSize, (self::$orderSlip ? '-' : '').'', 0, 0, 'R'); $this->Cell($w[$priceBreakDown['hasEcotax'] ? 5 : 4], $lineSize, (self::$orderSlip ? '-' : '').self::convertSign(Tools::displayPrice(self::$order->total_shipping, self::$currency, true)), 0, 0, 'R'); $this->Ln(); } et en regardant dans ma base, j'ai trouvé que la rubrique orders.carrier_tax_rate = 0.000 pour toutes les lignes. d'abord j'ai cru que la mise à jour ne s'est pas déroulée comme il faut alors je l'ai refait à plusieurs reprise est avec différente méthode (de la 1.25 vres 1.4.11 directement, en passant par des version majeures 1.2.5 -> 1.3 > 1.4.8.2 -> 1.411,..) mais le résultat est le même : rubrique carrier_tax_rate = 0.000. cette rubrique sera alimentée pour les nouvelles commandes qui viendrons avec le taxe transporteur 20.000. j'ai cherché partout dans le code du prestashop si je trouve un script a utiliser pour mettre à jour carrier_tax_rate mais j'ai rien trouvé. je me demande si quelqu'un a eu ce soucis ou je suis le seul a le noter. merci d'avance
  6. bonjour j'ai migré ma boutique 1.2.5 vers la 1.5.6.3 en passant par la 1.3 puis la 1.4.8.2(à l'aide du module d'upgrade). après des nombreuses bogues constatés au cours de mes tests, j'ai remarqué que mes anciens avoirs ont un montant = 0.00 €. donc j'a regardé dans la table ps_order_slip et ps_order_slip_detail et j'ai remarqué que les champs "amount" et "shipping_cost_amount" sont tous = 0.00 j'ai créer un nouveau avoir pour une commande et j'ai bien des valeurs dans les 2 rubriques de montant. au début j'ai cru qu'il y a eu un soucis lors de migration donc j'ai refait la migration étape par étape (la 1.3 puis la 1.4.8.2 puis la 1.5.63) tout en surveillant les 2 tables ps_order_slip et ps_order_slip_detail mais c'est toujours = 0.00 même en essayant de migrer vers la 1.6.1.10, c'est pareil. est ce bien un problème de migration ou c'est une bogue de prestashop ? merci d'avance
  7. Hello I migrated my shop 1.2.5 to the 1.5.6.3 going through the 1.3 then the 1.4.8.2. After many bugs found during my tests, I noticed that my old order slips have an amount = 0.000 €. I looked in the table ps_order_slip and ps_order_slip_detail and i noticed that the fields "amount" and "shipping_cost_amount" have amounts = 0.00 I create a new order slip in one of my orders and I have the right values in the 2 fields and the amount in BO order is correct. At first I thought there was a problem during migration so I re upgarde my shop one by one while watching the 2 tables ps_order_slip and ps_order_slip_detail but it is always = 0 Even trying to upgrading to the 1.6.1.10 and the same. I was wondering if i did a mistake during the upgrade or it's a bug.
  8. Bonjour a tous, j'ai trouvé d'ou ça vient le problème de n° bon de livraison. PS 1.5.63 : dans le fichier classes/pdf/HTMLTemplateDeliverySlip.php Ligne 42 $this->title = HTMLTemplateDeliverySlip::l('Delivery').' #'.Configuration::get('PS_DELIVERY_PREFIX', Context::getContext()->language->id).sprintf('%06d', $this->order_invoice->delivery_number); a modifier par $this->title = HTMLTemplateDeliverySlip::l('Delivery').' #'.Configuration::get('PS_DELIVERY_PREFIX', Context::getContext()->language->id).sprintf('%06d', $this->order->delivery_number);
  9. Bonjour, ça fait quelques jours que j'ai upgradé ma boutique presta du 1.4.8 vers la 1.5.6 à l'aide du module 1-click-upgrade. J'ai bien mes données dans la base. mais en testant les différentes fonctionnalités j'ai remarqué que le n° BL est toujours = 00000 dans le bon de livraison (voir pj) j'ai fouillé dans le code (et comme la nouvelle structuration des fichiers core presta m'est pas encore familier) je suis perdu. j'ai vérifier : - dans le paramétrage des n° BL en BO OK - avec une installation nette de la 1.5.6 => pas de n° BL dans les fichiers tpl du dossier /pdf/ il y a pas la variable du compteur du BL, d'avoir ou de la facture. Merci d'avance
  10. Bonjour, je viens de migrer ma boutique de la 1.3.1 vers la 1.5.6.3 en passant par la version 1.4.8. la migration c'est bien déroulé (avec quelques petites erreurs non bloquantes) au cours de mes tests en BO, j'ai eu une erreur lorsque je lance une recherche avec le n° avoir. Column 'id_order' in where clause is ambiguous j'ai affiché les erreur et je vois qu'il manque le nom de la table pour la rubrique 'id_order' dans le WHERE j'ai bien cherché sur le net et sur le forum mais j'ai rien trouvé. quelqu'un a rencontré cette anomalie ? merci d'avance
  11. bonjour, cette semaine j'ai remarqué que le lien de suivi Chronopost est KO. si je clique sur le lien suivre le colis j'ai sur cette page au lien de la page d'historique suivi colis . le lien dans le paramétrages du module Chronopost est le http://www.fr.chronopost.com/web/fr/tracking/[email protected] c quoi la nouvelle adresse de suivi colis chronopost auquelle on peut passer le n° de colis en paramètre dans l'url ? merci d'avance
  12. Bonjour, ça fait longtemps que j'utilise prestashop pour ma boutique et ces derniers jours que j'ai remarqué ce bug. en faite quand je génére un avoir pour une facture avec bon de réduction,et je vois que le montant dans l'avoir est erroné : - Facture TTC - Bon de réduction + frais transport - Avoir TTC + Bon de réduction + frais transport je crois que le problème vient du fichier classes/PDF.php lors de la génération d'avoir. est ce que quelqu'un a trouvé une solution ?
  13. j'ai remarqué que seul la page index.php est la plus lente, et dans cette page il y al'exécution des scripts qui récupères les statistiques de la boutique tel que le CA, les commandes passées,les inscriptions et les pages vues ainsi que les utilisateurs connectés c a d connexion a la base des données surtout les tables de connections qui sont les plus volumineuses > 750 Mo. est ce possible d'optimiser ça?
  14. bonjour, moi aussi je souffre de la lenteur du BO (version 1.2.5):ces derniers temps lorsque j'essaye de me connecter au BO ça prend + de 60 sec de chargement et par suite j'ai le message d'erreur du serveur pour dépassement de délai d'attente. je me demande bien quels sont les fichiers qui se chargent lors de la connexion au BO et si la taille des données dans la base (+ de 850 Mo) peuvent influencer? cordialement
  15. merci crystals-services pour m'avoir répondu et surtout de me rassurer par votre soutien a vrai dire c'est juste une idée dans la tête que je veux la réaliser et comme un développeur non expérimenté, j'aurais besoin des vos conseils (les développeurs pros ) pour me montrer mes erreurs. Et pour la cahier de charge, je n'ai que les grandes lignes : Inscription client au site :suivi téléphone, suivi paiement Sélectionner le modèle du téléphone grâce au moteur de recherche interne et indiquez son état :Fonctionnel ou Hors Service Découvrir la valeur du téléphone Ajouter le produit au panier de recyclage Remplir le formulaire de vente Choisir le mode de paiement : chèque ou virement Envoyer le téléphone Réception de paiement dans un délais de 10 jours Mais au fur et a mesure, c 'est sur j'aurais des problèmes et des obstacles a franchir avec un petit coup de main. Cordialement
  16. bonjour, J'ai un petit projet dans la tête mais j'ai besoin aussi de vos conseils. je vais créer un site de recyclage téléphone mobile (comme ce site ) en utilisant prestashop. le site consiste a ce que le client accède au site et sélectionne son téléphone puis il aura un petit formulaire de diagnostic de son téléphone et il aura un calcul de prix en arrière plan selon cette diagnostique. Après avoir afficher le prix, le client choisit s'il le recycle ou pas (= commander actuellement dans prestashop). s'il est d'accord il doit mettre son adresse et ces coordonnées (c a d créer un compte sur le site) d'ou il aura la possibilité de suivre son téléphone puis choisir le moyen dont il veut être payé (chèque ou virement bancaire) . ça ressemble un peu au fonctionnement de prestashop (mais a l'envers car le client qui va vendre et la boutique paye) mais a présent je ne sais pas la taille des changements dans prestashop pour arriver au but voulu. toute remarque est la bien venue. Cordialement
  17. but here, the developper say that it is compatible with 1.4.8.2. i think that it's a upgrading DB problem, but who know. i contact the developper to see the source of problem. thx Pippo
  18. Hi Pippo3000, No i had prestashop 1.2.5 version and i upgrade it to prestashop 1.4.8.2. version. when i use a the native DB of 1.4.8.2 version, orlique work nice but if i use the DB upgraded from prestashop 1.2.5, the module dont work correctly.
  19. Hi, ibought the module and i install it in my 1.4.8.2 version, but i have some problems: - if i try to creat a new order, this order don't appear in BO list coz he don't have a status in ps_order_history and after clicking save button the module don't redirect me to new order page. - If I click again on the Save button, the product stock change again in every click knowing that I did the update my version 1.4.8.2 from version 1.2.5 so I guess my problem come from here. thanks for your help
  20. Hi, ibought the module and i install it in my 1.4.8.2 version, but i have some problems: - if i try to creat a new order, this order don't appear in BO list coz he don't have a status in ps_order_history and after clicking save button the module don't redirect me to new order page. - If I click again on the Save button, the product stock change again in every click knowing that I did the update my version 1.4.8.2 from version 1.2.5 so I guess my problem come from here. thanks for your help
  21. bonjour: j'ai acheter ce module la semaine dernière et je l'ai installé sous ma version 1.4.8.2 en local sans soucis mais lors des test j'ai constaté que : - après avoir créer la commande et cliquer sur "Enregistrer la commande et la prévisualisation" ça reste dans la même page au lieu de me rediriger vers la fiche commande - et la commande et bien créée mais sans statut or que j'ai bien indiqué le statut lors de sa création et par suit elle est invisible dans la liste des commendes. Je ne crois pas que c'est un problème de compatibilité car le développeur a bien mentionné la version 1.4.8.2 alors je me demande bien d'ou vient le problème sachant que j'ai bien vérifier ma base et les tables concernés. cordialement
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More