Jump to content

whitespirit

Members
  • Posts

    264
  • Joined

  • Last visited

Everything posted by whitespirit

  1. Malheureusement, je n'ai plus accès au backoffice... comment activer manuellement l'extension ? J'ai cherché dans les fichiers du répertoire /config mais je n'ai rien vu. Peut-être dans la db ? 1000 merci, ça fait 4h que je coince dessus :-(
  2. "Cette extension est facultative, autant pour une installation que pour une mise à jour de PrestaShop, pas d’inquiétudes à avoir donc." Comment désactiver cette extension ? Du moins faire en sorte qu'elle ne soit pas utiliser ? J'ai un problème sur mon serveur, impossible d'installer mcrypt. Merci pour votre aide.
  3. je ne pourrais pas installer mycrypt sur mon serveur, j'ai l'erreur suivante après un "apt-get install php5-mycrypt" Fatal error: Call to undefined function mcrypt_encrypt() in /var/www/vhosts/xxx/httpdocs/classes/Rijndael.php on line 42
  4. j'ai vu que pour avoir le message d'erreur il fallait positionner un paramétre dans config.inc.php. Voici donc le message d'erreur Fatal error: Call to undefined function mcrypt_encrypt() in /var/www/vhosts/xxx/httpdocs/classes/Rijndael.php on line 42 Lorsque je fais une install normal, tout fonctionne bien. Du coup je ne sais pas pourquoi j'ai cette erreur. Je cherche en parallèle une solution sous google.
  5. Bonjour, Je travaillais en local sur mon ordinateur, j'ai envoyé le site sur le serveur (l'inverse à bien fonctionné) et là j'ai une page blanche. Les paramètres de la table ps_configuration et dans /config/settings.inc.php sont correctes. Je cherche l'erreur depuis 1h et je ne trouve toujours pas. Avez vous une idée ? Merci
  6. un big grand merci pour cette réponse ultra rapide. Effectivement j'ai l'impression qu'il s'agissait bien de ces deux variables dans la table configuration. Je vais d'ailleurs regarder plus attentivement ce qu'elle contient. merci, j'ai passé plus de 4h avant de recommencer la boutique à zéro, et là je devais reprendre... Alors Merchiche
  7. Bonjour tout le monde, Je travail en local pour tester et développer ma boutique. Lorsque je passe sur le nom de domaine, impossible de me connecter au site. J'ai regardé les paramètres dans les fichiers du répertoire /config mais ça ne fonctionne pas. Comment faire pour installer ma boutique sur une adresse local.site.fr en site.fr ? Merci d'avance.
  8. Va faire un tour dans le tpl du module cms dans le répertoire /module puis dans le repertoire /themes/tonthemes/
  9. En plus chez moi il est 1h45 du mat !! La misère, comment pourrir son samedi ! Si t'as modifié le fichier et que ton site a afficher quand même les éléments, c'est que tu n'es pas dans le bon fichier. Chez moi, quand je supprime un fichier de template, cache ou pas cache, il n'y a rien qui s'affiche. Il s'appelle comment ton module en français ? Je ne le trouve pas dans ma liste.
  10. juste pour avoir le coeur net, renomme le fichier blockvariouslinks en autre chose histoire de ne pas le perdre et recharge ta page. Si les blocs ne s'affichent plus, alors c'est obligé, c'est une histoire de cache, du moins, logiquement. Sinon, c'est que tu n'es pas dans le bon fichier. Enfin, dans tous les cas, c'est étrange !!!
  11. T'as essayé de désactiver le cache dans l'administration->préférence->performance comme indiqué ici http://www.prestashop.com/forums/viewthread/99055/developpement/tip_pour_modifications_de__dot_tpl_dont_les_effets_napparaissent_pas_sous_1_dot_4
  12. En fouillant plus dans le forum, j'ai trouvé la réponse ici : http://www.prestashop.com/forums/viewthread/99055/developpement/tip_pour_modifications_de__dot_tpl_dont_les_effets_napparaissent_pas_sous_1_dot_4
  13. Bonjour, Je vais tenter de créer un thème, mais j'ai remarqué que SMARTY met tous les fichiers template .tpl du thème, en cache (/tools/smarty/compile). A chaque modification dans un fichier .tpl je dois donc effacer tous les fichiers /compile pour voir le résultat. Avez vous une idée pour désactiver la génération des caches ? Merci
  14. Salut pour répondre à ta question, étant donné que j'ai passé 4h à chercher une solution hier : Prestashop utilise un moteur de template nommé SMARTY En gros, c'est pour facilité les graphistes à créer des design sans perdre du temps à comprendre le php, d'ailleurs, si tu comprends le HTML tu verras que le code {...} est assé simple à comprendre. Les {..}, c'est SMARTY. Ce saligaud met en cache tous les fichiers thèmes (.tpl) du coup même si tu supprime le contenu du fichier, rien ne change. Supprime tous les fichiers dans /tools/smarty/compile et relance ton site en prenant soin de bien réactualiser la page (SHIFT + F5 ou CTRL + F5). Voilà, si t'as un affichage bizarre, la première fois, c'est normal, faut qu'il recompile les thèmes. Tu réactualises et c'est bon. A++
  15. Merci pour le lien, je vais passer un petit temps à lire la doc. Je pense qu'il existe une solution plus facile, mais je vais créé un nouveau post car j'ai trouvé les réponses à la question posé ici. Merci encore pour tes infos.
  16. Finalement je crois avoir trouvé une réponse : - Les hook sont définis dans le fichier /classes/frontController.php - smarty gère des caches. Il fallait supprimer tous les fichiers dans le répertoire /tool/smarty/compile La dernière question de la soirée : comment désactiver la mise en cache de smarty ?
  17. Bonjour et merci pour cette réponse. Effectivement j'ai les variables dans config et setting. J'ai 2 nouvelles questions à poser, qui découle de mes recherches de ces dernières heures : - ou sont définies les {$HOOK} ? Par exemple {$HOOK_HEADER} est définie ou ? - J'ai copier et renommer le thème de base. Lorsque je regarde les feuilles de style du nouveau thème sélectionné, elles pointent bien vers mon nouveau répertoire. J'ai remarqué que la page d'accueil est déclaré dans le fichier header.tpl. Pourtant lorsque je modifie (j'ai effacé tout le code) ce fichier, la page d'accueil reste inchangé. J'ai fouillé dans tous les autres fichiers du thèmes et c'est bien le fichier à utiliser. J'ai raté un truc pour modifié un thème ? Pourtant j'ai rien dans les caches. [EDIT] Je ne comprends pas. J'ai effacer le fichier header.tpl et le site ne s'est pas affiché (page blanche). Par contre, si j'efface le contenu du fichier, le site se lance correctement. [/EDIT] Une réponse serait vraiment super ! Merci
  18. Bonjour à tous, J'espère que cette question n'a pas été posé ces derniers temps, je viens de parcourir le forum en diagonale. Je souhaite créer un nouveau thème (le dernier que j'ai créé et le seul date de la version 0.8). J'ai ouvert le fichier header.tpl pour découvrir la structure du site. Dans ce fichier, il y'a des variables php (ex: $shop_name). Je souhaiterai savoir ou sont définies toutes ces variables ? Existe t'il un document qui les répertories toutes ? Si vous avez des tuyaux (site internet, post, etc.) je suis preneur. A bientôt.
  19. Fait gaffe quand même avec ces histoires de TVA pour ne pas te faire avoir ! C'est quand même de l'arnaque quand on est dans un dom ! Quand j'achète des bouquins sur amazone par exemple, je paye la TVA applicable en France, puis arrivé ici je paie une autre taxe de voleurs sur le total incluant les frais de port (ils appellent ça l'Octroie de Mer, c'est un peu comme si vous payez une taxe lorsque vous achetez à Paris et que vous faites livrer à Marseille! Bref, un produit qui coute par exemple 100€ en France, on le paye à 150€ facile arrivé ici. Donc, si j'ai un conseil à te donner, regarde une boutique concurrente reconnu et fait la même chose.
  20. Salut, Je dois me remettre sous prestashop que je n'avais plus utiliser depuis la version 1.2. Je découvre ta boutique et je la trouve très sympa ! Bravo ! Pour moi, si je dois donner une critique constructive et en cherchant la petite bête car dans l'ensemble y'a pas grand chose à revoir, j'aurai bien marqué la séparation entre le footer et le contenu du site, peut être par la même barre qui sépare le header du contenu (et pourquoi pas remettre le fond du header dans le footer). J'aurai changé aussi la couleur de la police qui est soit noir, soit blanche. J'aurai mis un gris foncé pour les descriptions et peut-être ajouter un espace entre les lignes plus importants. Sinon j'aime bien l'affichage des instruments lorsqu'on est dans une catégorie. Peut-être que j'aurai joué aussi sur la taille et couleur de la police des produits en promotions pour mieux marquer le contraste. Je dois développer un thème rapidos, je stress à fond. Je pourrais te poser deux, trois questions en MP si besoin ? Encore bravo, on voit bien que t'as réussi à atteindre l'objectif que tu t'es fixé au la main ! C'est l'essentiel, après les gouts, les couleurs, certains vont aimé, d'autre pas, moi je trouve ça cool !
  21. Bonjour, J'ai installé la dernière béta de Prestashop et lorsque je clique sur un fabriquant la feuille css global.css n'est plus dans le header. Pour le moment je l'ai ajouté manuellement (/themes/prestashop/css/global.css). Sur cette version, j'ai eu aussi un bug suite à la génération du .htaccess (500 Internal...). Il fallait corriger une ligne dans le fichiers tools.php (vu dans un post de forum). A bientôt.
  22. Bonjour à tous, Je viens d'installer la version 1.4.0.14. L'installation s'est bien déroulé en français mais l'administration de la boutique est en anglais. Par contre la boutique est en français. Je suis allé dans les paramètres "outils"->"languages" afin d'activer la langue française qui ne l'était pas, mais l'administration reste en anglais. J'ai raté qq chose ? Merci
  23. Content de l'entendre. Désolé pour me manque de temps, en ce moment je bosse à fond sur un projet Drupal, nuit et jour...
  24. pas eu le temps... Faut que je passe un temps à revoir la base de données avant, et voir ce qui a changé pour faire la mise à jour. Mais fais un test après avoir sauvegarder ta base de données, au pire, tu restaures.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More