Jump to content

Madking

Members
  • Posts

    5
  • Joined

  • Last visited

Everything posted by Madking

  1. καλησπερα! αντιμετωπιζω ενα προβλημα με το eshop μου. Ακολουθησα καποια στανταρ debug βηματα, αλλα ακομα δεν εχω βγαλει ακρη... Τα προβληματα που αντιμετωπιζω ειναι: 1. Εχουν εξαφανιστει οι εκπτωσεις και δεν μπορω να εμφανιζω τις παλιες εκπτωσεις σε προιοντα καθως και να βαλω καινουριες. 2. Χρησιμοποιω το module smart blog και ξαφνικά εχω errοr οταν προσθετω καινουριο αρθρο. Συγκεριμενα: Μολις παω να κανω ενα καινουριο αρθρο αφου συμπληρωνω τα καταλληλα πεδια μου πεταει αυτο το error An error has occurred: Can't save the current object Πηγαινω στο module να κανω διαμορφωση με ανοιχτο το SQL debug και εχω αυτο το error: [PrestaShopException]Admin tab AdminAboutUsController is not a module tab at line 45 in file classes/controller/ModuleAdminController.php 39. 40. parent::__construct(); 41. 42. $tab = new Tab($this->id); 43. if (!$tab->module) 44. throw new PrestaShopException('Admin tab '.get_class($this).' is not a module tab'); 45. 46. $this->module = Module::getInstanceByName($tab->module); 47. if (!$this->module->id) 48. throw new PrestaShopException("Module {$tab->module} not found"); 49. } ModuleAdminControllerCore->__construct - [line 11 - modules/smartblog/controllers/admin/AdminAboutUsController.php] AdminAboutUsController->__construct - [line 524 - modules/smartblog/smartblog.php] smartblog->getContent - [line 805 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcessCallback - [line 1045 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcess - [line 171 - classes/controller/Controller.php] ControllerCore->run - [line 373 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 54 - admin/index.php] ========================================================================================= Μετα παω να κανω εγκατασταση ενα module ας πουμε το autoupgrade και εχω αυτο: Το(α) ακόλουθο(α) module(s) δεν έχουν εγκατασταθεί σωστά: autoupgrade : Unable to load the "AdminSelfUpgrade" tab και μετα το ξαναπαταω και βγαζει αυτο το SQL error [PrestaShopDatabaseException]Duplicate entry '0' for key 'PRIMARY' INSERT INTO `ps_tab` (`id_parent`, `position`, `module`, `class_name`, `active`, `hide_host_mode`) VALUES ('17', '11', 'autoupgrade', 'AdminSelfUpgrade', '1', '0') at line 635 in file classes/db/Db.php 629. WebserviceRequest::getInstance()->setError(500, ' '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97); 630. } 631. else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) 632. { 633. if ($sql) 634. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>'); 635. throw new PrestaShopDatabaseException($this->getMsgError()); 636. } 637. } 638. 639. /** DbCore->displayError - [line 325 - classes/db/Db.php] - [1 Arguments] DbCore->query - [line 609 - classes/db/Db.php] - [1 Arguments] DbCore->q - [line 390 - classes/db/Db.php] - [2 Arguments] DbCore->insert - [line 464 - classes/ObjectModel.php] - [3 Arguments] ObjectModelCore->add - [line 103 - classes/Tab.php] - [2 Arguments] TabCore->add - [line 425 - classes/ObjectModel.php] - [2 Arguments] ObjectModelCore->save - [line 115 - classes/Tab.php] TabCore->save - [line 74 - modules/autoupgrade/autoupgrade.php] Autoupgrade->install - [line 805 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcessCallback - [line 1045 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcess - [line 171 - classes/controller/Controller.php] ControllerCore->run - [line 373 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 54 - admin/index.php] ==================================================================================== Κλασικη περιπτωση βλαβης???????? Μπορει κανεις να βαλει ενα χερακι????????????????? Παρακατω εχω και δυο φωτο στο phpmyadmin...
  2. Nothing happens, i still got the same errors.......this is so strange. i removed the database, uploaded an older one, i delete the module, resinstall it, now i can see the blog page in my theme and the control panel also the module is fine, i can see the blog admin in my admin page, but. 1. I cant add a new article, i got the error " An error has occurred: Can't save the current object " 2. im navigating through modules, i find the smart blog module, clicking to configure the module and i get this: [PrestaShopException] Admin tab AdminAboutUsController is not a module tab at line 45 in file classes/controller/ModuleAdminController.php 3. I m trying to add discounts, not working, again.......................................... and all the previous discounts not anymore... (it was the same thing with the other database, nothing changed.......) im getting a little mad with this situation, i cant figure out what is going on..
  3. Οκ i already did that, set to AUTO_INCREMENT but still the problem is the shame...
  4. Thanks for answer my friend.. well i think im gonna need some help here...ok here's a shot of my DB http://imgur.com/kF5uAK0 I think i need help over here.. how im gonna AUTO_INCREMENT ?
  5. Hi i have about the same problem in a Presta Shop. When i try to install the OneClick Update module, i get this error [PrestaShopDatabaseException]Duplicate entry '0' for key 'PRIMARY' INSERT INTO `ps_tab` (`id_parent`, `position`, `module`, `class_name`, `active`, `hide_host_mode`) VALUES ('17', '11', 'autoupgrade', 'AdminSelfUpgrade', '1', '0') at line 635 in file classes/db/Db.php 629. WebserviceRequest::getInstance()->setError(500, ' '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97); 630. } 631. else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) 632. { 633. if ($sql) 634. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>'); 635. throw new PrestaShopDatabaseException($this->getMsgError()); 636. } 637. } 638. 639. /** DbCore->displayError - [line 325 - classes/db/Db.php] - [1 Arguments] DbCore->query - [line 609 - classes/db/Db.php] - [1 Arguments] DbCore->q - [line 390 - classes/db/Db.php] - [2 Arguments] DbCore->insert - [line 464 - classes/ObjectModel.php] - [3 Arguments] ObjectModelCore->add - [line 103 - classes/Tab.php] - [2 Arguments] TabCore->add - [line 425 - classes/ObjectModel.php] - [2 Arguments] ObjectModelCore->save - [line 115 - classes/Tab.php] TabCore->save - [line 74 - modules/autoupgrade/autoupgrade.php] Autoupgrade->install - [line 805 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcessCallback - [line 1045 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcess - [line 171 - classes/controller/Controller.php] ControllerCore->run - [line 373 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 54 - admin/index.php] I also try to manage the blog module (Smart Blog) and i get this error [PrestaShopException]Admin tab AdminAboutUsController is not a module tab at line 45 in file classes/controller/ModuleAdminController.php 39. 40. parent::__construct(); 41. 42. $tab = new Tab($this->id); 43. if (!$tab->module) 44. throw new PrestaShopException('Admin tab '.get_class($this).' is not a module tab'); 45. 46. $this->module = Module::getInstanceByName($tab->module); 47. if (!$this->module->id) 48. throw new PrestaShopException("Module {$tab->module} not found"); 49. } ModuleAdminControllerCore->__construct - [line 11 - modules/smartblog/controllers/admin/AdminAboutUsController.php] AdminAboutUsController->__construct - [line 524 - modules/smartblog/smartblog.php] smartblog->getContent - [line 805 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcessCallback - [line 1045 - controllers/admin/AdminModulesController.php] AdminModulesControllerCore->postProcess - [line 171 - classes/controller/Controller.php] ControllerCore->run - [line 373 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 54 - admin/index.php] I have recently move my Prestahop to a new host, but i cant have support, they say its not any permission, or a server error,
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More