Jump to content

jhnstcks

Members
  • Posts

    1,753
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by jhnstcks

  1. When you use the one click upgrade, you can specify not to update the default theme. If you are using a custom theme where the name of the thme is different, the upgrade won't touch that. As for the modules, you can create module overrides in your theme for the .tpl files (.php files won't be overridden). Put the files in themes>yourtheme>modules>nameofthemodule>. The problem is though, that any important updates will not be added onto the site if they are in the theme of module files.
  2. For the rounded corners you need to alter the css for that specific block and add the relevant code. Try this site -> http://border-radius.com/ just change the numbers in the corners to get the required rounding, then copy and paste the code in the middle to your css file.
  3. Have you cleared your browser cache and switched on force compile and off cache? For 404 errors have you regenerated the htaccess?
  4. If you switch back to the default theme, is the checkbox there?
  5. Have you tried clearing browser cache? Also turn off Prestashop cache and compile options and the refresh the page and see if that improves it.
  6. @simondavidson If you are having problems, i suggest you start topics asking people for help, and not topics that just whine about not being able to do something and then start rubbishing Prestashop. As mentioned above by someone else.....why take the job on if you don't like, or don't have the knowledge or expertise to install and customise Prestashop for your client. I don't like using Magento, so there is no way I would take a client on that wishes to use it. I suspect your "12 years website experience" is actually experience of using installatron or softuclous to easily install Magento, Joomla and Wordpress and then install templates created by someone else and then taking the credit for all the "hard work". As soon as you actually need to fix something your stumped. THREAD CLOSED
  7. You might not be able to remove the copyright and credits as the theme author might have added them.
  8. Open modules/feeder/rrs.php Find $orderBy = Tools::getProductsOrder('by', Tools::getValue('orderby')); $orderWay = Tools::getProductsOrder('way', Tools::getValue('orderway')); Replace with $orderByValues = array(0 => 'date_add', 1 => 'price', 2 => 'name', 3 => 'date_upd', 4 => 'position'); $orderWayValues = array(0 => 'DESC', 1 => 'ASC'); Find $products = Product::getProducts(intval($cookie->id_lang), 0, ($number > 10 ? 10 : $number), $orderBy, $orderWay, $id_category, true); Replace with $products = Product::getNewProducts(intval($cookie->id_lang), 0, 10, false, 'date_add', 'DESC'); Now we need to add the pubdate for the product to the rss Find $image = Image::getImages((int)($cookie->id_lang), $product['id_product']); echo "\t\t<item>\n"; Add after on a new line echo "\t\t\t<pubDate><![CDATA[".$product['date_add']." ]]></pubDate>\n"; Open modules/feeder/feeder.php Find 'feedUrl' => 'http://'.htmlspecialchars($_SERVER['HTTP_HOST'], ENT_COMPAT, 'UTF-8').__PS_BASE_URI__.'modules/'.$this->name.'/rss.php?id_category='.$id_category.'&orderby='.$orderBy.'&orderway='.$orderWay, Replace with 'feedUrl' => 'http://'.htmlspecialchars($_SERVER['HTTP_HOST'], ENT_COMPAT, 'UTF-8').__PS_BASE_URI__.'modules/'.$this->name.'/rss.php')); Find $this->_html .= Tools::getShopDomain(true, true).__PS_BASE_URI__.'modules/'.$this->name.'/rss.php?id_category=<span style="color:red;">{id_category}</span>&orderby='.$orderBy.'&orderway='.$orderWay; $this->_html .= '<br /><br />'.$this->l('Replace').' <span style="color:red;">{id_category}</span> '.$this->l('by the id category current or "0"'); and change to $this->_html .= Tools::getShopDomain(true, true).__PS_BASE_URI__.'modules/'.$this->name.'/rss.php';
  9. In the blank area of the page, where the content would normally be. Have you installed any custom modules, also what version of Prestashop are you using?
  10. Css does not have any thing to do with hooks, so the answer is no. If your modules page is not displaying correctly it is because there is an error in a module that is in your modules folder on the server. Try editing the file config/config.inc.php and changing @ini_set('display_errors', 'off'); to on. That should tell you which module has the error, so that you can either 1. fix it 2 remove it from the server.
  11. Changing image sizes and adding new images need regenerating images. Not too sure about png quality, never used them so not too sure.
  12. Back-office>preferences>images. Scroll down to the bottom and there is a section about regenerating.
  13. This should help with the list-mode by default http://www.templatemonster.com/help/prestashop-how-to-change-default-products-listing-view.html. It looks like you need to increase the height of ul#product_list li in your product-list.css file.
  14. You could try deleting the stores.tpl file in your theme and also the stores.php file in the root folder. Are you able to browse to the page manually? Alternatively, you could set up a 301 redirect in your htaccess file to direct any traffic to that page back to your homepage.
  15. @appliances can you post a link to your site so I can see exactly what is happening.
  16. Please don't spam the forum with the exact same question in 4 different posts, within 2 minutes of each other. The other posts have been deleted and I have left this one, for the moment. Anymore breaches of the forum rules could lead to a ban or suspension of your account. You can read the forum rules ---->here
  17. You only need to regenerate the images when you want to alter the image sizes on the front-end. This has always been a function on every Prestashop version.
  18. xxcoder why not take a full backup of your site and set up another prestashop installation in another folder on the server using that backup. The youn can an upgrade on your 1.2.9 version and see what problems might occur
  19. Module has been updated to be compatible with Prestashop v1.5.*
  20. Tried the module out, installed ok and displays on the front-end, but I am unable to change any of the options in the back-end for the module, including deleting demo slides and adding new slides. Using v1.4.9
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More