Jump to content

Project 14

Members
  • Posts

    5
  • Joined

  • Last visited

About Project 14

  • Birthday 07/14/1979

Project 14's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hey Adam, That line (251) in /classes/PaymentModule.php that you pointed me to doesn't seem to effect the totals at all - moving the order in which things are added doesn't do anything (at least to the checkout). Also, the total, when you add a discount, doesn't get pulled through in to GC properly - when I add a discount (ignoring the fact that it includes the shipping for the minute), PS says £15.35, but GC says £17.05 (for example). Any chance of looking at these couple of things this weekend? Thanks, PS2008 - once you've unzipped the module and FTP'd it to the modules directory, you need to go in to the back office and activate it...
  2. Hey, Do you have a schedule for looking at this module - these last couple of bugs are the very last thing I need! Thanks,
  3. Hey, I've found a small bug - there seems to be a problem with PrestaShop discount codes: The maths is correct BUT the 10% (or whatever) discount is being taken off the final total INCLUDING p+p....the discount is only meant to be applicable to the product price. Is it possible to select the product, apply the discounts and then for the p+p to be added on after? E.g. total = (price of products - discount) + shipping NOT total = (price of products + shipping) - discount Is it just a case of moving around the calculations? Can you show the discount in Google Checkout before adding the p+p? Thanks,
  4. Thanks for the reply - I think in the first place I'll only need option 1 - while complete integration would be nice, the quickest option is more preferable at the moment.
  5. I don't mind forking out some of the development costs for this module - it's holding up my project and I want to get it out of my hair! Any timeframe would be appreciated, even if it's to say 'next month' - then i can use something else! Thanks,
  6. Nevermind - the htaccess file in 1.0 is called htaccess.txt - renaming it to .htacess fixed the problem.
  7. Waaa - something's gone wrong with some .htaccess rewrite rules somewhere when I've upgraded. My site runs WordPress for most of it, and I've only installed PrestaShop in a directory '/shop/' - before I upgraded, WordPress (running in maintenance mode - which basically turns off the site) was working OK with PrestaShop, but now I can get to '/shop/' and view the page, but when I try to get into a category, I get shunted back to the WordPress maintenance mode page, like it thinks '/shop/' is part of WordPress and should be denied access. Turning off maintenance mode and trying to click into a category just points me to a WordPress error page, like it can't find a page in WordPress that it's expecting... Any tips on what I might have done wrong, or how I can get it back to where it was? I've still got backups of everything from RC5... Thanks,
  8. Any news? It's the last piece of my Prestashop installation that I need! Thanks,
  9. D'oh - I missed that one. That's what you get for trying to update complex stuff past midnight! Will try again when I've had some sleep!
  10. I've just tried updating from RC5 to 1.0, uploaded everything, copied what needed to be copied to the new directory, ran the install, and the option for upgrading was grayed out: "Update: Get the latest stable version (no old version detected)". Trying to go through the normal install (without installing any products) wanted me to create a new database as one already existed with the default name. Any ideas where I might have gone wrong?
  11. Any progress on this? Do you have an estimated release date - it would go very well with 1.0 final... Thanks,
  12. Thanks for the offer, but HSBC managed to reject my client's application for a merchant account due to low turnover, which they knew about in the first place when they sold it to them! We're going via Google/PayPal and 2co now. Thanks anyway - I'm sure it won't be the last question I thow out there!
  13. Nope, didn't want to work. =/ Any tips as to where in the hook_home the description hook needs to go? function hookHome($params) { global $smarty; $category = new Category(1); //adding this here didn't work when referencing {$category.description} //$category->description = nl2br2($category->description); $nb = intval(Configuration::get('HOME_categories_NBR')); $smarty->assign(array( 'category' => $category, 'lang' => Language::getIsoById(intval($params['cookie']->id_lang)), )); return $this->display(__FILE__, 'homecategories.tpl'); }
  14. My homecategories.tpl looks like this: <!-- MODULE Home categories created by Alpha Media (09 May 2008) --> {if isset($categories) AND $categories} {foreach from=$categories item=category name=homeCategories} {assign var='categoryLink' value=$link->getcategoryLink($category.id_category, $category.link_rewrite)} {$category.name} {$categoryDesc} More details {/foreach} {else} {l s='No categories' mod='homecategories'} {/if} <!-- END MODULE Home categories --> I need {$categoryDesc} to pull out the relevant description for the category...
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More