Jump to content

Claudia Llana

Members
  • Posts

    20
  • Joined

  • Last visited

1 Follower

Profile Information

  • Location
    Brasil, Rio de janeiro, RJ
  • First Name
    CLAUDIA
  • Last Name
    LLANA

Recent Profile Visitors

488 profile views

Claudia Llana's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Ok, you mean that I need to copy this class: if (Validate::isLoadedObject($cart) && $cart->OrderExists()) { $orderId = Db::getInstance()->getValue('SELECT `id_order` FROM `'._DB_PREFIX_.'orders` WHERE `id_cart` = '.(int)$cart->id); $hasDetailOrder = (bool)Db::getInstance()->getValue('SELECT count(*) FROM `'._DB_PREFIX_.'order_detail` WHERE `id_order` = '.(int)$orderId); if($hasDetailOrder) { PrestaShopLogger::addLog('Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart', 1, null, 'Cart', (int)$this->context->cookie->id_cart, true); unset($this->context->cookie->id_cart, $cart, $this->context->cookie->checkedTOS); $this->context->cookie->check_cgv = false; } } and place it at override/classes/controller but in which file should I do that? Because that are lots of files inside the folder controller. Thanks, Claudia Llana
  2. Hi, I am having the same issue in Prestashop version 1,6,1,20. Some customers when click de button to go to the payment page they got a blank page and at the logs page of prestashop I get this error: Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart. I read the post above and I would like to know where can I place this code below. In which page? if (Validate::isLoadedObject($cart) && $cart->OrderExists()) { $orderId = Db::getInstance()->getValue('SELECT `id_order` FROM `'._DB_PREFIX_.'orders` WHERE `id_cart` = '.(int)$cart->id); $hasDetailOrder = (bool)Db::getInstance()->getValue('SELECT count(*) FROM `'._DB_PREFIX_.'order_detail` WHERE `id_order` = '.(int)$orderId); if($hasDetailOrder) { PrestaShopLogger::addLog('Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart', 1, null, 'Cart', (int)$this->context->cookie->id_cart, true); unset($this->context->cookie->id_cart, $cart, $this->context->cookie->checkedTOS); $this->context->cookie->check_cgv = false; } } Can ou help me please? Thanks, Claudia Llana
  3. já resolvi é só mudar de lightbox para acesso a pagina direta no pagseguro.
  4. Caros, Vejam se você conseguem me ajudar. Eu não vejo mais a tela de Empregado. O que aparece pra mim é a msg Controlador não encontrado. Vocês sabem o que pode ter ocorrido e como posso resolver este problema, por favor? Aguardo retorno obrigada, Abs, Claudia Llana
  5. Olá, Vejam se vocês conseguem me ajudar. Eu montei uma loja para uma cliente na versão 1.6.20 e tudo está funcionando normalmente com exceção do pagamento por Pagseguro feito pelo Iphone e Safari. Ao clicar no botão de confirmação pra fazer a ponte com o Pagseguro para abrir a tela de popup para pagamento, nocaso para Iphone e safari não funciona, nada acontece e pra celulares Samsumg funciona normalmente. Não consegui descobrir de jeito nenhum o problema. O plugin que implementei do Pagseguro foi o 2.2 e fiz esta mesma implementação em um outra loja de um outro cliente, inclusive numa versão inferior e lá funciona tanto com Samsumg quanto com Iphone e Safari. Alguém poderia me ajudar, por favor? Desde já agradeço a ajuda, Abs, Claudia Llana
  6. Olá, Estou em busca de um módulo de entregas que pode ser pago que me permita adicionar faixas de ceps, definir o valor do frete pra cada faixa e tb bloquear faixas de ceps. Minha cliente que faz as próprias entregas ela tem uma frota de caminhões e com isto tenho que arranjar um modulo que atenda ela. Será que você poderiam me ajudar? Desde já agradeço, Abs, Claudia Llana
  7. Caros, Qual a versão mais estável do Prestashop indicada por vocês para uso? A última que instalei foi da série 1.6.x. Qual a versão mais estável no momento? Gostaria de usar uma versão mais recente. Desde já agradeço a ajuda, Abs, Claudia Llana
  8. Olá Daniel, Já descobri o problema agora a pouco...rs.. Eu fiz uma migração dos dados da loja na Versão 1.3 para a 1.6.1.14 e ao migrar os produtos vieram com a opção de preços e de disponibilizar na loja como false. Eu tinha já na loja dados de exemplo e estes estavam configurados corretamente. Aí eu resolvi deletá-los. Quando deletei começou a aparecer os dados migrados e com isto nem os preços e os botões de compra estavam sendo carregados, só que era um problema Graças a deus bem mais simples...rs.. Eu ao invés de entrar no produto e checar se a visualização dos preços e disponibilidade de pedido estavam marcadas, eu fui direto para a configuração da loja e fiquei batendo a cabeça atoa. Obrigada pela atenção, Abs, Claudia Llana
  9. Olá a todos, Bom dia! Estou com o mesmo problema. Só que já olhei todas as configurações e está udo normal incluindo a geolocalização. O botão e compra e os preços não carregam de jeito nenhum. Tudo estava funcionando corretamnte até ontem e não fiz nenhuma configuração diferente das já que faço para lojas em Prestashop. Estou aqui batendo a cabeça. Será que vocês poderiam me ajudar? Obrigada, Claudia Llana
  10. Olá Guialves, Qual é a versão da sua loja e qual módulo de frete que você está usando, pois eu tive o mesmo problema devido a problemas de configuração do módulo de fretes. Dependo se os dados não estiverem corretos pode dar este erro. Tem que olhar as dimensões e pesos colocados no produto no frete e também no próprio módulo. Abs, Claudia Llana
  11. Ok, mais precisa de alguma configuração significativa ou é só instalar o módulo?
  12. Caros, Boa tarde! Veja se vocês conseguem me ajudar. Eu configurei o pagseguro versão 2.1 para minha loja de prestashop versão 1.6.1.5. e quando tento finalizar uma compra pelo site ao clicar no botão confirmação de pagamento ocorre o seguinte erro: Fatal error: Uncaught Error: Call to undefined function mb_convert_encoding() in /home/desenvdotnet/www/flora-aquatica/modules/pagseguro/features/PagSeguroLibrary/utils/PagSeguroXmlParser.class.php:31 Stack trace: #0 /home/desenvdotnet/www/flora-aquatica/modules/pagseguro/features/PagSeguroLibrary/parser/PagSeguroPaymentParser.class.php(223): PagSeguroXmlParser->__construct('<?xml version="...') #1 /home/desenvdotnet/www/flora-aquatica/modules/pagseguro/features/PagSeguroLibrary/service/PagSeguroPaymentService.class.php(89): PagSeguroPaymentParser::readSuccessXml('<?xml version="...') #2 /home/desenvdotnet/www/flora-aquatica/modules/pagseguro/features/PagSeguroLibrary/domain/PagSeguroPaymentRequest.class.php(630): PagSeguroPaymentService::createCheckoutRequest(Object(PagSeguroAccountCredentials), Object(PagSeguroPaymentRequest), false) #3 /home/desenvdotnet/www/flora-aquatica/modules/pagseguro/features/util/converterorderforpaymentrequest.php(334): PagSeguroPaymentRequest->register(Object(PagSeguroAccountCredentials)) #4 in /home/desenvdotnet/www/flora-aquatica/modules/pagseguro/features/PagSeguroLibrary/utils/PagSeguroXmlParser.class.php on line 31 Alguém sabe como solucionar este problema? Abs, Claudia llana
  13. Olá, Boa tarde! Alguém saberia me dizer se o modulo Authorize.net é seguro. Vocês saberiam me dizer também, quanto tempo que eles levam pra pagar o comerciante? Meu cliente estava querendo instalar o módulo porque ele não tem taxa, mas antes disso gostaria de conhecer melhor o modulo até por segurnaça. eu andei olhando a net em busca de informações e não encontrei muita informações sobre este módulo. se você puderem me ajudar te agradeço. Abs, Claudia Llana
  14. Olá, Boa noite! Eu comprei um módulo pago do frete dos correios instalei e configurei, o mesmo estava funcionando corretamente já ha semanas e de repente ele parou de calcular o frete no carrinho. a Versão que estou usando do prestashop é a 1.6.1.5 e estou em vias de fato de implantar a loja e aconteceu isto com o frete. Alguém já teve este problema e sabe como resolver? O carrinho parou de enxergar as transportadoras...muito estranho. Agradeço muito se alguém puder me ajudar.. Obrigada, Abs, Claudia Llana Olá Eu consegui descobri o problema e resolver em parte. Na realidade o frete não estava sendo calculado, porque eu tenho que estar logada como cliente. Se eu estiver como convidado e visitante mesmo que estes grupos estejam habilitados o sistema não mostra o calculo do frete no carrinho. No caso só consigo simular o frete na opção de simular, mas o frete não e habilitado. quando eu logo como cliente no front end funciona. Se a funcionalidade funcionar somente assim tudo bem. só não entendo porque habilitados para os grupos de convidado e visitante não funciona. Abs, Claudia Llana
  15. Caros, Vejam se conseguem me ajudar. Estou com problemas na tradução de um tema pago. Já até enviei e-mail para o desenvolvedor, mas ainda não obtive retorno. Veja o erro que estou recebendo ao tentar modificar a tradução o tema para português Brasil. [PrestaShopException] File "br.php" doesn't exists and cannot be created in /home/flora-aquatica/www/themes/flower_shop/lang/ at line 1710 in file controllers/admin/AdminTranslationsController.php 1705. throw new PrestaShopException('Directory '.$dir.' cannot be created.'); 1706. } 1707. } 1708. if (!Tools::file_exists_cache($dir.DIRECTORY_SEPARATOR.$file)) { 1709. if (!file_put_contents($dir.'/'.$file, "<?phpnnglobal $".$var.";n$".$var." = array();nn?>")) { 1710. throw new PrestaShopException('File "'.$file.'" doesn't exists and cannot be created in '.$dir); 1711. } 1712. } 1713. if (!is_writable($dir.DIRECTORY_SEPARATOR.$file)) { 1714. $this->displayWarning(Tools::displayError('This file must be writable:').' '.$dir.'/'.$file); 1715. } AdminTranslationsControllerCore->fileExists - [line 1779 - controllers/admin/AdminTranslationsController.php] AdminTranslationsControllerCore->initFormFront - [line 146 - controllers/admin/AdminTranslationsController.php] AdminTranslationsControllerCore->initForm - [line 101 - controllers/admin/AdminTranslationsController.php] - [1 Arguments] AdminTranslationsControllerCore->initContent - [line 189 - classes/controller/Controller.php] ControllerCore->run - [line 367 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 58 - admin/index.php] Tem como arrumar isto? A versão do meu prestashop é a 1.6.1.5. O engraçado é que parte veio traduzido e parte não. Eu já consegui resolver.. eu dei permissão no diretorio e copiei a tradução do meu tema anterior para o novo e funcionou. Obrigada, Abs, Obrigada, Claudia Llana
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More