Jump to content

Designinfo

Members
  • Posts

    66
  • Joined

  • Last visited

Everything posted by Designinfo

  1. Not working. I tried on my website with enable full screen mode however it doesn't work.
  2. which part of the code do I enter that? Not working
  3. The my-account login button in the front office has gone missing . It should appear next to the contact us button however it suddenly dissappeared. I have reset , uninstalled and reinstalled several times and also hooked it in the header . please help. www.designinfo.in
  4. Is there a possibility this module might work without ssl ? If not is there a solution to the same?
  5. I want the final amount posted to be multiplied by 1.02 The following is the payment.php of the PAYUMONEY zip file $ total has to be multiplied by 1.02 I dont know if this is the right way but I am attaching the entire module also.I want the final amount posted on the Payumoney website multiplied by 1.02 Reason I want to add a tax on payment by credit card tax of 2% $payu = new payu(); $context = Context::getContext(); $cart = $context->cart; if (!$cookie->isLogged(true)) Tools::redirect('authentication.php?back=order.php'); elseif (!$cart->getOrderTotal(true, Cart::BOTH)) Tools::displayError('Error: Empty cart'); if ($cart->id_customer == 0 OR $cart->id_address_delivery == 0 OR $cart->id_address_invoice == 0 OR !$payu->active) Tools::redirectLink(__PS_BASE_URI__.'order.php?step=1'); // Prepare payment $customer = new Customer((int)$cart->id_customer); if (!Validate::isLoadedObject($customer)) Tools::redirectLink(__PS_BASE_URI__.'order.php?step=1'); $currency = new Currency(Tools::getValue('currency_payement', false) ? Tools::getValue('currency_payement') : $cookie->id_currency); $total = (float)($cart->getOrderTotal(true, Cart::BOTH)); $payu->validateOrder($cart->id, Configuration::get('PS_OS_BANKWIRE'), $total, $payu->displayName, NULL,NULL, (int)$currency->id, false, $customer->secure_key); Tools::redirect('index.php?controller=order-confirmation&id_cart='.(int)$cart->id.'&id_module='.$payu->id.'&id_order='.$payu->currentOrder.'&key='.$customer->secure_key); include('../../footer.php'); payu.zip
  6. I dont know what error this is but nothing was loading. I was getting blank pages.
  7. I have two methods to pay 1. Credit card and 2. Cheque I have two shipping methods 1. Ship fast 2. Ship slow I want ship fast to only show 'credit card' payment gateway and ship slow to only show 'cheque' Basically payment gateway to be restricted by the shipping method chosen. Please give the change in code in detail with the file name to be edited . I am doing all this to charge extra tax on the payment gateway chosen and the only way to do this is by charging the shipping . So different payment gateway in specific shipping method
  8. My default currency for backend is euro . But in front end all prices should be shown in INR first as default . I give all my prices in euro in the back end but when the customer views my webiste the currency shown should be INR WHICH MEANS - Customer should not have to have to change currency by clicking on 'change currency' at the top right hand side. Basically I do not want a customer to view the prices in EURO but all my prices in back end are in euro and I want to continue giving my prices in euro. Current status New customer arrives all prices in euro customer can change currency to INR backend all prices in euro Expected change new customer arrives all prices in INR customer can change currency if he wants back end all prices in euro The first currency for all my products seen should be INR and not EURO BUT back end will have all products in euro
  9. I figured in the console of chrome that i need this to be changed .sf-menu > li > ul { padding: 26px 30px 31px; width: 100%; } .sf-menu > li > ul > li > a { text-transform: uppercase; font: 600 18px/28px "Open Sans", sans-serif; color: #000000; } .sf-menu > li > ul > li > a:hover { color: #0079C1; } how do i add this in the superfish.scss ???
  10. This is blocktopmenu I want to increase the font and increase the spacing/padding of the subcategories. They are all cramped up. font of all and spacing/ padding of only subcategories. PS explain the change in code in detail and mention the files in which the changes have to be made. prestashop 1.6.1.0 /*** ESSENTIAL STYLES ***/ .sf-contener { clear: both; } .sf-right { margin-right: 14px; float: right; width: 7px; } .sf-menu, .sf-menu * { margin: 0; padding: 0; list-style: none; } .sf-menu { margin: 10px 0; padding:0; width:980px;/* 980 */ background: #383838; } .sf-menu ul { position: absolute; top: -999em; width: 10em; /* left offset of submenus need to match (see below) */ } .sf-menu ul li { width: 100%; } .sf-menu li:hover { visibility: inherit; /* fixes IE7 'sticky bug' */ } .sf-menu li { float: left; position: relative; border-right: 1px solid #777; } .sf-menu a { display: block; position: relative; color:#fff; text-shadow:0 1px 0 #333; } .sf-menu li:hover ul, .sf-menu li.sfHover ul { left: 0; top: 34px; /* match top ul list item height */ z-index: 99; width:auto } ul.sf-menu li:hover li ul, ul.sf-menu li.sfHover li ul { top: -999em; } ul.sf-menu li li:hover ul, ul.sf-menu li li.sfHover ul { left: 200px; /* match ul width */ top: 0; } ul.sf-menu li li:hover li ul, ul.sf-menu li li.sfHover li ul { top: -999em; } ul.sf-menu li li li:hover ul, ul.sf-menu li li li.sfHover ul { left: 200px; /* match ul width */ top: 0; } /*** DEMO SKIN ***/ .sf-menu { float: left; margin-bottom: 1em; } .sf-menu a { display:block; margin-right:2px; padding: 0 22px 0 20px; line-height:34px; border: 0; text-decoration:none; } .sf-menu a, .sf-menu a:visited { /* visited pseudo selector so IE6 applies text colour*/ color: #fff; white-space:nowrap; } .sf-menu li li { background: rgba(113, 113, 113, 0.9); } .sf-menu li li li { background: rgba(113, 113, 113, 0.9); } .sf-menu a:focus, .sf-menu a:hover, .sf-menu a:active { background: #4E4E4E; } .sf-menu ul li:hover, .sf-menu ul li.sfHover, .sf-menu ul li a:focus, .sf-menu ul li a:hover, .sf-menu ul li a:active { background: #4e4e4e; outline: 0; } /*** arrows **/ .sf-menu a.sf-with-ul { padding-right: 2.25em; min-width: 1px; /* trigger IE7 hasLayout so spans position accurately */ } .sf-sub-indicator { position: absolute; display: block; right: 10px; top: 1.05em; /* IE6 only */ width: 10px; height: 10px; text-indent: -999em; overflow: hidden; background: url('../img/arrows-ffffff.png') no-repeat -10px -100px; /* 8-bit indexed alpha png. IE6 gets solid image only */ } a > .sf-sub-indicator { /* give all except IE6 the correct values */ top: 11px; background-position: 0 -100px; /* use translucent arrow for modern browsers*/ } /* apply hovers to modern browsers */ a:focus > .sf-sub-indicator, a:hover > .sf-sub-indicator, a:active > .sf-sub-indicator, li:hover > a > .sf-sub-indicator, li.sfHover > a > .sf-sub-indicator { background-position: -10px -100px; /* arrow hovers for modern browsers*/ } /* point right for anchors in subs */ .sf-menu ul .sf-sub-indicator { background-position: -10px 0; } .sf-menu ul a > .sf-sub-indicator { background-position: 0 0; } /* apply hovers to modern browsers */ .sf-menu ul a:focus > .sf-sub-indicator, .sf-menu ul a:hover > .sf-sub-indicator, .sf-menu ul a:active > .sf-sub-indicator, .sf-menu ul li:hover > a > .sf-sub-indicator, .sf-menu ul li.sfHover > a > .sf-sub-indicator { background-position: -10px 0; /* arrow hovers for modern browsers*/ } /*** shadows for all but IE6 ***/ .sf-shadow ul { background: url('../img/shadow.png') no-repeat bottom right; padding: 0 8px 9px 0; -moz-border-bottom-left-radius: 17px; -moz-border-top-right-radius: 17px; -webkit-border-top-right-radius: 17px; -webkit-border-bottom-left-radius: 17px; } .sf-shadow ul.sf-shadow-off { background: transparent; } li.sf-search { background: inherit; float: right; line-height: 25px; } li.sf-search input { -moz-border-radius: 0 5px 5px 0; padding: 3px 0; padding-left: 20px; margin: 6px 6px 0 0; background: #fff url('../img/search.gif') no-repeat left center; border:1px solid #777 } /* hack IE7 */ .sf-menu a, .sf-menu a:visited {height:34px !IE;} .sf-menu li li { width:200px; background:#726f72 !IE; }
  11. Website- designinfo.in This payment gateway which I have attached is working fine and converts the currency from Dollar or Euro to Rupee before sending the value to the payment gateway (Payumoney Payment Gateway) The PROBLEM is that when the customer changes the quantity of products or purchases a new product from the same browser then the price shown in the payment gateway does not change . Example- Order 1 ------Final Cost =$1000 Price sent to payment gateway = INR 64000 ( $1000*64 ) .....( If 64 is the exchange rate for $ to INR ). Order 2-------Final Cost =$2000 Price sent to payment gateway = INR 64000 unchanged ( $1000*64 ) .....( If 64 is the exchange rate for $ to INR ). In order 2 the price sent should have been INR 128000 ( $2000*64 ). Therefore the cache is not getting deleted and hence the old price is being shown. Please note - 1.The conversion is correct for the first time. 2. Closing the browser and rebuying the product is not solving the problem. 3. Changing the browser is solving the problem. The attached file has the entire payment gateway along with the payment.php file where the modification for the conversion code ( From Yahoo Finance ) is added. Please advise what should I change. payment.php PayUMoney_prestashop.zip
  12. Yes , confirmed it works with ps 1.6.1.0 Please tell me how to hook it.
  13. I have tried all ...it is not working. I have not touched the module. It was working correctly even in the latest prestashop update but recently when I deleted many dashboard ( Back Office ) modules the PayuMoney module stopped being displayed.
  14. The image of the product is not visible in the check out page . The is happening for all the products, What can be the possible reason. If any coding is involved please mention the exact file and code. All the images are visible everywhere else. Attached - image of the problem
  15. Payment gateway of Payumoney was working in the old version of prestashop but now after upgrading to 1.6.1.0 ...it seems to have been unhooked. How do i hook it again to the payment page. I have attached the files for missing hooking. Also i have attached the payumoney gateway plugin. I believe it has to be hooked in the payment.tpl payu.zip
  16. Thank you . Does this disable the module and make loading of the page faster ?
  17. I want to get a new image on the right-hand side . Right column blank side , where I have written here. Please note after uploading a new image in the theme configurator and hooking it to the HOOK ( Home) section is not solving the problem. Hooking to the right , left , top column make the image disappear . Please note I have deleted the default images from the hook top , bottom , right and footer section. Will I have to make changes in the CSS file to float it to right side? I do not have right column enabled . I have the left column enabled. Attached images. If any coding is required please mention the exact file and the exact code. CSS FILE /* Home hook CSS */ #htmlcontent_home ul { margin: 0 -5px; } #htmlcontent_home ul li { padding: 0 5px 10px; } @media (max-width: 479px) { #htmlcontent_home ul li { width: 100%; } } #htmlcontent_home ul li img { max-width: 100%; height: auto; } @media (max-width: 479px) { #htmlcontent_home ul li img { min-width: 100%; } } #htmlcontent_home ul li.htmlcontent-item-1 { width: 66.6667%; } @media (max-width: 479px) { #htmlcontent_home ul li.htmlcontent-item-1 { width: 100%; float: right; } } #htmlcontent_home ul li.htmlcontent-item-2 { width: 66.6667%; } @media (max-width: 479px) { #htmlcontent_home ul li.htmlcontent-item-2 { width: 100%; } } #htmlcontent_home ul li.htmlcontent-item-3 { width: 66.6667%; } @media (max-width: 479px) { #htmlcontent_home ul li.htmlcontent-item-3 { width: 100%; } } /* Top hook CSS */ #htmlcontent_top { float: right; width: 33%; max-width: 391px; padding-left: 5px; } @media (max-width: 767px) { #htmlcontent_top { width: 100%; max-width: 100%; padding-left: 0; padding-top: 0px; } } @media (max-width: 767px) { #htmlcontent_top ul { margin: 0 -5px; } } #htmlcontent_top ul li { width: 100%; margin-bottom: 10px; } @media (max-width: 767px) { #htmlcontent_top ul li { float: left; padding-left: 5px; padding-right: 5px; width: 50%; } } #htmlcontent_top ul li:last-child { margin-bottom: 0; } #htmlcontent_top ul li img { max-width: 100%; height: auto; } /* Left hook CSS */ /* Right hook CSS */ /* Footer hook CSS *
  18. Thank you @PhilCorleone Things have not speeded up .In fact even my product edit section takes about 30 seconds for the save button to complete loading .( The entire page loads for editing but the save /save and keep changes button keeps loading for 30-60 seconds and sometimes over a minute also ) . in the edit product section when image subsection is opened...so many times none of the images are visible. Google analytics says I have only one current user on my website and that is me . So where is this load / pressure for loading so slow coming from. I am barly using 250 Mb ram of the 1 Gb ram provided to me and i/o usage (1 MB/s) is also not exceded. The server guy keeps telling me that too many MySQL queries are running in the back ground with so many cookies at one go . He says that i have a limit of 15 seconds for any query to run and post that the server will automatically kill those queries. Apart from this any page on my website ...whether totally blank or filled with images/ products or even the contact shop page takes a minimum of 5 seconds to load. GtMetrix and YSlow say that time to first byte is very long . When i am not depleting my resources of the server why should there by such a large Time For First byte. He says that there are others using even more heavier websites and upto 1.2 Mb each page size on the same exact plan as I use ...but their site takes 0.2 seconds for time to first byte. Hence there is a problem with the prestashop that I am using. ( 1.6.1.0 ) I have deleted all dashboard modules . Using only 31 total modules as of now. Google analytics instead. No third party modules. So what can be pther possible reasons for the above issues ?
  19. How to unhook the information block module from here ? attachment
  20. See attachment This appears in the product section in the back office. I want to remove this.
  21. I do not use third party modules . I have disabled - 'disable all overrides' section ....please note this implies overrides will be overridden . I use the top horizontal menu ...not sure if that is official.
  22. Thank you. To use google analytics will i need to know any coding?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More